Guest

Cisco 1400 Series Routers

Configuring a Cisco 1417 Router With IP Unnumbered E0, DHCP, PPPoA, and PPP-CHAP

Cisco - Configuring a Cisco 1417 Router With IP Unnumbered E0, DHCP, PPPoA, and PPP-CHAP

Document ID: 12826

Updated: Jun 01, 2005

   Print

Introduction

This sample configuration shows a Cisco 1417 Digital Subscriber Line (DSL) Router connecting to a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM) and terminating on a Cisco 6400 Universal Access Concentrator (UAC). The Cisco 1417 has been configured as a Dynamic Host Configuration Protocol (DHCP) server with PPP over ATM (PPPoA).

The Internet Service Provider (ISP) has given the subscriber a range of IP addresses, 10.0.0.1 to 10.0.0.X, with a mask of 255.0.0.0. IP address "10.0.0.1" will be manually configured on the Ethernet interface of the Cisco 1417. The remaining IP addresses will be assigned to a DHCP pool and leased to local LAN devices attached to the Ethernet network of the Cisco 1417.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software versions below.

  • Cisco 1417 DSL Router IOS® Software Release 12.1(1.3)T

  • Cisco 6400 UAC-NRP IOS Software Release 12.0(7)DC

  • Cisco 6400 UAC-NSP IOS Software Release 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(1)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

1417unnum.gif

Configurations

This document uses the configurations shown below.

Cisco 1417
Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
! 
ip subnet-zeroip dhcp excluded-address 10.0.0.1 

!--- The DHCP pool will not lease this address; it's used by interface E0.

!
ip dhcp pool <pool name>
 network 10.0.0.0 255.0.0.0 

!--- You need to adjust this for your range of addresses.

 default-router 10.0.0.1

!--- The default gateway will be assigned to local devices.

!
interface Ethernet0
 ip address 10.0.0.1 255.0.0.0
!
interface ATM0
 no ip address
 atm vc-per-vp 4096
 no atm ilmi-keepalive
 pvc 1/44 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
! 
interface Dialer0
 ip unnumbered Ethernet0 
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname <username>
 ppp chap password <password>
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0 
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jun 01, 2005
Document ID: 12826