Guest

Cisco 1400 Series Routers

Cisco 1417 Router Frequently Asked Questions

Document ID: 12822

Updated: Jun 01, 2005

   Print

Contents

Introduction

This document provides frequently asked questions about the Cisco 1417 router.

1417_faqs.gif 1417_faqs_rear_panel.gif

Cisco 1417 Router

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Q. 1. How do I configure the router for RFC1483 Routing?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 171.68.9.1 255.255.255.0
!
interface ATM0
 no ip address
 atm vc-per-vp 4096
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip address 209.1.1.2 255.255.255.0
 pvc 1/35
  encapsulation aal5snap
 !
!
ip classless
ip route 0.0.0.0 0.0.0.0 209.1.1.1
no ip http server
!
!
line con 0
 transport input none
line vty 0 4
!
end

Q. 2. How do I configure the router for RFC1483 Routing and Port Address Translation (PAT)?

! 
service timestamps debug datetime 
service timestamps log datetime 
no service password-encryption 
! 
hostname 1417 
! 
logging buffered 4096 debugging 
! 
! 
! 
! 
! 
ip subnet-zero 
! 
! 
! 
interface Ethernet0 
 ip address 10.0.0.2 255.255.255.0 
 ip nat inside 
! 
interface ATM0 
 no ip address 
 atm vc-per-vp 4096 
 no atm ilmi-keepalive 
! 
interface ATM0.1 point-to-point 
 ip address 209.1.1.2 255.255.255.0 
 ip nat outside 
 pvc 1/35 
  encapsulation aal5snap 
 ! 
! 
ip nat pool PAT-Test-Pool 209.1.1.2 209.1.1.2 netmask 255.255.255.0 
ip nat inside source list 1 pool PAT-Test-Pool overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 209.1.1.1 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.0.0.255 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end

Q. 3. How do I configure the router for RFC1483 Routing and Network Address Translation (NAT)?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 10.0.0.2 255.255.255.0
 ip nat inside
!
interface ATM0
 no ip address
 atm vc-per-vp 4096
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip address 209.1.1.2 255.255.255.248
 ip nat outside
 pvc 1/35
  encapsulation aal5snap
 !
!
ip nat pool NAT-Test-Pool 209.1.1.2 209.1.1.6 netmask 255.255.255.248
ip nat inside source list 1 pool NAT-Test-Pool overload
ip classless
ip route 0.0.0.0 0.0.0.0 209.1.1.1
no ip http server
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
line con 0
 transport input none
line vty 0 4
 login
!
end

Q. 4. How do I configure the router for RFC1483 Bridging?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
no ip routing 
!
! 
! 
interface Ethernet0 
 no ip address 
 no ip directed-broadcast 
 bridge-group 1 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 atm vc-per-vp 64 
 pvc 1/35 
  encapsulation aal5snap 
 ! 
 bridge-group 1 
! 
bridge 1 protocol ieee 
 ! 
line con 0 
 transport input none 
line vty 0 4 
 password it 
 login 
! 
end

Q. 5. How do I configure the router for RFC1483 Bridging and PAT?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
bridge irb
!
!
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface ATM0
 no ip address
 atm vc-per-vp 4096
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 pvc 1/35
  encapsulation aal5snap
 !
 bridge-group 1
!
interface BVI1
 ip address 209.1.1.2 255.255.255.0
 ip nat outside
!
ip nat inside source list 1 pool PAT-Test-Pool overload
ip nat pool PAT-Test-Pool 209.1.1.2 209.1.1.2 netmask 255.255.255.0
ip classless
ip route 0.0.0.0 0.0.0.0 209.1.1.1
no ip http server
!
access-list 1 permit 10.0.0.0 0.0.0.255
bridge 1 protocol ieee
 bridge 1 route ip
!
end

Q. 6. How do I configure the router for RFC1483 Bridging and NAT?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
bridge irb
!
!
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface ATM0
 no ip address
 atm vc-per-vp 4096
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 pvc 1/35
  encapsulation aal5snap
 !
 bridge-group 1
!
interface BVI1
 ip address 209.1.1.2 255.255.255.0
 ip nat outside
!
ip nat inside source list 1 pool NAT-Test-Pool overload
ip nat pool NAT-Test-Pool 209.1.1.4 209.1.1.9 netmask 255.255.255.0
ip classless
ip route 0.0.0.0 0.0.0.0 209.1.1.1
no ip http server
!
access-list 1 permit 10.0.0.0 0.0.0.255
bridge 1 protocol ieee
 bridge 1 route ip
!
end

Q. 7. How do I configure the router for Point-to-Point Protocol over Ethernet over ATM (PPPoE)?

A. Please refer to Answer #4.

Q. 8. How do I configure the router for PPPoE and PAT?

A. That is not possible as of April 2000.

Q. 9. How do I configure the router for PPPoE and NAT?

A. That is not possible as of April 2000.

Q. 10. How do I configure the router for PPP over ATM (PPPoA)?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 209.1.1.3 255.255.255.0
 no ip directed-broadcast
!
interface Virtual-Templatel
 ip address 209.1.1.2
 no ip directed-broadcast
 ppp chap hostname cisco
 ppp chap password 0 cisco
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm vc-per-vp 64       
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35
  encapsulation aal5mux ppp Virtual-Template1
 !
!
ip classless
ip route 0.0.0.0 0.0.0.0 209.1.1.1
no ip http server
!
end

Q. 11. How do I configure the router for PPPoA and PAT?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
!
interface Virtual-Templatel
 ip address 209.1.1.2 255.255.255.0
 no ip directed-broadcast
 ip nat outside
 ppp chap hostname cisco
 ppp chap password 0 cisco
!
interface ATM0
 no ip address 
 no ip directed-broadcast
 atm vc-per-vp 64
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35
  encapsulation aal5mux ppp Virtual-Template1
 !
!
ip nat pool PAT-Test-Pool 209.1.1.2 209.1.1.2 netmask 255.255.255.0
ip nat inside source list 1 pool PAT-Test-Pool overload
ip classless
ip route 0.0.0.0 0.0.0.0 209.1.1.1
no ip http server
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
line con 0
 transport input none
line vty 0 4
 login
!
end

Q. 12. How do I configure the router for PPPoA and NAT?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
!
interface Virtual-Template1
 ip address 209.1.1.2 255.255.255.248
 no ip directed-broadcast
 ip nat outside
 ppp chap hostname cisco
 ppp chap password 0 cisco
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm vc-per-vp 64
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 no ip directed-broadcast
 pvc 1/35
  encapsulation aal5mux ppp Virtual-Template1
 !
!
ip nat pool PAT-Test-Pool 209.1.1.2 209.1.1.6 netmask 255.255.255.248
ip nat inside source list 1 pool PAT-Test-Pool overload
ip classless
ip route 0.0.0.0 0.0.0.0 209.1.1.1
no ip http server
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
line con 0
 transport input none
line vty 0 4
 login
!
end

Q. 13. How do I configure the router for PPPoA using the "Dialer Interface"?

!
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname 1417
!
logging buffered 4096 debugging
!
!
!
!
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
!

interface ATM0
 no ip address
 no ip directed-broadcast
 atm vc-per-vp 4096
 no atm ilmi-keepalive
 pvc 1/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Dialer0
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp hostname cisco
 ppp chap password 0 cisco
!
ip nat inside source list 1 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
access-list 1 permit 10.0.0.1 0.0.0.255
!
line con 0
 exec-timeout 0 0
 transport input none
line vty 0 4
 password cisco
 login
!
end

Q. 14. Why is my ATM0 interface Down/Down?

A. An ATM interface will come Up/Up once an ATM carrier is detected. Therefore, there are a number of reasons why an ATM interface may be Down/Down. Below is a list of some of the more common reasons:

  • No cable is attached.

  • The wrong type of cable is being used. (We use 4 or 6 pin RJ-11 straight through cables from the dsl port of the router to the wall jack/demarc.)

  • The pinout of the wall jack is wrong:

    • 6-pin RJ-11 cable - Use pins 2 and 5.

    • 4-pin RJ-11 cable - Use pins 1 and 4.

      Important: Make certain that you are not using a 4-pin cable with a 6-pin jack.

  • The line has not been provisioned yet, or has not been provisioned properly.

  • The router hardware has failed.

Q. 15. How Do I negotiate my IP Address with my ISP via IPCP during PPP negotiation?

A. Use the following command: ip address negotiated. Do not put an IP Address on the WAN interface (BVI, ATM, or Virtual-Template).

Q. 16. Can I do NAT/PAT while using "IP Address Negotiated"?

A. We hope to provide this functionality in the future on the Bridge Group Virtual Interface (BVI) for bridged interfaces. However, for routed interfaces, this functionality will never work with the Virtual Template, because it is always Down/Down. We hope to provide this functionality in the future as well.

BVI for example

! 
interface BVI1 
ip address negotiated 
. 
. 
! 
ip nat inside source list 1 interface BVI1 overload 
ip route 0.0.0.0 0.0.0.0 BVI1 
! 
access-list 1 permit 
!

Dialer for example Refer to Answer # 13.

Q. 17. Why can't I specify the BVI interface as my NAT/PAT inside source?

A. This feature was removed from all Cisco 1417 Router code after Cisco IOS Software Release version 12.0(4)XI. We hope to return this feature at in the future.

Q. 18. Why can't I specify the Virtual-Template as my NAT/PAT inside source?

A. The option exists to configure the Virtual-Template as a Network Address Translation (NAT) inside source interface, however, this configuration will not work properly. This is not a supported configuration as of April 2000 because you can not make a NAT connection to an interface that is Down/Down, which the Virtual-Template always is. Only the Virtual-Access interfaces will come Up/Up, and they can not be specified as inside source list interfaces.

Q. 19. How do I configure a Bridge Group Virtual Interface (BVI) if my Cisco 1400 Router is configured as a bridge, and my ISP is doing Dynamic Host Configuration Protocol (DHCP) to my PC?

A. The BVI would have to be configured as a DHCP client, which is not possible as of April 2000. We hope to provide this ability in the future.

Q. 20. Can the router act as a DHCP Client?

A. Not at this time (April 2000). We hope to offer this feature in future releases of Cisco IOS Software.

Q. 21. Can the router act as a DHCP Server?

!
ip dhcp pool dhcp-test
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.1
   dns-server 206.5.3.2 206.5.9.7
   domain-name my-network.net
!

Q. 22. Why do I get the error message "Invalid input detected at '^' marker." when I try to configure a permanent virtual circuit (PVC) under the ATM interface?

A. The reason for this is that the Cisco 1417 Router has PVC ceilings which are determined by the command: atm vc-per-vp. This command takes three arguments, which allow for three different vpi/vci combinations:

atm vc-per-vp 8192      vpi = [0-1]   /  vci = [1-8191]
atm vc-per-vp 4096      vpi = [0-3]   /  vci = [1-4095]
atm vc-per-vp 64        vpi = [0-255] /  vci = [1-63]

Q. 23. Why do I get the error message "Incomplete Command" when I try to configure a PVC?

A. The reason for this is that the Cisco 1417 Router has PVC ceilings which are determined by the command: atm vc-per-vp. This command takes three arguments, which allow for three different vpi/vci combinations:

atm vc-per-vp 8192      vpi = [0-1]   /  vci = [1-8191]
atm vc-per-vp 4096      vpi = [0-3]   /  vci = [1-4095]
atm vc-per-vp 64        vpi = [0-255] /  vci = [1-63]

Note: Questions #22 and #23 are the same error with two different manifestations and a single solution.

Q. 24. My ATM0 interface is Up/Up, my PVC is Up/Up. Why can't I ping my next HOP?

A. There are many reasons why no traffic is passed on the Cisco 1417 Router when an ATM interface comes Up/Up and a PVC comes Up/Up. When an ATM interface comes Up/Up all we know is that we are receiving carrier detect from the ATM link. Below are three of the most common reasons for "No Traffic Passed."

  • In certain situations it is possible to get a false positive where the Cisco 1417 Router's ATM interface comes Up/Up, but the wall jack is actually pinned out for the wrong pins. This phenomena occurs because the sensitivity of the Alcatel chipset is so great that even with the 40dB isolation between the pins, if you have the wrong pinout, you can still sometimes train with the weakened signal. Of course, there is no hope of passing any data in this scenario, which might be your problem. A show controller atm 0 would help here, as it would show you if you are getting a lot of layer 1 CRC errors (show interface only shows layer 2 CRC errors, so that is probably going to be 0). A show controller atm 0 should also show the ADSL train rate, which will give you an idea of whether or not your Up/Up scenario is a false positive.

    The solution is to get your telco to repin the jack.

  • Another thing to keep in mind is that no matter what PVC you provision on an Up/Up ATM interface, the PVC WILL come Up/Up also. This does not mean you have end to end connectivity. The PVC on the other side of the link may be configured for a completely different vpi/vci, and you will still see the PVC Up/Up. The solution is to configure the proper PVC

  • IP Routing may also be an issue in this situation. You have got to make sure that you have a next hop or more commonly, a default route configured to the gateway router that will be terminating your PPP connection. The only case where a route is not required is in PURE RFC1483 Routing where both the ATM0 and Ethernet0 interfaces are configured in a bridge group with NO BVI interface. All other config scenarios require a next hop route.

    The solution is to configure the proper default or next hop route.

The above are the most common reasons for "No Traffic Passed" problems that we encounter in the TAC.

Related Information

Updated: Jun 01, 2005
Document ID: 12822