Guest

Cisco ONS 15454 Series Multiservice Provisioning Platforms

Configure EtherChannel Using an ML Card on ONS 15454 and Catalyst Switch Across RPR

Document ID: 69342

Updated: Apr 10, 2006

   Print

Introduction

This documentdescribes the procedure to configure EtherChannel and 802.1Q tunneling using a Cisco Catalyst 3500XL switch and the ML-Series card across the Resilient Packet Ring (RPR) in an Cisco ONS 15454 environment.

Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

  • Cisco ONS 15454

  • Cisco ONS 15454 ML-Series Ethernet Cards

  • Catalyst 3500XL switch

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco ONS 15454 Version 6.x

  • Catalyst 3500XL switch that runs Cisco IOS® Software Release 12.0(5)XC

  • ML (bundled as part of the ONS 15454 6.0 release) that runs Cisco IOS® Software Release 12.2(27)SV and later

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Network Diagram

This document uses a lab setup with two ONS 15454 nodes and two Catalyst 3500 XL switches. EachONS 15454 is equipped with one ML 1000-2 card, and a Resilient Packet Ring (RPR) is built between them across the ML 1000-2 card. Two Gigabit Ethernet ports on Catalyst 3500 XL are connected to two Gigabit Ethernet ports on the ML 1000-2 card respectively. The network diagram is displayed in Figure 1.

Figure 1: Network Diagram

f1.gif

Configuration

Configuring RPR

Complete these steps to build RPR:

  1. Create a circuit between POS 0 of ML1000-2 on ONS 15454 A and POS 1 of ML1000-2 on ONS 15454 B.

  2. Create a circuit between POS 1 of ML1000-2 on ONS 15454 A and POS 0 of ML1000-2 on ONS 15454 B.

  3. Configure ML1000-2 card on ONS 15454 A.

    1. Turn on Integrated Bridging and Routing (IRB).

      bridge irb
      
    2. Create bridge 1

      Bridge 1 protocol rstp  
    3. Configure the SRP interface.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 3
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
    4. Configure interface POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Configure interface POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
  4. Configure ML1000-2 card on ONS 15454 B.

    1. Turn on Integrated Bridging and Routing (IRB).

      bridge irb
      
    2. Create bridge 1

      Bridge 1 protocol rstp
      
    3. Configure the SRP interface.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 4
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
    4. Configure interface POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Configure interface POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      

Configuring EtherChannel

Complete these steps to build EtherChannel:

  1. Configure interface GigabitEthernet0/1 and GigabitEthernet0/2 on CAT3500_A.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  2. Configure interface GigabitEthernet0/1 and GigabitEthernet0/2 on CAT3500_B.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  3. Configure ML1000-2 on ONS 15454 A.

    1. Configure interface GigabitEthernet 0 and GigabitEthernet 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Configure Port-Channel.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
  4. Configure ML1000-2 on ONS 15454 B.

    1. Configure interface GigabitEthernet0 and GigabitEthernet 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Configure Port-Channel.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      

Verification

Complete these steps to verify the configuration:

  1. Issue the show interfaces port-channel command from the ML1000-2 on ONS 15454 A. This command showsthat the EtherChannel contains two Gigabit Ethernet ports (see the boldface characters).

    15454A_ML1000-2>show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 000d.28bd.0b34 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 4000 bits/sec, 7 packets/sec
    
      5 minute output rate 2000 bits/sec, 4 packets/sec
    
         495875 packets input, 33757916 bytes
    
         Received 493640 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         55924 packets output, 4080533 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
  2. Issue the show interfaces port-channel command from the ML1000-2 on ONS 15454 B. This command shows that the EtherChannel contains two Gigabit Ethernet ports (see the boldface characters).

    15454B_ML1000-2>show int port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 0013.60f8.65f4 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 3000 bits/sec, 5 packets/sec
    
      5 minute output rate 3000 bits/sec, 6 packets/sec
    
         1970114 packets input, 143644364 bytes
    
         Received 1969971 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         2256335 packets output, 164715496 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
    
  3. Issue the show cdp neighbor command on the CAT3500_A (see Figure 2). This command displays CAT3500_B as its neighbor through the EtherChannel.

    Figure 2: show cdp neighbor on CAT3500_A

    f2.gif

  4. Issue the show cdp neighbor command on the CAT3500_B (see Figure 3). This command displays CAT3500_A as its neighbor through the EtherChannel.

    Figure 3: show cdp neighbor on CAT3500_B

    f3.gif

  5. Perform a ping test.

    1. Configure VLAN2 on CAT3500_A with an IP Address 192.168.0.2.

      !
      interface VLAN2
       ip address 192.168.0.2 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    2. Configure VLAN2 on CAT3500_B with an IP Address 192.168.0.4.

      !
      interface VLAN2
       ip address 192.168.0.4 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    3. Issue the ping command on CAT3500_A (see Figure 4).

      ping 192.168.0.4
      
      Figure 4: PING Test from CAT3500_A to CAT3500_B

      f4.gif

    4. Issue the ping command on CAT3500_B (see Figure 5).

      ping 192.168.0.2
      
      Figure 5: PING Test from CAT3500_B to CAT3500_A

      f5.gif

Related Information

Updated: Apr 10, 2006
Document ID: 69342