Guest

Multiprotocol Label Switching over ATM (MPLS over ATM)

Multiprotocol Label Switching (MPLS) over ATM without VC-merge

Document ID: 10467

Updated: Nov 15, 2007

   Print

Introduction

This document illustrates a Multiprotocol Label Switching (MPLS) network with ATM. Since VC-merge is not used, there is one VC allocated per route as determined by the prefix in the routing table.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco IOS® Software Release 12.0 or later is for MPLS on Guilder and Damme.

  • This setup uses one ATM switch that is used as the label switch router (LSR). In this example, it is a Catalyst 8540MSR. It can also be a LS1010. Cisco recommends software version WA4.8d or later on the LS1010. Any software on the 8540MSR is sufficient.

  • Cisco Express Forwarding (CEF) needs to be enabled on the routers that run MPLS/Tag switching. In this example, Guilder and Damme are Cisco 3600s. If a 7500 is used, ip cef distributed must be enabled.

Note: Although not a requirement, this document uses VPI 2, 3, or 4 for all Tag VCs in this example.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

mpls_basic2.gif

Note: Loopback interfaces have been set on all routers/LSRs. They are not shown in the network diagram for the sake of simplicity.

Configurations

This document uses these configurations:

Pound
!         
interface Loopback0
 ip address 100.100.0.1 255.255.0.0
 no ip directed-broadcast
!         
interface Ethernet0/1
 ip address 123.123.0.2 255.255.0.0
 no ip directed-broadcast
!         
router ospf 1
 network 100.100.0.0 0.0.255.255 area 1.1.1.1
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
!

Guilder
!
ip cef
!
interface Loopback0
 ip address 102.102.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 123.123.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM1/0.1 tag-switching
 ip address 129.129.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 102.102.0.0 0.0.255.255 area 0.0.0.0
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Capri (8540MSR)
!
interface Loopback0
 ip address 103.103.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM3/0/0
 ip address 128.128.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
interface ATM3/0/3
 ip address 129.129.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 103.103.0.0 0.0.255.255 area 0.0.0.0
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Damme
!
ip cef
!
interface Loopback0
 ip address 104.104.0.1 255.255.0.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 125.125.0.1 255.255.0.0
 no ip directed-broadcast
 duplex auto
 speed 10
 tag-switching ip
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 0/16 ilmi
 !        
 pvc 0/5 qsaal
 !
!
interface ATM1/0.2 tag-switching
 ip address 128.128.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 104.104.0.0 0.0.255.255 area 0.0.0.0
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
!

Lira
!
interface Loopback0
 ip address 101.101.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 125.125.0.2 255.255.0.0
 no ip directed-broadcast
!
router ospf 1
 network 101.101.0.0 0.0.255.255 area 2.2.2.2
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
!

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show tag-switching forwarding-table—Shows the Tag Forwarding Information Base (TFIB).

  • show tag-switching atm-tdp bindings—Shows dynamic ATM tagging information.

  • show tag-switching int atm [int number] detail—Shows detailed per-interface tag switching information.

This output shows that the routing table is complete on Guilder:

Guilder#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     102.0.0.0/16 is subnetted, 1 subnets

C       102.102.0.0 is directly connected, Loopback0

     103.0.0.0/32 is subnetted, 1 subnets

O       103.103.0.1 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

     100.0.0.0/32 is subnetted, 1 subnets

O       100.100.0.1 [110/11] via 123.123.0.2, 23:45:47, Ethernet0/1

     101.0.0.0/32 is subnetted, 1 subnets

O IA    101.101.0.1 [110/13] via 129.129.0.2, 23:13:01, ATM1/0.1

O    128.128.0.0/16 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

C    129.129.0.0/16 is directly connected, ATM1/0.1

     125.0.0.0/16 is subnetted, 1 subnets

O IA    125.125.0.0 [110/12] via 129.129.0.2, 23:13:08, ATM1/0.1

     123.0.0.0/16 is subnetted, 1 subnets

C       123.123.0.0 is directly connected, Ethernet0/1

     104.0.0.0/32 is subnetted, 1 subnets

O       104.104.0.1 [110/3] via 129.129.0.2, 23:14:32, ATM1/0.1

Check the prefix to label/VC mapping with the show tag-switching forwarding-table command.

Guilder#show tag-switching forwarding-table 

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    

tag    tag or VC   or Tunnel Id      switched   interface              

26     Untagged    100.100.0.1/32    570        Et0/1      123.123.0.2  

27     2/33        103.103.0.1/32    0          AT1/0.1    point2point  

28     2/34        128.128.0.0/16    0          AT1/0.1    point2point  

29     2/35        104.104.0.1/32    0          AT1/0.1    point2point  

30     2/37        125.125.0.0/16    0          AT1/0.1    point2point  

31     2/38        101.101.0.1/32    0          AT1/0.1    point2point 

On Capri (the ATM LSR), you can check the TVC to route binding with the show tag atm-tdp bindings command. One TVC is used for each routing table entry.

Capri#show tag atm-tdp bindings 

 Destination: 103.103.0.0/16

    Tailend Switch ATM3/0/0 2/34 Active -> Terminating Active

    Tailend Switch ATM3/0/3 2/34 Active -> Terminating Active

 Destination: 129.129.0.0/16

    Tailend Switch ATM3/0/0 2/35 Active -> Terminating Active

 Destination: 101.101.0.1/32

    Transit ATM3/0/3 2/33 Active -> ATM3/0/0 2/36 Active

 Destination: 104.104.0.1/32

    Transit ATM3/0/3 2/35 Active -> ATM3/0/0 2/37 Active

 Destination: 125.125.0.0/16

    Transit ATM3/0/3 2/36 Active -> ATM3/0/0 2/38 Active

 Destination: 128.128.0.0/16

    Tailend Switch ATM3/0/3 2/37 Active -> Terminating Active

 Destination: 102.102.0.1/32

    Transit ATM3/0/0 2/53 Active -> ATM3/0/3 2/33 Active

 Destination: 100.100.0.1/32

    Transit ATM3/0/0 2/54 Active -> ATM3/0/3 2/34 Active

 Destination: 123.123.0.0/16

    Transit ATM3/0/0 2/55 Active -> ATM3/0/3 2/35 Active

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Nov 15, 2007
Document ID: 10467