Guest

MPLS

MPLS/VPN with EIGRP on the Customer Side Configuration Example

Cisco - MPLS/VPN with EIGRP on the Customer Side Configuration Example

Document ID: 40883

Updated: Jan 11, 2007

   Print

Introduction

This document provides a sample configuration of a Multiprotocol Label Switching (MPLS) Virtual Private Network (VPN) when EIGRP (Enhanced Interior Gateway Routing Protocol) is present on the customer side.

This document provides a sample configuration for EIGRP at the customer side in an MPLS/VPN environment. These scenarios are detailed:

  • Two connection endpoints (CEs) that belong to the same EIGRP autonomous systems.

  • Two CEs that belong to different EIGRP autonomous systems.

For both scenarios, you are presented with the configuration and verification steps. A sample of routing exchange for both protocols involved—Border Gateway Protocol (BGP) and EIGRP—is also provided.

When used with MPLS, the VPN feature allows several sites to interconnect transparently through a service provider network. One service provider network can support several different IP VPNs. Each of these appear to its users as a private network, separate from all other networks. Within a VPN, each site can send IP packets to any other site in the same VPN.

Each VPN is associated with one or more VPN routing/forwarding instances (VRFs). A VRF consists of an IP routing table, a derived Cisco Express Forwarding (CEF) table, and a set of interfaces that use this forwarding table.

The router maintains a separate routing and CEF table for each VRF. This prevents information being sent outside the VPN and allows the same subnet to be used in several VPNs without causing duplicate IP address problems.

The router that uses Multiprotocol BGP (MP-BGP) distributes the VPN routing information using the MP-BGP extended communities.

Refer to these documents for more information on the propagation of updates through a VPN:

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

The EIGRP between PE and CE in MPLS/VPN environment feature was introduced in Cisco IOS® Software Releases 12.0(22)S and 12.2(15)T.

Related Products

This configuration can also be used with these router series:

  • Cisco 7200

  • Cisco 7500

  • Cisco 10000

  • Cisco 10700

  • Cisco 12000

  • Cisco 12000 series Performance Route Processor (PRP)

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

EIGRP routes are converted to BGP routes on the service provider backbone by new EIGRP-specific extended community attributes. The provider edge (PE) router uses BGP to distribute the VPN routing information using the EIGRP-specific extended community attributes, which are appended to the BGP route. The BGP routes are converted back to EIGRP routes by the EIGRP-specific extended community attributes when they reach the PE router that is connected to the destination customer edge (CE) router.

This table describes the extended community attributes that are appended to BGP routes and used to carry EIGRP information across the service provider backbone.

EIGRP Attribute Type Usage Value
General 0x8800 EIGRP General Route Information Route Flag and Tag
Metric 0x8801 EIGRP Route Metric Information and Autonomous System Autonomous System and Delay
0x8802 EIGRP Route Metric Information Reliability, Next Hop, and Bandwidth
0x8803 EIGRP Route Metric Information Reserve, Load and Maximum Transmission Unit (MTU)
External 0x8804 EIGRP External Route Information Remote Autonomous System and Remote ID
0x8805 EIGRP External Route Information Remote Protocol and Remote Metric

Scenario 1: Configure a Single EIGRP Autonomous System

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Network Diagram

This section uses this network setup:

mplsvpneigrp1.gif

Configurations

This section uses these configurations:

PE-1
PE-1#show run
Building configuration...
ip cef

!--- vpn1 commands.

ip vrf vpn1

!--- Enables the VPN routing and forwarding (VRF) routing table.


!--- This command can be used in global or
 

!--- router configuration mode.
  
rd 100:1

!--- Route distinguisher creates routing and forwarding
 

!--- tables for a VRF.

route-target export 100:1

!--- Creates lists of import and export route-target extended
 

!--- communities for the specified VRF.
 
route-target import 100:1
!
interface Loopback0
 ip address 7.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip vrf forwarding vpn1

!--- Associates a VRF instance with an interface or subinterface.
 
ip address 9.0.1.1 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family ipv4 vrf vpn1

!--- To enter address family configuration mode
 

!--- for configuring EIGRP routing sessions,
 

!--- that use standard VPN version 4 address prefixes.
 
redistribute bgp 1

!--- Enables redistribution of bgp into this specific instance of EIGRP.
  
 network 9.0.0.0 
 default-metric 10000 1 255 1 1500 
 no auto-summary
 autonomous-system 10

!--- Defines the autonomous system number for this specific instance of EIGRP.
  
 exit-address-family
 !
router bgp 1
 no bgp default 
 ipv4-unicast bgp 
 log-neighbor-changes 
 neighbor 7.0.0.4 remote-as 1

!--- Adds an entry to the BGP or multiprotocol BGP neighbor table.

 neighbor 7.0.0.4 update-source Loopback0

!--- Enables BGP sessions to use a specific operational
 

!--- interface for TCP connections.

!
 address-family vpnv4

!--- To enter address family configuration mode
 

!--- for configuring routing sessions, such as BGP,
 

!--- that use standard VPN version 4 address prefixes.

 neighbor 7.0.0.4 activate
 neighbor 7.0.0.4 send-community both

!--- Sends the community attribute to a BGP neighbor.
 
 no auto-summary 
 exit-address-family
!
 address-family ipv4 
 neighbor 7.0.0.4 activate
 exit-address-family
!
 address-family ipv4 vrf vpn1
 redistribute eigrp 10

!--- Enables redistribution of EIGRP AS 10 into BGP.

 no auto-summary
 no synchronization
 exit-address-family
!
end

PE-4
PE-4#show running-config
Building configuration...
Current configuration : 2439 bytes
!
ip cef
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
!         
interface Loopback0
 ip address 7.0.0.4 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 6.0.2.3 255.255.255.0
 no ip directed-broadcast
 tag-switching ip
!
!
interface Serial2/0
 ip vrf forwarding vpn1
 ip address 10.1.2.1 255.255.255.252
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family ipv4 vrf vpn1
 redistribute bgp 1
 network 10.0.0.0
 default-metric 10000 1 255 1 1500
 no auto-summary
 autonomous-system 10
 exit-address-family
!
 router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.0.0.1 remote-as 1
 neighbor 7.0.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 7.0.0.1 activate
 neighbor 7.0.0.1 send-community extended
 no auto-summary
 exit-address-family
 !
 address-family ipv4
 redistribute connected
 neighbor 7.0.0.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute eigrp 10
 no auto-summary
 no synchronization
 network 13.0.0.1 mask 255.255.255.255
 exit-address-family
!
end

Verify

In order to verify your configuration, use a step-by-step approach and verify these points in order. Complete these steps:

  1. Verify that the EIGRP instance is configured on the desired interface—verify the vrf command and the eigrp network command under the correct address-family.

    In this example, the VRF is called vpn1.

    PE-1#show ip vrf vpn1
       Name                             Default RD          Interfaces
       vpn1                             100:1               Ethernet0/0
                                                           
    PE-1#show ip eigrp vrf vpn1 interfaces
     IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
    Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
    Et0/0            1         0/0    103          0/10         416          0
    PE-1#
  2. Verify that the EIGRP neighborship is established.

    In this example, you can see that 9.0.1.2 (CE-1) is a neighbor.

    PE-1#show ip eigrp vrf vpn1 neighbors
     IP-EIGRP neighbors for process 10
    H   Address            Interface      Hold Uptime   SRTT   RTO  Q  Seq Type
                                          (sec)         (ms)       Cnt Num
    0   9.0.1.2            Et0/0            13 00:30:19  103   618  0  9
       PE-1#
  3. Verify that the EIGRP topology table contains the local subnets learned via EIGRP (9.0.0.2/32).

    In this example, you can see that the EIGRP topology table also contains subnets learned across the MPLS/VPN backbone (10.1.2.0/30).

    The subnets are shown as learned via Redistributed and has a reported distance of 0.

    PE-1#show ip eigrp vrf vpn1 topology
     IP-EIGRP Topology Table for AS(10)/ID(9.0.0.1) Routing Table: vpn1
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
           r - Reply status
    P 10.1.3.0/24, 1 successors, FD is 2195456
             via Redistributed (2195456/0)
    P 9.0.1.0/24, 1 successors, FD is 281600
             via Connected, Ethernet0/0
    P 9.0.0.1/32, 1 successors, FD is 128256
             via Connected, Loopback1
    P 10.1.2.0/30, 1 successors, FD is 2169856
             via Redistributed (2169856/0)
    P 9.1.0.2/32, 1 successors, FD is 45867776
             via 9.0.1.2 (45867776/45842176), Ethernet0/0
    P 9.0.0.2/32, 1 successors, FD is 409600
             via 9.0.1.2 (409600/128256), Ethernet0/0
    P 10.0.0.6/32, 1 successors, FD is 2297856
             via Redistributed (2297856/0)
    P 13.0.0.1/32, 1 successors, FD is 256256
             via Redistributed (256256/0)
    PE-1#
  4. If subnets are missing, verify that they are in the BGP table with these show commands for one specific VRF.

    If the redistribution between BGP and EIRGP is not configured correctly, you might see the subnet in one table and not in the other.

    PE-1#show ip bgp vpnv4 vrf vpn1
    BGP table version is 45, local router ID is 7.0.0.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 100:1 (default for vrf vpn1)
    *> 9.0.0.1/32       0.0.0.0                  0         32768 ?
    *> 9.0.0.2/32       9.0.1.2             409600         32768 ?
    *> 9.0.1.0/24       0.0.0.0                  0         32768 ?
    *> 9.1.0.2/32       9.0.1.2           45867776         32768 ?
    *>i10.0.0.6/32      7.0.0.4            2297856    100      0 ?
    *>i10.1.2.0/30      7.0.0.4                  0    100      0 ?
    *>i10.1.3.0/24      7.0.0.4            2195456    100      0 ?
    *>i13.0.0.1/32      7.0.0.4                  0    100      0 i
    PE-1#
    
    PE-1#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
    BGP routing table entry for 100:1:9.0.0.1/32, version 12
    Paths: (1 available, best #1, table vpn1)
      Advertised to update-groups:
         1
               Local
        0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.1)
          Origin incomplete, metric 0, localpref 100, weight 32768, 
    valid, sourced, best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
     0x8802:65280:256 0x8803:65281:1514
    PE-1#
    
    PE-1# show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
    BGP routing table entry for 100:1:10.1.2.0/30, version 40
    Paths: (1 available, best #1, table vpn1)
      Not advertised to any peer
      Local
        7.0.0.4 (metric 139) from 7.0.0.4 (7.0.0.4)
          Origin incomplete, metric 0, localpref 100, valid, internal,
     best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:512000
     0x8802:65280:1657856 0x8803:65281:1500
    

    The same show commands must be used on the remote PE.

    In this example, the remote PE is PE-4:

    PE-4#show ip eigrp vrf vpn1 interfaces
     IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
    Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
    Se1/0             0        0/0         0       0/10           0           0
    Se2/0             1        0/0       100       0/15         415           0
    
    PE-4#show ip eigrp vrf vpn1 neighbors
     IP-EIGRP neighbors for process 10
    H   Address            Interface      Hold Uptime   SRTT   RTO  Q  Seq Type
                                          (sec)         (ms)       Cnt Num
    0   10.1.2.2           Se2/0            10 00:18:57  100   600  0  2   
    
    PE-4#show ip eigrp vrf vpn1 topology
     IP-EIGRP Topology Table for AS(10)/ID(13.0.0.1) Routing Table: vpn1
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
           r - Reply status
    P 10.1.3.0/24, 1 successors, FD is 2195456
             via 10.1.2.2 (2195456/281600), Serial2/0
    P 9.0.0.1/32, 1 successors, FD is 128256
             via Redistributed (128256/0)
    P 9.0.1.0/24, 1 successors, FD is 281600
             via Redistributed (281600/0)
    P 10.1.2.0/30, 1 successors, FD is 2169856
             via Connected, Serial2/0
    P 9.1.0.2/32, 1 successors, FD is 45867776
             via Redistributed (45867776/0)
    P 9.0.0.2/32, 1 successors, FD is 409600
             via Redistributed (409600/0)
    P 10.0.0.6/32, 1 successors, FD is 2297856
             via 10.1.2.2 (2297856/128256), Serial2/0
    P 13.0.0.1/32, 1 successors, FD is 256256
             via Redistributed (256256/0)
    
    PE-4#show ip bgp vpnv4 vrf vpn1
     BGP table version is 61, local router ID is 7.0.0.4
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    Route Distinguisher: 100:1 (default for vrf vpn1)
    *>i9.0.0.1/32       7.0.0.1                  0    100      0 ?
    *>i9.0.0.2/32       7.0.0.1             409600    100      0 ?
    *>i9.0.1.0/24       7.0.0.1                  0    100      0 ?
    *>i9.1.0.2/32       7.0.0.1           45867776    100      0 ?
    *> 10.0.0.6/32      10.1.2.2           2297856         32768 ?
    *> 10.1.2.0/30      0.0.0.0                  0         32768 ?
    *> 10.1.3.0/24      10.1.2.2           2195456         32768 ?
    *> 13.0.0.1/32      0.0.0.0                  0         32768 i
    
    PE-4#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
    BGP routing table entry for 100:1:9.0.0.1/32, version 45
    Paths: (1 available, best #1, table vpn1)
      Not advertised to any peer
      Local
        7.0.0.1 (metric 139) from 7.0.0.1 (7.0.0.1)
          Origin incomplete, metric 0, localpref 100, valid, internal,
     best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
     0x8802:65280:
    256 0x8803:65281:1514
    
    PE-4#show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
    BGP routing table entry for 100:1:10.1.2.0/30, version 56
    Paths: (1 available, best #1, table vpn1)
      Advertised to update-groups:
         1
               Local
        0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.4)
          Origin incomplete, metric 0, localpref 100, weight 32768, 
    valid, sourced,
     best
          Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:512000
     0x8802:65280:
    1657856 0x8803:65281:1500
    
    PE-4#
    CE-1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
    Gateway of last resort is not set
         9.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C       9.0.1.0/24 is directly connected, Ethernet0/0
    D       9.0.0.1/32 [90/409600] via 9.0.1.1, 1d02h, Ethernet0/0
    C       9.1.0.2/32 is directly connected, Loopback1
    C       9.0.0.2/32 is directly connected, Loopback0
         10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
    D       10.1.3.0/24 [90/2221056] via 9.0.1.1, 1d02h, Ethernet0/0
    D       10.1.2.0/30 [90/2195456] via 9.0.1.1, 1d02h, Ethernet0/0
    D       10.0.0.6/32 [90/2323456] via 9.0.1.1, 1d02h, Ethernet0/0
         13.0.0.0/32 is subnetted, 1 subnets
    D EX    13.0.0.1 [170/281856] via 9.0.1.1, 1d02h, Ethernet0/0

Troubleshooting

In this section, information about the eigrp query received by the PE and the corresponding BGP update sent through the MPLS/VPN cloud is provided. This is done for the subnet 10.0.0.6/32 directly connected to the router CE-4 at the right hand of the diagram. A 'shut' and 'no shut' performed on the loopback interface on CE-4 together with the appropriate debug command helps you to understand the tiggers.

Update Propagation in a Single Autonomous System

These debug commands are used to track subnet 10.0.0.6/32 (loopback address of CE-4) updates:

  • debug eigrp fsm

  • debug eigrp packets query reply request update

  • debug ip eigrp 10 10.0.0.6 255.255.255.255

  • debug ip bgp vpnv4

  • debug ip bgp update

This example shows an EIGRP entry withdrawn after a shut command is performed on the loopback0 interface on CE-4:

PE-4
*Apr 30 08:36:59.913: DUAL: dual_rcvquery():10.0.0.6/32 via 10.1.2.2 
metric 4294967295/4294967295, RD is 2297856
*Apr 30 08:36:59.913: DUAL: Find FS for dest 10.0.0.6/32. FD is 2297856, 
RD is 2297856
*Apr 30 08:36:59.913: DUAL:     10.1.2.2 metric 4294967295/4294967295 not
 found Dmin is 4294967295
*Apr 30 08:36:59.913: DUAL: Dest 10.0.0.6/32 (Split Horizon) not entering
 active state.
*Apr 30 08:36:59.913: DUAL: Send reply about 10.0.0.6/32 to 10.1.2.2
*Apr 30 08:36:59.965: vpn: bgp_router, vpn ipv4 redistQ len = 1
*Apr 30 08:36:59.965: BGP(2): route 100:1:10.0.0.6/32 down
*Apr 30 08:36:59.965: BGP(2): no valid path for 100:1:10.0.0.6/32
*Apr 30 08:36:59.965: BGP(2): nettable_walker 100:1:10.0.0.6/32 no best path
*Apr 30 08:37:00.085: DUAL: Removing dest 10.0.0.6/32, nexthop 10.1.2.2
*Apr 30 08:37:00.085: DUAL: No routes.  Flushing dest 10.0.0.6/32
*Apr 30 08:37:00.961: vpn: bgp_router, vpn ipv4 redistQ len = 1
*Apr 30 08:37:00.961: BGP(2): route 100:1:10.0.0.6/32 down
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 computing updates, afi 2, neighbor 
version 73, table version 74, starting at 0.0.0.0
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 send unreachable 100:1:10.0.0.6/32
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 send UPDATE 100:1:10.0.0.6/32 -- 
unreachable
*Apr 30 08:37:01.993: BGP(2): 1 updates (average = 45, maximum = 45)
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 updates replicated for neighbors:
*Apr 30 08:37:01.993: BGP(2): 7.0.0.1 update run completed, afi 2, ran for
 0ms, neighbor version 74, start version 74, throttled to 74
*Apr 30 08:37:05.925: BGP: Import walker start version 73, end version 
74*Apr 30 08:37:05.925: BGP: ... start import cfg version = 0

PE-1
*Apr 30 08:35:04.069: BGP(2): 7.0.0.4 rcv UPDATE about 100:1:10.0.0.6/32
 -- withdrawn
*Apr 30 08:35:04.069: BGP: Withdraw path from 7.0.0.4
*Apr 30 08:35:04.069: BGP(2): no valid path for 100:1:10.0.0.6/32
*Apr 30 08:35:04.089: BGP(2): nettable_walker 100:1:10.0.0.6/32 no best path
*Apr 30 08:35:04.109: DUAL: dual_rcvupdate(): 10.0.0.6/32 via Redistributed 
metric 4294967295/4294967295
*Apr 30 08:35:04.109: DUAL: Find FS for dest 10.0.0.6/32. FD is 2297856,
 RD is 2297856
*Apr 30 08:35:04.109: DUAL:     0.0.0.0 metric 4294967295/4294967295 not
 found Dmin is 4294967295
*Apr 30 08:35:04.109: DUAL: Dest 10.0.0.6/32 entering active state.
*Apr 30 08:35:04.109: DUAL: Set reply-status table. Count is 1.
*Apr 30 08:35:04.109: DUAL: Not doing split horizon
*Apr 30 08:35:04.137: EIGRP: Enqueueing QUERY on Ethernet0/0 iidbQ un/rely
 0/1 serno 35-35
*Apr 30 08:35:04.169: EIGRP: Sending QUERY on Ethernet0/0
*Apr 30 08:35:04.169:   AS 10, Flags 0x0, Seq 17/0 idbQ 0/0 iidbQ un/rely
 0/0 serno 35-35
*Apr 30 08:35:04.349: EIGRP: Received REPLY on Ethernet0/0 nbr 9.0.1.2
*Apr 30 08:35:04.349:   AS 10, Flags 0x0, Seq 16/17 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:35:04.349: DUAL: dest(10.0.0.6/32) active
*Apr 30 08:35:04.349: DUAL: dual_rcvreply(): 10.0.0.6/32 via 9.0.1.2 metric
 4294967295/4294967295
*Apr 30 08:35:04.349: DUAL: Count is 1*Apr 30 08:35:04.349: DUAL: Clearing
 handle 0, count is now 0
*Apr 30 08:35:04.349: DUAL: Freeing reply status table
*Apr 30 08:35:04.349: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:35:04.349: DUAL: Removing dest 10.0.0.6/32, nexthop 0.0.0.0
*Apr 30 08:35:04.349: DUAL: Removing dest 10.0.0.6/32, nexthop 9.0.1.2
*Apr 30 08:35:04.349: DUAL: No routes.  Flushing dest 10.0.0.6/32

PE-1#
CE-1
*Apr 30 08:26:30.813: EIGRP: Received QUERY on Ethernet0/0 nbr 9.0.1.1
*Apr 30 08:26:30.813:   AS 10, Flags 0x0, Seq 13/0 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:26:30.813: DUAL: dual_rcvquery():10.0.0.6/32 via 9.0.1.1 metric
 4294967295/4294967295, RD is 2323456
*Apr 30 08:26:30.813: DUAL: Find FS for dest 10.0.0.6/32. FD is 2323456,
 RD is 2323456
*Apr 30 08:26:30.813: DUAL:     9.0.1.1 metric 4294967295/4294967295 not
 found Dmin is 4294967295
*Apr 30 08:26:30.813: DUAL: Dest 10.0.0.6/32 (Split Horizon) not entering
 active state.
*Apr 30 08:26:30.813: DUAL: Send reply about 10.0.0.6/32 to 9.0.1.1
*Apr 30 08:26:30.849: EIGRP: Enqueueing REPLY on Ethernet0/0 nbr 9.0.1.1 
iidbQ un/rely 0/1 peerQ un/rely 0/0 serno 31-31
*Apr 30 08:26:30.877: EIGRP: Sending REPLY on Ethernet0/0 nbr 9.0.1.1
*Apr 30 08:26:30.877:   AS 10, Flags 0x0, Seq 12/13 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/1 serno 31-31
*Apr 30 08:26:30.989: DUAL: Removing dest 10.0.0.6/32, nexthop 9.0.1.1
*Apr 30 08:26:30.989: DUAL: No routes.  Flushing dest 10.0.0.6/32

This example shows the creation of an EIGRP entry after a no shut command is performed on the loopback0 interface on CE-4:

PE-4
*Apr 30 08:38:53.685: DUAL: dest(10.0.0.6/32) not active
*Apr 30 08:38:53.685: DUAL: dual_rcvupdate(): 10.0.0.6/32 via 10.1.2.2
 metric 2297856/128256
*Apr 30 08:38:53.685: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:38:53.685: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:38:53.685: DUAL: RT installed 10.0.0.6/32 via 10.1.2.2
*Apr 30 08:38:53.685: DUAL: Send update about 10.0.0.6/32.  Reason: metric chg
*Apr 30 08:38:53.685: DUAL: Send update about 10.0.0.6/32.  Reason: new if
*Apr 30 08:38:53.745: vpn: bgp_router, vpn ipv4 redistQ len = 1
*Apr 30 08:38:53.745: BGP(2): route 100:1:10.0.0.6/32 up
*Apr 30 08:38:53.745: vpn: bgp allocate label: route_tag_change for 
vpn1:10.0.0.6/255.255.255.255
*Apr 30 08:38:53.745: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:38:53.745: vpn: intag=21, outtag=unknown, outtag owner=BGP
*Apr 30 08:38:53.745: BGP(2): nettable_walker 100:1:10.0.0.6/32 route 
sourced locally
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 computing updates, afi 2, neighbor
 version 77, table version 78, starting at 0.0.0.0
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 send UPDATE (format) 100:1:10.0.0.6/32,
 next 7.0.0.4, metric 2297856, path , extended community RT:100:1 0x8800:32768:0
 0x8801:10:640000 0x8802:65281:1657856 0x8803:65281:1500
*Apr 30 08:38:55.813: BGP(2): 1 updates (average = 123, maximum = 123)
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 updates replicated for neighbors:
*Apr 30 08:38:55.813: BGP(2): 7.0.0.1 update run completed, afi 2, ran 
for 0ms, neighbor version 78, start version 78, throttled to 78
*Apr 30 08:39:07.053: BGP: Import walker start version 77, end version 78
*Apr 30 08:39:07.053: BGP: ... start import cfg version = 0
*Apr 30 08:39:07.053: vpn: vpn1 same RD import, do best path
*Apr 30 08:39:07.053: vpn: bgp allocate label: route_tag_change for 
vpn1:10.0.0.6/255.255.255.255
*Apr 30 08:39:07.053: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:39:07.053: vpn: intag=21, outtag=unknown, outtag owner=BGP
*Apr 30 08:39:07.305: BGP(2): nettable_walker 100:1:10.0.0.6/32 route 
sourced locally
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 computing updates, afi 2, neighbor
 version 78, table version 79, starting at 0.0.0.0
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 send UPDATE (format) 100:1:10.0.0.6/32,
 next 7.0.0.4, metric 2297856, path , extended community RT:100:1 0x8800:32768:0
 0x8801:10:640000 0x8802:65281:1657856 0x8803:65281:1500
*Apr 30 08:39:09.413: BGP(2): 1 updates (average = 123, maximum = 123)
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 updates replicated for neighbors:
*Apr 30 08:39:09.413: BGP(2): 7.0.0.1 update run completed, afi 2, ran for 
0ms, neighbor version 79, start version 79, throttled to 79

PE-1
*Apr 30 08:35:36.409: BGP: 7.0.0.3 multihop open delayed 15100ms (no route) 
*Apr 30 08:35:37.981: BGP: Incoming path from 7.0.0.4
*Apr 30 08:35:37.981: BGP(2): 7.0.0.4 rcvd UPDATE w/ attr: nexthop 7.0.0.4,
 origin ?, localpref 100, metric 2297856, extended community RT:100:1 
0x8800:32768:0 0x8801:10:640000 0x8802:65281:1657856 0x8803:65281:1500
*Apr 30 08:35:37.981: BGP(2): 7.0.0.4 rcvd 100:1:10.0.0.6/32
*Apr 30 08:35:37.981: vpn: bgp_vpnv4_bnetinit: 100:1:10.0.0.6/32
*Apr 30 08:35:37.981: BGP: Accepted path from 7.0.0.4
*Apr 30 08:35:38.001: BGP(2): nettable_walker 100:1:10.0.0.6/32 no RIB
*Apr 30 08:35:38.189: BGP(2): 7.0.0.4 computing updates, afi 2, neighbor
 version 55, table version 56, starting at 0.0.0.0
*Apr 30 08:35:38.189: BGP(2): 7.0.0.4 update run completed, afi 2, 
ran for 0ms, neighbor version 56, start version 56, throttled to 56
*Apr 30 08:35:39.081: BGP: 7.0.0.2 multihop open delayed 16412ms (no route)
*Apr 30 08:35:50.437: BGP: Import walker start version 55, end version 56
*Apr 30 08:35:50.437: BGP: ... start import cfg version = 0
*Apr 30 08:35:50.437: vpn: vpn1 same RD import, do best path
*Apr 30 08:35:50.869: BGP(2): Revise route installing 1 of 1 route 
for10.0.0.6/32 -> 7.0.0.4(main) to vpn1 IP table
*Apr 30 08:35:50.889: DUAL: dest(10.0.0.6/32) not active
*Apr 30 08:35:50.889: DUAL: dual_rcvupdate(): 10.0.0.6/32 via Redistributed
 metric 2297856/0
*Apr 30 08:35:50.889: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:35:50.889: DUAL: RT installed 10.0.0.6/32 via 0.0.0.0
*Apr 30 08:35:50.889: DUAL: Send update about 10.0.0.6/32.  Reason: 
metric chg
*Apr 30 08:35:50.889: DUAL: Send update about 10.0.0.6/32.  Reason:
new if
*Apr 30 08:35:50.929: EIGRP: Enqueueing UPDATE on Ethernet0/0 iidbQ 
un/rely 0/1 serno 36-36
*Apr 30 08:35:50.957: EIGRP: Sending UPDATE on Ethernet0/0
*Apr 30 08:35:50.957:   AS 10, Flags 0x0, Seq 18/0 idbQ 0/0 iidbQ un/rely
 0/0 serno 36-36
*Apr 30 08:35:51.149: EIGRP: Received UPDATE on Ethernet0/0 nbr 9.0.1.2
*Apr 30 08:35:51.149:   AS 10, Flags 0x0, Seq 17/0 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:35:51.417: vpn: tag_vpn_find_route_tags: 100:1:10.0.0.6
*Apr 30 08:35:51.417: vpn: intag=vpn-route, outtag=20, outtag owner=BGPCE-1
*Apr 30 08:28:17.669: EIGRP: Received UPDATE on Ethernet0/0 nbr 9.0.1.1
*Apr 30 08:28:17.669:   AS 10, Flags 0x0, Seq 14/0 idbQ 0/0 iidbQ un/rely
 0/0 peerQ un/rely 0/0
*Apr 30 08:28:17.669: DUAL: dest(10.0.0.6/32) not active
*Apr 30 08:28:17.669: DUAL: dual_rcvupdate(): 10.0.0.6/32 via 9.0.1.1 
metric 2323456/2297856
*Apr 30 08:28:17.669: DUAL: Find FS for dest 10.0.0.6/32. FD is 4294967295,
 RD is 4294967295 found
*Apr 30 08:28:17.669: DUAL: RT installed 10.0.0.6/32 via 9.0.1.1
*Apr 30 08:28:17.669: DUAL: Send update about 10.0.0.6/32.  Reason:
 metric chg
*Apr 30 08:28:17.669: DUAL: Send update about 10.0.0.6/32.  Reason:
 new if
*Apr 30 08:28:17.709: EIGRP: Enqueueing UPDATE on Ethernet0/0 iidbQ 
un/rely 0/1 serno 32-32
*Apr 30 08:28:17.737: EIGRP: Sending UPDATE on Ethernet0/0
*Apr 30 08:28:17.737:   AS 10, Flags 0x0, Seq 13/0 idbQ 0/0 iidbQ un/rely
 0/0 serno 32-32

Scenario 2: Configure a Multiple EIGRP Autonomous System

Network Diagram

This section uses this network setup:

mplsvpneigrp2.gif

Configurations

This section uses these configurations:

PE-1
PE-1#show run
Building configuration...
ip cef
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface Loopback0
 ip address 7.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 9.0.1.1 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family ipv4 vrf vpn1
 redistribute bgp 1
 network 9.0.0.0
 default-metric 10000 1 255 1 1500
 no auto-summary
 autonomous-system 10
 exit-address-family
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.0.0.4 remote-as 1
 neighbor 7.0.0.4 update-source Loopback0
!
 address-family vpnv4
 neighbor 7.0.0.4 activate
 neighbor 7.0.0.4 send-community both
 no auto-summary exit-address-family
!
 address-family ipv4
 neighbor 7.0.0.4 activate
 exit-address-family
!
 address-family ipv4 vrf vpn1
 redistribute eigrp 10
 no auto-summary
 no synchronization
 exit-address-family
!
end

PE-4
PE-4#show running-config
Building configuration...
Current configuration : 2439 bytes
!
ip cef
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
!
interface Loopback0
 ip address 7.0.0.4 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 6.0.2.3 255.255.255.0
 no ip directed-broadcast
 tag-switching ip
!
!
interface Serial2/0
 ip vrf forwarding vpn1
 ip address 10.1.2.1 255.255.255.252
 no ip directed-broadcast
!
router eigrp 1
 !
 address-family
 ipv4 vrf vpn1
 redistribute bgp 1
 network 10.0.0.0
 default-metric 10000 1 255 1 1500
 no auto-summary
 autonomous-system 20   

!--- The autonomous system is different from Scenario 1.

 exit-address-family
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.0.0.1 remote-as 1
 neighbor 7.0.0.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 7.0.0.1 activate
 neighbor 7.0.0.1 send-community extended
 no auto-summary
 exit-address-family
 !
 address-family ipv4
 redistribute connected
 neighbor 7.0.0.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute eigrp 20  

!--- The autonomous system is different from Scenario 1.

 no auto-summary
 no synchronization
 network 13.0.0.1 mask 255.255.255.255
 exit-address-family
!
end

Verify

Use these commands to verify your configuration:

  • show ip eigrp vrf vpn1 interfaces

  • show ip eigrp vrf vpn1 neighbors

  • show ip eigrp vrf vpn1 topology

IP-EIGRP Topology Table for AS(10)/ID(9.0.0.1) Routing Table: vpn1
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status
P 10.1.3.0/24, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.0.1.0/24, 1 successors, FD is 281600
         via Connected, Ethernet0/0
P 9.0.0.1/32, 1 successors, FD is 128256
         via Connected, Loopback1
P 10.1.2.0/30, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.1.0.2/32, 1 successors, FD is 45867776
         via 9.0.1.2 (45867776/45842176), Ethernet0/0
P 9.0.0.2/32, 1 successors, FD is 409600
         via 9.0.1.2 (409600/128256), Ethernet0/0
P 13.0.0.1/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.0.0.6/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.0.0.7/32, 1 successors, FD is 256256
         via Redistributed (256256/0)

PE-1#show ip bgp vpnv4 vrf vpn1
 BGP table version is 99, local router ID is 7.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best,
 i - internal,

              S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*> 9.0.0.1/32       0.0.0.0                  0         32768 ?
*> 9.0.0.2/32       9.0.1.2             409600         32768 ?
*> 9.0.1.0/24       0.0.0.0                  0         32768 ?
*> 9.1.0.2/32       9.0.1.2           45867776         32768 ?
*>i10.0.0.6/32      7.0.0.4            2297856    100      0 ?
*>i10.0.0.7/32      7.0.0.4            2323456    100      0 ?
*>i10.1.2.0/30      7.0.0.4                  0    100      0 ?
*>i10.1.3.0/24      7.0.0.4            2195456    100      0 ?
*>i13.0.0.1/32      7.0.0.4                  0    100      0 i

PE-1#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
BGP routing table entry for 100:1:9.0.0.1/32, version 12
Paths: (1 available, best #1, table vpn1)
  Advertised to update-groups:
     1
           Local
    0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.1)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid,
 sourced, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
 0x8802:65280:256 0x8803:65281:1514

PE-1#show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
BGP routing table entry for 100:1:10.1.2.0/30, version 95
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    7.0.0.4 (metric 139) from 7.0.0.4 (7.0.0.4)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:20:512000 
 0x8802:65280:1657856 0x8803:65281:1500

PE-1#
PE-4#show ip eigrp vrf vpn1 interfaces <output removed>
PE-4#show ip eigrp vrf vpn1 neighbors <output removed>
PE-4#show ip eigrp vrf vpn1 topology
IP-EIGRP Topology Table for AS(20)/ID(13.0.0.1) Routing Table: vpn1
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status
P 9.0.1.0/24, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.0.0.1/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.1.3.0/24, 1 successors, FD is 2195456
         via 10.1.2.2 (2195456/281600), Serial2/0
P 10.1.2.0/30, 1 successors, FD is 2169856
         via Connected, Serial2/0
P 9.1.0.2/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 9.0.0.2/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 13.0.0.1/32, 1 successors, FD is 256256
         via Redistributed (256256/0)
P 10.0.0.6/32, 1 successors, FD is 2297856
         via 10.1.2.2 (2297856/128256), Serial2/0
P 10.0.0.7/32, 1 successors, FD is 2323456
         via 10.1.2.2 (2323456/409600), Serial2/0

PE-4#show ip bgp vpnv4 vrf vpn1
BGP table version is 23, local router ID is 7.0.0.4
Status codes: s suppressed, d damped, h history, * valid, > best,
 i - internal,
              S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*>i9.0.0.1/32       7.0.0.1                  0    100      0 ?
*>i9.0.0.2/32       7.0.0.1             409600    100      0 ?
*>i9.0.1.0/24       7.0.0.1                  0    100      0 ?
*>i9.1.0.2/32       7.0.0.1           45867776    100      0 ?
*> 10.0.0.6/32      10.1.2.2           2297856         32768 ?
*> 10.0.0.7/32      10.1.2.2           2323456         32768 ?
*> 10.1.2.0/30      0.0.0.0                  0         32768 ?
*> 10.1.3.0/24      10.1.2.2           2195456         32768 ?
*> 13.0.0.1/32      0.0.0.0                  0         32768 i

PE-4#show ip bgp vpnv4 vrf vpn1 9.0.0.1 255.255.255.255
BGP routing table entry for 100:1:9.0.0.1/32, version 13
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    7.0.0.1 (metric 139) from 7.0.0.1 (7.0.0.1)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:10:128000
 0x8802:65280:256 0x8803:65281:1514

PE-4#show ip bgp vpnv4 vrf vpn1 10.1.2.0 255.255.255.252
BGP routing table entry for 100:1:10.1.2.0/30, version 19
Paths: (1 available, best #1, table vpn1)
  Advertised to update-groups:
     1
           Local
    0.0.0.0 (via vpn1) from 0.0.0.0 (7.0.0.4)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid,
 sourced, best
      Extended Community: RT:100:1 0x8800:32768:0 0x8801:20:512000
 0x8802:65280:1657856 0x8803:65281:1500

PE-4#
CE-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
Gateway of last resort is not set
     9.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       9.0.1.0/24 is directly connected, Ethernet0/0
D       9.0.0.1/32 [90/409600] via 9.0.1.1, 1d06h, Ethernet0/0
C       9.1.0.2/32 is directly connected, Loopback1
C       9.0.0.2/32 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
D EX    10.1.3.0/24 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
D EX    10.1.2.0/30 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
D EX    10.0.0.6/32 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
D EX    10.0.0.7/32 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0
     13.0.0.0/32 is subnetted, 1 subnets
D EX    13.0.0.1 [170/281856] via 9.0.1.1, 00:27:15, Ethernet0/0

CE-1#show ip eigrp topology 10 10.1.2.0 255.255.255.252
IP-EIGRP topology entry for 10.1.2.0/30
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281856
  Routing Descriptor Blocks:
  9.0.1.1 (Ethernet0/0), from 9.0.1.1, Send flag is 0x0
      Composite metric is (281856/256256), Route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1010 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 9.0.0.1
        AS number of route is 1
        External protocol is BGP, external metric is 0
        Administrator tag is 0 (0x00000000)
CE-1#

Related Information

Updated: Jan 11, 2007
Document ID: 40883