Guest

Asymmetric Digital Subscriber Line (ADSL)

Cisco DSL Router Configuration and Troubleshooting Guide - IRB with a Static IP Address

Document ID: 71103

Updated: Sep 11, 2006

   Print

Introduction

Your Internet Service Provider (ISP) has assigned a static public IP address to your Cisco DSL Router.

Tip: If you are not familiar with how to configure Cisco devices and would like to follow a step-by-step configuration, refer to Step-by-Step Configuration of IRB with a Static IP Address.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Tasks to Perform

Note: This example highlights two types of configurations:

  • Dynamic Host Configuration Protocol (DHCP) Server

  • Network Address Translation (NAT).

The tasks to perform are:

  • Design an IP addressing scheme for your private LAN.

  • Configure an IP address and subnet mask on the Cisco DSL Router Ethernet interface.

  • Configure the ATM interface (Asymmetric Digital Subscriber Line (ADSL) interface) of the Cisco DSL Router with an ATM permanent virtual circuit (PVC) and encapsulation.

  • Enable integrated routing and bridging (IRB).

  • Create and configure the Bridge Group Virtual Interface (BVI) of the Cisco DSL Router for IRB with a static IP address.

  • For NAT: Configure NAT on the Cisco DSL Router in order to allow sharing of the static public IP address of the BVI interface.

    • Optional: NAT Pool, if additional IP addresses have been provided by your ISP.

    • Optional: Static NAT, if Internet users require access to internal servers.

  • Configure each host PC with an IP address, subnet mask, default gateway, and Domain Name System (DNS) server(s).

    For DHCP Server: Alternatively, if you want the Cisco DSL Router to assign the dynamic IP addresses of your PC client, configure each PC to obtain an IP address and DNS server(s) automatically via DHCP.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Configuration

Tip: If you are not familiar with how to configure Cisco devices and would like to follow a step-by-step configuration, refer to Step-by-Step Configuration of IRB with a Static IP Address.

Cisco DSL Router with a Static IP Address

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
!
bridge irb
!
ip subnet-zero
!

!--- For DHCP Server:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>

!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 
!--- For NAT:


 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
 bridge-group 1
!
interface bvi1
 ip address <ip address> <subnet mask>

!--- For NAT:


 ip nat outside
 no ip directed-broadcast
!

!--- For NAT:


ip nat inside source list 1 interface bvi1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface bvi1 overload
!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!--- netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, the configuration of  
!--- access-list 1 permit 10.10.10.0 0.0.0.255 allows NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
bridge 1 protocol ieee
 bridge 1 route ip
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

Refer to Troubleshooting RFC1483 Bridging with IRB if your ADSL service does not work properly.

Return to the previous page of this configuration and troubleshooting guide - RFC1483 Bridging with IRB Implementation Options.

Return to the main page of the Cisco DSL Router Configuration and Troubleshooting Guide.

Related Information

Updated: Sep 11, 2006
Document ID: 71103