Guest

Asymmetric Digital Subscriber Line (ADSL)

Configuring a Cisco 1700/2600/3600 ADSL WIC With IRB and NAT Using RFC1483 Bridging

Cisco - Configuring a Cisco 1700/2600/3600 ADSL WIC With IRB and NAT Using RFC1483 Bridging

Document ID: 12969

Updated: Feb 26, 2008

   Print

Introduction

The Cisco 1700, 2600, and 3600 Series Routers support the Asymmetric Digital Subscriber Line (ADSL) WAN Interface Card (WIC). All three platforms are configured essentially the same, but there are differences in hardware and in the Cisco IOS® Software release required for each one. Throughout this document the Cisco 1700/2600/3600 will be called the "Cisco ADSL WIC."

This sample configuration shows a Cisco ADSL WIC that is connected to a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM), terminating on a Cisco 6400 Universal Access Concentrator (UAC).

The Cisco ADSL WIC, configured with RFC1483 Bridging and integrated routing and bridging (IRB), runs network address translation (NAT).

The Cisco 6400 ATM interface is configured with routed bridge encapsulation (RBE).

For the Cisco 6400, the ATM RBE feature on the Cisco 6400 node route processor (NRP) routes IP over bridged RFC1483 Ethernet traffic from a stub-bridged LAN.

Bridged IP packets received on an ATM interface configured in route-bridged mode are routed via the IP header. The interfaces take advantage of the characteristics of a stub LAN topology commonly used for DSL access and offer increased performance and flexibility over IRB.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco 6400 UAC-NRP IOS Software Release 12.1(3)DC1

  • Cisco 6400 UAC-Node Switch Processor (NSP) IOS Software Release 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(5)DA

  • For ADSL WIC on the Cisco 2600 - Chassis WIC slots and NM-2W

  • For ADSL WIC on the Cisco 3600 - NM-1FE1R2W, NM-1FE2W, NM-2FE2W, and NM-2W

Note: For the Cisco 3600, the following do not support the ADSL WIC:

  • NM-1E1R2W

  • NM-1E2W

  • NM-2E2W

To support the ADSL WIC, the following minimum Cisco IOS Software releases are required:

  • Cisco IOS Software Release 12.1(5)YB (Plus versions only) on the Cisco 2600/3600.

  • Cisco IOS Software Release 12.1(3)XJ or later (Plus versions or ADSL feature set only) on the Cisco 1700. The ADSL feature set is identified by "y7" in the image name; for example, c1700-sy7-mz.121-3.XJ.bin.

    When you download the image for the Cisco 1700, make sure you select the image name of 1700. Do not download a 1720 or a 1750 image; the features will not support the ADSL WIC.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

wicadsl_rfc_irb_nat_1.gif

Configurations

This document uses the configurations shown below.

Cisco ADSL WIC
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address 172.16.0.1 255.255.0.0 
 no ip directed-broadcast 
 ip Nat outside 
! 
ip Nat inside source list 1 interface BVI1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 <next hop IP address>

!--- The next hop IP address is also called the default
!--- gateway and is provided by your ISP. For this example,
!--- one valid default gateway could be the loopback 
!--- interface of the Cisco 6400 NRP, 172.16.0.2.

no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
end 

Cisco 6400 NRP - Example 1
Current configuration: 
! 
version 12.0 
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 172.16.0.2 255.255.0.0 
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--The interface ATM0/0/0.4 point-to-point uses IP 
!--unnumbered Loopback1 for its IP address requirements.
 
 ip unnumbered Loopback1 
 no ip directed-broadcast 
 no ip route-cache 
 ATM route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 172.16.0.1 255.255.255.255 ATM0/0/0.4 
end 

Cisco 6400 NRP - Example 2
Current configuration: 
! 
version 12.0 
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-CPU 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point 
 ip address 172.16.0.2 255.255.0.0 
 no ip directed-broadcast 
 no ip route-cache 
 ATM route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 172.16.0.1 255.255.255.255 ATM0/0/0.4
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 12969