Guest

Asymmetric Digital Subscriber Line (ADSL)

Configuring a Cisco 1700/2600/3600 ADSL WIC With NAT, a DHCP Server, and Easy IP Using PPPoA (aal5mux ppp)

Document ID: 12962

Updated: Feb 26, 2008

   Print

Introduction

The Cisco 1700, 2600, and 3600 Series routers support the Asymmetric Digital Subscriber Line (ADSL) WAN Interface Card (WIC). All the three platforms are configured essentially the same. However, there are differences present in the hardware and in the Cisco IOS® Software release required for each one. Throughout this document, the Cisco 1700/2600/3600 is referred to as the Cisco ADSL WIC.

This document shows a Cisco ADSL WIC that connects to a Cisco 6130 DSL access multiplexer (DSLAM) and terminats on a Cisco 6400 Universal Access Concentrator (UAC). The Cisco ADSL WIC router has been configured with PPP over ATM (PPPoA) with Network Address Translation (NAT) and IP address negotiation turned on. The Cisco ADSL WIC also functions as a server for its local Ethernet clients.

Prerequisites

Requirements

Before attempting this configuration, ensure that you meet these requirements. Before you attempt this configuration, ensure that you use one of the these prerequisite software releases:

  • Cisco 6400 UAC-NRP IOS Software Release 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS Software Release 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(5)DA

Components Used

The information in this document is based on these software and hardware versions.

To support the ADSL WIC on the Cisco 2600/3600, these hardware products are required:

  • 2600: Chassis WIC slots, NM-2W

  • 3600: NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W

Note: For the Cisco 3600, ADSL is not supported on WIC NM-1E1R2W, NM-1E2W, or NM-2E2W.

To support the ADSL WIC, a minimum of these Cisco IOS Software releases are required:

  • Cisco IOS Software Release 12.1(5)YB (Plus versions only) on the Cisco 2600/3600

  • Cisco IOS Software Release IOS 12.1(3)XJ or later (Plus versions or ADSL feature set only) on the Cisco 1700. The ADSL feature set is identified by "y7" in the image name; for example, c1700-sy7-mz.121-3.XJ.bin.

Note: When you download the image for the Cisco 1700, ensure that you select the image name of 1700. Do not download a 1720 or a 1750 image; the features do not support the ADSL WIC.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, use the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup shown in the diagram .

wicadsl_pppoa_nat_dhcp_12962a.gif

Configurations

This document uses these configurations .

Cisco ADSL WIC
! version 12.1 
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1 
!
ip dhcp pool pool name
 
 network 10.0.0.0 255.0.0.0
   default-router 10.0.0.1 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside 
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
 ip address negotiated 
 no ip directed-broadcast 
 ip nat outside 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp pap sent-username username password password

! 
ip nat inside source list 1 interface Dialer0 overload
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 1 protocol ip permit
! 
end

Cisco Access 6400 NRP1
! interface ATM0/0/0.200 point-to-point 

!--- The username and password values must match
!--- the username and password values of the remote device.

 no ip directed-broadcast
 no ip route-cache
 pvc 1/301
  encapsulation aal5mux ppp Virtual-Template11 
!
interface Virtual-Template11 
 ip unnumbered Ethernet0/0/0 
 no ip directed-broadcast 
 peer default ip address pool pool name

 ppp authentication pap 
!
ip local pool pool name 172.17.0.1 172.17.0.10

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 12962