Guest

Asymmetric Digital Subscriber Line (ADSL)

Configuring a Cisco 1700/2600/3600 ADSL WIC With a Single IP Address, DHCP, PPPoA, and PPP-PAP

Document ID: 12958

Updated: Jun 01, 2005

   Print

Introduction

The Cisco 1700, 2600, and 3600 Series Routers support the Asymmetric Digital Subscriber Line (ADSL) WAN Interface Card (WIC). All the three platforms are configured in the same way. However, there are differences in the hardware and in the Cisco IOS Software release required for each one. Throughout this document the Cisco 1700/2600/3600 is called the "Cisco ADSL WIC."

This document shows a Cisco ADSL WIC connected to a Cisco 6130 DSL Access Multiplexer (DSLAM). It terminates on a Cisco 6400 Universal Access Concentrator (UAC). The Cisco ADSL WIC is configured as a Dynamic Host Configuration Protocol (DHCP) server with PPP over ATM (PPPoA).

The Internet Service Provider (ISP) gives the subscriber a single IP address, 172.18.0.1, for Internet connectivity. However, the subscriber has a small network of PCs and wants to have Internet access for all the devices.

The solution is to configure Network Address Translation (NAT) on the Cisco ADSL WIC. NAT is designed for IP address simplification and conservation. It enables private IP internetworks that use nonregistered IP addresses to connect to the Internet. NAT operates on a router that usuallyconnects two networks. It translates the private (in this case the 10.0.0.0 network) addresses in the internal network to the legal (in this case 172.18.0.1) addresses before the packets are forwarded to another network. As apart of this function, NAT is configured to advertise only one address (172.18.0.1) for the entire network. This provides additional security by effectively hiding the entire internal network behind that address.

NAT has a dual function of security and address conservation that is implemented in remote access environments. An IP address of 10.0.0.1 is manually configured on the Ethernet interface of the Cisco ADSL WIC. The Cisco ADSL WIC is configured to act as a DHCP server. It leases IP addresses to local LAN devices attached to its Ethernet network.

This configuration shows NAT configured for the Ethernet and ATM interfaces. The Ethernet0 interface has an IP address of 10.0.0.1 with a subnet mask of 255.0.0.0. NAT is configured for inside. This means that the interface is connected to the inside network sthat is subjected to NAT translation. The ATM interface "Dialer0" has an IP address of 172.18.0.1 and a subnet mask of 255.255.0.0. NAT is configured for outside. This means that the interface is connected to an outside network, such as the Internet.

Prerequisites

Requirements

Before you attempt this configuration, ensure that you meet these requirements. To support the ADSL WIC on the Cisco 2600/3600, thishardware is required:

  • 2600: Chassis WIC slots, NM-2W

  • 3600: NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W

    Note: For the Cisco 3600, t these donot support the ADSL WIC: NM-1E1R2W, NM-1E2W, NM-2E2W.

To support the ADSL WIC, these Cisco IOS Software releases are required:

  • Cisco IOS Software Release 12.1(5)YB (Plus versions only) on the Cisco 2600/3600.

  • Cisco IOS Software Release IOS 12.1(3)XJ or later (Plus versions or ADSL feature set only) on the Cisco 1700. The ADSL feature set is identified by "y7" in the image name; for example, c1700-sy7-mz.121-3.XJ.bin.

    Note: When you download the image for the Cisco 1700, make sure you select the image name of 1700. Do not download a 1720 or a 1750 image. The features will not support the ADSL WIC.

Components Used

The information in this document is based on these software and hardware versions .

  • Cisco 6400 UAC-NRP IOS Software Release 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS Software Release 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(5)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in this diagram .

wicadsl_dhcp_1ip.gif

Configuration

This document uses this configuration .

Cisco ADSL WIC
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- the DHCP pool  does not lease this address; 
!--- it is  used by interface FastEthernet0

!
ip dhcp pool poolname

network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1
 
!--- default gateway  is assigned to local devices

! 
interface FastEthernet0
 ip address 10.0.0.1 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username username password password

! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 

end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jun 01, 2005
Document ID: 12958