Guest

Asymmetric Digital Subscriber Line (ADSL)

Configuring a Cisco 1700/2600/3600 ADSL WIC and a Cisco 6400 in RBE Mode Using RFC1483 Bridging

Document ID: 12957

Updated: Feb 26, 2008

   Print

Introduction

The Cisco 1700, 2600, and 3600 Series Routers support the asymmetric digital subscriber line (ADSL) WAN interface card (WIC). All three platforms are configured in the same way. However, there are differences in hardware and in the Cisco IOS® Software Release required for each one. Throughout this document the Cisco 1700/2600/3600 is called the "Cisco ADSL WIC."

This sample configuration shows a Cisco ADSL WIC connected to a Cisco 6130 digital subscriber line access multiplexer (DSLAM). It terminates on a Cisco 6400 Universal Access Concentrator (UAC).

The Cisco ADSL WIC is configured with RFC 1483 Bridging. The Cisco 6400 is configured with routed bridge encapsulation (RBE).

The ATM RBE feature in the Cisco 6400 node route processor (NRP) routes IP over bridged RFC 1483 Ethernet traffic from a stub-bridged LAN.

Bridged IP packets received on an ATM interface configured in route-bridge mode are routed through an IP header. The interface takes advantage of the characteristics of a stub LAN topology commonly used for DSL access. It offers increased performance and flexibility over integrated routing and bridging (IRB).

Prerequisites

Requirements

Before you attempt this configuration, ensure that you meet these prerequisites. To support the ADSL WIC, at least these Cisco IOS Software Releases are required:

  • Cisco IOS Software Release 12.1(5)YB (Plus versions only) on the Cisco 2600/3600.

  • Cisco IOS Software Release IOS 12.1(3)XJ or later (Plus versions or ADSL feature set only) on the Cisco 1700. The ADSL feature set is identified by "y7" in the image name; for example, c1700-sy7-mz.121-3.XJ.bin.

    When you download the image for the Cisco 1700, make sure you select the image name of 1700. Do not download a 1720 or a 1750 image. The features do not support the ADSL WIC.

To support the ADSL WIC on the Cisco 2600/3600, these hardware versions are required:

  • 2600: Chassis WIC slots, NM-2W.

  • 3600: NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W.

    Note: For the Cisco 3600, the NM-1E1R2W, NM-1E2W, and NM-2E2W do not support the ADSL WIC .

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco 6400 UAC-NRP IOS Software Release 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS Software Release 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(5)DA

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in this diagram:

wicadsl_6400rbe_1.gif

Configurations

To Telnet to (or ping) the Cisco ADSL WIC from the Internet, configure an IP address and a MAC address on the ATM interface. For the IP address, configure the same IP address on the ATM interface that you configured on the Ethernet interface. For the MAC address, issue the show interface eth0 command. Note the MAC address and configure this same MAC address on the ATM interface.

When the Cisco ADSL WIC bridges the IP on the Ethernet and ATM interfaces, both interfaces have the same IP address.

Note the no ip routing command in the configuration.

Cisco ADSL WIC (R1)
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec
! 
hostname R1 
! 
ip subnet-zero 
no ip routing 
! 
interface FastEthernet0 
 ip address 10.0.0.1 255.0.0.0 

!--- When the router is in bridge mode, the FastEthernet 
!--- and ATM interfaces can have the same IP address.

 no ip directed-broadcast
 bridge-group 1 
! 
interface ATM0 
 mac-address 0030.96f8.45bd

!--- This is the MAC address of interface FastEthernet0.
!--- Use the IOS command show interface fastethernet 0
!--- to get the MAC address. 

 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
!
ip classless 
no ip http server 
! 
bridge 1 protocol ieee 
! 
end

Cisco 6400 NRP
Current configuration:
! 
version 12.0 
no service pad 
service timestamps debug datetime msec
service timestamps log datetime msec 
! 
hostname NRP
! 
redundancy 
 main-cpu 
  no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 10.0.0.2 255.0.0.0  
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
! 
interface ATM0/0/0.4 point-to-point 
 ip unnumbered Loopback1
 no ip directed-broadcast
 atm route-bridged ip 
 pvc 4/100
  encapsulation aal5snap 
! 
! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 10.0.0.1 255.255.255.255 ATM0/0/0.4 
! 
end 

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 12957