Guest

Asymmetric Digital Subscriber Line (ADSL)

Configuring a Cisco 827 Router to Support PPPoE Clients, Terminating on a Cisco 6400 UAC

Cisco - Configuring a Cisco 827 Router to Support PPPoE Clients, Terminating on a Cisco 6400 UAC

Document ID: 12889

Updated: Feb 26, 2008

   Print

Introduction

This sample configuration shows you how to support a Point-to-Point Protocol over Ethernet (PPPoE) client when it is connected to the Ethernet interface of a Cisco 827 Digital Subscriber Line (DSL) Router.

The Cisco 827 is configured with RFC1483 bridging and terminates on a Cisco 6400 Universal Access Concentrator (UAC) that has been configured to support PPPoE using a multipoint ATM subinterface.

The PPPoE feature allows you to initiate a PPP session on a simple bridging Ethernet connected client. The session is transported over the Asynchronous Transfer Mode (ATM) link through encapsulated Ethernet-bridged frames. The session can be terminated at either a local exchange carrier central office or an Internet Service Provider (ISP) point of presence.

PPPoE is a client-initiated connection. On the Customer Premises Equipment (CPE) side, a PC with an Ethernet Network Interface Card (NIC) and the PPPoE client code are established. This PC and other PCs are connected to the 827 Ethernet segment.

The 827 ATM interface is connected to a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM) and terminates on a Cisco 6400 UAC.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software versions below.

  • Cisco 827-4V CPE Cisco IOS® Software Release 12.1(1)XB

  • Cisco 6400 UAC-NRP IOS Software Release 12.0(7)DC

  • Cisco 6400 UAC-NSP IOS Software Release 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(1)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

827pppoe.gif

Configurations

This document uses the configurations shown below.

Note: In the Cisco 6400 NRP configuration, you set the Maximum Transmission Unit (MTU). For more information about changing the MTU size, see Troubleshooting MTU Size in PPPoE Dialin Connectivity.

  • Cisco 827

  • Cisco 6400 NRP

Cisco 827
Current configuration:
!
version 12.1
no service pad
service timestamps debug datetime msec              
service timestamps log datetime msec
no service password-encryption
!
hostname R1
! 
ip subnet-zero
no ip routing
! 
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 3/100 
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
ip classless
no ip http server
! 
bridge 1 protocol ieee
!
voice-port 1
timing hookflash-in 0
!
voice-port 2
timing hookflash-in 0
!
voice-port 3
timing hookflash-in 0
!
voice-port 4
timing hookflash-in 0
!
!
line con 0
end

Cisco 6400 NRP
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NRP1
! 
username <username> password <password>

!--- Username/password must match 
!--- client username/password.

! 
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
ip cef
! 
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 101
pppoe limit per-vc 102
! 
interface ATM0/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0/0/0.1 multipoint
 no ip directed-broadcast
pvc 3/100
encapsulation aal5snap
protocol pppoe
! 
interface Ethernet0/0/1
ip address 10.0.0.1  255.0.0.0
no ip directed-broadcast
!
interface Ethernet0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet0/0/0
no ip address
no ip directed-broadcast
half-duplex
!
interface Virtual-Template1

!--- Do not use a static IP assignment within a 
!--- virtual template; routing problems can occur.

ip mtu 1492
ip unnumbered Ethernet0/0/1

!--- Always use the ip unnumbered command when 
!--- configuring a virtual template.
 
no ip directed-broadcast
ip mroute-cache
peer default ip address pool <pool name> 
ppp authentication chap
!
ip local pool <pool name> 10.0.0.2 10.0.0.12  
ip classless
no ip http server
! 
line con 0 
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 12889