Guest

Asymmetric Digital Subscriber Line (ADSL)

PPPoA Session Termination Using Static Routes: xDSL to a Cisco 6400 UAC Using aal5ciscoppp

Document ID: 12851

Updated: Aug 09, 2006

   Print

Introduction

This sample configuration enables a PC connected to a Cisco 677 Asymmetric Digital Subscriber Line (ADSL) router to connect via a Cisco 6130 Advanced Digital Subscriber Line Access Multiplexer (ADSLAM) to a single or multiple Cisco Universal Access Concentrators (UAC). The specific equipment that this configuration uses is not required. For example, you can replace the Cisco 677 with a Cisco 678.

This sample configuration has a few features enabled on the Cisco 677 that are common to an ADSL rollout. These features are Network Address Translation (NAT), Port Address Translation (PAT), and Dynamic Host Configuration Protocol (DHCP). These features allow for a cookie cutter rollout. Since all the boxes have the same configuration, there is a significant cost reduction for rollout and documentation.

You can copy and paste the code for the Cisco IOS®-based Node Route Processor (NRP) and Node Switch Processor (NSP) to your configurations. However, the Cisco 677 uses the Cisco Broadband Operating System (CBOS) and you cannot copy and paste this code. The commands you use to configure the Cisco 677 are also included in this sample configuration.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

Hardware

  • PC or workstation

  • Cisco 677 ADSL customer premises equipment (CPE)

  • ADSL service from your local Telco

  • Cisco 6130 ADSLAM with NI-2, DMT-II ATU-C

  • Cisco 6400 UAC with 1 x NRP and 1 x NSP

Software

  • Cisco IOS Software Release 12.0.7-DC for Cisco 6400 UAC NRP

  • Cisco IOS Software Release 12.0.7-DB for Cisco 6400 UAC NSP

  • CBOS Release 2.3.0.012 for Cisco 677 ADSL Router

  • Cisco IOS Software Release 12.0.8-DA1 for Cisco 6130 ADSLAM

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions .

Configure

In this section, you are presented with the information you can use to configure the features described in this document.

Note: In order to find additional information on the commands used in this document, refer to the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

6400dsl_pppoa_stat.gif

Configurations

Configuration Notes

You must configure a permanent virtual connection (PVC) on the Cisco 6130 that allows the test subscriber to connect. When you configure the PVP on the NSP and terminate the PPP session on the NRP, the virtual path identifier/virtual channel identifier (VPI/VCI) configuration must be recorded on the Cisco 6400.

This sample configuration shows a virtual path on the NSP. This path allows the Cisco 6400 to pass through the cells from the ADSLAM to the terminating router, or to another ATM switch. Here you can set a PVP to switch the ATM cells to a corporate network or an ISP without the termination of the PPP session at the Cisco 6400 located in the central office.

This sample configuration allows remote users transparent access to their corporate networks (if they are connected) for e-mail, to share file/print, corporate intranet, and to the Internet for Web browsing, and so forth. without the use of the corporate Internet connection.

When multiple PVCs are configured on the Cisco 677, it is possible to route traffic via each PVC. Configuration of the ADSLAM and the UAC-NSP routes/switches these PVCs to the correct destination, ISP/ASP or corporate, where PPP can terminate. This configuration reduces traffic, and thereby increases available bandwidth on the corporate network and uses a current ISP account in order to carry Web traffic.

This document uses these configurations:

PC Configuration
Set IP addressing so that it obtains an IP address automatically. Set WINS so that it uses DHCP for WINS resolution. Ensure that no default gateway is set. It can be necessary to set a domain name because DHCP cannot pass this information.

Cisco 67x CPE (show run)
[[ IP Routing = Section Start ]]
IP NAT = enabled
IP Port Address = 00, 172.22.10.254
IP Default Route for Unnumbered Links = 002, 01, 0
IP Static Route Table Entries for Unnumbered Links = 172.22.32.0, 001, 255.255.2
55.0, 1, 0;
[[ CBOS = Section Start ]]
NSOS Maximum Number of VCs = 2
NSOS Root Password = <
root password
>
NSOS Enable Password = <
enable password
>
[[ PPP Device Driver = Section Start ]]
PPP Port User Name = 00, <
username for wan0-0
>
PPP Port User Password = 00, <
password for wan0-0
>
PPP Port User Name = 01, <
username for wan0-1
>
PPP Port User Password = 01, <
password for wan0-1
>
PPP Port Option = 01, IPCP,IP Address,3,Auto,Negotiation Not Required,Negotiable
,IP,0.0.0.0
[[ DHCP = Section Start ]]
DHCP Server = enabled
DHCP Server Pool IP = 00, 172.22.10.0
DHCP Server Pool Gateway = 00, 172.22.10.254
[[ ATM WAN Device Driver = Section Start ]]
ATM WAN Virtual Connection Parms = 00, 1, 32, 0
ATM WAN Virtual Connection Parms = 01, 2, 63, 0

Commands to Issue to the Cisco 67x CPE
cbos#set nat enabled
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos#set int wan0 maxvcs 2
You must use "write" and reboot for changes to take effect.

cbos#write
NVRAM written.

cbos#reboot
 Hello! Expanding CBOS image...
CBOS v2.3.5.012 - Release Software
User Access Verification
Password:<
root password
>

cbos>en
Password:<
enable password
>

cbos#set ppp wan0-0 login <username for wan0-0>
User name for wan0-0 has been set to router.

cbos#set ppp wan0-0 password <password for wan0-0>
Password for wan0-0 has been set to <password for wan0-0>

cbos#set ppp wan0-1 login <username for wan0-1>
Password for wan0-1 has been set to <username for wan0-1>

cbos#set ppp wan0-1 password <password for wan0-1>
Password for wan0-1 has been set to <password for wan0-1>

cbos#set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos#set ppp wan0-1 ipcp 0.0.0.0
PPP wan0-1 IPCP Address set to 0.0.0.0

cbos#set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos#set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0
You must use "write" then reboot for changes to take effect

cbos#set dhcp server enable
DHCP Server enabled

cbos#set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos#set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0
Size of pool 0 is automatically changed to max size 252

cbos#set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos#set password exec <root password>
Exec Password Change Successful! 

cbos#set password enable <enable password>
Enable Password Change Successful! 

cbos#set route default wan0-1
Default Route set

cbos#set route add ip 172.22.32.0 mask 255.255.255.0 gw wan0-0
Route added
cbos#set int wan0-0 close
Closing connection wan0-0

cbos#set int wan0-1 close
Closing connection wan0-1

cbos#set int wan0-0 vpi 1
Change completed.

cbos#set int wan0-0 vc1 32
Change completed.

cbos#set int wan0-1 vpi 2
Change completed.

cbos#set int wan0-1 vci 63
Change completed.

cbos#set int wan0-0 open
Opening connection wan0-0

cbos#set int wan0-1 open
Opening connection wan0-1

cbos#write
NVRAM written

cbos#reboot

61xx ADSLAM
interface ATM 1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1 32 int atm 0/1 40 40
 pvc 2 63 int atm 0/1 50 51

6400 NSP (slot 8)
interface ATM 8/0/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 40 interface ATM 1/0/0 40
 atm pvp 50 interface ATM 2/0/0 50

6400 NRP (slot 1)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-0> password <password for wan0-0>
!
!
interface ATM 0/0/0.200 multipoint
 no ip directed-broadcast
 pvc 40/40 
  encapsulation aal5ciscoppp Virtual-Template 2
!
!
interface FastEthernet 0/0/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name A>
 ppp authentication pap
!
!
ip local pool <pool name A> 172.22.40.25 172.22.40.50

6400 NRP (slot 2)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-1> password <password for wan0-1>
!
!
interface ATM 0/0/0.300 multipoint
 no ip directed-broadcast
 pvc 50/51 
  encapsulation aal5ciscoppp Virtual-Template 21
!
!
interface FastEthernet 0/0/0
 ip address 172.16.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 21
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name B>
 ppp authentication pap
!
!
ip local pool <pool name B> 172.16.100.10 172.16.100.25

Verify

This section provides information you can use to confirm your configuration works properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Use these commands on the Cisco 675 CPE:

  • show interface wan0—Shows trained up speed for the ADSL link.

  • show interface wan0-0—Shows PPP session information on wan0-0.

  • show interface wan0-1—Shows PPP session information on wan0-1.

  • show dhcp server pool 0—Shows DHCP information at the client site.

Use this command on the Cisco 6400 UAC:

  • show atm pvc—Shows whether the correct PVC is established.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Use these commands on the Cisco 6400 UAC:

  • debug ppp negotiation—Shows PPP negotiation debug messages.

  • debug ppp authentication—Shows if a client passes authentication.

  • debug ppp error—Displays protocol errors and error statistics associated with PPP connection negotiation and operation.

Before you attempt any of the debug commands, refer to the Important Information on Debug Commands.

Related Information

Updated: Aug 09, 2006
Document ID: 12851