Guest

EtherChannel

Configuring Layer 2 EtherChannel and Trunking Between 2900XL/3500XL/2950 Series Switches and Catalyst Switches That Run Cisco IOS Software

Document ID: 22422

Updated: Feb 26, 2006

   Print

Introduction

This document provides sample configurations on IEEE 802.1Q/Inter-Switch Link (ISL) trunking and Layer 2 (L2) EtherChannel between Cisco Catalyst 2900 XL/3500 XL or Catalyst 2950 series switches and a Catalyst 6500/6000 switch that runs Cisco IOS® Software. You can also use a Catalyst 4500/4000 switch that runs Cisco IOS Software instead of the Catalyst 6500/6000 for this example. This document discusses the most important factors to consider when you configure trunking and channeling between the switches. The document also includes configuration examples.

In this document, four Fast Ethernet ports from each of the switches have been trunked and bundled into Fast EtherChannels (FECs). Trunking protocol was used for the 3500 XL ISL, and 802.1Q was used for the 2950 example.

Note: The Catalyst 2950 does not support ISL trunking. Use 802.1Q trunking instead.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

In order to create the examples in this document, these switches were used in a lab environment, with cleared configurations:

  • Catalyst 3548 XL switch that runs Cisco IOS Software Release 12.0(5)WC2

  • Catalyst 2950-24 switch that runs Cisco IOS Software Release 12.1(6)EA2c

  • Catalyst 6509 switch with Supervisor Engine II that runs Cisco IOS Software Release 12.1(11b)E

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

DTP

Trunks between devices may be configured statically or with the use of Dynamic Trunking Protocol (DTP). DTP allows both devices connected to negotiate the trunk settings before actually forming the trunk connection. Configurable Cisco IOS Software switch port (trunking) modes include: dynamic (the port negotiates either access or trunk mode), trunk (unconditionally sets the port to trunking), and access (non-trunk access port). The most commonly used mode combination settings on two sides of a static (non-DTP negotiated) trunk are trunk-trunk. For dynamic (DTP-negotiated) trunks, the usual settings are dynamic-dynamic. Other combinations may produce valid results but are outside the scope of this document. A trunk connection between a Port Aggregation Protocol (PAgP)-capable switch and a non-PagP device requires the trunk mode to be on.

Note: Most Cisco routers and some Catalyst switches do not support DTP and require static trunking configuration. For example, Catalyst XL series, Catalyst 2948G-L3, Catalyst 4908G-L3, Catalyst 8500 series, 2/3/4/7xxx series Cisco routers, and so on do not support DTP and require static trunking configuration.

802.1Q Native VLAN Consideration

802.1Q trunking inserts a 4-byte 802.1Q tag field into frames sent over the trunk, which contain VLAN information. The 802.1Q tag is inserted into each frame transferred over the trunk except for frames transmitted on the native VLAN, which are sent untagged. In most cases, the native VLAN has to match on both sides of the trunk unless there is a specific unusual configuration requirement, which is outside the scope of this document. If the native VLANs do not match, the switch logs Cisco Discovery Protocol (CDP) messages stating the mismatch. While not catastrophic, this setup effectively causes the two different native VLANs to be merged into one larger L2 broadcast domain (VLAN). These two VLANs attempt to calculate one common Spanning Tree Protocol (STP) topology for such bridged native VLANs, with the risk of eventually exceeding the maximum supported STP diameter.

Note: There is a special case when a neighbor or third-party device requires all VLANs to be tagged. If this occurs, you may implement a workaround to create a dummy VLAN and set it up as native VLAN. This will tag all other necessary VLANs, and they will pass traffic over the trunk to the neighbor or third-party device. In Cisco IOS Software Release 12.1.11bEX, 12.1.13E, and later, the Catalyst 6500 that runs Cisco IOS Software supports the 802.1Q trunking option that will tag all VLAN traffic including native VLAN. Issue the vlan dot1q tag native command under global configuration mode. On the Catalyst 4500/4000 that runs Cisco IOS Software, the vlan dot1q tag native command was first introduced in Cisco IOS Software Release 12.2(18)EW.

PAgP

Gigabit EtherChannels (GECs) and FECs between switches can also be configured statically or dynamically with the use of PAgP. PAgP allows both devices connected to negotiate the settings before actually forming the channel. PAgP channel modes include: desirable (the port actively initiates channel negotiation), auto (default, in which the port does not initiate negotiation but responds to negotiation attempts started by the other side), and on (unconditionally sets the port to channel and does not exchange PAgP frames). A connection between a PAgP-capable switch and a non-PAgP device requires the on mode to form a channel.

The most commonly used mode combination on two sides of a static (non-PAgP negotiated) channel is on-on. For dynamic (PAgP-negotiated) channels, the usual settings are either desirable-desirable or desirable-auto. The connected ports configured for desirable mode perform channel negotiation and verification before starting the channeling and also keep verifying the channel when it is in operation. Due to the added protection offered by PAgP, this is usually the recommended setup if both connected switches support PAgP.

Note: PAgP has some deliberate configuration limitations. The ports to negotiate a channel must have the same speed, duplex, trunking encapsulation, and VLAN set. Also, the channel load balancing algorithm across links may be configurable on certain platforms.

Note: An EtherChannel is considered to be one unique STP port as soon as it is up. Therefore, to avoid STP inconsistencies when setting up a non-negotiated channel, proceed as follows:

  1. Shut down all ports of the channel to configure on both sides.

  2. Perform the configuration on both ends.

  3. Reenable all ports.

Attempting to configure such a channel while the ports are up may result in temporary STP inconsistencies and/or loops. The steps only apply if PAgP is not used.

Catalyst 2900 XL/3500 XL

Catalyst 2900 XL/ 3500 XL series switches do not support DTP and PAgP, and therefore require static trunk and channel setup. Refer to the note above for more information. Catalyst 2900 XL/ 3500 XL series switches currently support both ISL and 802.1Q trunking encapsulations. For more information, refer to this document:

ISL is supported in Cisco IOS Software Release 11.2(8)SA4 and later, and 802.1Q is supported in Cisco IOS Software Release 11.2(8)SA5 and later.

With a Catalyst 2900 XL that runs Cisco IOS Software Release 11.2(8)SA1 or 11.2(8)SA2, you are allowed four EtherChannels (port groups) per switch with an unlimited number of ports per group. Load balancing across the links in the channel is always destination address-based. Switched Port Analyzer (SPAN) and port security features are not supported.

On a Catalyst 2900 XL that runs Cisco IOS Software Release 11.2(8)SA3 or later, a Catalyst 3500 XL that runs Cisco IOS Software Release 11.2(8)SA6 or later, and a Catalyst 2950, load balancing across the links in the channel is configurable to be based on the source or destination MAC address. Source is the default. Source-based forwarding allows up to eight ports in a FEC (port group). Destination-based forwarding allows unlimited ports per port group. You can configure up to 12 port groups per switch and can have a mix of source-/destination-based groups. SPAN and port security are not supported.

Catalyst 2950

Catalyst 2950 switches only support 802.1Q trunking and do not support ISL trunking. Catalyst 2950 switches support DTP and PAgP dynamic trunking and channel negotiation with Cisco IOS Software Release 12.1 releases and static modes only with Cisco IOS Software Release 12.0 releases. EtherChannel load balancing can use either source-MAC or destination-MAC address forwarding. You can configure the load balancing method by issuing the port-channel load-balance global configuration command. These switches support up to eight switch ports per channel.

Catalyst 6500 That Runs Cisco IOS Software

Catalyst 6500 switches that run Cisco IOS Software support L2 (switchport) and Layer 3 (L3) (routed port) EtherChannel configurations. A Catalyst 6500/6000 series switch supports a maximum of 64 EtherChannels (256 with Cisco IOS Software Release 12.1(2)E and earlier). You can form an EtherChannel with up to eight compatibly configured LAN ports on any module in a Catalyst 6000 series switch, with the exception of Digital Feature Card (DFC)-equipped modules (such as WS-X6816 and so on) which currently allow an L2 channel only using ports on the same DFC module. However, an L3 channel can be configured across different DFC-equipped modules. This limitation has been removed in Catalyst 6500/6000 Cisco IOS Software Release 12.1(11b)EX and later. This document configures an L2 EtherChannel.

The Catalyst 6500/6000 that runs Cisco IOS Software allows you to configure EtherChannel load balancing to use MAC addresses, IP addresses, or Layer 4 (L4) port information in any source, destination, and source-destination combination by issuing the port-channel load-balance global configuration command. The default is to use a hash function between source and destination IP addresses.

Catalyst 6500/6000 switches support both ISL and 802.1Q trunking encapsulations and DTP. Detailed information on port capabilities is available by issuing the show interface interface_id capabilities command.

Catalyst 4000 That Runs Cisco IOS Software

Catalyst 4000 switches that run Cisco IOS Software (with Supervisor Engine III and IV) support L2 (switchport) and L3 (routed port) EtherChannel configurations. A Catalyst 4000 series switch supports a maximum of 64 EtherChannels. You can form an EtherChannel with up to eight compatibly configured Ethernet interfaces on any module, and across modules in a Catalyst 4000 series switch. All interfaces in each EtherChannel must be the same speed and must all be configured as either L2 or L3 interfaces.

The Catalyst 4000 that runs Cisco IOS Software allows you to configure EtherChannel load balancing to use MAC addresses, IP address, or L4 port information in any source, destination, and source-destination combination by issuing the port-channel load-balance global configuration command. The default is to use a hash function between source and destination IP addresses.

The Catalyst 4000 that runs Cisco IOS Software supports ISL and 802.1Q trunking encapsulations and DTP. ISL is not available on certain modules. For a complete list of such modules, refer to the Understanding VLAN Trunks section of Configuring Layer 2 Ethernet Interfaces. In a future software release, detailed information on port capabilities will be available by issuing the show interface capabilities command. Currently this command is not available.

Configuration 1: ISL Trunking and EtherChannel Between Catalyst 3500 XL and Catalyst 6500 That Runs Cisco IOS Software

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This configuration uses this network setup:

144-a.gif

Catalyst 3524 XL

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel 
!--- and then enable them back when the configuration is complete on both switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Output suppressed.


!
interface FastEthernet0/17
port group 1

!--- Assigned port to port channel 1.


switchport trunk encapsulation isl

!--- Configured the port to use the trunking encapsulation ISL.


switchport mode trunk

!--- Configured the port to be in trunking mode.


!
interface FastEthernet0/18

!--- Repeated the trunk and channel configuration.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Output suppressed.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500 (Cisco IOS Software)

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel, 
!--- and then enable them back when the configuration is complete on both switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q

!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


no ip address 
channel-group 1 mode on

!--- Configured the port to participate in port channel 1 with channel mode on.


! 
Interface FastEthernet4/3

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4

!--- Repeated the trunk and channel configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

Configuration 2: 802.1Q Trunking and EtherChannel with Use of DTP and PAgP Between Catalyst 2950 and Catalyst 6500 That Runs Cisco IOS Software

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This configuration uses this network setup:

144-b.gif

Catalyst 2950

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk

!--- Configured port to be in trunking mode.


channel-group 1 mode desirable

!--- Configured port to participate in PAgP-negotiated port channel 1.


!
interface FastEthernet0/3

!--- Repeated trunk and channel configuration.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Output suppressed.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500 (Cisco IOS Software)

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q


!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


No ip address 
channel-group 1 mode desirable

!--- Configured port to participate in port channel 1 with channel mode desirable.


! 
Interface FastEthernet4/3

!--- Repeated trunk and channel configuration. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4

!--- Repeated trunk and channel configuration.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5

!--- Repeated trunk and channel configuration. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

Verify: ISL Trunking

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Catalyst 3500 XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

Note: If you have an eight-port EtherChannel, issuing the show etherchannel summary command can crash the switch if you run a Cisco IOS Software release that is earlier than Cisco IOS Software Release 12.0(5)WC5.

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500 (Cisco IOS Software)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

Verify: 802.1Q Trunking

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Catalyst 6500 Cisco IOS Software

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

Troubleshoot

Use this section to troubleshoot your configuration.

Traffic Is Not Passing on an 802.1Q Trunk

One of these causes can result in the issue:

  • There is a native VLAN configuration mismatch on the ports that are connected between two switches.

    Verify the native VLAN configuration on both the switches. Issue the show trunk command on the CatOS switch in order to see the native VLAN setting. Issue the show interface interface_id switchport command on the XL switch in order to see the native VLAN setting. If there is a native VLAN mismatch between the two switches, configure the switches with the same native VLAN. Issue the switchport trunk native vlan interface configuration command in order to change the native VLAN on the XL switch. Issue the set vlan command in order to change the native VLAN on the CatOS switch.

  • DTP frames are not supported in XL switches.

    The CatOS switches send DTP frames over the trunk link, but the XL switches do not support DTP frames. DTP is not supported in XL switches. In order to avoid this problem, set the CatOS switch port status to no negotiate. Issue the set trunk mod/port nonegotiate dot1q command in order to set the trunk mode to nonegotiate for the dot1q trunking mode.

  • There is an encapsulation mismatch on the XL switch.

    On the XL switch, verify that the trunk encapsulation is set to dot1q. Issue the show interface interface_id switchport command in order to see the current setting. Issue the switchport trunk encapsulation dot1q interface configuration command in order to change the encapsulation to dot1q.

  • An early version of CatOS does not support dot1q trunking.

    The early version of CatOS that was used in the switches does not support dot1q trunking. Upgrade the CatOS of the switch to a later version that supports both the dot1q trunk and ISL trunk.

Related Information

Updated: Feb 26, 2006
Document ID: 22422