Guest

IP Routing

OSPF Routers Connected by an Unnumbered Serial Link

Cisco - OSPF Routers Connected by an Unnumbered Serial Link

Document ID: 47860

Updated: May 19, 2005

   Print

Introduction

The ip unnumbered configuration command allows you to enable IP processing on a serial interface without assigning it an explicit IP address. The IP unnumbered interface can "borrow" the IP address of another interface that is already configured on the router. This conserves network and address space. For more information on the ip unnumbered command, refer to Understanding and Configuring the ip unnumbered Command. This document illustrates two Open Shortest Path First (OSPF) routers connected by an unnumbered serial link.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in this diagram:

ospfdb1.gif

Configurations

This document uses these configurations:

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet0/0/4
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verify

This section provides information to confirm that the configuration works properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) . This allows you to view an analysis of show command output.

  • show ip ospf database —Displays a list of the Link State Advertisements (LSAs) in the link state database. This list shows only the information in the LSA header.

  • show ip ospf database [router] [link-state-id]—Displays the content of the Router LSA (Type-1 LSA) in the database. Router LSAs are produced by every router. These fundamental LSAs list all of the routers' links, or interfaces, along with the states and outgoing costs of the links. They are flooded only within the area in which they originate.

Examine the OSPF Database

To see how the OSPF database looks when it is given this network environment, look at the output of the show ip ospf database command.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#           Checksum     Link count 
1.1.1.1   1.1.1.1     254   0x8000001A     0xA6FA           2 
2.2.2.2   2.2.2.2     253   0x80000017     0x4858           2 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 279 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1   
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line). 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router which created 
  !--- this LSA.

  LS Seq Number: 8000001A 
  Checksum: 0xA6FA 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that this router (1.1.1.1) is a neighbor 
 !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
		
!--- In the case of unnumbered link, use the MIB II IfIndex  
  !--- value. This value usually starts with 0. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
	   
!--- This is the OSPF cost of the link that connects 
!--- the two routers.


    Link connected to: a Stub Network 
	
!--- This entry represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10  
	   
!--- This is the OSPF cost of the Ethernet segment. 



r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 295 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000017 
  Checksum: 0x4858 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

Calculate the Shortest Path

This section calculates the shortest path tree from the perspective of Router 2.2.2.2.

Router 2.2.2.2 looks in its own LSA and sees that Router 1.1.1.1 is a neighbor. It then looks at Router 1.1.1.1's LSA to verify that 1.1.1.1 sees 2.2.2.2 as a neighbor. If both routers see each other as neighbors, they are considered reachable. The routers then install routes for any stub networks listed in their neighbor's LSA.

In this example, Router 2.2.2.2 installs a route for 4.0.0.0/8 in its routing table because Router 1.1.1.1 lists 4.0.0.0/8 as a stub network in its LSA. This is seen with the help of the show ip route ospf command.

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:06:01, Serial0/1/0 

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:06:16, Serial2/1/0 

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: May 19, 2005
Document ID: 47860