Guest

IP Routing

Initial Configurations for OSPF over Non-Broadcast Links

Cisco - Initial Configurations for OSPF over Non-Broadcast Links

Document ID: 13690

Updated: Dec 29, 2005

   Print

Introduction

On non-broadcast media such as Frame Relay, X.25, ATM, and Switched Multimegabit Data Service (SMDS), OSPF can run in two modes:

  • NBMA: simulates a broadcast model by electing a designated router (DR) and a backup designated router (BDR). There are two ways to simulate a broadcast model on an NBMA network: define the network type as broadcast with the ip ospf network broadcast interface sub-command or configure the neighbor statements using the router ospf command.

  • Point-to-mutipoint: treats non-broadcast network as a collection of point-to-point links by configuring the ip ospf network point-to-multipoint command.

You must define the network type on non-broadcast networks to avoid configuring neighbor statements. Below are sample configurations for OSPF over non-broadcast links. Use the show ip ospf interface command to check the network type of an interface running OSPF and the command show ip ospf neighbor is used to know the status of the neighbor router.

Prerequisites

Requirements

This document requires that you understand basic configuration of the Open Shortest Path First (OSPF) routing protocol.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco 2500 routers

  • Cisco IOS® Software Release 12.2(24a) running on routers

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Network Diagram

Below is the network diagram used in the configuration examples in this document.

18a_01.gif

Configurations for NBMA (Using Network Type Broadcast)

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Verification Tips

Below is the show command output for Router1.

Router1# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:00:37    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:00
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

And the output for Router2 is as follows.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:00:38     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:03
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configurations for NBMA (Using Neighbor Statements)

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf priority 2
      no keepalive
      frame-relay map ip 1.1.1.1 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.1
     !

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.2
     !

Note:  In the configurations shown above, the ip ospf priority 2 command on Router1 sets a higher interface priority than the default priority value of 1, which makes it a DR and Router2 the BDR for the NBMA network. If needed, you can set the priority value to 0 to configure a router to never become a DR/BDR. This is necessary in hub and spoke networks where the hub should be configured to become the DR, where as the spokes should neither be DR nor BDR. Though configuring the neighbor statement on one end is sufficient to form adjacency, it is a good practice to have it configured on both the ends as shown. Also, the frame-relay map commands do not need to have the broadcast parameter because the OSPF packets are unicasted with the neighbor statement.

Verification Tips

Below is the show command output for Router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:01:39    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:19
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

And the output for Router2 is as follows.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:01:49     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:01
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configurations for Point-to-Multipoint

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Verification Tips

Below is the show command output for Router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/  -        00:01:53    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)

And the output for Router2 is as follows.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/  -        00:01:58     1.1.1.2         Serial1/0

Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Note: There are no DR and BDR elected when the NBMA network is configured as Point-to-Multipoint as shown in the outputs, since it is treated as a collection of point-to-point links.

For more information, see Configuring OSPF over Different Physical Networks.

Related Information

Updated: Dec 29, 2005
Document ID: 13690