Guest

IP Version 6 (IPv6)

Sample Configuration for OSPFv3

Document ID: 112100

Updated: Aug 11, 2010

   Print

Introduction

Open Shortest Path First (OSPF) is a routing protocol for IP. It is a link-state protocol, as opposed to a distance-vector protocol. A link-state protocol makes routing decisions based on the states of the links that connect source and destination machines. The state of a link is a description of that interface and the relationship to its neighboring networking devices. The interface information includes the IPv6 prefix of the interface, the network mask, the type of network it is connected to, the routers connected to that network, and so forth. This information is propagated in various type of link-state advertisements (LSAs).

OSPF version 3, which is described in RFC 2740, supports IPv6.

Prerequisites

Requirements

Before you enable OSPF for IPv6 on an interface, you must perform the following:

  • Complete the OSPF network strategy and planning for your IPv6 network. For example, you must decide whether multiple areas are required.

  • Enable IPv6 unicast routing.

  • Enable IPv6 on the interface.

  • Configure the IP Security (IPsec) secure socket application program interface (API) on OSPF for IPv6 in order to enable authentication and encryption.

Components Used

This document is not restricted to specific software and hardware versions.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

ospfv3-config-guide-01.gif

Configuration

This is the configuration of OSPFv3 for the routers shown in the diagram:

Stub Router
ipv6 unicast-routing
ipv6 cef
!
interface serial 0/0
 no ip address
 ipv6 enable
 ipv6 address 2001:ABAB::/64 eui-64
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 3.3.3.3
 area 2 stub
!

ABR1 Router
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 speed auto
 ipv6 address 2003::1/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2002:ABAB::/64 eui-64
 ipv6 enable
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 1.1.1.1
 area 2 stub no-summary
!

ASBR Router
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 ipv6 address 2003::2/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:1/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router ospf 1
 router-id 2.2.2.2
 default-metric 25
 redistribute rip EXT metric-type 1 include-connected
!
ipv6 router rip EXT
 redistribute ospf 1 match internal external 1 external 2 include-connected
!

External Router
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address 2004:ABAB::/64 eui-64
 ipv6 enable
 ipv6 rip EXT enable
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:2/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router rip EXT

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

The show ipv6 ospf database command shows the Link State Database (LSDB) of the router.

Stub_Router#show ipv6 ospf database

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

ADV Router      Age         Seq#            Fragment ID  Link count  Bits
1.1.1.1             885         0x80000007      0                    1           B
3.3.3.3             919         0x80000008      0                    1           None

                Inter Area Prefix Link States (Area 2)

ADV Router      Age         Seq#                Prefix
1.1.1.1             373         0x80000002          ::/0

                Link (Type-8) Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Interface
1.1.1.1             964         0x80000006      5          Se0/0
3.3.3.3             1165        0x80000006     5          Se0/0

                Intra Area Prefix Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Ref-lstype  Ref-LSID
1.1.1.1             964         0x80000005      0          0x2001      0
3.3.3.3             1172        0x80000005     0          0x2001      0

The show ipv6 ospf database router self-originate command shows the Router LSAs where the router originates and receives. The Router LSAs carry no address or prefix information.

Stub_Router#

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

  Routing Bit Set on this LSA
  LS age: 753
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000007
  Checksum: 0xFCA4
  Length: 40
  Area Border Router
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 3.3.3.3


  LS age: 791
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000008
  Checksum: 0x178A
  Length: 40
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 1.1.1.1

The LSAs carry an Options field which has these bits:

  • V6 bit—Indicates whether the router/link should be used in routing calculation.

  • R bit—This is the "Router bit". It indicates if the originator is an active router.

  • DC bit—Indicates the router's handling of Demand Circuit.

The show ipv6 ospf database link self-originate command shows that Link LSAs carry link-specific addresses.

Stub_Router#show ipv6 ospf database link self-originate

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Link (Type-8) Link States (Area 2)

  LS age: 627
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000006
  Checksum: 0x215C
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20E:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2002:ABAB::
  Prefix Length: 64, Options: None

  LS age: 828
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000006
  Checksum: 0xB4C2
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20D:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2001:ABAB::
  Prefix Length: 64, Options: None

Because the Stub Router belongs to a Totally-Stub Area, the ABR1 Router sends only the default route to the Stub Router.

Stub_Router#
show ipv6 route

IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OI  ::/0 [110/65]
     via FE80::D20E:16FF:FE50:0, Serial0/0
C   2001:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2001:ABAB::D20D:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
O   2002:ABAB::/64 [110/128]
     via FE80::D20E:16FF:FE50:0, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

The ABR1 Router is the Area Border Router.

ABR1#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 1.1.1.1
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 2. 1 normal 1 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 5 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 2
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
          generates stub default route with cost 1
        SPF algorithm executed 6 times
        Number of LSA 7. Checksum Sum 0x042237
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

The ABR1 Router receives external routes (RIP routes) from the ASBR Router.

ABR1#
show ipv6 route

IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   2001:ABAB::/64 [110/128]
     via FE80::D20D:16FF:FE50:0, Serial0/0
C   2002:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2002:ABAB::D20E:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
C   2003::/124 [0/0]
     via ::, FastEthernet0/0
L   2003::1/128 [0/0]
     via ::, FastEthernet0/0
OE1  2003::1:0/124 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
OE1  2004:ABAB::/64 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

The ASBR Router is the Autonomous System Boundary Router for the network. It is connected to the RIP network through Serial 0/0 interface.

ASBR#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 2.2.2.2
 It is an autonomous system boundary router
 Redistributing External Routes (with default metric 25) from,
    rip with metric-type 1 include-connected
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 2 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

ASBR#
show ipv6 rip

RIP process "EXT", port 521, multicast-group FF02::9, pid 156
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 69, trigger updates 6
  Interfaces:
    Serial0/0
  Redistribution:
    Redistributing protocol ospf 1 include-connected

Troubleshoot

Use this section to troubleshoot your configuration.

Note: Refer to Important Information on Debug Commands before you use debug commands.

debug ipv6

As soon as OSPFv3 is enabled on the Stub Router, it sends out OSPFv3 Type 1 Hello messages to the FF02::5 multicast address. Once it receives Hello packets from the ABR1 Router, they negotiate the Master/Slave relationship and then start to send DBD packets.

Stub_Router#debug ipv6 ospf events

Stub_Router# debug ipv6 ospf packet
*Mar  1 00:14:20.999: OSPFv3: rcv. v:3 t:1 l:36 rid:1.1.1.1
      aid:0.0.0.2 chk:142A inst:0 from Serial0/0
*Mar  1 00:14:21.023: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:EB8A inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: rcv. v:3 t:1 l:40 rid:1.1.1.1
      aid:0.0.0.2 chk:E1C inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: 2 Way Communication to 1.1.1.1 on Serial0/0, state 2WAY
*Mar  1 00:14:21.027: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 
flag 0x7 len 28
*Mar  1 00:14:21.031: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x2402 opt 0x0011 
flag 0x7 len 28  mtu 1500 state EXSTART
*Mar  1 00:14:21.031: OSPFv3: First DBD and we are not SLAVE
*Mar  1 00:14:21.035: OSPFv3: rcv. v:3 t:2 l:88 rid:1.1.1.1
      aid:0.0.0.2 chk:5CF3 inst:0 from Serial0/0
*Mar  1 00:14:21.039: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 flag 
0x2 len 88  mtu 1500 state EXSTART
*Mar  1 00:14:21.039: OSPFv3: NBR Negotiation Done. We are the MASTER
*Mar  1 00:14:21.039: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x3 len 88
*Mar  1 00:14:21.043: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85B inst:0 from Serial0/0
*Mar  1 00:14:21.047: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.047: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x1 len 28Send LS REQ to 1.1.1.1 length 36 LSA count 3
*Mar  1 00:14:21.051: OSPFv3: rcv. v:3 t:3 l:52 rid:1.1.1.1
      aid:0.0.0.2 chk:C326 inst:0 from Serial0/0
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85A inst:0 from Serial0/0

Once the DBD packets are exchanged, the routers send Link-State Request (LS REQ) and Link-State Update (LS UPD) messages to build their LSDB. After successive LS REQ and LS UPD messages, and when the state reaches FULL, the routers continue to exchange Hello packets.

Stub_Router#
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:4 l:144 rid:1.1.1.1
      aid:0.0.0.2 chk:58BC inst:0 from Serial0/0Rcv LS REQ from 1.1.1.1 on Serial0/0 length 52 
LSA count 3Send UPD to 131.88.101.156 on Serial0/0 length 128 LSA count 3
*Mar  1 00:14:21.059: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.063: OSPFv3: Exchange Done with 1.1.1.1 on Serial0/0Rcv LS UPD from 
1.1.1.1 on Serial0/0 length 144 LSA count 3
*Mar  1 00:14:21.067: OSPFv3: Synchronized with 1.1.1.1 on Serial0/0, state FULL
*Mar  1 00:14:21.067: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/0 from 
LOADING to FULL, Loading Done
*Mar  1 00:14:21.687: OSPFv3: rcv. v:3 t:4 l:60 rid:1.1.1.1
      aid:0.0.0.2 chk:66EB inst:0 from Serial0/0Rcv LS UPD from 1.1.1.1 on Serial0/0 length 60 
LSA count 1
*Mar  1 00:14:23.683: OSPFv3: rcv. v:3 t:5 l:96 rid:1.1.1.1
      aid:0.0.0.2 chk:4BB5 inst:0 from Serial0/0

Related Information

Updated: Aug 11, 2010
Document ID: 112100