Guest

IP Routing

Configuring IS-IS over IPv6

Document ID: 40262

Updated: Aug 10, 2005

   Print

Introduction

This document provides a sample configuration for Intermediate System-to-Intermediate System (IS-IS) over IP version 6 (IPv6). It also discusses how to verify and troubleshoot the configuration.

Prerequisites

Requirements

Before you attempt this configuration, ensure that you meet these requirements:

Components Used

The information in this document is based on these software and hardware versions:

  • 12.2(13)T with Enterprise feature set

  • Cisco 7200 Platform

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

ipv6_sample_config.gif

Configurations

This document uses the configurations shown below.

c7200-1
c7200-1# show run

ipv6 unicast-routing 
! Enable the forwarding of IPv6 unicast datagrams
!
interface Loopback0
 no ip address
 ipv6 address 2000:1::1/96
 circuit-type level-2-only
 address-family ipv6 unicast
!

!--- If the sole purpose of the loopback is a router ID, 
!--- a /128 is preferred. 
!--- A /96 is used here to advertise this route through IS-IS.
!--- Last two commands for getting advertised in the LSP


 ipv6 router isis alpha

!--- Enables IS-IS on the interface for area "alpha."

!
interface FastEthernet3/0
 ip address 172.16.88.51 255.255.255.224
 duplex half
 ipv6 address 1000:1:1:1:1:1:1:1/112
 ipv6 router isis alpha
!
router isis alpha

!--- Enables the IS-IS routing process for area "alpha."

 net 49.1111.2220.3330.4440.00

!--- Defines the area addresses for the IS-IS area and the system ID
!--- of the router. 49.1111 is the area id SysID is 2220.3330.4440.

!
end

c7200-2
c7200-2# show run
ipv6 unicast-routing
!
interface Loopback0                                                  
 no ip address
 ipv6 address 3000:1::1/96
 ipv6 router isis alpha
!
interface FastEthernet0/0
 ip address 172.16.88.50 255.255.255.224
 duplex auto
 speed auto
 ipv6 address 1000:1:1:1:1:1:1:2/112
 ipv6 router isis alpha
!
 router isis alpha
 net 49.1111.2222.3333.4444.00
 !
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show clns interface- Used to list the Connectionless Network Service (CLNS)-specific information about interface

    c7200-1# show clns int fa3/0 
    FastEthernet3/0 is up, line protocol is up 
      Checksums enabled, MTU 1497, Encapsulation SAP 
      ERPDUs enabled, min. interval 10 msec. 
      CLNS fast switching enabled 
      CLNS SSE switching disabled 
    
      DEC compatibility mode OFF for this interface 
      Next ESH/ISH in 43 seconds 
      Routing Protocol: IS-IS 
        Circuit Type: level-1-2 
        Interface number 0x0, local circuit ID 0x1 
        Level-1 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-1 adjacencies: 1 
        Level-2 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-2 adjacencies: 1 
        Next IS-IS LAN Level-1 Hello in 1 seconds 
        Next IS-IS LAN Level-2 Hello in 1 seconds
  • show clns neighbors - Used to show the CLNS neighbors state.

    c7200-1# show clns neighbors
    System Id      Interface   SNPA                     State  Holdtime  Type Protocol 
    c7200-2        Fa3/0       0004.281e.e008           Up      25        L1L2 IS-IS
  • show ipv6 route - Used to verify if a route exists on the IPv6.

    c7200-1# show ipv6 route 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         L   1000:1:1:1:1:1:1:1/128 [0/0] 
              via ::, FastEthernet3/0 
         C   1000:1:1:1:1:1:1:0/112 [0/0] 
              via ::, FastEthernet3/0 
         L   2000:1::1/128 [0/0] 
              via ::, Loopback0 
         C   2000:1::/96 [0/0] 
              via ::, Loopback0 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
         L   FE80::/10 [0/0] 
              via ::, Null0 
         L   FF00::/8 [0/0] 
              via ::, Null0
    
    c7200-1# show ipv6 route 3000:1::1 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
  • show isis database detail - Used to show the IS-IS database details.

    c7200-1# show isis database detail
    IS-IS Level-1 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DB        0xC383        1103                   0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 10         IS c7200-1.01      
         c7200-1.01-00       * 0x000000D8        0x5C9A        1078                   0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DD        0x0219        757                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 3000:1::/96      
           Metric: 10         IS c7200-1.01      
         IS-IS Level-2 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DC        0x2569        893                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 20         IPv6 3000:1::/96      
         c7200-1.01-00       * 0x000000D9        0xE994        773                    0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DF        0x88E8        937                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 20         IPv6 2000:1::/96      
           Metric: 10         IPv6 3000:1::/96
  • ping - Used to determine if a remote host is active or inactive, and the round-trip delay in communicating with the host.

    7200-2# ping 1000:1:1:1:1:1:1:1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1000:1:1:1:1:1:1:1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

  • debug isis adj-packets - Used to show the IS-IS Hello (IIH) packets going across CLNS neighbors.

Troubleshooting Procedure

Below is troubleshooting information relevant to this configuration. If IPv6 IS-IS is not working properly, follow the instructions below to troubleshoot your configuration.

  1. Ping the neighbor and make sure the pings works. If it fails, check to make sure the addresses fall in the same subnet, and also check Layer 1 and Layer 2. It is helpful to have an IPv4 address on each interface. Check to see if the IPv4 pings work, and this will help exclude any Layer 1 and Layer 2 issues.

  2. Check to see if the configuration is correct. Refer to the sample configurations in the Configurations section of this document. If the configuration appears correct, issue a debug clns adj-packets command.

    You should see IIH packets going in both directions, as shown in sample debug output below:

    Note: Before issuing debug commands on a production network, refer to Important Information on Debug Commands.

    c7200-1# debug isis adj-packets 
    IS-IS Adjacency related packets debugging is on 
    
    5d23h: ISIS-Adj: Sending L1 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on Loopback0, length 1514n 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Rec L1 IIH from 0004.281e.e008 (FastEthernet3/0), cir type L1L2,
     cir id 2220.3330.4440.01, length 1497
  3. If the IS-IS IPv6 neighbors are not binding, check for a duplicate system-id.

For more details on configuring IS-IS over IPv6, refer to Cisco IOS IPv6 Configuration Library.

Related Information

Updated: Aug 10, 2005
Document ID: 40262