Guest

IP Application Services

How to Use the standby preempt and standby track Commands

Document ID: 13780

Updated: Aug 10, 2005

   Print

Introduction

This document describes how the standby preempt and standby track commands work together, and when you must use each one.

The standby preempt command enables the Hot Standby Router Protocol (HSRP) router with the highest priority to immediately become the active router. Priority is determined first by the configured priority value, and then by the IP address. In each case, a higher value is of greater priority. When a higher priority router preempts a lower priority router, the router sends a Coup message. When a lower priority active router receives a Coup message or a Hello message from an active, higher priority router, the router changes to the Speak state and sends a resign message.

The standby track command allows you to specify another interface on the router for the HSRP process to monitor in order to alter the HSRP priority for a given group. If the line protocol of the specified interface goes down, the HSRP priority is reduced. This means that another HSRP router with higher priority can become the active router if that router has standby preempt enabled.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco IOS® Software Release 12.2(10b)

  • Cisco 2503 Routers

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

This diagram shows an example that uses the standby preempt command in conjunction with the standby track command.

6a.gif

Configuration Examples

In the network diagram, HSRP is configured in this manner:

  • R1 is the active router and tracks the R1 serial 0 interface state. When R1 is the active router, all the traffic from the hosts (Host 1, 2, 3) to the servers is routed through R1.

  • R2 is the standby router and tracks the R2 serial 1 interface state.

  • If the R1 serial 0 interface goes down, the R1 HSRP priority is decreased by 10. At this point the R2 HSRP priority is higher than R1, and R2 takes over as the active router. When R2 becomes the active router, all the traffic from the hosts to the servers is routed through R2.

Note: The default gateway for Hosts 1, 2, and 3 is configured with the HSRP virtual IP address (171.16.6.100, in this case). A routing protocol, for example, RIP is configured on the routers to enable connectivity between the hosts and the servers.

Here is the configuration for each router:

Router 1 ( Cisco 2503)
interface Ethernet0 
ip address 171.16.6.5 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Assigns a standby group and standby IP address

standby 1 priority 105

!--- Assign a priority (105 in this case) to the router interface (e0)
!--- for a particular group number (1). The default is 100.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial0

!--- Indicates that HSRP tracks Serial0 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.

interface Serial0 
ip address 171.16.2.5 255.255.255.0

Router 2 ( Cisco 2503)
interface Ethernet0
ip address 171.16.6.6 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects
standby 1 ip

!--- Indicates the hot standby group. Here the IP address of the virtual router 
!--- is not configured. See the note after this table.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial1

!--- Indicates that HSRP tracks Serial1 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.
!--- The priority is also not configured and hence the default 
!--- priority value of 100 is applied.

interface Serial1
ip address 171.16.7.6 255.255.255.0

Note: R2 does not have a standby IP address configured. This is intentional in order to demonstrate that this is a valid configuration. When R1 and R2 exchange HSRP hellos, R2 learns the standby IP address from R1. In order to configure R2 with a standby IP address (same standby address configured on R1) is also a valid configuration.

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up
 
R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Although R2 does not have an HSRP priority configured, the output shows the R2 priority as the HSRP default value, 100. The output of both routers indicates that the routers track the state of serial 0. The state of R1 is active and the state of R2 is standby. Lastly, both routers are configured with the standby preempt command.

What happens if the serial 0 interface of R1 goes down? The output of the show standby command looks like this:

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down
   
R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Notice in the output that the HSRP priority of R1 is reduced by 10—to 95. This change makes the R2 priority of 100 higher. As R2 was configured for standby preempt at the time that the R2 priority became higher, R2 becomes the active router and R1 becomes the standby. Now, if the R1 serial 0 interface comes back up, the R1 priority is 105, again. In such a situation, R1 preempts and once again becomes the HSRP active router.

Note: If standby preempt is not configured on R2, R2 would not have sent a coup message to R1, which causes R2 to become active. Instead R1 would have remained the active router.

For example, consider this configuration:

standby priority 120
standby track serial 0
standby track serial 1

An HSRP priority of 120 is configured with the standby priority command and HSRP is configured to track the state of two interfaces, Serial0 and Serial 1. Because no decrement value is specified in the standby track command, the HSRP priority is decremented by the default value of 10 when the tracked interface goes down. Initially, both the interfaces are up and the HSRP priority of the interface is 120, as in the show standby command output:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up
R1#

Now, interface Serial 0 is brought down.

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

This reduces the HSRP priority by 10—from 120 to a value of 110. You can use the show standby command to verify this:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

Next, the second tracked interface—Serial 1—is brought down:

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

This again reduces the HSRP priority by 10—from 110 to a value of 100. You can use the show standby command to verify this:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

When any one of the tracked serial interfaces (either serial 0 or serial 1) go down, the resultant priority is 110. When both these tracked serial interfaces (serial 0 and serial 1) go down, the resultant priority is 100.

Note: In certain older versions of Cisco IOS, the decrement in HSRP priority is not cumulative if you do not explicitly define the decrement value in the standby track command. Refer to bug ID CSCdp72834 (registered customers only) for more information.

Related Information

Updated: Aug 10, 2005
Document ID: 13780