Guest

IP Routing

EIGRP IPv6 Configuration Example

Document ID: 113267

Updated: Sep 26, 2011

   Print

Introduction

This document describes how to configure Enhanced Interior Gateway Routing Protocol (EIGRP) for IPv6. EIGRP is an enhanced version of the IGRP developed by Cisco. It is an enhanced distance vector protocol that relies on the Diffused Update Algorithm (DUAL) to calculate the shortest path to a destination within a network. EIGRP for IPv6 works in the same way as EIGRP IPv4 where they can be configured and managed separately.

Prerequisites

  • Basic Knowledge of EIGRPv4

  • Basic Knowledge of IPv6 Addressing

Restrictions

Configuring EIGRP for IPv6 has some restrictions; they are listed below:

  • The interfaces can be directly configured with EIGRP for IPv6, without the use of a global IPv6 address. There is no network statement in EIGRP for IPv6.

  • The router ID needs to be configured for an EIGRPv6 protocol instance before it can run.

  • EIGRP for IPv6 has a shutdown feature. Ensure that the routing process is in "no shut" mode to start running the protocol.

Components Used

The configurations in this document are based on the Cisco 3700 series router on Cisco IOS Software Release 12.4 (15)T 13.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this example, two routers (R1 and R2) are configured with IPv6 address. Loopback addresses are assigned in both routers, and they are configured to be in EIGRP1. The EIGRPv6 is enabled per interface level using this command: ipv6 eigrp as-number

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This example uses this network setup:

eigrp-ipv6-01.gif

Configurations

This example uses these configuration:

R1 Configuration
hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1010:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2020:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3030:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::1 link-local
 ipv6 address 2010:AB8::1/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 2.2.2.2
 no shutdown
!
end

R2 Configuration
hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::2 link-local
 ipv6 address 2010:AB8::2/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 1.1.1.1
 no shutdown
!
end

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Show Commands

The show ipv6 eigrp neighbors command displays the neighbors discovered by the EIGRPv6.

Show ipv6 eigrp neighbors
Router R1
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             13 15:17:58   44   264  0  12
    FE80::2

!--- Shows the link local address of router R2. 

Router R2
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             14 16:32:05   30   300  0  12
    FE80::1

!--- Shows the link local address of router R1. 

The show ipv6 route eigrp command shows the content of the IPv6 routing table that includes the routes specific to EIGRP.

show ipv6 route eigrp
Router R1
R1#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   2000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   3000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0

!--- This command shows IPv6-specific EIGRP routes.

Router R2
R2#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1010:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   2020:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   3030:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0

The show ipv6 eigrp interfaces command displays the information about the interfaces that are configured for EIGRP.

show ipv6 eigrp interfaces
Router R1
R1#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        44       0/15         199           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

!--- This command determines which interface EIGRP is active.

Router R2
R2#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        30       0/15         135           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

Related Information

Updated: Sep 26, 2011
Document ID: 113267