Guest

Cisco High Density Voice/Fax Network Modules

Second-Generation 1- and 2-Port T1/E1 Multiflex Trunk Voice/WAN Interface Cards

Document ID: 65322

Updated: Oct 14, 2009

   Print

Introduction

This document provides a sample configuration for the second-generation 1- and 2-port T1/E1 multiflex trunk (MFT) voice/WAN interface cards (multiflex VWICs), which support data and voice applications in Cisco multiservice routers. The multiflex VWIC combines WAN interface card (WIC) and voice interface card (VIC) functionality to provide the following improvements:

  • Support for both T1 and E1--T1/E1 MFT VWIC2 cards provide additional flexibility in configuring the MFT VWIC2 cards by supporting T1, fractional T1, E1, and fractional E1 for both voice and WAN applications.
  • Drop and insert capability on all versions--All MFT VWIC2 modules now include the drop and insert multiplexing capability, which eliminates external third party CSU/DSUs and drop and insert multiplexers.
  • Enhanced clocking capabilities--The 2-port MFT VWIC2s can enable each port to be clocked from independent clock sources for data applications. This independent clocking capability is not supported for voice applications and not supported with the AIM-ATM-VOICE-30 module.
  • Dedicated echo cancellation option--MFT VWIC2s have an onboard slot for a multiflex trunk dedicated echo cancellation module (EC-MFT-32 and EC-MFT-64), offering an enhanced echo cancellation capability for demanding network conditions. For more information about this feature, refer to the “Configuring Hardware Echo Cancellation” chapter in the Voice Port Configuration Guide.

Prerequisites

Requirements

Before attempting this configuration, please ensure that you meet the following prerequisites:

  • Cisco IOS Image -- To run these features on T1/E1 interfaces, you must install an IP Plus or IP Voice image (minimum) of Cisco IOS Release 12.3(14)T or a later release.
  • VWIC Support -- The multiflex VWIC cards are supported on Cisco 2600XM series, Cisco 2691, Cisco 2800 series, Cisco 3700 series, and Cisco 3800 series routers when installed on the network modules listed in Components Used. The multiflex VWIC cards can also be installed in any VIC slot on the router.
  • Independent Clocking Mode -- The independent clocking mode is supported only on these modules:
    • VWIC2-1MFT-G703
    • VWIC2-2MFT-G703
    • VWIC2-2MFT-T1/E1
    • VWIC2-1MFT-T1/E1

To enable independent clocking mode, use the keyword independent in the clock source command. The  independent keyword expands on the clock source internal and clock source line commands to specify that the port can operate on an independent clocking domain. Prior to the addition of the  independentkeyword, port 0 was the default primary clock source, and port 1 was the default secondary clock source and is loop-timed. With independent clocking enabled, this dependency no longer exists, so the  independent keyword means that both ports can be independently clocked.

When independent clocking is configured, the controller will support only one channel group and no voice applications. If more than one channel group is configured, the following error message occurs:

channel-group 2 timeslots 3
%Channel-group already created.
%Only 1 channel-group can be configured with independent clocking.
%Insufficient resources to create channel group

When you are configuring the clock source independent and no clock source independent commands, the channel group has to be removed from the configuration.

Components Used

The information in this document is based on combinations of the network modules supported by the second-generation 1- and 2-port T1/E1 multiflex trunk voice/WAN interface cards. If your network module is:

  • NM-HDV (for VWIC option, choose 0 or 1), these cards can be used:
    • VWIC2-1MFT-T1/E1
    • VWIC2-2MFT-T1/E1
    • VWIC2-2MFT-G703
  • NM-HDV2 (for VWIC option, choose 0 or 1), these cards can be used:
    • VWIC2-1MFT-T1/E1
    • VWIC2-2MFT-T1/E1
    • VWIC2-1MFT-G703
    • VWIC2-2MFT-G703
  • NM-HD-2VE (for VWIC option, choose 0, 1, or 2), these cards can be used:
    • VWIC2-1MFT-T1/E1
    • VWIC2-2MFT-T1/E1
  • NM-2W, NM-1FE1R2W, NM-1FE2W-V2, NM-2FE2W-V2 (for VWIC option, choose 0, 1, or 2), these cards can be used:
    • VWIC2-1MFT-T1/E1
    • VWIC2-2MFT-T1/E1
    • VWIC2-1MFT-G703
    • VWIC2-2MFT-G703

Note: For this feature to work properly, the network modules listed here must be installed in one of the following platforms: Cisco 2600XM, Cisco 2691, Cisco 2800 series, Cisco 3662 (telco models), Cisco 3700 series, and Cisco 3800 series.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Background Information

Key Features

The second-generation 1- and 2-port T1/E1 multiflex trunk voice/WAN interface cards have the following key features:

  • Full support for T1 Facility Data Link (FDL)
  • Controller local loopbacks
  • Controller remote loopbacks
  • RFC 1406 and integrated CSU/DSU MIB
  • MIB and Simple Network Management Protocol (SNMP) management
  • Firmware to support T1 and E1 Layer 1 homologation
  • User-initiated VWIC reset and field-programmable gate array (FPGA) download
  • Voice support (includes DS0-group and PRI-group configuration)

The following list shows the names and descriptions of the modules with second-generation 1- and 2-port T1/E1 multiflex trunk voice/WAN interface cards.

  • VWIC2-1MFT-T1/E1-- 1-port RJ-48 multiflex voice/WAN trunk (T1/E1)
  • VWIC2-2MFT-T1/E1--2-port RJ-48 multiflex voice/WAN trunk (T1/E1)
  • VWIC2-1MFT-G703-- 1-port RJ-48 multiflex trunk (E1 G.703)
  • VWIC2-2MFT-G703-- 2-port RJ-48 multiflex trunk (E1 G.703)

Note: These baseboards can also provide hardware echo cancellation if there is a daughter card (EC-MFT-32 or EC-MFT-64) mounted on the baseboard. For more information, refer to the Voice Port Configuration Guide on Cisco.com.

Note: Although unstructured G.703 operation is particular to E1 operation, the VWIC2-1/2MFT-G703 cards also support structured T1 operation.

Integrated Drop and Insert Capability

The drop and insert feature enables the removal of DS0 time slots from one E1 interface and insertion into time slots of the other E1 interface. This feature is available in VWIC applications. If you configure drop and insert, be sure that the E1 framing under the controllers involved (the tdm-groups configuration location) is the same. If you use different frame types, the signaling bits may not be read properly. This failure occurs during the drop of a channel from one controller and insertion into a channel from another controller. Drop and insert time slots do not need to be contiguous.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only).

Network Diagram

This document uses the network setup shown in the diagram below.

Configurations

This document uses the configurations shown below.


  • This example shows a T1 controller configured for data and drop-and-insert capability
    Router# show run
    Building configuration...
    
    version 12.4
    
    card type t1 0 0
    !
    no network-clock-participate wic 0
    ip subnet-zero
    ip cef
    !
    no ip dhcp use vrf connected
    !
    controller t1 0/0
     framing esf
     linecode b8zs
     channel-group 1 timeslots 1-12 speed 64
     tdm-group 2 timeslots 13-24
    !
    controller t1 0/1
     framing esf
     linecode b8zs
     channel-group 1 timeslots 1-12 speed 64
     tdm-group 2 timeslots 13-24
    !
    !
    interface Serial0/0:1
     ip address 10.0.0.1 255.255.255.0
    !
    interface Serial0/1:1
     ip address 10.0.0.2 255.255.255.0
    !
    connect t1-xconnect T1 0/0 2 T1 0/1 2
     !
    !
    
    
  • This example shows a Cisco 2620XM T1 controller with a 2-port VWIC2-2MFT-T1 installed.
    Router# show run
    
    Building configuration...
    
    version 12.4
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    !
    hostname vnt-2620XM-55a
    !
    boot-start-marker
    boot-end-marker
    !
    card type t1 0 0 
    logging buffered 64000 debugging
    enable password 7 095B59
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone EST -5
    clock summer-time EDT recurring
    no network-clock-participate slot 1
    network-clock-participate wic 0
    network-clock-select 1 T1 0/0
    voice-card 0
     dspfarm
     no local-bypass
    !
    voice-card 1
     no dspfarm
    !
    ip subnet-zero
    ip cef
    !
    !
    no ip domain lookup
    ip host redclay 172.18.108.26
    !
    !
    !
    controller T1 0/0
     framing esf
     linecode b8zs
     ds0-group 0 timeslots 1-24 type fxo-ground-start
    !
    controller T1 0/1
     framing sf
     linecode ami
    !
    controller T1 1/0
     framing esf
     linecode b8zs
     ds0-group 0 timeslots 1 type e&m-immediate-start
     ds0-group 1 timeslots 2 type e&m-immediate-start
    !
    !
    !
    interface FastEthernet0/0
     ip address 14.80.55.38 255.255.255.0
     duplex auto
     speed auto
    !
    ip default-gateway 14.80.55.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    !
    ip http server
    !
    connect TieA voice-port 1/1/0 T1 1/0 0
     !
    !
    connect TieB voice-port 1/1/1 T1 1/0 1
     !
    !
    control-plane
    !
    !
    !
    voice-port 1/0:0
    !
    voice-port 1/0:1
    !
    voice-port 1/1/0
     signal immediate
    !
    voice-port 1/1/1
     signal immediate
    !
    !
    dial-peer cor custom
    !
    !
    line con 0
     exec-timeout 0 0 
    line aux 0
    line vty 0 4
     exec-timeout 0 0
     password 7 131200
     login
    !
    ntp clock-period 17180246
    ntp server 172.18.106.15
    !
    end
    
    
    

  • Verify

    There is currently no verification procedure available for this configuration.



    Troubleshooting

    There is currently no specific troubleshooting information available for this configuration.


    Related Information


    Updated: Oct 14, 2009
    Document ID: 65322