Guest

Cisco SCE 1000 Series Service Control Engine

Field Notice: FN - 63002 - SCA-BB 3.1.1 - Problem Porting PQB Taken from SCA-BB Version 3.0.6/3.1.0 Installed with Protocol-Pack 10


November 13, 2007

NOTICE:

THIS FIELD NOTICE IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTY OF MERCHANTABILITY. YOUR USE OF THE INFORMATION ON THE FIELD NOTICE OR MATERIALS LINKED FROM THE FIELD NOTICE IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS FIELD NOTICE AT ANY TIME.


Revision History

Revision

Date

Comment

1.0

13-NOV-2007

Initial Public Release

Products Affected

Products Affected

Comments

SCE SCAS BB - 3.1.1

Service Control Application for Broadband

Problem Description

An issue was found recently that relates to the upgrade from SCA-BB version 3.0.6 or 3.1.0 installed with Protocol-Pack 10 (PP10) to SCA-BB version 3.1.1.

Specifically this refers to the following defect which was found during internal testing:

CSCsl08938 - Error message during 3.0.6PP10 or 3.1.0PP10 PQB application upon version 3.1.1 and further.

During an upgrade to SCA-BB version 3.1.1, when opening a saved PQB generated by SCA-BB 3.0.6 or 3.1.0 version installed with Protocol-Pack 10 with the console of SCA-BB 3.1.1, an error message will pop up. The error message will indicate that a protocol violation has occurred and the error must be resolved.

Background

During the development of SCA-BB 3.1.1, a change was made in the default PQB. The change consists of removing the "ICQ Voice" protocol, which was introduced as part of PP10, and moving the corresponding "ICQ Voice" signature under the "ICQ VoIP" protocol. This change in default configuration contradicts the PQB of SCA-BB versions 3.0.6 and 3.1.0 which are installed with PP10.

Problem Symptoms

During an upgrade to SCA-BB 3.1.1, the PQB taken from 3.0.6 or 3.1.1 installed with Protocol-Pack 10 will create a conflict with the default PQB of 3.1.1.

SCA-BB 3.1.1 will indicate this by issuing an error message claiming that a protocol violation has occurred and the error must be resolved.

Workaround/Solution

Solution

To resolve the error the following should be done:

  1. On the Service configuration editor, go to 'Configuration' -> 'Protocols' then search and delete the 'ICQ Voice' protocol from the protocol list. Note that there are 3 ICQ based protocols defined in the protocol list - ICQ, ICQ VoIP and ICQ Voice. Only the last one should be deleted.

  2. As soon as the 'ICQ Voice' protocol is removed, the message appearance will stop.

  3. Then you can safely apply the fixed policy to the 3.1.1 SCE.

The next time you will retrieve the policy from the SCE, go to 'Configuration' -> 'Protocols' and make sure that the ICQ VoIP protocol now has both ICQ VoIP and ICQ Voice signatures - previously it had only the ICQ VoIP.

Workaround

The aforementioned solution should be used.

Another method that can be used is to upgrade to Protocol-Pack 11 for 3.0.6 or 3.1.0 versions prior to the upgrade to the SCA-BB 3.1.1 release.

DDTS

To follow the bug ID link below and see detailed bug information, you must be a registered user and you must be logged in.

DDTS

Description

CSCsl08938 (registered customers only)

PP11: duplicate protocol element ICQ at 3.1.1pp11 3.1.5

For More Information

If you require further assistance, or if you have any further questions regarding this field notice, please contact the Cisco Systems Technical Assistance Center (TAC) by one of the following methods:

Receive Email Notification For New Field Notices

Product Alert Tool - Set up a profile to receive email updates about reliability, safety, network security, and end-of-sale issues for the Cisco products you specify.