Guest

Cisco Unity

Field Notice: FN - 29198 - Upgrading a Cisco Unity 2.X System to Version 4.0(3) or Later


March 29, 2004

NOTICE:

THIS FIELD NOTICE IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTY OF MERCHANTABILITY. YOUR USE OF THE INFORMATION ON THE FIELD NOTICE OR MATERIALS LINKED FROM THE FIELD NOTICE IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS FIELD NOTICE AT ANY TIME.


Products Affected

  • Cisco Unity 2.X

Problem Description

The Cisco Unity Database Export (FullDbExport) and earlier versions of Database Import (FullDbImport) utilities, which exports data from the Cisco Unity 2.x system to Cisco Unity 4.0 only works through Cisco Unity 4.0(2).

If you are upgrading directly to Cisco Unity 4.0(3) or later, you must use the latest version of the Cisco Unity Database Import (FullDbImport) tool that will only work for upgrades to 4.0(3) and later. The same Database Export (FullDbExport) is used in both cases. Only the import tools are different.

Background

There are two versions of the Cisco Unity Database Import. The Cisco Unity Database Import utility, which imports data from the Cisco Unity 2.x system to Cisco Unity 4.0 only works for Cisco Unity 2.3(4.104) through Cisco Unity 4.0(2).

The latest version of Cisco Unity Database Import utility imports data from the Cisco Unity 2.x system to Cisco Unity 4.0(3) and later.

Problem Symptoms

The Cisco Unity Database Import utility, which imports data from the Cisco Unity 2.x system to Cisco Unity 4.0 only works through Cisco Unity 4.0(2). If you are upgrading to from Cisco Unity 2.X to Cisco Unity 4.0(3) or later, you will not be able to import the data to the new system.

To upgrade from Cisco Unity 2.X to Cisco Unity 4.0(3) or later, you will need to use the latest Cisco Unity Database Import utility.

Workaround/Solution

FullDBImport for Cisco Unity 4.0(3) and later is now available on the Cisco Unity Tools page. This is a separate version from the FullDBImport for Cisco Unity that works with versions 3.0(1) through 4.0(2).

DDTS

To follow the bug ID link below and see detailed bug information, you must be a registered user and you must be logged in.

DDTS

Description

CSCed69998 (registered customers only)

Bulk Export Import Tool doesnt support 4.0(3) Upgrade

Other Considerations

System requirements changed between Cisco Unity 2.x and 4.0. Refer to the Cisco Unity 4.0 System Requirements, and Supported Hardware and Software page to confirm that the hardware and software that you intend to use for the 4.0 system is supported.

Some hardware, software, configurations, and Cisco Unity versions are no longer supported. In particular, note the following: Some servers and voice cards that were supported for Cisco Unity 2.x are not supported with Cisco Unity 4.0. If the Cisco Unity server contains cards that are not supported with version 4.0, the cards must be replaced before you upgrade because Cisco Unity 4.0 will not run with unsupported cards.

Fax cards on the Cisco Unity server and ActiveFax are not supported. You must remove fax cards before you begin the upgrade. ActiveFax, the fax server available with previous versions of Cisco Unity, is no longer supported either on the Cisco Unity server or on a separate fax server. Windows NT is not supported on the Cisco Unity server. The Cisco Unity server can be added to a Windows NT domain, but the operating system on the Cisco Unity server must be Windows 2000 Server.

Exchange is not supported on the Cisco Unity server for Unified Messaging. If Cisco Unity is configured for Unified Messaging, Exchange cannot be installed on the Cisco Unity server for Cisco Unity 4.0. You must either move Exchange mailboxes to other Exchange servers or, if there are no other Exchange servers, you must install Exchange on another server and move Exchange mailboxes to the new server. If Cisco Unity is configured for Voice Messaging, Exchange 5.5 is supported on a Cisco Unity 4.0 server only if you are upgrading from a previous version of Cisco Unity. Exchange 2000 is still supported on the Cisco Unity server both for upgrades and for new installations.

Upgrades from Cisco Unity versions earlier than 2.3(4.104) are not supported. The Cisco Unity Database Export and Database Import utilities, which let you export subscriber and other information from a 2.x system and import it into a 4.0(x) system do not work on a Cisco Unity system earlier than version 2.3(4.104). You must install Cisco Unity 4.0(x) as a new system and all Cisco Unity data from the old system is lost.

For More Information

If you require further assistance, or if you have any further questions regarding this field notice, please contact the Cisco Systems Technical Assistance Center (TAC) by one of the following methods:

Receive Email Notification For New Field Notices

Product Alert Tool - Set up a profile to receive email updates about reliability, safety, network security, and end-of-sale issues for the Cisco products you specify.