Guest

Cisco Catalyst 8500 Series Campus Switch Routers

Field Notice: LS1010/Cat8540m IOS Upgrade Migration Issues from 12.0 mainline to 12.1E


February 27, 2003


Products Affected

Product

Comments

Cisco IOS® Software Release 12.0

Cisco IOS Software Release 12.0 mainline

cat8540m-wp-mz.121-X.E

Cisco IOS Software Release 12.1E

cat8540m-wp-mz.120-XX.W5.XX.bin

Catalyst 8540m images earlier than Cisco IOS Software Release 12.(13)W5(19c)

Problem Description

When upgrading Lightstream 1010 and Catalyst 8540m images from the Cisco IOS Software Release 12.0 mainline to any image based on the Cisco IOS Software Release 12.1E train, or any image later than the Cisco IOS Software Release 12.0(W5)19c from the Cisco IOS Software Release 12.0(W5) train, the soft-vcs and SVCs using tunnel interfaces will not be set up.

Background

This problem occurs because of the architecture changes between Cisco IOS Software Release 12.0 and Cisco IOS Software Release 12.0(W5), and bug fixes to address standards in Cisco IOS Software Rlease 12.0(W5). This new code will not interoperate with code based on Cisco IOS Software Release 12.0(M).

Prior to Release 12.0(13)W5(19c) the SVCs were signalled with the EXPLICIT VPI EXPLICIT VCI flags enabled in the connection ID. Cisco IOS Software Release release 12.0(13)W5(19c) fixed DDTS CSCdr95813, and allowed the Catalyst 8500 series and Lightstream 1010 to interoperate correctly with requests for EXPLICIT VPI ANY VCI, but at the same time all requests from Catalyst 8500 series were EXPLICIT VPI EXPLICIT VCI regardless of the atm address (for NNI interface).

With Cisco IOS Software Release 12.0(16)W05(21), DDTS CSCdt10434 was fixed and made allocation of VPI-VCI happen only on the higher node for a VP tunnel interface. The check was strict, and calls from a node with lower node address and EXPLICIT VPI EXPLICIT VCI flag set were rejected. This caused interoperability issue with earlier Cisco IOS software releases.

With Cisco IOS Software Release 12.0(18)W05(23) and later, DDTS CSCdv48352 was used to fix the strict checking introduced by DDTS CSCt10434. Now the code allows a node with a lower atm address to allocate the VPI-VCI. If these are free they will be allocated allowing to interoperate with Cisco IOS Software Release 12.0(13)W5(19c) and later. Images earlier than Cisco IOS Software Release 12.(13)W5(19c) do not understand the Connection Id flags for VPI-VCI allocation and expect them to be set for EXPLICIT VPI EXPLICIT VCI. Therefore, when Cisco IOS Software Release 12.0(18)W05(23) is a lower node it will set the flags for EXPLICIT VPI ANY VCI and expect the other node to allocate these.

Problem Symptoms

When upgrading Lightstream 1010 and Catalyst 8540m images from the Cisco IOS Software Release 12.0 mainline to any image based on Cisco IOS Software Release 12.1E or any image later than Cisco IOS Software Release 12.0(W5)19c from the 12.0(W5) train, in customer configurations with VP tunnels of any form (with or without hierarchical shaping), the soft-vcs and SVCs using tunnel interfaces will not be setup.

Workaround/Solution

This only affects customer configurations with VP tunnels of any form (with or without hierarchical shaping), wanting to migrate from Cisco IOS Software Release 12.0 to Cisco IOS Software Release 12.1E.

Customers will not experience the upgrade migration issues from Cisco IOS Software Release 12.0 to Cisco IOS Software Release 12.1E if they upgrade in these steps:

1. All the switches are upgraded from the Cisco IOS Software Release 12.0 images to Cisco IOS Sofware Release12.1E images.

2. All the switches have the Cisco IOS software image released after Release 12.0(13)W5(19c) on the 12.0(W5) train then upgrade to Cisco IOS Software Release12.1E.

For customer configurations with VP tunnels of any form (with or without hierarchical shaping), wanting to migrate from Cisco IOS Software Release 12.0 to Cisco IOS Software Release 12.1E, we recommend that the network first be upgraded to at least Cisco IOS Software Release 12.0(13)W5(19c) if customer is running anything earlier (either from 12.0(x) or 12.0(x)W5(y)).

After the above upgrade, customers should move at least to Cisco IOS Software Release 12.0(18)W05(23) or later. Optionally, depending on the feature needs, they can move directly to any Cisco IOS Software Release 12.1(10)E or later since all the fixes were present in this first 12.1E release.

OR

To upgrade in a single step from any release earlier than Cisco IOS Software Release 12.0(13)W5(19c) to 12.0(18)W05(23) or later, the customer should upgrade their switches with the node with the highest atm address to the lowest.

DDTS

To follow the bug ID link below and see detailed bug information, you must be a registered user and you must be logged in.

DDTS

Description

CSCdr95813 (registered customers only)

VP Associated Signaling - Explicit VPCI, Any VCI calls are rejected

CSCdt10434 (registered customers only)

vpi/vci collision with p2mp conn when burst of add_party gets queued

CSCdv48352 (registered customers only)

Multiple VC Fail will going accross a PVP tunnel

For More Information

If you require further assistance, or if you have any further questions regarding this field notice, please contact the Cisco Systems Technical Assistance Center (TAC) by one of the following methods:

Receive Email Notification For New Field Notices

Product Alert Tool - Set up a profile to receive email updates about reliability, safety, network security, and end-of-sale issues for the Cisco products you specify.