Guest

Cisco 7200 Series Routers

Field Notice: Cisco 7200 and 7400 Boot Issue


Revised July 23, 2002

April 22, 2002


Products Affected

  • Cisco 7200VXR Series Routers

  • Cisco 7400 Series Routers

Problem Description

In either of these scenarios:

  • There is no startup configuration in the NVRAM.

  • The first boot system command you configure points to an image that you have stored on a disk filesystem.

If you have set up the router to autoboot by changing the configuration register to x2102, the router always boots the image in the bootflash even though a full Cisco IOS® Software image may be present in the advanced technology attachment (ATA) flash disk.

Background

Several versions exhibit this behavior. A boot from linear flash PC cards is unaffected for Cisco 7200 only. The Cisco 7400 only supports disk filesystems.

Problem Symptoms

This output is the console output of the symptom during power on and boot from the boot image:

System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMENT SOFTWARE
Copyright (c) 1994-2000 by cisco Systems, Inc.
C7200 platform with 131072 Kbytes of main memory


Self decompressing the image : ##########################################################################################################################################################################################################################
#######################################################################################################################################################################################################################################################
[OK]
Self decompressing the image : ##########################################################################################################################################################################################################################
#######################################################################################################################################################################################################################################################
[OK]


Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706



Cisco Internetwork Operating System Software 
IOS (tm) 7200 Software (C7200-KBOOT-M), Version 12.2(6a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Sat 01-Dec-01 12:40 by pwade
Image text-base: 0x600089C0, data-base: 0x607EA000

cisco 7206VXR (NPE400) processor (revision A) with 114688K/16384K bytes of memory.
Processor board ID 25860090
R7000 CPU at 350Mhz, Implementation 39, Rev 3.2, 256KB L2, 4096KB L3 Cache
6 slot VXR midplane, Version 2.5

Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
2 FastEthernet/IEEE 802.3 interface(s)
4 Serial network interface(s)
125K bytes of non-volatile configuration memory.

46976K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
47040K bytes of ATA PCMCIA card at slot 1 (Sector size 512 bytes).
8192K bytes of Flash internal SIMM (Sector size 256K).

--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: n


Would you like to terminate autoinstall? [yes]: 



Press RETURN to get started!


00:00:07: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:00:07: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
00:00:07: %LINK-3-UPDOWN: Interface Serial2/0, changed state to down
00:00:07: %LINK-3-UPDOWN: Interface Serial2/1, changed state to down
00:00:07: %LINK-3-UPDOWN: Interface Serial2/2, changed state to down
00:00:07: %LINK-3-UPDOWN: Interface Serial2/3, changed state to down
00:00:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
00:00:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
00:00:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
00:00:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
00:00:27: %LINK-5-CHANGED: Interface Serial2/0, changed state to administratively down
00:00:27: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
00:00:27: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
00:00:27: %LINK-5-CHANGED: Interface Serial2/1, changed state to administratively down
00:00:27: %LINK-5-CHANGED: Interface Serial2/2, changed state to administratively down
00:00:27: %LINK-5-CHANGED: Interface Serial2/3, changed state to administratively down
00:00:35: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software 
IOS (tm) 7200 Software (C7200-KBOOT-M), Version 12.2(6a), RELEASE SOFTWARE (fc1)
!--- The system booted from Cisco IOS Software kboot image.

Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Sat 01-Dec-01 12:40 by pwade
00:00:35: %SYS-6-BOOTTIME: Time taken to reboot after reload = 454 seconds
Router(boot)> enable
Router(boot)# dir bootflash:
Directory of bootflash:/

1 -rw- 4941856 Dec 19 1916 03:41:07 c7200-kboot-mz.122-6a.bin

7602176 bytes total (2660192 bytes free)
Router(boot)# dir disk0:
Directory of disk0:/

1 -rw- 11663876 Jan 24 2002 11:52:20 c7200-is-mz.122-6a.bin
!--- There is a Cisco IOS Software main image on ATA flash card.


47898624 bytes total (36229120 bytes free)
Router(boot)# dir disk1:
Directory of disk1:/

1 -rw- 11663876 Dec 19 1980 03:51:18 c7200-is-mz.122-6a.bin

47964160 bytes total (36294656 bytes free)
Router(boot)# show tech-support

------------------ show version ------------------

Cisco Internetwork Operating System Software 
IOS (tm) 7200 Software (C7200-KBOOT-M), Version 12.2(6a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Sat 01-Dec-01 12:40 by pwade
Image text-base: 0x600089C0, data-base: 0x607EA000

ROM: System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMENT SOFTWARE

Router uptime is 1 minute
System returned to ROM by power-on
Running default software

cisco 7206VXR (NPE400) processor (revision A) with 114688K/16384K bytes of memory.
Processor board ID 25860090
R7000 CPU at 350Mhz, Implementation 39, Rev 3.2, 256KB L2, 4096KB L3 Cache
6 slot VXR midplane, Version 2.5

Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
2 FastEthernet/IEEE 802.3 interface(s)
4 Serial network interface(s)
125K bytes of non-volatile configuration memory.

46976K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
47040K bytes of ATA PCMCIA card at slot 1 (Sector size 512 bytes).
8192K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102
!--- The configuration register is 0x2102.


------------------ show running-config ------------------


Building configuration...

Current configuration : 699 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
ip cef
!
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0
no ip address
shutdown
no fair-queue
!
interface Serial2/1
no ip address
shutdown
!
interface Serial2/2
no ip address
shutdown
!
interface Serial2/3
no ip address
shutdown
!
ip classless
no ip http server
ip pim bidir-enable
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
!
end

Workaround/Solution

A workaround is to set the router to boot the image from the disk with use of the boot system global configuration command.

The solution to the problem is to upgrade Cisco IOS Software boot and/or kboot images to a release that has the fix. These releases contain a fix for the problem: Cisco IOS Software Releases 12.2(8)T1, 12.0(22)SY2, 12.2(8)B, 12.0(22)S, 12.2(9)S, 12.2(10), and 12.2(4)B4.

DDTS

To follow the bug ID link below and see detailed bug information, you must be a registered user and you must be logged in.

DDTS

Description

CSCdw52832

Cisco 7200/Cisco 7400 bootldr fails to boot image from flash disks.

How To Upgrade Software

Refer to How to Choose a Cisco IOS Software Release .

For More Information

If you require further assistance, or if you have any further questions regarding this field notice, please contact the Cisco Systems Technical Assistance Center (TAC) by one of the following methods:

Receive Email Notification For New Field Notices

Product Alert Tool - Set up a profile to receive email updates about reliability, safety, network security, and end-of-sale issues for the Cisco products you specify.