Guest

ISDN, CAS

Configuring an Access Server with PRIs for Incoming Multilink Async and ISDN Calls

Document ID: 6310

Updated: Jan 29, 2008

   Print

Introduction

In many environments, you need to configure an Access Server that can accept incoming calls from both Async and ISDN users. These users are then able to seamlessly connect to the network as if they were physically present. Such a setup is commonly used to provide network connectivity to users who travel and are telecommuters, and also for Small Office-Home Office (SOHO) sites.

This document describes how to configure an Access Server to accept incoming Async and ISDN calls on ISDN T1 PRI circuits. The configuration provides the minimum setup required for the network access server (NAS) to accept the call. You can add additional features to this configuration based on your needs.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco AS5300 with 192 MICA modems and eight T1 ports that run Cisco IOS® Software Release 12.2(5).

  • Two T1 PRIs.

  • A PC that runs Microsoft Windows. This PC has an analog modem and a phone connection to the Public Switch Telephone Network. The PC dials the T1 PRI that is connected to the AS5300.

  • Cisco 800 and 1600 series routers with ISDN BRI circuits. These routers are the ISDN dialin clients. The configuration for the Cisco 1600 is provided. You can apply this client configuration to any router with a BRI interface.

  • Local Authentication, Authorization and Accounting (AAA). If you have a AAA Radius or Tacacs+ Server, you can use either of them to provide AAA for the incoming calls.

Note: The configuration of the Cisco 800 router is similar to the configuration of the Cisco 1600 router, and is not included in this document.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Related Products

You can use this configuration with any router that has T1 or PRI Cards and Internal Digital Modems (for example, MICA, NextPort or Microcom). Any AS5xxx series router with a T1 or PRI card and digital modems can use the concepts in this configuration.

Cisco 2600 series routers do not support Internal Digital Modems. You can configure Cisco 2600 series routers to accept only ISDN calls, provided the router has a T1 or PRI WIC or Network Module.

Cisco 3600 series routers can support both ISDN and Modem calls. However, Cisco 3600 series routers require a T1 or PRI WIC or Network Module, and the NM-xDM Digital Modem Network Module.

You can also make modifications to use this configuration with E1 or PRI Ports. Configure the E1 controller with the linecoding, framing and other physical characteristics that your Telco supplies. The D-channel configuration (interface Serial x:15 for E1s) is similar to the one shown in this document.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions .

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

5300.gif

Configurations

This document uses these configurations:

maui-nas-02 (5300)
maui-nas-02#show running-config 
 Building configuration...

 Current configuration : 3671 bytes
 !
 ! No configuration change since last restart
 !
 version 12.2
 service timestamps debug datetime msec
 service timestamps log datetime msec
 service password-encryption
 !
 hostname maui-nas-02
 !
 boot system flash:c5300-i-mz.122-5.bin
 aaa new-model
 aaa authentication login default local
 aaa authentication login NO_AUTHEN none
 aaa authentication ppp default local
 aaa authorization network default local 
 
!--- PPP authentication and network authorization are local.
 !--- Replace local with radius or tacacs if you use an AAA server.

 enable secret 5 <deleted>
 !
 username admin password 7 <deleted>
 username async_user password 7 <deleted>
 username travis_isdn password 7 <deleted>
 username austin_isdn password 7 <deleted>
 
!--- Usernames for local authentication of the call.
 !--- The client presents the username/password and the NAS 
!--- authenticates the peer.

 spe 1/0 1/8
  firmware location mica-modem-pw.2.7.3.0.bin
 spe 2/0 2/7
  firmware location mica-modem-pw.2.7.3.0.bin
 !
 ip subnet-zero
 ip domain-name maui-onions.com
 
!--- Tells the NAS how to qualify DNS lookups. 
 !--- In this example, maui-onions.com is appended to the end of each 
 !--- looked-up name.

 ip name-server 172.22.53.210
 
!--- Specifies the primary name server.

 !
 async-bootp dns-server 172.22.53.210
 
!---  Specifies (for async clients) the IP address of domain name servers. 

 isdn switch-type primary-ni
 
!--- Switch-type for this NAS. Obtain this information from the Telco.

 !
 controller T1 0
 
!--- First T1 PRI

  framing esf
 
!--- Framing for this T1 is Extended Super Frame (ESF). 
 !--- Obtain this information from the Telco.

  clock source line primary
 
!--- T1 0 is the primary clock source for this NAS. 
 !--- Clock source must be specified for the timing and synchronization 
 !--- of the T1 carrier.

  linecode b8zs
 
!--- Linecoding for this T1. Obtain this information from the Telco.

  pri-group timeslots 1-24
 
!--- For T1 PRI scenarios, all 24 T1 timeslots are assigned as 
 !--- ISDN PRI channels. The router now automatically creates the 
 !--- corresponding D-channel: interface Serial 0:23.

 !
 controller T1 1
 
!--- Second T1 PRI.

  framing esf
 
!--- Framing for this T1 is Extended Super Frame (ESF).
 !--- Obtain this information from the Telco.

  clock source line secondary 1
 
!--- T1 1 is the first secondary clock source for this NAS. 
 !--- If the primary clock fails, this secondary clock takes over.

  linecode b8zs
 
!--- Linecoding for this T1. Obtain this information from the Telco.

  pri-group timeslots 1-24
 
!--- For T1 PRI scenarios, all 24 T1 timeslots are assigned as ISDN 
 !--- PRI channels. The router now automatically creates the 
 !--- corresponding D-channel: interface Serial 1:23.

 !
 controller T1 2
 
!--- This T1 is unused.

  framing sf
  clock source line secondary 2
  linecode ami
 !
 
!--- Unused interface configuration is omitted here.

 !
 interface Loopback0
  ip address 172.22.60.1 255.255.255.0
 
!--- The IP pool for async users is in this subnet.
 !--- The routes for all async clients are summarized and 
 !--- propagated to the backbone instead of 254 routes.

 !
 interface Loopback1
  ip address 172.22.61.1 255.255.255.0
 
!--- The IP pool for ISDN users is in this subnet.
 !--- The routes for all ISDN clients are summarized and 
 !--- propagated to the backbone instead of 254 routes.

 !
 interface Ethernet0
  ip address 172.22.53.140 255.255.255.0
 !         
 
!--- Unused interface configuration is omitted here.

 !
 interface Serial0:23
 
!--- D-channel configuration for T1 0.

  no ip address
  encapsulation ppp

 !--- PPP encapsulation on this interface.

  dialer rotary-group 10
 
!--- T1 0 is a member of rotary group 10.
 !--- The rotary group configuration is in interface Dialer 10.

  isdn switch-type primary-ni
  isdn incoming-voice modem
 
!--- All incoming voice calls on this T1 are sent to the modems.
 !--- This command is required if this T1 is to accept async calls.

  no cdp enable
  ppp authentication chap
  ppp multilink
 !
 interface Serial1:23
 
!--- D-channel configuration for T1 1.

  no ip address
  encapsulation ppp
 
!--- PPP encapsulation on this interface.

  dialer rotary-group 10
 
!--- T1 1 is a member of rotary group 10.
 !--- The rotary group configuration is in interface Dialer 10.

  isdn switch-type primary-ni
  isdn incoming-voice modem
 
!--- All incoming voice calls on this T1 are sent to the modems.
 !--- This command is required if this T1 is to accept async calls.

  no cdp enable
  ppp authentication chap
  ppp multilink
 !
 interface Group-Async0
 
!--- This group-async interface is the configuration template for all modems.
 !--- You need not configure individual async interfaces because you can 
 !--- clone the interfaces from one managed copy.

  ip unnumbered Loopback0
 
!--- A Loopback interface is always up/up. So, unnumber the loopback interface 
 !--- for stability.

  encapsulation ppp
  dialer in-band
  dialer idle-timeout 900
  dialer-group 5
 
!--- Interesting traffic is defined in dialer-list 5.
 !--- Note: The specified dialer-group number must be the same as the 
 !--- dialer-list number. In this example, the number is defined as "5".

  async mode interactive
 
!--- Users can dial in and get to a shell or PPP session on that line.  
 !--- You can use this command in conjunction with autoselect ppp
 !--- under the line configuration to automatically detect the connection type.

  peer default ip address pool ASYNC
 
!--- Clients are assigned addresses from the IP address pool named ASYNC.

  no fair-queue
  ppp authentication chap
 
!--- Use CHAP authentication.

  ppp multilink
  group-range 1 192
 
!--- Modems 1 through 192 are members of this group async interface.

 !
 interface Dialer10
 
!--- Configuration for rotary group 10.
 !--- The Dialer interface number (10) must exactly match rotary 
 !--- group number configured on the physical interfaces.

  ip unnumbered Loopback1
 
!--- A Loopback interface is always up/up. So, unnumber the loopback interface 
 !--- for stability.

  encapsulation ppp
  dialer in-band

 !--- Enable V.25bis on this interface.

  dialer idle-timeout 900
 
!--- Idle timeout for incoming calls is 900 seconds (15 mins).

  dialer-group 5
 
!--- Apply interesting traffic definition from dialer-list 5.
 !--- Note: The specified dialer-group number must be the same 
 !--- as the dialer-list number. 
 !--- In this example, the number is defined as "5".

  peer default ip address pool ISDN
 
!--- Clients are assigned addresses from the IP address pool named ISDN.

  ppp authentication chap
  ppp multilink
 !
 router eigrp 69
  network 172.22.0.0
  auto-summary
  no eigrp log-neighbor-changes
 !
 ip local pool ASYNC 172.22.60.2 172.22.60.254
 ip local pool ISDN 172.22.61.2 172.22.61.254
 
!--- IP address pools for dialin clients.

 ip classless
 no ip http server
 !
 access-list 101 remark Interesting Traffic Definition to be 
 used in dialer-list 5
 access-list 101 deny   eigrp any any
 access-list 101 permit ip any any
 dialer-list 5 protocol ip list 101
 
!--- Access-list 101 defines interesting traffic. This definition is applied 
 !--- to interface Dialer 10 and Group-Async 0 through dialer-group 5.
 !--- Note: The specified dialer-list number must be the same as the 
 !--- dialer-group number. In this example, the number is defined as "5".

 !
 line con 0
  exec-timeout 0 0
  login authentication NO_AUTHEN
 
!--- Apply AAA list NO_AUTHEN configured previously. 
 !--- That list has method "none".
 !--- There is no authentication on the console port.

 line 1 192
  modem InOut
 
!--- Support incoming and outgoing modem calls.

  transport input all
  autoselect during-login
 !
---  Displays the username:password prompt after modems connect.

  autoselect ppp
 
!--- Automatically launches PPP if the router detects incoming PPP packets.
 !--- Without this command the dialin client must manually 
 !--- launch PPP (from Exec mode).

 line aux 0
 line vty 0 4
 !
 ntp clock-period 17180107
 ntp server 172.22.53.1
 end

maui-soho-01 (1600)
maui-soho-01#show running-config
 Building configuration...

 Current configuration : 1609 bytes
 !
 version 12.1
 no service single-slot-reload-enable
 service timestamps debug datetime msec
 service timestamps log datetime msec
 service password-encryption
 !
 hostname maui-soho-01
 !
 logging rate-limit console 10 except errors
 !
 username admin password 7 <deleted>
 ip subnet-zero
 no ip finger
 !
 isdn switch-type basic-ni
 
!--- Switch-type for the BRI circuit. Obtain this information from the Telco.

 !
 interface Ethernet0
  ip address 10.0.0.1 255.255.255.0
  no keepalive
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface BRI0
 
!--- BRI physical interface configuration.

  no ip address
 
!--- An IP address is not required on the physical BRI interface because 
 !--- this is a dialer pool.
 !--- The IP addressing functionality is in interface Dialer 1 (dialer pool).

  encapsulation ppp
  dialer pool-member 1 
 
!--- Places the interface into dialer pool 1 from which Dialer interfaces
 !--- can draw channels as needed.
 !--- Links the physical interface with the logical dialer interfaces.
 !--- Dialer Pool 1 is defined in interface Dialer 1.

  isdn switch-type basic-ni
  isdn spid1 51255511110101 5551111
  isdn spid2 51255511120101 5551112
 
!--- Service Profile IDentifiers (SPIDs) are found primarily in North America.
 !--- SPIDs are not required for certain switch types. Confirm with your Telco.
 !--- If the Telco informs you that you do not need SPIDs, do not use these 
 !--- two SPID commands.

  ppp authentication chap callin
 
!--- Perform one way CHAP authentication.

  ppp multilink
 
!--- Permit multilink on this BRI interface.

 !
 interface Dialer1
 
!--- This dialer is the logical interface for the dialer pool.

  ip address negotiated
 
!--- IP address for this interface is obtained from the NAS during 
 !--- IPCP negotiation. Alternatively, you can also unnumber this interface 
 !--- to a working interface (example, ethernet 0).

encapsulation ppp
  dialer pool 1
 
!--- Defines Dialer pool 1.
 !--- BRI 0 is a member of this pool.

  dialer idle-timeout 900
 
!--- Idle-timout for this link is 900 seconds (15 minutes).
 !--- The link is disconnected if there is no interesting traffic for 900 secs.

  dialer string 81560 class 56k
 
!--- Dial 81560 and use the map-class named "56k".

  dialer load-threshold 1 outbound
 
!--- Sets the outbound load level for traffic at which
 !--- additional connections are added to the MP bundle load level.
 !--- Values range from 1 (unloaded) to 255 (fully loaded). 
 !--- With a threshold of 1, the additional links are immediately 
 !--- brought up and added to the bundle.

  dialer-group 1
 
!--- Apply interesting traffic definition from dialer-list 1.

  ppp authentication chap callin
 
!--- Use one way PPP CHAP authentication.

  ppp chap hostname austin_isdn
 
!--- Use the CHAP username austin_isdn to authenticate to the other router.

  ppp chap password 7 <deleted>
 
!--- Use this CHAP password to authenticate to the other router.

  ppp multilink
 
!--- Allow multilink for the dialer profile.
 !--- Without this command multilink is NOT negotiated.

 !
 !
 ip classless
 ip route 0.0.0.0 0.0.0.0 Dialer1
 
!--- Set the default route to be interface Dialer 1 (the dialer pool).
 !--- Traffic sent to int Dialer1 causes the dialer pool member (int BRI 0)
 !--- to be dialed.

 no ip http server
 !
 !
 map-class dialer 56k
 
!--- Map-class named "56k" that you used with the dialer string in int Dialer1.

  dialer isdn speed 56
 
!--- Set the speed of the call to be 56k (the default speed is 64k).
 !--- This setting is optional for your connection.
 !--- Consult your Telco to find out if you need to configure the dial
 !--- speed to 56k.

 access-list 101 remark Interesting traffic for dialer-list 1
 access-list 101 deny   udp any any eq ntp
 access-list 101 permit ip any any
 
!--- Define NTP traffic as NOT interesting to prevent periodic NTP traffic
 !--- from keeping the link up indefinitely. 
 !--- All other IP traffic is interesting.
 !--- Change this depending on your traffic needs.

 dialer-list 1 protocol ip list 101
 
!--- Access-list 101 defines interesting traffic.
 !--- Apply this to interface Dialer 1 through the command dialer-group 1.
 !--- Note: The specified dialer-list number must be the same as the 
 !--- dialer-group number. In this example, the number is defined as "1"

 !
 line con 0
  transport input none
 line vty 0 4
  login
 !
 ntp clock-period 17042429
 ntp server 172.22.53.1
 end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show isdn status—ensures that the router communicates properly with the ISDN switch. In the output, ensure that Layer 1 Status is ACTIVE, and that the Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED appears. This command also displays the number of active calls. Refer to Using the show isdn status Command for BRI Troubleshooting for more information.

  • show ppp multilink—displays information on active multilink bundles. Use this command to verify the multilink connection.

  • show dialer [interface type number]—displays general diagnostic information for interfaces configured for DDR. If the dialer comes up properly, the Dialer state is data link layer up message must appear. If physical layer up appears, the implication is that line protocol came up, but the Network Control Protocol (NCP) did not. The source and destination addresses of the packet that initiated the dialing are shown in the Dial reason line. This show command also displays the configuration of the timer, and the time before the connection times out.

  • show caller user username detail—shows parameters for the particular user, for example, the IP address assigned, PPP and PPP bundle parameters. If your version of the Cisco IOS software does not support this command, use the show user command.

  • show dialer map—displays configured dynamic and static dialer maps. You can use this command to check whether a dynamic dialer map is created. You cannot route packets without a dialer map.

Sample show Output

Here are some show command outputs for successful calls. Pay attention to the bold sections and the comments provided in the output. Compare the output that you obtain with the results shown here.

General View

maui-nas-02#show users
  Line         User       Host(s)              Idle       Location
* 0 con 0                 idle                 00:00:00   
  97 tty 97    async_user Async interface      00:06:36   PPP: 172.22.60.2

!--- Async User.  The IP address of the peer is indicated.


  Interface    User        Mode                Idle     Peer Address
  Vi1          austin_isd Virtual PPP (Bundle) 00:03:35 172.22.61.2
     Vi2          travis_isd Virtual PPP (Bundle) 00:00:20 172.22.61.3

!--- Virtual-Access Interface for the two multilink PPP users.

  Se0:1        austin_isd Sync PPP                    -   Bundle: Vi1
     Se0:2        austin_isd Sync PPP                    -   Bundle: Vi1

!--- User austin_isdn is connected through two B-channels(Multilink PPP).
!--- Interface Virtual-Access 1 (Vi1) controls the two B-channels.

     Se0:3        travis_isd Sync PPP                    -   Bundle: Vi2
     Se0:4        travis_isd Sync PPP                    -   Bundle: Vi2

!--- User travis_isdn is connected through two B-channels (Multilink PPP).
!--- Interface Virtual-Access 2 (Vi2) controls the two B-channels.


maui-nas-02#show dialer map

!--- Observe the Dynamic Dialer Maps created for each dialin client.

Dynamic dialer map ip 172.22.60.2 name async_user () on As97
Dynamic dialer map ip 172.22.61.2 name austin_isdn () on Di10
Dynamic dialer map ip 172.22.61.3 name travis_isdn () on Di10
maui-nas-02#show users
  Line         User       Host(s)              Idle       Location
* 0 con 0                 idle                 00:00:00   
  97 tty 97    async_user Async interface      00:06:36   PPP: 172.22.60.2

!---  Async User.  The IP address of the peer is indicated.


  Interface    User        Mode                Idle     Peer Address
  Vi1          austin_isd Virtual PPP (Bundle) 00:03:35 172.22.61.2
  Vi2          travis_isd Virtual PPP (Bundle) 00:00:20 172.22.61.3

!--- Virtual-Access Interface for the two multilink PPP users.

  Se0:1        austin_isd Sync PPP                    -   Bundle: Vi1
  Se0:2        austin_isd Sync PPP                    -   Bundle: Vi1

!--- User austin_isdn is connected through two B-channels(Multilink PPP).
!--- Interface Virtual-Access 1 (Vi1) controls the two B-channels.

 Se0:3        travis_isd Sync PPP                    -   Bundle: Vi2
 Se0:4        travis_isd Sync PPP                    -   Bundle: Vi2


!--- User travis_isdn is connected through two B-channels (Multilink PPP).
!--- Interface Virtual-Access 2 (Vi2) controls the two B-channels.


maui-nas-02#show dialer map

!--- Observe the Dynamic Dialer Maps created for each dialin client.

Dynamic dialer map ip 172.22.60.2 name async_user () on As97
Dynamic dialer map ip 172.22.61.2 name austin_isdn () on Di10
Dynamic dialer map ip 172.22.61.3 name travis_isdn () on Di10
maui-nas-02#show users
  Line         User       Host(s)              Idle       Location
* 0 con 0                 idle                 00:00:00
  97 tty 97    async_user Async interface      00:06:36   PPP: 172.22.60.2

!---  Async User.  The IP address of the peer is indicated.


       Interface    User        Mode                Idle     Peer Address
       Vi1          austin_isd Virtual PPP (Bundle) 00:03:35 172.22.61.2
       Vi2          travis_isd Virtual PPP (Bundle) 00:00:20 172.22.61.3
     
!--- Virtual-Access Interface for the two multilink PPP users.

       Se0:1        austin_isd Sync PPP                    -   Bundle: Vi1
       Se0:2        austin_isd Sync PPP                    -   Bundle: Vi1
     
!--- User austin_isdn is connected through two B-channels(Multilink PPP).
     !--- Interface Virtual-Access 1 (Vi1) controls the two B-channels.

       Se0:3        travis_isd Sync PPP                    -   Bundle: Vi2
       Se0:4        travis_isd Sync PPP                    -   Bundle: Vi2
     
!--- User travis_isdn is connected through two B-channels (Multilink PPP).
     !--- Interface Virtual-Access 2 (Vi2) controls the two B-channels.


     maui-nas-02#show dialer map
     
!--- Observe the Dynamic Dialer Maps created for each dialin client.

     Dynamic dialer map ip 172.22.60.2 name async_user () on As97
     Dynamic dialer map ip 172.22.61.2 name austin_isdn () on Di10
     Dynamic dialer map ip 172.22.61.3 name travis_isdn () on Di10

For an Analog Call

maui-nas-02#show caller user async_user detail

       User: async_user, line tty 97, service Async
     
!--- Shows hardware-level settings for the user named async_user.

             Active time 00:00:34, Idle time 00:00:16
       Timeouts:            Absolute  Idle      Idle
                                      Session   Exec
           Limits:          -         -         00:10:00  
           Disconnect in:   -         -         -         
       TTY: Line 97, running PPP on As97
     
!--- The call is terminated on interface Async 97. 
     !--- This interface is included in the Group-Async configuration.

       Location: PPP: 172.22.60.2
     
!--- IP address for the peer. This address is obtained from the IP pool "ASYNC".

       DS0: (slot/unit/channel)=0/0/2
     
!--- T1 channel on which the call arrived. 
     !--- The call arrived on channel 0 in T1 0. 

       Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
       Status: Ready, Active, No Exit Banner, Async Interface Active
               HW PPP Support Active
       Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                     Modem Callout, Modem RI is CD, 
                     Line usable as async interface, Integrated Modem
       Modem State: Ready

       User: async_user, line As97, service PPP
     
!--- PPP setting for the user named async_user. 
     !--- Notice that the call is terminated on int Async97.

             Active time 00:00:32, Idle time 00:00:30
       Timeouts:            Absolute  Idle
           Limits:          -         00:15:00  
           Disconnect in:   -         00:14:28  
       PPP: LCP Open, multilink Closed, CHAP (<- AAA), IPCP
     
!--- LCP state is OPEN. If LCP state is not OPEN,  
     !--- use debug ppp negotiation to isolate LCP issues.

       LCP: -> peer, ACCM, AuthProto, MagicNumber, PCompression, ACCompression
            <- peer, ACCM, MagicNumber, PCompression, ACCompression
       NCP: Open IPCP
     
!--- IPCP state is open. If IPCP state is not OPEN, 
     !--- use debug ppp negotiation to isolate IPCP issues.

       IPCP: <- peer, Address
             -> peer, Address
       Dialer: Connected, inbound
               Idle timer 900 secs, idle 31 secs
               Type is IN-BAND ASYNC, group As97
       IP: Local 172.22.60.1, remote 172.22.60.2
     
!--- NAS IP address and the IP address assigned to the peer.

       Counts: 27 packets input, 1545 bytes, 0 no buffer
               1 input errors, 1 CRC, 0 frame, 0 overrun
               14 packets output, 347 bytes, 0 underruns
               0 output errors, 0 collisions, 0 interface resets
     
!--- Packets pass through the connection.

For an ISDN Call

     maui-nas-02#show caller user austin_isdn detail 
     
!--- The user named austin_isdn has two PPP links, 
     !--- and one virtual interface bundle.


       User: austin_isdn, line Se0:3, service PPP
     
!--- Shows PPP layer settings for the first channel 
     !--- that belongs to the user named austin_isdn.

             Active time 00:04:01, Idle time 00:00:00
       Timeouts:            Absolute  Idle
           Limits:          -         -         
           Disconnect in:   -         -         
       PPP: LCP Open, multilink Open, CHAP (<- AAA)
     
!--- LCP state is OPEN. If LCP state is not OPEN, 
     !--- use debug ppp negotiation to isolate LCP issues.

       LCP: -> peer, AuthProto, MagicNumber, MRRU, EndpointDisc
            <- peer, MagicNumber, MRRU, EndpointDisc
       Dialer: Connected, inbound
               Type is ISDN, group Di10
     
!--- Incoming call used rotary group of int Dialer 10.

       IP: Local 172.22.61.1
     
!--- IP address of the int Loopback 1. 
     !--- Remember that int Dialer 1 was unnumbered to Loop 1.
     !--- The remote IP address is indicated under the virtual-interface.

       Bundle: Member of austin_isdn, last input 00:00:00
       Counts: 55 packets input, 1635 bytes, 0 no buffer
               0 input errors, 0 CRC, 0 frame, 0 overrun
               82 packets output, 3479 bytes, 0 underruns
               0 output errors, 0 collisions, 0 interface resets

       User: austin_isdn, line Se0:4, service PPP
     
!--- Shows PPP layer settings for the second channel
     !--- that belongs to the user named austin_isdn.

             Active time 00:03:59, Idle time 00:00:00
       Timeouts:            Absolute  Idle
           Limits:          -         -         
           Disconnect in:   -         -         
       PPP: LCP Open, multilink Open, CHAP (<- AAA)
       LCP: -> peer, AuthProto, MagicNumber, MRRU, EndpointDisc
            <- peer, MagicNumber, MRRU, EndpointDisc
       Dialer: Connected to , inbound
               Type is ISDN, group Di10
       IP: Local 172.22.61.1
       Bundle: Member of austin_isdn, last input 00:00:00
       Counts: 50 packets input, 1589 bytes, 0 no buffer
               0 input errors, 0 CRC, 0 frame, 0 overrun
               77 packets output, 3429 bytes, 0 underruns
               0 output errors, 0 collisions, 0 interface resets       

       User: austin_isdn, line Vi1, service PPP Bundle
     
!--- Shows Virtual-Access Interface Bundle that controls the connections.

             Active time 00:04:02, Idle time 00:04:01
       Timeouts:            Absolute  Idle
           Limits:          -         00:15:00  
           Disconnect in:   -         00:10:58  
       PPP: LCP Open, multilink Open, IPCP, CDPCP
       LCP: -> peer, MagicNumber, MRRU, EndpointDisc
            <- peer
       NCP: Open IPCP, CDPCP
     
!--- IPCP State is open. If IPCP state is not OPEN,
     !--- use debug ppp negotiation to isolate IPCP issues.

       IPCP: <- peer, Address
             -> peer, Address
       Dialer: Connected, inbound
               Idle timer 900 secs, idle 1 secs
               Type is IN-BAND SYNC, group Di10
       IP: Local 172.22.61.1, remote 172.22.61.2
     
!--- Dialer interface (Local) IP address
     !--- and the IP address assigned to the peer.

       Bundle: First link of austin_isdn, 2 links, last input 00:00:01
       Counts: 12 packets input, 1712 bytes, 0 no buffer
               0 input errors, 0 CRC, 0 frame, 0 overrun
               67 packets output, 5030 bytes, 0 underruns
               0 output errors, 0 collisions, 0 interface resets

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Resources

Use these resources as required:

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug dialer—displays DDR debugging information about the packets received on a dialer interface. This information can help to ensure there is interesting traffic that uses the dialer interface.

  • debug isdn q931—shows call setup and tear down of the ISDN network connection (Layer 3).

  • debug modem—displays modem line activity on an access server. The output displays when the modem line changes state.

  • debug modem csm—enables you to troubleshoot Call Switching Module (CSM) problems on routers with internal digital modems. With this command, you can trace the complete sequence of switching incoming and outgoing calls.

  • debug ppp negotiation—displays information on the PPP traffic and exchanges, and negotiates Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation first opens the LCP state, then authenticates, and finally negotiates NCP. Multilink Parameters such as Maximum Receive Reconstructed Unit (MRRU) are established during LCP negotiation.

  • debug ppp authentication—displays PPP authentication protocol messages, including CHAP packet exchanges and Password Authentication Protocol (PAP) exchanges.

  • debug ppp error—displays protocol errors and error statistics associated with PPP connection negotiation and operation.

Sample debug Output

Here are some debug outputs for successful calls. Pay attention to the bolded sections and the comments provided in the outputs. Compare the output that you obtain with the result shown here.

For an Analog Call

maui-nas-02#debug isdn q931
     ISDN Q931 packets debugging is on
     maui-nas-02#debug modem
     Modem control/process activation debugging is on
     maui-nas-02#debug modem csm
     Modem Management Call Switching Module debugging is on
     maui-nas-02#debug ppp negotiation
     PPP protocol negotiation debugging is on
     maui-nas-02#debug ppp authentication
     PPP authentication debugging is on

     maui-nas-02#
     Sep 28 13:13:28.369: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x5285

     
!--- Incoming Q.931 SETUP message. This indicates an incoming call.
     !--- For more information on Q.931 refer to
     !--- Troubleshooting ISDN BRI Layer 3 using the debug isdn q931 Command.

     Sep 28 13:13:28.369:   Bearer Capability i = 0x9090A2
     Sep 28 13:13:28.369:   Channel ID i = 0xA18383
     Sep 28 13:13:28.369:   Progress Ind i = 0x8183 - Origination address is non-ISDN 
     Sep 28 13:13:28.369:   Called Party Number i = 0xA1, '81560', Plan:ISDN, Type:National
     Sep 28 13:13:28.373: VDEV_ALLOCATE: 2/0 is allocated
     
!--- The Call Switch Module (CSM) is informed about the call. 
     !--- The CSM allocates modem 2/0 to the incoming call.

     Sep 28 13:13:28.373: EVENT_FROM_ISDN::dchan_idb=0x618569F4, call_id=0x28, 
     ces=0x0 bchan=0x2, event=0x1, cause=0x0
     Sep 28 13:13:28.373:  dev in call to isdn : set dnis_collected & fap_notify
     Sep 28 13:13:28.373: EVENT_FROM_ISDN:(0028): DEV_INCALL at slot 2 and port 0
     Sep 28 13:13:28.373:  EVENT_FROM_ISDN: decode:calling 0ct3 0x0, called oct3 
     0xA1, oct3a 0x0,mask 0x3C
     Sep 28 13:13:28.373:  EVENT_FROM_ISDN: csm_call_info:calling 0ct3 0x0, 
     called oct3 0xA1, oct3a 0x0,mask 0x3C
     Sep 28 13:13:28.377: CSM_PROC_IDLE: CSM_EVENT_ISDN_CALL at slot 2, port 0
     Sep 28 13:13:28.377: Mica Modem(2/0): Configure(0x1 = 0x0) 
     Sep 28 13:13:28.377: Mica Modem(2/0): Configure(0x23 = 0x0) 
     Sep 28 13:13:28.377: Mica Modem(2/0): Call Setup
     
!--- CSM sends the Call Setup Message to Modem 2/0.
     !--- The modem must now go off-hook.

     Sep 28 13:13:28.377: csm_connect_pri_vdev: TS allocated at bp_stream 0, 
     bp_Ch 0,vdev_common 0x6141BB68
     Sep 28 13:13:28.377: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0xD285
     Sep 28 13:13:28.377:         Channel ID i = 0xA98383
     
!--- The Call Proceeding Message is sent through the D-channel.

     Sep 28 13:13:28.377: ISDN Se0:23: TX ->  ALERTING pd = 8  callref = 0xD285
     Sep 28 13:13:28.445: Mica Modem(2/0): State Transition to Call Setup
     
!--- Modem transitions to state Call Setup. 
     !--- For more information on MICA Modem States refer to MICA Modem States.

     Sep 28 13:13:28.445: Mica Modem(2/0): Went offhook
     
!--- Modem informs the CSM that it went offhook.

     Sep 28 13:13:28.445: CSM_PROC_IC2_RING: CSM_EVENT_MODEM_OFFHOOK at slot 2, port 0
     Sep 28 13:13:28.445: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0xD285
     
!--- D-channel transmits a CONNECT.

     Sep 28 13:13:28.461: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x5285
     
!--- The Q.931 CONNECT_ACK message is received.

     Sep 28 13:13:28.461: ISDN Se0:23: CALL_PROGRESS: CALL_CONNECTED call id 0x28, 
     bchan 2, dsl 0
     Sep 28 13:13:28.461: EVENT_FROM_ISDN::dchan_idb=0x618569F4, call_id=0x28, 
     ces=0x0 bchan=0x2, event=0x4, cause=0x0
     Sep 28 13:13:28.461: EVENT_FROM_ISDN:(0028): DEV_CONNECTED at slot 2 and port 0
     Sep 28 13:13:28.461: CSM_PROC_IC6_WAIT_FOR_CONNECT: 
     CSM_EVENT_ISDN_CONNECTED at slot 2, port 0
     Sep 28 13:13:28.465: Mica Modem(2/0): Link Initiate
     
!--- When the Q.931 CONNECT_ACK message is received, the Link initiate message 
     !--- is sent to the MICA modem, and negotiation with remote modem occurs.

     Sep 28 13:13:28.465: %ISDN-6-CONNECT: Interface Serial0:2 is now connected to N/A N/A
     Sep 28 13:13:29.557: Mica Modem(2/0): State Transition to Connect
     
!--- Modem moves to the Connect state.

     Sep 28 13:13:34.073: Mica Modem(2/0): State Transition to Link
     Sep 28 13:13:45.478: Mica Modem(2/0): State Transition to Trainup
     Sep 28 13:13:53.642: Mica Modem(2/0): State Transition to EC Negotiating
     Sep 28 13:13:54.122: Mica Modem(2/0): State Transition to Steady State
     
!--- Modem tranistions to the Steady state.

     Sep 28 13:13:54.266: TTY97: DSR came up
     
!--- Indicates that the modem trainup is complete.

     Sep 28 13:13:54.266: tty97: Modem: IDLE->(unknown)
     Sep 28 13:13:54.266: TTY97: EXEC creation
     Sep 28 13:13:54.266: TTY97: set timer type 10, 30 seconds
     Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7E
     Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7EFF
     Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7EFF7D
     Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7EFF7D23
     Sep 28 13:13:57.202: TTY97 Autoselect cmd:  ppp negotiate
     
!--- The router detects PPP packets and automatically launches PPP.

     Sep 28 13:13:57.206: TTY97: EXEC creation
     Sep 28 13:13:57.206: TTY97: create timer type 1, 600 seconds
     Sep 28 13:13:57.334: TTY97: destroy timer type 1
     Sep 28 13:13:57.334: TTY97: no timer type 0 to destroy
     Sep 28 13:13:57.334: As97 IPCP: Install route to 172.22.60.2
     Sep 28 13:13:59.334: %LINK-3-UPDOWN: Interface Async97, changed state to up
     Sep 28 13:13:59.334: As97 PPP: Treating connection as a callin
     Sep 28 13:13:59.334: As97 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]
     Sep 28 13:13:59.334: As97 LCP: State is Listen
     
!--- LCP negotiation begins.

     Sep 28 13:14:00.214: As97 LCP: I CONFREQ [Listen] id 3 len 23
     
!--- Incoming LCP CONFREQ.
     !--- For more information on how to interpret PPP debugs, refer to 
     !--- Dialup Technology: Troubleshooting Techniques.

     Sep 28 13:14:00.214: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)
     Sep 28 13:14:00.214: As97 LCP:    MagicNumber 0x0F7CD34A (0x05060F7CD34A)
     Sep 28 13:14:00.214: As97 LCP:    PFC (0x0702)
     Sep 28 13:14:00.214: As97 LCP:    ACFC (0x0802)
     Sep 28 13:14:00.214: As97 LCP:    Callback 6  (0x0D0306)
     Sep 28 13:14:00.214: Unthrottle 97
     Sep 28 13:14:00.214: As97 LCP: O CONFREQ [Listen] id 1 len 43
     Sep 28 13:14:00.214: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)
     Sep 28 13:14:00.214: As97 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:14:00.214: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)
     Sep 28 13:14:00.214: As97 LCP:    PFC (0x0702)
     Sep 28 13:14:00.214: As97 LCP:    ACFC (0x0802)
     Sep 28 13:14:00.214: As97 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:14:00.214: As97 LCP:    EndpointDisc 1 Local (
     0x130E016D6175692D6E61732D3032)
     Sep 28 13:14:00.214: As97 LCP: O CONFREJ [Listen] id 3 len 7
     Sep 28 13:14:00.214: As97 LCP:    Callback 6  (0x0D0306)
     Sep 28 13:14:00.342: As97 LCP: I CONFREQ [REQsent] id 4 len 20
     Sep 28 13:14:00.342: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)
     Sep 28 13:14:00.342: As97 LCP:    MagicNumber 0x0F7CD34A (0x05060F7CD34A)
     Sep 28 13:14:00.342: As97 LCP:    PFC (0x0702)
     Sep 28 13:14:00.342: As97 LCP:    ACFC (0x0802)
     Sep 28 13:14:00.342: As97 LCP: O CONFACK [REQsent] id 4 len 20
     Sep 28 13:14:00.342: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)
     Sep 28 13:14:00.342: As97 LCP:    MagicNumber 0x0F7CD34A (0x05060F7CD34A)
     Sep 28 13:14:00.342: As97 LCP:    PFC (0x0702)
     Sep 28 13:14:00.342: As97 LCP:    ACFC (0x0802)
     Sep 28 13:14:02.214: As97 LCP: TIMEout: State ACKsent
     Sep 28 13:14:02.214: As97 LCP: O CONFREQ [ACKsent] id 2 len 43
     Sep 28 13:14:02.214: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)
     Sep 28 13:14:02.214: As97 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:14:02.214: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)
     Sep 28 13:14:02.214: As97 LCP:    PFC (0x0702)
     Sep 28 13:14:02.214: As97 LCP:    ACFC (0x0802)
     Sep 28 13:14:02.214: As97 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:14:02.214: As97 LCP:    EndpointDisc 1 Local 
     (0x130E016D6175692D6E61732D3032)
     Sep 28 13:14:02.326: As97 LCP: I CONFREJ [ACKsent] id 2 len 22
     Sep 28 13:14:02.326: As97 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:14:02.326: As97 LCP:    EndpointDisc 1 Local 
     (0x130E016D6175692D6E61732D3032)
     Sep 28 13:14:02.326: As97 LCP: O CONFREQ [ACKsent] id 3 len 25
     Sep 28 13:14:02.326: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)
     Sep 28 13:14:02.326: As97 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:14:02.326: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)
     Sep 28 13:14:02.326: As97 LCP:    PFC (0x0702)
     Sep 28 13:14:02.326: As97 LCP:    ACFC (0x0802)
     Sep 28 13:14:02.518: As97 LCP: I CONFACK [ACKsent] id 3 len 25
     Sep 28 13:14:02.518: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)
     Sep 28 13:14:02.518: As97 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:14:02.518: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)
     Sep 28 13:14:02.518: As97 LCP:    PFC (0x0702)
     Sep 28 13:14:02.518: As97 LCP:    ACFC (0x0802)
     Sep 28 13:14:02.518: As97 LCP: State is Open
     
!--- LCP negotiation is complete.

     Sep 28 13:14:02.518: As97 PPP: Phase is AUTHENTICATING, 
     by this end [0 sess, 0 load]
     Sep 28 13:14:02.518: As97 CHAP: O CHALLENGE id 1 len 32 from "maui-nas-02"
     Sep 28 13:14:02.646: As97 CHAP: I RESPONSE id 1 len 31 from "async_user"
     Sep 28 13:14:02.646: As97 AUTH: Started process 0 pid 34
     Sep 28 13:14:02.650: As97 CHAP: O SUCCESS id 1 len 4
     
!--- CHAP authentication is successful. 
     !--- If authentication fails, check the username and password.
     !--- Refer to Dialup Technology: Troubleshooting Techniques

.
     Sep 28 13:14:02.650: As97 PPP: Phase is UP [0 sess, 0 load]
     Sep 28 13:14:02.650: As97 IPCP: O CONFREQ [Closed] id 1 len 10
     
!--- IPCP negotiation begins.

     Sep 28 13:14:02.650: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)
     Sep 28 13:14:02.758: As97 IPCP: I CONFREQ [REQsent] id 1 len 40
     Sep 28 13:14:02.758: As97 IPCP:    CompressType VJ 15 slots CompressSlotID 
     (0x0206002D0F01)
     Sep 28 13:14:02.758: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
     Sep 28 13:14:02.758: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
     Sep 28 13:14:02.758: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)
     Sep 28 13:14:02.758: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
     Sep 28 13:14:02.758: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)
     Sep 28 13:14:02.758: As97 AAA/AUTHOR/IPCP: Start.  
     Her address 0.0.0.0, we want 172.22.60.2
     Sep 28 13:14:02.758: As97 AAA/AUTHOR/IPCP: Done.  
     Her address 0.0.0.0, we want 172.22.60.2
     
!--- Address is obtained from the Address Pool named "Async".

     Sep 28 13:14:02.758: As97 IPCP: O CONFREJ [REQsent] id 1 len 28
     Sep 28 13:14:02.758: As97 IPCP:    CompressType VJ 15 slots CompressSlotID 
     (0x0206002D0F01)
     Sep 28 13:14:02.758: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)
     Sep 28 13:14:02.758: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
     Sep 28 13:14:02.758: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)
     Sep 28 13:14:02.802: As97 CCP: I CONFREQ [Not negotiated] id 1 len 15
     Sep 28 13:14:02.802: As97 CCP:    MS-PPC supported bits 0x00000001 
     (0x120600000001)
     Sep 28 13:14:02.802: As97 CCP:    Stacker history 1 check mode EXTENDED 
     (0x1105000104)
     Sep 28 13:14:02.802: As97 LCP: O PROTREJ [Open] id 4 len 21 protocol CCP
     Sep 28 13:14:02.802: As97 LCP:  (0x80FD0101000F12060000000111050001)
     Sep 28 13:14:02.802: As97 LCP:  (0x04)
     Sep 28 13:14:02.802: As97 IPCP: I CONFACK [REQsent] id 1 len 10
     Sep 28 13:14:02.802: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)
     Sep 28 13:14:04.650: As97 IPCP: TIMEout: State ACKrcvd
     Sep 28 13:14:04.650: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
     Sep 28 13:14:04.650: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)
     Sep 28 13:14:04.758: As97 IPCP: I CONFACK [REQsent] id 2 len 10
     Sep 28 13:14:04.758: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)
     Sep 28 13:14:05.750: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34
     Sep 28 13:14:05.750: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
     Sep 28 13:14:05.750: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
     Sep 28 13:14:05.750: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)
     Sep 28 13:14:05.750: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
     Sep 28 13:14:05.750: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)
     Sep 28 13:14:05.750: As97 AAA/AUTHOR/IPCP: Start.  
     Her address 0.0.0.0, we want 172.22.60.2
     Sep 28 13:14:05.750: As97 AAA/AUTHOR/IPCP: Done.  
     Her address 0.0.0.0, we want 172.22.60.2
     Sep 28 13:14:05.750: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22
     Sep 28 13:14:05.750: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)
     Sep 28 13:14:05.754: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
     Sep 28 13:14:05.754: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)
     Sep 28 13:14:05.878: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
     Sep 28 13:14:05.878: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
     Sep 28 13:14:05.878: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
     Sep 28 13:14:05.878: As97 AAA/AUTHOR/IPCP: Start.  
     Her address 0.0.0.0, we want 172.22.60.2
     Sep 28 13:14:05.878: As97 AAA/AUTHOR/IPCP: Done.  
     Her address 0.0.0.0, we want 172.22.60.2
     Sep 28 13:14:05.878: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10
     Sep 28 13:14:05.878: As97 IPCP:    Address 172.22.60.2 (0x0306AC163C02)
     Sep 28 13:14:05.990: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16
     Sep 28 13:14:05.990: As97 IPCP:    Address 172.22.60.2 (0x0306AC163C02)
     Sep 28 13:14:05.990: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
     Sep 28 13:14:05.990: As97 AAA/AUTHOR/IPCP: Start.  
     Her address 172.22.60.2, we want 172.22.60.2
     Sep 28 13:14:05.990: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, using 172.22.60.2
     Sep 28 13:14:05.990: As97 AAA/AUTHOR/IPCP: Done.  
     Her address 172.22.60.2, we want 172.22.60.2
     Sep 28 13:14:05.994: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16
     Sep 28 13:14:05.994: As97 IPCP:    Address 172.22.60.2 (0x0306AC163C02)
     Sep 28 13:14:05.994: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
     Sep 28 13:14:05.994: As97 IPCP: State is Open
     
!--- IPCP negotiation is complete. The user is now connected.

For an ISDN Call

maui-nas-02#debug isdn q931
     ISDN Q931 packets debugging is on
     maui-nas-02#debug ppp negotiation
     PPP protocol negotiation debugging is on
     maui-nas-02#debug ppp authentication
     PPP authentication debugging is on

     Sep 28 13:25:02.630: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x5346
     
!--- Incoming Q.931 Setup message.

     Sep 28 13:25:02.630:         Bearer Capability i = 0x8890218F
     Sep 28 13:25:02.630:         Channel ID i = 0xA18384
     Sep 28 13:25:02.630:         Called Party Number i = 0xA1, '81560', 
     Plan:ISDN, Type:National
     Sep 28 13:25:02.634: %LINK-3-UPDOWN: Interface Serial0:3, changed state to up
     Sep 28 13:25:02.638: Se0:3 PPP: Treating connection as a callin
     Sep 28 13:25:02.638: Se0:3 PPP: Phase is ESTABLISHING, 
     Passive Open [0 sess, 1 load]
     Sep 28 13:25:02.638: Se0:3 LCP: State is Listen
     Sep 28 13:25:02.638: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0xD346
     Sep 28 13:25:02.638:         Channel ID i = 0xA98384
     Sep 28 13:25:02.638: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0xD346
     Sep 28 13:25:02.638:         Channel ID i = 0xA98384
     Sep 28 13:25:02.658: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x5346

     Sep 28 13:25:02.658: ISDN Se0:23: CALL_PROGRESS: 
     CALL_CONNECTED call id 0x2B, bchan 3, dsl 0
     
!--- Call is connected.

     Sep 28 13:25:02.886: Se0:3 LCP: I CONFREQ [Listen] id 61 len 28
     Sep 28 13:25:02.886: Se0:3 LCP:    MagicNumber 0x1EB88B1C (0x05061EB88B1C)
     Sep 28 13:25:02.886: Se0:3 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:02.886: Se0:3 LCP:    EndpointDisc 1 Local 
     (0x130E0161757374696E5F6973646E)
     Sep 28 13:25:02.886: Se0:3 LCP: O CONFREQ [Listen] id 1 len 33
     Sep 28 13:25:02.886: Se0:3 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:25:02.886: Se0:3 LCP:    MagicNumber 0x309AFABD (0x0506309AFABD)
     Sep 28 13:25:02.886: Se0:3 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:02.886: Se0:3 LCP:    EndpointDisc 1 Local 
     (0x130E016D6175692D6E61732D3032)
     Sep 28 13:25:02.886: Se0:3 LCP: O CONFACK [Listen] id 61 len 28
     Sep 28 13:25:02.886: Se0:3 LCP:    MagicNumber 0x1EB88B1C (0x05061EB88B1C)
     Sep 28 13:25:02.886: Se0:3 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:02.886: Se0:3 LCP:    EndpointDisc 1 Local 
     (0x130E0161757374696E5F6973646E)
     Sep 28 13:25:02.922: Se0:3 LCP: I CONFACK [ACKsent] id 1 len 33
     Sep 28 13:25:02.922: Se0:3 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:25:02.922: Se0:3 LCP:    MagicNumber 0x309AFABD (0x0506309AFABD)
     Sep 28 13:25:02.922: Se0:3 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:02.922: Se0:3 LCP:    EndpointDisc 1 Local 
     (0x130E016D6175692D6E61732D3032)
     Sep 28 13:25:02.922: Se0:3 LCP: State is Open
     
!--- LCP negotiation is complete.

     Sep 28 13:25:02.922: Se0:3 PPP: 
     Phase is AUTHENTICATING, by this end [0 sess, 1 load]
     Sep 28 13:25:02.922: Se0:3 CHAP: O CHALLENGE id 1 len 32 from "maui-nas-02"
     Sep 28 13:25:02.954: Se0:3 CHAP: I RESPONSE id 1 len 32 from "austin_isdn"
     Sep 28 13:25:02.954: Se0:3 CHAP: O SUCCESS id 1 len 4
     
!--- PPP CHAP authentication is successful.

     Sep 28 13:25:02.958: Se0:3 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
     Sep 28 13:25:02.958: Vi1 PPP: Phase is DOWN, Setup [0 sess, 1 load]
     Sep 28 13:25:02.982: Vi1 PPP: Phase is DOWN, Setup [0 sess, 1 load]
     Sep 28 13:25:02.982: Se0:3 IPCP: 
     Packet buffered while building MLP bundle interface
     Sep 28 13:25:02.986: %LINK-3-UPDOWN: Interface Virtual-Access1, 
     changed state to up
     
!--- Virtual-Access Interface is up. 
     !--- This interface controls the incoming call.

     Sep 28 13:25:02.986: Vi1 PPP: Treating connection as a callin
     Sep 28 13:25:02.986: Vi1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 1 load]
     Sep 28 13:25:02.986: Vi1 LCP: State is Listen
     Sep 28 13:25:02.986: Vi1 PPP: Phase is UP [0 sess, 1 load]
     Sep 28 13:25:02.986: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
     Sep 28 13:25:02.986: Vi1 IPCP:    Address 172.22.61.1 (0x0306AC163D01)
     Sep 28 13:25:02.990: Vi1 MLP: Added first link Se0:3 to bundle austin_isdn
     Sep 28 13:25:02.990: Vi1 PPP: Pending ncpQ size is 1
     Sep 28 13:25:02.990: Se0:3 IPCP: Redirect packet to Vi1
     Sep 28 13:25:02.990: Vi1 IPCP: I CONFREQ [REQsent] id 45 len 10
     Sep 28 13:25:02.990: Vi1 IPCP:    Address 10.0.0.1 (0x03060A000001)
     Sep 28 13:25:02.990: Vi1 AAA/AUTHOR/IPCP: Start.  
     Her address 10.0.0.1, we want 0.0.0.0
     Sep 28 13:25:02.990: Vi1 AAA/AUTHOR/IPCP: Reject 10.0.0.1, using 0.0.0.0
     Sep 28 13:25:02.990: Vi1 AAA/AUTHOR/IPCP: Done.  
     Her address 10.0.0.1, we want 0.0.0.0
     Sep 28 13:25:02.990: Vi1 IPCP: O CONFNAK [REQsent] id 45 len 10
     Sep 28 13:25:02.990: Vi1 IPCP:    Address 172.22.61.2 (0x0306AC163D02)
     
!--- Peer IP address is assigned from IP Pool named "ISDN".

     Sep 28 13:25:02.990: Se0:3 CDPCP: MLP bundle interface is built, 
     process packets now 
     Sep 28 13:25:02.990: Se0:3 CDPCP: Redirect packet to Vi1
     Sep 28 13:25:02.990: Vi1 CDPCP: I CONFREQ [Not negotiated] id 23 len 4
     Sep 28 13:25:02.990: Vi1 LCP: O PROTREJ [Open] id 1 len 10 protocol CDPCP 
     (0x820701170004)
     Sep 28 13:25:03.010: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10
     Sep 28 13:25:03.010: Vi1 IPCP:    Address 172.22.61.1 (0x0306AC163D01)
     Sep 28 13:25:03.010: Vi1 IPCP: I CONFREQ [ACKrcvd] id 46 len 4
     Sep 28 13:25:03.010: Vi1 IPCP: O CONFACK [ACKrcvd] id 46 len 4
     Sep 28 13:25:03.010: Vi1 IPCP: State is Open
     
!--- IPCP negotiation is complete. The call is now connected.

     Sep 28 13:25:03.014: Di10 IPCP: Install route to 172.22.61.2
     Sep 28 13:25:03.958: %LINEPROTO-5-UPDOWN: 
     Line protocol on Interface Serial0:3, changed state to up
     Sep 28 13:25:03.986: %LINEPROTO-5-UPDOWN: 
     Line protocol on Interface Virtual-Access1, changed state to up
     Sep 28 13:25:04.146: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x5409
     
!--- The second link in the multilink connection arrives.

     Sep 28 13:25:04.150:         Bearer Capability i = 0x8890218F
     Sep 28 13:25:04.150:         Channel ID i = 0xA18385
     Sep 28 13:25:04.150:         Called Party Number i = 0xA1, '81560', Plan:ISDN, 
     Type:National
     Sep 28 13:25:04.154: %LINK-3-UPDOWN: Interface Serial0:4, changed state to up
     Sep 28 13:25:04.154: %ISDN-6-CONNECT: Interface Serial0:3 is now connected to  
     austin_isdn
     Sep 28 13:25:04.154: Se0:4 PPP: Treating connection as a callin
     Sep 28 13:25:04.154: Se0:4 PPP: Phase is ESTABLISHING, 
     Passive Open [0 sess, 1 load]
     Sep 28 13:25:04.154: Se0:4 LCP: State is Listen
     Sep 28 13:25:04.158: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0xD409
     Sep 28 13:25:04.158:         Channel ID i = 0xA98385
     Sep 28 13:25:04.158: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0xD409
     Sep 28 13:25:04.158:         Channel ID i = 0xA98385
     Sep 28 13:25:04.178: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x5409

     Sep 28 13:25:04.178: ISDN Se0:23: CALL_PROGRESS: 
     CALL_CONNECTED call id 0x2C, bchan 4, dsl 0
     Sep 28 13:25:04.394: Se0:4 LCP: I CONFREQ [Listen] id 51 len 28
     Sep 28 13:25:04.394: Se0:4 LCP:    MagicNumber 0x1EB8910D (0x05061EB8910D)
     Sep 28 13:25:04.394: Se0:4 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:04.394: Se0:4 LCP:    EndpointDisc 1 Local 
     (0x130E0161757374696E5F6973646E)
     Sep 28 13:25:04.394: Se0:4 LCP: O CONFREQ [Listen] id 1 len 33
     Sep 28 13:25:04.394: Se0:4 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:25:04.394: Se0:4 LCP:    MagicNumber 0x309B00A6 (0x0506309B00A6)
     Sep 28 13:25:04.394: Se0:4 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:04.394: Se0:4 LCP:    EndpointDisc 1 Local 
     (0x130E016D6175692D6E61732D3032)
     Sep 28 13:25:04.394: Se0:4 LCP: O CONFACK [Listen] id 51 len 28
     Sep 28 13:25:04.394: Se0:4 LCP:    MagicNumber 0x1EB8910D (0x05061EB8910D)
     Sep 28 13:25:04.394: Se0:4 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:04.394: Se0:4 LCP:    EndpointDisc 1 Local 
     (0x130E0161757374696E5F6973646E)
     Sep 28 13:25:04.430: Se0:4 LCP: I CONFACK [ACKsent] id 1 len 33
     Sep 28 13:25:04.430: Se0:4 LCP:    AuthProto CHAP (0x0305C22305)
     Sep 28 13:25:04.430: Se0:4 LCP:    MagicNumber 0x309B00A6 (0x0506309B00A6)
     Sep 28 13:25:04.430: Se0:4 LCP:    MRRU 1524 (0x110405F4)
     Sep 28 13:25:04.430: Se0:4 LCP:    EndpointDisc 1 Local 
     (0x130E016D6175692D6E61732D3032)
     Sep 28 13:25:04.430: Se0:4 LCP: State is Open
     Sep 28 13:25:04.430: Se0:4 PPP: Phase is AUTHENTICATING, 
     by this end [0 sess, 1 load]
     Sep 28 13:25:04.430: Se0:4 CHAP: O CHALLENGE id 1 len 32 from "maui-nas-02"
     Sep 28 13:25:04.462: Se0:4 CHAP: I RESPONSE id 1 len 32 from "austin_isdn"
     Sep 28 13:25:04.466: Se0:4 CHAP: O SUCCESS id 1 len 4
     Sep 28 13:25:04.466: Se0:4 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
     Sep 28 13:25:04.466: Vi1 MLP: Added link Se0:4 to bundle austin_isdn
     
!--- An additional Link is now added to exiting Virtual Interface Bundle.

     Sep 28 13:25:05.466: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:4, 
     changed state to up
     Sep 28 13:25:10.154: %ISDN-6-CONNECT: 
     Interface Serial0:4 is now connected to austin_isdn
     
!--- The second call is connected. The multilink Bundle is complete. 

     maui-nas-02# 

Related Information

Updated: Jan 29, 2008
Document ID: 6310