Guest

ISDN, CAS

Configuring an Async Interface as a Backup for a Serial Line

Document ID: 14281

Updated: Sep 14, 2005

   Print

Introduction

It is common to provide redundant paths for WAN connections, such as serial, lease-line or Frame Relay, with dial-on-demand (DDR) circuits. Asynchronous modems and circuit-switched Plain Old Telephone Service (POTS) lines are used to backup WAN interfaces. Careful planning is necessary when designing dial backup scenarios. Consider factors such as traffic on the backup links, the number of links susceptible to failure, and port capacity planning to support backup circuits.

Prerequisites

Requirements

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • A Cisco 2500 router platform.

  • Cisco IOS® Software Release 12.1(2)T on router gaugin.

  • Cisco IOS Software Release 12.0(7)T on router sphinx.

  • Excternal modems connected to the Serial port on the routers.

Note: This document can be modified for use on any router with async interfaces (or built-in modems). The configuration of the backup interface (interface Serial 2, in this example) would be included under "interface Async x".

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Background Information

Three common methods available to provide backup for a WAN link are:

  • Backup interfaces - A backup interface remains in standby mode until the primary link goes down. The backup link is then activated, re-establishing the connection between the two sites.

  • Dialer watches - A dialer watch provides reliable connectivity without relying solely on defining interesting traffic to trigger outgoing calls at the central router. The dialer watch monitors certain specific routes and, if those networks are unreachable, the dialer watch brings up the secondary link.

  • Floating static routes - Floating static routes are static routes that have an administrative distance greater than the administrative distance of dynamic routes. Administrative distances can be configured on a static route so that the static route is less desirable than a dynamic route; hence, the static route is not used when the dynamic route is available. However, if the dynamic route is lost, the static route can take over and traffic can be sent through this alternative route.

This scenario uses Backup Interface to perform backup.For more information on the uses of backup interface refer to the document Evaluating Backup Interfaces, Floating Static Routes, and Dialer Watch for DDR Backup.

For more information on configuring backup please refer to the document Configuring and Troubleshooting DDR Backup. The document provides information on determining which backup method should be used and other configuration information.

Please read and understand the above two documents before proceeding with this configuration.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

async_backup_14281.gif

Configurations

In this configuration we are using two Cisco routers (gaugin and sphinx) that are connected over a leased line through their serial 0 interfaces. The serial 2 interfaces are connected by async modems over a Public Switched Telephone Network (PSTN) line, and used as a backup for the leased line.

Note: By default, these interfaces work in sync mode, you have to manually configure them (using the physical-layer async command) to work in async mode.

By using the show version command, you can find out whether these interfaces can work in async mode too. The relevant information displayed by the show version command is shown below:

2 Low-speed serial(sync/async) network interfaces

! --- This means it can work in sync or async mode.

It is recommended that you complete the configuration and verify that the modem connection can be done. You can do this by reverse telnetting to the modems, and making a call to the number of the remote modem.

Note: It is also compulsory to use a modem capability (modemcap) depending on the modem type. For further information on this, refer to Modem-Router Connection Guide

gaugin (Cisco 2500) - Calling Router
gaugin#show running-config
 Building configuration...

 Current configuration:
 hostname gaugin

 username sphinx password 0 cisco

 !---Username and shared secret for CHAP authentication.

 !
 chat-script CALLOUT "" "atdt\T" TIMEOUT 60 CONNECT \c

 !--- Chat script used for dialout.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W;

 !--- Modemcap for the external modem.
 !--- Refer to Modem-Router Connection Guide for more information.

 interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 !
 interface Serial0
 
!--- Primary link.

  ip address 3.3.3.1 255.255.255.0

 !--- Remote peer serial interface is in same subnet.

  backup interface serial 2

 !--- Designate interface serial 2 as the backup interface.

 !
 interface Serial2

 !--- Backup interface. This interface will be in "Standby" mode until the
 !--- line protocol on interface Serial 0 (the primary) goes down.

  physical-layer async
 
!--- Permit async mode.

  ip unnumbered Loopback1
  encapsulation ppp
  dialer in-band
  dialer map ip 2.2.2.1 name sphinx modem-script CALLOUT 8029

 !--- Dialer map for the peer. 
!--- Note the ip address, the name (which matches the
!--- authenticated username, the chat script used and the number to dial.

  dialer-group 1

 !--- Interesting traffic definition for dialout.

  async mode dedicated
  no peer default ip address

 !--- Do not provide the peer with an IP address. 
!--- It must have one configured.

  no fair-queue
  ppp authentication chap callin

 !--- Use one-way chap authentication.

 !
 ip route 2.2.2.1 255.255.255.255 Serial0
 ip route 2.2.2.1 255.255.255.255 Serial2

 ! -- Identical routes for the peer. 
!--- Note the IP address matches the dialer map ip.
 !--- When the primary is up, the backup in in Standby hence the route using
 !--- Serial 2 will not be used. When the backup is brought out of standby
 !--- it will get used and the serial 0 route is removed (since the link is down/down)
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 2.2.2.1.



 dialer-list 1 protocol ip permit

 !--- Interesting traffic definition. 
!--- Once the backup link is brought out of standby
!--- dialout is ONLY initiaited after the router receives interesting traffic.


 line 2

 !--- Line configuration for the modem on interface Serial 2. 

 script dialer CALLOUT

 !--- Use script CALLOUT.

 modem InOut
 modem autoconfigure type usr

 !--- Use modemcap named "usr" configured earlier.

 transport input all
 speed 115200

 !--- DTE-DCE speed.

 flowcontrol hardware

sphinx (Cisco 2500) - Called Router
sphinx#show running-config
 Building configuration...

 Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname sphinx
 username gaugin password 0 cisco

 !--- Username and shared secret for CHAP authentication.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W; !
 interface Loopback1
 ip address 2.2.2.1 255.255.255.255
 no ip directed-broadcast
 !
 interface Serial0

 !--- Primary interface
 !--- Note that this router does not initiate the backup when the primary fails
 !--- it will rely on the peer to initiate the connection.

 ip address 3.3.3.2 255.255.255.0
 !
 interface Serial2

 !--- Interface providing backup.
 !--- There is no dialer map/dialer string since it is only accepting the call.
 !--- This interface will be in Up/Up(Spoofing) mode when the primary interface is up.
 !--- Later, configure a floating static route to prevent packet loss.

 physical-layer async
 ip unnumbered Loopback1
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer-group 1
 async mode dedicated
 no peer default ip address
 no fair-queue
 no cdp enable
 ppp authentication chap

 ip route 1.1.1.1 255.255.255.255 Serial0
 ip route 1.1.1.1 255.255.255.255 Serial2 2 

 !--- The 2 makes the route a floating static route.
 !--- This is important since the async interface will be in spoofing mode 
 !--- (not in standby mode) when the primary interface is up.
 !--- If we do not use the 2 here, we lose half of the packets in the return path
 !--- since the router will attempt to load balance
 !--- across the 2 links (eventhough the backup is down).
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 1.1.1.1.


 line 2
  modem InOut
  modem autoconfigure type usr
  transport input all
  speed 115200
  flowcontrol hardware

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show interface serial - Displays information about a serial interface.

  • show ip route - Displays the current state of the routing table.

  • show line - Displays parameters of a terminal line.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

For more information on troubleshoting backup interface please refer to the document Configuring and Troubleshooting DDR Backup

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • show dialer - Displays information about a dialer interface.

  • ping - Tests connectivity.

  • debug modem - Observes modem line activity on an access server.

  • debug ppp negotiation - Displays information on PPP traffic and exchanges while negotiating the PPP components including Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation will first open the LCP state, then Authenticate, and finally negotiate NCP.

  • debug ppp authentication - Displays the PPP authentication protocol messages, including Challenge Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges. If you observe a failure, verify that the chap username and password are configured correctly.

  • debug chat - Displays the chat script activity.

  • debug dialer - Displays DDR debugging information about the packets received on a dialer interface.

In the sample output below, we can see that the main serial connection (serial 0) on gaugin (the calling router) has a problem and drops the connection. The backup interface (serial 2) starts making the backup connection. For this example, we disconnected the cable to test the backup link.

Note: Issuing the shutdown command on the primary interface will not cause the backup to dial. If you issue a shutdown command to bring down the primary connection , the Cisco IOS software will not automatically bring up a backup connection. You must physically bring down the primary connection by unplugging cables or some equivalent method in order to bring up the backup interfaces.

   gaugin#
   *Mar 1 00:57:25.127: %LINK-3-UPDOWN: Interface Serial0, changed state to down
   *Mar 1 00:57:26.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
    changed state to down

    !--- Primary Link is brought down. 
    !--- This will cause the backup link (int Serial 2) to be taken out of standby.

   *Mar 1 00:57:37.143: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   
!--- The Backup link is changes from Standby to Down.

   *Mar 1 00:57:37.147: Se2 LCP: State is Closed..
   *Mar 1 00:57:40.019: TTY2: restoring DTR
   *Mar 1 00:57:41.019: TTY2: autoconfigure probe started
   *Mar 1 00:57:52.147: Se2 DDR: re-enable timeout.
   *Mar 1 00:57:55.067: Se2 DDR: Dialing cause ip (s=1.1.1.1, d=2.2.2.1)
   
!--- Interesting traffic for the peer causes the dialout.

   *Mar 1 00:57:55.071: Se2 DDR: Attempting to dial 8029
   *Mar 1 00:57:55.071: CHAT2: Attempting async line dialer script
   *Mar 1 00:57:55.075: CHAT2: Dialing using Modem script: CALLOUT 
   & System script: none
   
!--- Chat-script named CALLOUT is used.

   *Mar 1 00:57:55.083: CHAT2: process started
   *Mar 1 00:57:55.083: CHAT2: Asserting DTR
   *Mar 1 00:57:55.087: CHAT2: Chat script CALLOUT started
   *Mar 1 00:57:55.087: CHAT2: Sending string: atdt\T<8029>
   *Mar 1 00:57:55.091: CHAT2: Expecting string: CONNECT.........
   *Mar 1 00:58:12.859: CHAT2: Completed match for expect: CONNECT
   *Mar 1 00:58:12.859: CHAT2: Sending string: \c
   *Mar 1 00:58:12.863: CHAT2: Chat script CALLOUT finished, status = Success
   *Mar 1 00:58:12.867: TTY2: no timer type 1 to destroy
   *Mar 1 00:58:12.867: TTY2: no timer type 0 to destroy
   *Mar 1 00:58:12.875: Se2 IPCP: Install route to 2.2.2.1.
   *Mar 1 00:58:14.871: %LINK-3-UPDOWN: Interface Serial2, changed state to up
       Dialer state change to up Serial2 Dialer call has been placed Serial2
   *Mar 1 00:58:14.891: Se2 PPP: Treating connection as a callout

    !--- PPP LCP negotiation begins.

   *Mar 1 00:58:14.891: Se2 PPP: Phase is ESTABLISHING, Active Open
   *Mar 1 00:58:14.895: Se2 PPP: No remote authentication for call-out
   *Mar 1 00:58:14.899: Se2 LCP: O CONFREQ [Closed] id 10 len 20
   *Mar 1 00:58:14.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:14.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:14.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:14.907: Se2 LCP: ACFC (0x0802).
   *Mar 1 00:58:16.895: Se2 LCP: TIMEout: State REQsent
   *Mar 1 00:58:16.899: Se2 LCP: O CONFREQ [REQsent] id 11 len 20
   *Mar 1 00:58:16.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:16.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:16.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:16.907: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.063: Se2 LCP: I CONFACK [REQsent] id 11 len 20
   *Mar 1 00:58:17.067: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.067: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:17.071: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.075: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.083: Se2 LCP: I CONFREQ [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.083: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.087: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.091: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.095: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.095: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.099: Se2 LCP: O CONFACK [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.103: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.103: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.107: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.111: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.111: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.115: Se2 LCP: State is Open
    
!--- LCP negotiation is complete.

   *Mar 1 00:58:17.115: Se2 PPP: Phase is AUTHENTICATING, by the peer
   *Mar 1 00:58:17.263: Se2 CHAP: I CHALLENGE id 4 len 27 from "sphinx"
   *Mar 1 00:58:17.271: Se2 CHAP: O RESPONSE id 4 len 27 from "gaugin"
   *Mar 1 00:58:17.391: Se2 CHAP: I SUCCESS id 4 len 4
   *Mar 1 00:58:17.395: Se2 PPP: Phase is UP
   *Mar 1 00:58:17.399: Se2 IPCP: O CONFREQ [Closed] id 4 len 10
   *Mar 1 00:58:17.399: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.407: Se2 CDPCP: O CONFREQ [Closed] id 4 len 4
   *Mar 1 00:58:17.411: Se2 IPCP: I CONFREQ [REQsent] id 5 len 10
   *Mar 1.00:58:17.415: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.419: Se2 IPCP: O CONFACK [REQsent] id 5 len 10
   *Mar 1 00:58:17.423: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.527: Se2 IPCP: I CONFACK [ACKsent] id 4 len 10
   *Mar 1 00:58:17.531: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.535: Se2 IPCP: State is Open
   *Mar 1 00:58:17.543: Se2 LCP: I PROTREJ [Open] id 33 len 10 protocol 
   CDPCP (0x820701040004)
   *Mar 1 00:58:17.547: Se2 CDPCP: State is Closed
   *Mar 1 00:58:17.547: Se2 DDR: dialer protocol up
   *Mar 1 00:58:18.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
    changed state to up

   !--- Connection is successful. Backup link is now active.


   gaugin#show ip route 2.2.2.1
   Routing entry for 2.2.2.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The route for the peer uses the backup link.
   !--- Note the static route for primary link is removed
   !--- (since the link is down/down).

   Route metric is 0, traffic share count is 1

   gaugin#show dialer
   Se2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Dial reason: ip (s=1.1.1.1, d=2.2.2.1)
   Time until disconnect 108 secs
   Connected to 8029
   
   Dial String Successes Failures Last     DNIS  Last status
   8029        4           0      00:01:00       successful
   
   gaugin#show interface serial 2
   Serial2 is up, line protocol is up 

   !--- Backup link is verified to be up.

   Hardware is CD2430 in async mode
   Interface is unnumbered. Using address of Loopback1 (1.1.1.1)
   MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec,    ...   ...

   gaugin#ping 2.2.2.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 128/132/136 ms

Here is the same call from the perspective of sphinx who received the call:

sphinx#
   00:57:29: TTY2: DSR came up

   !--- Modem DSR is first changed to up, indicating an incoming call.

   00:57:29: TTY2: destroy timer type 1
   00:57:29: TTY2: destroy timer type 0
   00:57:29: tty2: Modem: IDLE->(unknown)
   00:57:31: Se2 LCP: I CONFREQ [Closed] id 10 len 20
   
!--- Begin LCP negotiation
.
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: Lower layer not up, Fast Starting
   00:57:31: Se2 PPP: Treating connection as a callin
   00:57:31: Se2 PPP: Phase is ESTABLISHING, Passive Open
   00:57:31: Se2 LCP: State is Listen
   00:57:31: Se2 LCP: O CONFREQ [Listen] id 31 len 25
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:31: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: O CONFACK [Listen] id 10 len 20
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: %LINK-3-UPDOWN: Interface Serial2, 
   changed state to upDialer statechange 
   to up Serial2
   00:57:31: Serial2 DDR: Dialer received incoming call from <unknown>
   00:57:33: Se2 LCP: I CONFREQ [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: O CONFACK [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: TIMEout: State ACKsent
   00:57:33: Se2 LCP: O CONFREQ [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: I CONFACK [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   0:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: State is Open
   
!--- LCP negotiation is complete.

   00:57:33: Se2 PPP: Phase is AUTHENTICATING, by this end
   00:57:33: Se2 CHAP: O CHALLENGE id 4 len 27 from "sphinx"
   00:57:33: Se2 CHAP: I RESPONSE id 4 len 27 from "gaugin"
   00:57:33: Se2 CHAP: O SUCCESS id 4 len 4

   !--- CHAP authentication is successful.

   00:57:33: Serial2 DDR:
   Authenticated host gaugin with no matching dialer map
   00:57:33: Se2 PPP: Phase is UP
   00:57:33: Se2 IPCP: O CONFREQ [Closed] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: I CONFREQ [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 IPCP: O CONFACK [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 CDPCP: I CONFREQ [Not negotiated] id 4 len 4
   00:57:33: Se2 LCP: O PROTREJ [Open] id 33 len 10 protocol CDPCP
   (0x820701040004)
   00:57:33: Se2 IPCP: I CONFACK [ACKsent] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: State is Open
   00:57:33: Serial2 DDR: dialer protocol up
   00:57:33: Se2 IPCP: Install route to 1.1.1.1

   !--- A route to the peer is installed.

   00:57:34: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial2, changed state to up
   
!--- Backup link is up.


   sphinx#ping 1.1.1.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 132/142/152 ms

   sphinx#show ip route 1.1.1.1
   Routing entry for 1.1.1.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The floating static route is now installed.

   Route metric is 0, traffic share count is 1

   sphinx#show dialer

   Serial2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 119 secs (gaugin)

Let us now reconnect the cable for the primary link. The primary link will be move to state Up/Up and the backup link (Serial 2) will be turned into Standby state on gaugin (since it has the backup interface serial 2 command). This will cause the modem link to die and the interface serial 2 on sphinx to go down as well.

The following debug on gaugin shows this proccess:

   gaugin#
   *Mar 1 00:59:38.859: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   *Mar 1 00:59:39.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
   changed state to up
   
!--- Primary link is re-established.

   *Mar 1 00:59:59.315: TTY2: Async Int reset: Dropping DTR
   *Mar 1 01:00:00.875: TTY2: DSR was dropped
   *Mar 1 01:00:00.875: tty2: Modem: READY->(unknown)
   *Mar 1 01:00:01.315: %LINK-5-CHANGED: Interface Serial2, 
    changed state to standby mode

   !--- the backup link is returned to standby mode. 
   !--- The modem connection is terminated

   *Mar 1 01:00:01.331: Se2 IPCP: State is Closed
   *Mar 1 01:00:01.335: Se2 PPP: Phase is TERMINATING
   *Mar 1 01:00:01.335: Se2 LCP: State is Closed
   *Mar 1 01:00:01.339: Se2 PPP: Phase is DOWN
   *Mar 1 01:00:01.343: Se2 IPCP: Remove route to 2.2.2.1
   *Mar 1 01:00:01.883: TTY2: dropping DTR, hanging up
   *Mar 1 01:00:01.883: tty2: Modem: HANGUP->(unknown)
   *Mar 1 01:00:02.315: %LINEPROTO-5-UPDOWN: 
   Line protocol on Interface Serial2, changed state to down
   *Mar 1 01:00:02.899: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:03.927: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:04.323: TTY2: no timer type 0 to destroy
   *Mar 1 01:00:04.323: TTY2: no timer type 1 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 3 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 4 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 2 to destroy
   *Mar 1 01:00:04.331: Serial2: allowing modem_process to continue hangup!

The following debugs shows the same transaction from the perspective on sphinx.

   sphinx#
   00:58:54: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   00:58:55: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial0, changed state 
to up
   
!--- Primary link is brought up.

   00:59:16: TTY2: DSR was dropped

   !--- Modem connection is terminated by the peer.

   00:59:16: tty2: Modem: READY->(unknown)
   00:59:17: TTY2: dropping DTR, hanging up
   00:59:17: TTY2: Async Int reset: Dropping DTR
   00:59:17: tty2: Modem: HANGUP->(unknown)
   00:59:18: TTY2: cleanup pending. Delaying DTR
   00:59:19: %LINK-5-CHANGED: Interface Serial2, changed state to reset
   
!--- The Backup Interface (serial 2)is reset.

   00:59:19: Se2 IPCP: State is Closed
   00:59:19: Se2 PPP: Phase is TERMINATING
   00:59:19: Se2 LCP: State is Closed
   00:59:19: Se2 PPP: Phase is DOWN
   00:59:19: TTY2: cleanup pending. Delaying DTR
   00:59:19: Se2 IPCP: Remove route to 1.1.1.1
   
!--- The route to 1.1.1.1 using Serial 2 is removed since 
   !--- it is has a higher administrative distance of 2.

   00:59:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2, 
   changed state to down
   00:59:20: TTY2: cleanup pending. Delaying DTR
   00:59:21: TTY2: cleanup pending. Delaying DTR
   00:59:22: TTY2: destroy timer type 0
   00:59:22: TTY2: destroy timer type 1
   00:59:22: TTY2: destroy timer type 3
   00:59:22: TTY2: destroy timer type 4
   00:59:22: TTY2: destroy timer type 2
   00:59:22: Serial2: allowing modem_process to continue hangup
   00:59:22: TTY2: restoring DTR
   00:59:22: TTY2: autoconfigure probe started
   00:59:24: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   00:59:24: Se2 LCP: State is Closed
   sphinx(config-if)#

Related Information

Updated: Sep 14, 2005
Document ID: 14281