Guest

ISDN, CAS

Configuring Modem Connectivity with a Cisco 3640 BRI

Document ID: 10307

Updated: Sep 09, 2005

   Print

Introduction

This configuration supports remote users (for example, a home user or a traveling employee) connecting to the network with an analog dial-up modem using V.90 protocol. Using a PC and an analog modem, the user connects through dial-up PPP to a Basic Rate Interface (BRI) on a Cisco 3640 router. A BRI provides a high speed modem connection and costs less than a Primary Rate Interface (PRI).

Note: Only two async users can dial into each BRI at a time due to the channel limitations on a BRI.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

This configuration was developed and tested using the software and hardware versions below.

  • Cisco 3640

  • Cisco BRI network module (use one of the following):

    • NM-4B-S/T - Four-port ISDN BRI network module, minimum version 800-01236-03

    • NM-4B-U - Four-port ISDN BRI with integrated NT-1 network module, minimum version 800-01238-06

    • NM-8B-S/T - Eight-port ISDN BRI network module, minimum version 800-01237-03

    • NM-8B-U - Eight-port ISDN BRI with integrated NT-1 network module, minimum version 800-01239-06

  • Digital modem network module (use one of the following: NM-6DM, NM-12DM, NM-18DM, NM-24DM, or NM-30DM)

  • LAN interface card

  • Cisco IOS® Software Release 12.0(2)XC

For more information regarding minimum hardware and software requirements (for example, part numbers and revision numbers), see the Modem over ISDN BRI for the Cisco 3640 Router documentation.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Background Theory

This configuration uses a local user list for access security on the Cisco router.

Below are the relevant sections of the show version command output with the Cisco IOS Software version and the modem firmware versions used to implement this configuration:

Cisco Internetwork Operating System Software IOS (tm) 3600 Software (C3640-I-M), Version 12.0(5)XK1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 
   System image file is "flash:c3640-i-mz.120-5.XK1"   
   MICA-6DM Firmware: CP ver 2310 - 6/3/1998, SP ver 2310 - 6/3/1998.

Use the show diag EXEC command to determine the type of hardware installed in your router. The show diag command displays the version number as well as the part number of the hardware modules in the router. Following is the relevant section of the sample output from the show diag EXEC command:

maui-nas-04#show diag

Slot 1:
BRI (U) port adapter, 4 ports
Serial number 17156199 Part number 800-01238-06

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the IOS Command Lookup tool

Network Diagram

This document uses the network setup shown in the diagram below.

bri_3640.gif

Configurations

This document uses the configurations shown below.

Cisco 3640
maui-nas-04#show run
Building configuration...
Current configuration:
!
! Last configuration change at 10:11:43 CST Thu Apr 13 2000 
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname maui-nas-04
!
aaa new-model
AAA authentication login default group tacacs+ local
AAA authentication ppp default if-needed group tacacs+ local
!
enable secret <deleted>
!
username admin privilege 15 password 7 0213100D52050024
!
modem country mica 
<country>


!-- The country information is mandatory for the configuration to work

!
clock timezone CST -6
clock summer-time CST recurring
!
ip subnet-zero
ip domain-name maui-onions.com
ip name-server 172.22.53.210
!
isdn switch-type basic-ni

! --- Global ISDN switchtype

!
!
process-max-time 200
!
interface Loopback0
 ip address 172.22.87.4 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1
 no ip address
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI1/0
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/2
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI1/3

! --- Active BRI

 no ip address
 no ip directed-broadcast
 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111 
 isdn spid2 51255522220101 5552222 
 isdn incoming-voice modem

! --- Direct incoming voice calls to the modems
! --- Add the above command to all BRIs that will accept analog calls

!
interface Group-Async1
 ip unnumbered Loopback0

! --- Loopback0 is assigned above
 
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 peer default ip address pool default

! --- Use local pool defined below

 ppp authentication pap

! --- Use PAP authentication

 group-range 65 66

! --- Line range is configured below

!
router eigrp 69
network 172.22.0.0
!
ip local pool default 172.22.84.2 172.22.84.253

! --- IP address pool assignment

ip default-gateway 172.22.80.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.80.1
ip http server
ip http authentication local
!
tacacs-server host 172.22.53.201
tacacs-server key <deleted>
!
line con 0
 transport input all
 line 65 66

! --- This must match the group-range in the Group-Async Interface
! --- Use the show line command to determine which lines are to be configured for dialin

 autoselect during-login
 autoselect ppp
 modem Dialin
line 67 70
line aux 0
line vty 0 4
password 
!
ntp clock-period 17179861
ntp server 172.22.255.1 prefer

end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

  • show isdn stat - The status should be:

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    If Layer 1 is not active, the wiring adapter or port may be damaged or not plugged in. If Layer 2 is in a state of TEI_Assign, the router is not talking to the switch.

  • show line - To display the parameters of the lines. Use the show line command to decide which lines need to be configured for dial in.

  • show users - To display the line number, connection name, idle time, and terminal location.

  • show diag - To determine the type of hardware installed in your router.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug modem - To observe modem line activity on an access server.

  • debug modem csm - To debug the call state machine used to connect calls on the modem.

  • debug isdn Q931 - To check ISDN connections as users dial in to see what is happening with the ISDN call (for example, if the connection is being dropped).

Related Information

Updated: Sep 09, 2005
Document ID: 10307