Guest

Asynchronous Connections

Async Multilink PPP Dialup from Microsoft Windows Clients

Document ID: 9553

Updated: Jan 29, 2008

   Print

Introduction

In this Async Multilink PPP configuration, remote dialin users with Microsoft Windows 95/98 PCs use multiple modems to increase the access speed available. Async Multilink PPP can also be configured with other clients, such as Linux and Apple Macintosh, with appropriate client PPP software. The configuration of the router for multilink PPP is independent of the client PC platform.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco AS5300 running Cisco IOS® Software Release 12.07(T).

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Background Theory

Multilink PPP (MPPP) allows devices to send data to the same destination over multiple point-to-point data links by implementing a virtual link. The MPPP connection has a maximum bandwidth equal to the sum of the bandwidths of the component links. MPPP can be configured for multiplexed links, such as ISDN and Frame Relay, or for multiple async lines.

Async Multilink PPP can be used to connect remote clients at a greater speed than that available through a single analog connection. In Async MPPP, the remote client uses multiple modems, and therefore multiple phone lines, to dialin to the central router and access the network. Because multiple phone lines are often cheaper than ISDN Basic Rate Interface (BRI) service, Async MPPP provides an effective way to increase the connection speed for remote users while controlling costs. Async MPPP is also an effective way of obtaining higher access speeds for remote areas that cannot be serviced by ISDN.

Async MPPP bundles together separate modem connections to an Access Server. PPP software on each peer fragments the packets and transmits the pieces to the other side through the multiple analog connections. The receiving end gathers the packets from the separate connections and, based on the PPP information embedded within them, reassembles the pieces into valid data packets, thus providing an end-to-end virtual link with higher bandwidth. Async MPPP can be either configured between two routers or between a router and a client PC.

Though it is possible to use more than two modems for a multilink connection from a client PC, the overhead that results from fragmentation and reassembly of the packets on the PC can negate any additional bandwidth gained.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in this diagram:

async_multilink.gif

NAS Configuration

In this configuration, an AS5300 server with a T1 Primary Rate Interface (PRI) connection is used as the analog user dialin Network Access Server (NAS). Because none of the other T1 controllers on this NAS are configured, this Access Server is used exclusively for async dialup. This AS5300 configuration uses virtual templates to clone virtual access interfaces for inbound calls. The Multilink PPP bundle replicates its interface parameters from the virtual template definitions.

Some basic Authentication, Authorization, and Accounting (AAA) commands are included as examples of best practice methodology. User names and passwords for dialin users are configured on the router. The IP addresses assigned to dialin users are provided from an address pool.

Cisco AS5300
bobslake-nas-01#show running-config
Building configuration...

Current configuration:
!
! Last configuration change at 16:01:01 UTC Wed Jun 28 2000
! NVRAM config last updated at 15:30:28 UTC Wed Jun 28 2000 
!
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service tcp-small-servers
!
hostname bobslake-nas-01
!
logging buffered 10000 debugging
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local

!--- authenticate for PPP if not authenticated during login
!--- allows users with Terminal Window after Dial to initiate PPP!

username admin password <deleted> 
username charlie password <deleted> 
spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
ip subnet-zero
no ip source-route
ip domain-name the.net
!
multilink virtual-template 1

!--- use virtual-template 1 for multilink connections

async-bootp dns-server 172.22.53.210
isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary 3
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.21.10.10 255.255.255.255
 no ip directed-broadcast
!
interface Loopback1
 ip address 172.21.104.254 255.255.255.0

!--- summarizes addresses in address pool 
!--- Loopback 1 is in the same subnet as the address pool 

no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Virtual-Template1
 description Template for Multilink Users
 ip unnumbered Loopback0  
 no ip directed-broadcast
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls
 
ppp authentication chap

!--- authenticate using Challenge Handshake Authentication Protocol (CHAP)

 ppp multilink
!

!--- configure D channel on PRI interface Serial0:23

 description Headquarters 324-1939 active PRI line
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial2:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial3:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 ip address 172.21.101.23 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Group-Async1

!--- template to control all async interface configuration 

ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp

!--- use PPP encapsulation dialer in-band

 dialer-group 5
 async mode interactive
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls 

 no fair-queue
 no cdp enable
 ppp authentication chap callin

!--- CHAP authenticate for dialin users only 

 ppp multilink
 group-range 1 48

!--- assign modems 1-48 to the Group-Async 1 configuration template

 router eigrp 1
 network 172.21.0.0
!
ip local pool addr-pool 172.21.104.1 172.21.104.48

!--- define IP address pool range for dialin clients 

ip classless
no ip http server
!

access-list 105 permit ip any any
dialer-list 5 protocol ip list 105
!
line con 0
 exec-timeout 0 0
 transport input none
line 1 48
 autoselect during-login

!--- permits user login prompts after dialin 

 autoselect ppp

!--- automatically launch PPP on the line




 modem InOut

!--- modems can be used to dialin and dialout
!--- InOut may be replaced by Dialin 
!--- if NAS handles only incoming calls

 transport preferred none
 transport output telnet
line aux 0
line vty 0 4
 transport preferred none
 transport input telnet
 transport output telnet
!
ntp clock-period 17180374
ntp update-calendar
ntp server 172.22.255.1 prefer
end

bobslake-nas-01#

Configuring Windows 9x Clients

The following procedure is a quick overview on configuring your Windows 9x clients for MPPP. Refer to the Microsoft web site leavingcisco.com if you have difficulty.

In order to configure Microsoft Windows 9x clients for MPPP, make sure you have Dial Up Networking version 1.3 or later installed.

Go to the Microsoft web site leavingcisco.com for more information and to download the latest version of Dial Up Networking (DUN).

  1. Connect and configure each modem separately.

    From the Windows Control Panel, use the "Add New Hardware" utility to add the modems to the client. If you have trouble adding modems, contact your PC vendor or Microsoft for troubleshooting procedures. Verify that each modem is connected correctly and is recognized by the operating system. You may want to use a terminal emulator to verify that your modem works properly.

  2. Create a new dialup connection.

    In Windows double-click the "My Computer" icon and navigate to "Dialup Networking." Next, double-click "Make New Connection." Follow the directions to create a dial up connection using the primary modem. Multilink features are configured later. Test the connection by dialing in to your service provider.

  3. Add multilink features to your dialup connection.

    Double-click the "My Computer" icon and navigate to "Dialup Networking." Right-click the connection icon that was just set up. From the menu that appears, select "Properties."

    Click the "Multilink" tab, select "Use additional devices," and click the "Add" button. Select an additional modem from the drop-down menu and enter only the seven digit phone number of the Access Server, or accept the number shown. Do not include the area code when configuring the additional device, even if it is a long distance call. The connection automatically uses the area code configured for the first modem. Click "OK" twice to complete the setup.

    Here are some screen captures for a Windows multilink configuration:

    win95_mppp_1.gif

    win95_mppp_2.gif

  4. Initiate the modem connection to the Access Server.

    Double-click the dialup connection icon that was just created. Enter the username and password configured on the router, then click the "Connect" button. Dial Up Networking will dial the number configured for the primary modem specified for the connection. When the first connection is established, Dial Up Networking dials using the additional modems specified in the Additional Devices list.

    When all connections are established, you can either view status information about the link by double-clicking on the "Communicating Computers" icon displayed in the task bar, or you may disconnect the connection. Click on "Details" to verify that the connection is using multiple devices. When you select a device in the list box, a Suspend or Resume button appears. If a Suspend button appears, the device is now in use and "bundled" into the multilink connection. Clicking on the "Suspend" button disconnects that line and removes the line from the bundled connections. If the "Resume" button appears, click it to dial that connection and add that line to the bundle. You can dynamically suspend and resume the multilink without dropping the connection.

Verify

There is currently no verification procedure available for this configuration.

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

  • show ppp multilink - To display information on multilink bundles that are active. This command should be used to verify the multilink connection.

  • show caller - To display information on individual users and consumed resources on the NAS. This command displays active call statistics for large pools of connections, and shows the absolute and idle times for each user.

  • show caller user - To show parameters for the particular user such as the TTY line used, asynchronous interface (shelf/slot/port), DS0 channel number, modem number, IP address assigned, PPP and PPP bundle parameters, and so on.

To assist in verifying and troubleshooting the MPPP connection, refer to these suggestions:

  • Ensure that prefixes, such as using 9 before dialing an outside line, are configured correctly on the client PC. If this is not configured properly, you'll hear a busy signal as soon as the number starts to dial.

  • Create separate DUN clients for each modem and verify that you have full connectivity to your service provider. Use each modem separately before proceeding with troubleshooting your multilink connection.

  • Use a terminal emulator to connect to the modem. Dial the number of the NAS using the atdt command. For example, in HyperTerminal enter atdt 55511111. Verify that the modem dials correctly and connects to the NAS. If the modem does not connect, troubleshoot your modem. See the Using Basic AT Modem Commands leavingcisco.com documentation on the Microsoft web site for more information on troubleshooting client modems.

  • If your primary connection connects properly, but the second dialup connection gives a busy signal, verify that the phone number for the additional modem is correctly configured in DUN. Remember, area codes should not to be added to the configuration for additional devices. Refer to the configuration steps in the Configuring Windows 9x Clients section above.

Sample show and debug Output

Here are some show and debug outputs from the AS5300. Portions of the debugs have been removed for brevity. Pay attention to the bolded sections and the comments provided in the outputs.

Notice that the caller is connected on Async5 and Async6 until after authentication. A temporary IP address is provided to the caller from the address pool. The call is then virtualized or tied to an existing virtual bundle. This is because the Access Server needs to know who the caller is to determine if they belong to an established virtual bundle. Once the caller is tied to the bundle, the temporary IP address is removed and the caller uses the IP address of the virtual bundle.

bobslake-nas-01#
bobslake-nas-01#show ppp multilink 

Virtual-Access1, bundle name is charlie
  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x29/0x17 rcvd/sent
  0 discarded, 0 lost received, 1/255 load
  Member links: 2 (max not set, min not set)
    Async5
    Async6


!--- Note that the bundle is using Async line 5 and 6 for multilink. 

bobslake-nas-01#show caller 
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        admin              Host connect  1w4d      16:50:19  
  tty 5        charlie             Async         00:04:34  00:01:54  
  tty 6        charlie             Async         00:02:00  00:00:57  
  vty 1        admin              VTY           00:13:43  00:00:00  
  As5          charlie             PPP           00:04:25  00:00:00  
  As6          charlie             PPP           00:01:53  00:00:00  
  Vi1          charlie             PPP   Bundle  00:04:25  00:00:57  


!--- User charlie has two async lines, two tty, 
!--- and one virtual interface bundle.

bobslake-nas-01#show caller user charlie

  User: charlie, line tty 5, service Async

!--- shows hardware level settings for user charlie (first connection)

        Active time 00:04:43, Idle time 00:00:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 5, running PPP on As5

!--- user charlie is using tty 5

  DS0: (slot/unit/channel)=0/0/0  Line: Baud rate (TX/RX) is 115200/115200, 
no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line tty 6, service Async


!--- shows hardware level settings for user charlie (second connection)

        Active time 00:02:09, Idle time 00:01:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 6, running PPP on As6

!--- user charlie is using tty 6

  DS0: (slot/unit/channel)=0/0/1
  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line As5, service PPP

!--- PPP setting for user charlie (first connection).

        Active time 00:04:34, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async5
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 54 packets input, 4110 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          73 packets output, 4150 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

  User: charlie, line As6, service PPP

!--- PPP setting for user charlie (second connection).

        Active time 00:02:02, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is Open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async6
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 6 packets input, 462 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          20 packets output, 1129 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

    
User: charlie, line Vi1, service PPP Bundle


!--- Bundle information for user charlie

        Active time 00:04:34, Idle time 00:00:06
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, IPCP
  IP: Local 172.21.104.254, remote 172.21.104.2

!--- Remote IP address is obtained from IP pool.

  Counts: 50 packets input, 4034 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          80 packets output, 8750 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

 

bobslake-nas-01#debug vtemplate
Virtual Template debugging is on
bobslake-nas-01#debug ppp multilink events 
Multilink events debugging is on
bobslake-nas-01#debug ppp negotiation 
PPP protocol negotiation debugging is on
bobslake-nas-01#debug ppp authentication 
PPP authentication debugging is on
bobslake-nas-01#debug ppp error 
PPP protocol errors debugging is on
bobslake-nas-01#debug modem
Modem control/process activation debugging is on
bobslake-nas-01#show debug
General OS:
  Modem control/process activation debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol errors debugging is on
  PPP protocol negotiation debugging is on
  Multilink events debugging is on
VTEMPLATE:
  Virtual Template debugging is on

bobslake-nas-01#
Jun 28 15:41:46.281 UTC: TTY5: DSR came up
Jun 28 15:41:46.281 UTC: tty5: Modem: IDLE->(unknown)

!--- Modem responds to first dialin connection.

Jun 28 15:41:46.281 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.537 UTC: TTY5 Autoselect cmd:  ppp negotiate
Jun 28 15:41:48.537 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.545 UTC: As5 IPCP: Install route to 172.21.104.4

!--- IP address for first link obtained from address pool.
!--- Route will be removed when link is virtualized later. 

Jun 28 15:41:50.541 UTC: As5 PPP: Treating connection as a callin
Jun 28 15:41:50.541 UTC: As5 PPP: Phase is ESTABLISHING, Passive Open
Jun 28 15:41:50.541 UTC: As5 LCP: State is Listen

!--- LCP negotiation begins.

Jun 28 15:41:51.549 UTC: As5 LCP: I CONFREQ [Listen] id 3 len 46
...
Jun 28 15:41:51.549 UTC: Unthrottle 5
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREJ [Listen] id 3 len 7
...
Jun 28 15:41:53.549 UTC: As5 LCP: O CONFREQ [REQsent] id 2 len 47
Jun 28 15:41:53.549 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.549 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.549 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.549 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.549 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.549 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size 
!--- that the peer will reconstruct.
!--- Both sides must agree on the packet size (MRRU).

Jun 28 15:41:53.549 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x3031)
Jun 28 15:41:53.789 UTC: As5 LCP: I CONFACK [REQsent] id 2 len 47
Jun 28 15:41:53.789 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.789 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.789 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.789 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.789 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.789 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size that 
!--- the peer will reconstruct.

Jun 28 15:41:53.789 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x3031)Jun 28 15:41:54.541 UTC: 
As5 LCP: I CONFREQ [ACKrcvd] id 4 len 46
...
Jun 28 15:41:54.541 UTC: As5 LCP: O CONFREJ [ACKrcvd] id 4 len 7
...
Jun 28 15:41:54.717 UTC: As5 LCP: I CONFREQ [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.717 UTC: As5 LCP: O CONFACK [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.721 UTC: As5 LCP: State is Open

!--- LCP negotiation is complete.

Jun 28 15:41:54.721 UTC: As5 PPP: Phase is AUTHENTICATING, by this end

!--- CHAP authentication begins.

Jun 28 15:41:54.721 UTC: As5 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:41:54.909 UTC: As5 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:41:54.909 UTC: As5 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful.

Jun 28 15:41:54.909 UTC: As5 MLP: Multilink up event pending
Jun 28 15:41:54.913 UTC: As5 PPP: Phase is VIRTUALIZED

!--- Call is virtualized after authentication.

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Hardware address 0010.7b4d.7046
Jun 28 15:41:54.913 UTC: Vi1 PPP: Phase is DOWN, Setup
Jun 28 15:41:54.913 UTC: Vi1 MLP: VP: Clone from Vtemplate 1 block=1
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Has a new cloneblk vtemplate
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: ************* CLONE VACCESS1 ***********
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Clone from Virtual-Template1

!--- Cloning from Virtual-Template.

interface Virtual-Access1
default ip address
no ip address
encap ppp
description Template for Multilink Users
ip unnumbered Loopback0
no ip directed-broadcast
no logging event link-status
no snmp trap link-status
peer default ip address pool addr-pool
ppp authentication chap
ppp multilink
ip unnum loop 1
end
Jun 28 15:41:55.005 UTC: Vi1 PPP: Treating connection as a dedicated line
Jun 28 15:41:55.005 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open
Jun 28 15:41:55.005 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 len 37
...
Jun 28 15:41:55.009 UTC: Vi1 PPP: Phase is UP
Jun 28 15:41:55.009 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
Jun 28 15:41:55.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:55.009 UTC: As5 MLP: charlie, multilink up, first link

!--- First link in multilink bundle for user charlie is up.

Jun 28 15:41:55.009 UTC: As5 IPCP: Remove route to 172.21.104.4

!--- Temporary route to first link removed since link is virtualized.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 40
...
Jun 28 15:41:55.069 UTC: Vi1 IPCP: Pool returned 172.21.104.2

!--- IP address for virtual bundle obtained from address pool.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 1 len 22
...
Jun 28 15:41:55.085 UTC: Vi1 CCP: I CONFREQ [Not negotiated] id 1 len 15
Jun 28 15:41:55.085 UTC: Vi1 CCP:    MS-PPC supported bits 0x00000001 (0x120600)
...
Jun 28 15:41:55.181 UTC: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10
Jun 28 15:41:55.181 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:57.009 UTC: Vi1 IPCP: TIMEout: State ACKrcvd
Jun 28 15:41:57.009 UTC: Vi1 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Jun 28 15:41:57.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.009 UTC: Vi1 IPCP: TIMEout: State REQsent
Jun 28 15:41:59.009 UTC: Vi1 IPCP: O CONFREQ [REQsent] id 3 len 10
Jun 28 15:41:59.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.617 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 2 len 34
...
Jun 28 15:41:59.617 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 2 len 16
...
Jun 28 15:41:59.633 UTC: Vi1 PPP: Replace IPCP code 2 id 3 with id 3
Jun 28 15:41:59.633 UTC: Vi1 IPCP: I CONFACK [REQsent] id 3 len 10
Jun 28 15:41:59.633 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.777 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.777 UTC: Vi1 IPCP: O CONFNAK [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.937 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 
(0x0306AC156802)

!--- IP address of virtual bundle was previously obtained from 
!--- address pool.

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: O CONFACK [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 (0x0306AC156802)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: State is Open
Jun 28 15:41:59.941 UTC: Vi1 IPCP: Install route to 172.21.104.2

!--- Add route for virtual bundle to routing table.

Jun 28 15:42:44.383 UTC: TTY51: timer type 1 expired
Jun 28 15:42:44.383 UTC: TTY51:  Exec timer (continued)

!--- Modem comes up for multilink connection.

Jun 28 15:44:20.385 UTC: TTY6: DSR came up

!--- Async 6 is used for second connection.

Jun 28 15:44:20.385 UTC: tty6: Modem: IDLE->(unknown)
Jun 28 15:44:20.385 UTC: TTY6: EXEC creation
...
Jun 28 15:44:20.529 UTC: TTY6 Autoselect cmd:  ppp negotiate
Jun 28 15:44:20.529 UTC: TTY6: EXEC creation
...Jun 28 15:44:20.661 UTC: As6 IPCP: Install route to 172.21.104.5

!--- IP address for second link is obtained from the pool.
!--- Route will be removed when link is added to the MPPP bundle.

Jun 28 15:44:22.661 UTC: As6 PPP: Treating connection as a callin
Jun 28 15:44:22.661 UTC: As6 PPP: Phase is ESTABLISHING, Passive Open

!--- LCP negotiation begins.

Jun 28 15:44:22.661 UTC: As6 LCP: State is Listen
Jun 28 15:44:23.521 UTC: As6 LCP: I CONFREQ [Listen] id 2 len 46
...
Jun 28 15:44:23.525 UTC: Unthrottle 6
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREJ [Listen] id 2 len 7
Jun 28 15:44:23.525 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:25.525 UTC: As6 LCP: TIMEout: State REQsent
Jun 28 15:44:25.525 UTC: As6 LCP: O CONFREQ [REQsent] id 2 len 47
...
Jun 28 15:44:25.765 UTC: As6 LCP: I CONFACK [REQsent] id 2 len 47
...
Jun 28 15:44:26.533 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 3 len 46
...
Jun 28 15:44:26.533 UTC: As6 LCP: O CONFREJ [ACKrcvd] id 3 len 7
Jun 28 15:44:26.533 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:26.741 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: O CONFACK [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: State is Open

!--- LCP negotiation is complete.
!--- CHAP authentication begins.

Jun 28 15:44:26.745 UTC: As6 PPP: Phase is AUTHENTICATING, by this end
Jun 28 15:44:26.745 UTC: As6 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:44:26.981 UTC: As6 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:44:26.981 UTC: As6 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful. 

Jun 28 15:44:26.981 UTC: As6 MLP: Multilink up event pending
Jun 28 15:44:26.981 UTC: As6 PPP: Phase is VIRTUALIZED

!--- Link is virtualized.

Jun 28 15:44:26.985 UTC: As6 MLP: charlie, multilink up

!--- Multilink connection is up.

Jun 28 15:44:26.985 UTC: As6 IPCP: Remove route to 172.21.104.5

!--- Use IP address previously assigned to the bundle 
!--- (in this case, 172.21.104.2).

bobslake-nas-01#

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

Note: Before issuing debug commands, see Important Information on Debug Commands.

  • debug vtemplate - Displays cloning information for a virtual access interface from the time it is cloned from a virtual template to the time it comes down.

  • debug ppp multilink events - Displays information about events affecting multilink bundles.

  • debug ppp negotiation - Displays information on the PPP traffic and exchanges while negotiating Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation will first open the LCP state, then Authenticate, and finally negotiate NCP.

  • debug ppp authentication - Displays PPP authentication protocol messages, including Challenge Handshake Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges.

  • debug ppp error - Displays protocol errors and error statistics associated with PPP connection negotiation and operation.

  • debug modem - Displays modem line activity on an Access Server.

Related Information

Updated: Jan 29, 2008
Document ID: 9553