Guest

Asynchronous Connections

DNIS and Modem Pooling With a PRI Line

Cisco - DNIS and Modem Pooling With a PRI Line

Document ID: 10383

Updated: Sep 09, 2005

   Print

Introduction

The sample configurations in this document illustrate how to configure Digital Number Identification Service (DNIS) support for a Primary Rate Interface (PRI) and how to set up modem pooling. Three configurations are provided:

  1. Modem pooling with multiple modems defined in the pool-range.

  2. Modem pooling with one modem in the pool-range.

  3. Modem pooling without a pool-range.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco IOS® Software Release 11.3(1.1)T or later.

  • PRI provisioned by the Telco for DNIS support.

  • Cisco AS5x00 series router.

Note: Modem Pooling is not possible on the Cisco 3600 Series Router.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Background Theory

If you are using Remote Dial-In User Service (RADIUS) as your authentication protocol, you need to know RADIUS (IETF) Accounting Attribute 30 (Station-ID).

Station-ID allows the Network Access Server (NAS) to send the number the user called as part of the Access-Request packet (using DNIS or similar technology). Station-ID is supported only on ISDN and modem calls on the Cisco AS5x00 when it is used with PRI.

Configure

This document uses the configurations shown below.

  • Multiple Modems in a Pool-Range

  • One Modem in a Pool

  • Modem Pooling Without a Pool-Range

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup tool

Network Diagram

This document uses the network setup shown in the diagram below.

pri_dnis_mpool.gif

Configuration 1: Multiple Modems in a Pool-Range

Configuration Notes

A customer dials 5557528 and connects to a modem in the pool-range of 3 to 5. Lines 3 to 5 have been configured to autocommand telnet the user to a specific IP address after the login user ID and password have been entered at the router prompt (>).

caution Caution: When you configure the called-number feature and don't put in the max-conn number, the Cisco router defaults to the number of modems in the pool. In this sample configuration, modems 3 to 5 are configured so the Cisco IOS Software puts in max-conn 3 at the end of the called-number command.

If you change the number of modems in the pool, you must manually change the max-conn number.

This sample configuration uses local authentication.

Multiple Modems in a Pool-Range
Current configuration: 
! 
version 11.3 
service timestamps debug datetime msec 
service password-encryption 

service udp-small-servers 
service tcp-small-servers 
! 
hostname isdn2-2 
! 

aaa new-model 
! 
username cisco password 7 xxxxxxxxx 
! 
modem-pool tito 
 pool-range 3-5 
 called-number 5557528 max-conn 3 
ip domain-name cisco.com 
isdn switch-type primary-5ess 
clock timezone PST -8 
clock summer-time PDT recurring 
! 
! 
controller T1 0 
 framing esf 
 clock source line primary 
 linecode b8zs 
 pri-group timeslots 1-24 
 description 5557528 pri 
! 
controller T1 1 
 framing esf 
 clock source line secondary 
 linecode b8zs 
! 
interface Loopback0 
 ip address 10.1.1.1 255.0.0.0 
! 
interface Ethernet0 
 ip address 172.16.25.52 255.255.255.240 
! 
interface Serial0 
 no ip address 
 shutdown 
! 
interface Serial1 
 no ip address 
 shutdown 
! 
interface Serial0:23 
 no ip address 
 no ip mroute-cache 
 isdn incoming-voice modem 
 no cdp enable 
! 
interface Group-Async1 
 no ip address 
 group-range 1 24 
! 
router eigrp 202 
 network 172.16.0.0 
 distance 90 172.16.25.49 0.0.0.0 
 distance 255 0.0.0.0 255.255.255.255 
 no auto-summary 
! 
ip default-gateway 172.16.25.49 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.25.49 
! 
line con 0 
 exec-timeout 0 0 
line 1 2 
 modem InOut 
line 3 5 
 modem InOut 
 autocommand telnet 10.1.1.1 
line 6 24 
 modem InOut 
line aux 0 
line vty 0 4 
 password 7 xxxxx 
! 
end 
 
isdn2-2# 

Debug and Verification Tips

To ensure that your configuration is working properly, use the show and debug commands. Output from these commands should be similar to the output that follows.

isdn2-2#show version 
Cisco Internetwork Operating System Software 
IOS (tm) 5200 Software (C5200-D-L), Version 11.3(1.1)T, 
MAINTENANCE INTERIM SOFTWARE 
Copyright (c) 1986-1998 by cisco Systems, Inc. 
Compiled Sun 11-Jan-98 07:12 by ccai 
Image text-base: 0x03034CD4, data-base: 0x00005000 
 
ROM: System Bootstrap, Version 11.1(473), SOFTWARE 
 
isdn2-2 uptime is 18 hours, 41 minutes 
System restarted by reload 
System image file is "bootflash:c5200-d-l.113-1.1.T", booted via flash 
 
cisco AS5200 (68030) processor (revision 0x00) with 16384K/8192K 
bytes of memory. 
Processor board ID 03676053 
Bridging software. 
X.25 software, Version 3.0.0. 
Primary Rate ISDN software, Version 1.0. 
Mother board without terminator card. 
1 Ethernet/IEEE 802.3 interface(s) 
26 Serial network interface(s) 
24 terminal line(s) 
2 Channelized T1/PRI port(s) 
128K bytes of non-volatile configuration memory. 
8192K bytes of processor board System flash (Read/Write) 
8192K bytes of processor board Boot flash (Read ONLY) 
 
Configuration register is 0x2101 
 
isdn2-2#
  • show modem-pool When No User Is Connected

    Modems 3, 4, and 5 have been configured for the modem pool named "tito" and no modems have dialed in yet. The default pool is for users who dial a number that is not configured for a defined modem-pool.

    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool
    
    !--- default pool 
    
    modems in pool: 21 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito
    
    !--- modem-pool named 'tito'  
    
    modems in pool: 3 active conn: 0 
     0 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 3, active conn: 0 
      0 max-conn exceeded, 0 no free modems in pool 
    
    
  • show modem-pool With One User Connected

    One user is dialed in and connected to modem 5. The show modem-pool command does not display which modem in the pool was used.

    show modem-pool 
         ------------- 
    modem-pool: tito 
    modems in pool: 3 active conn: 1 
     0 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 3, active conn: 1 
      0 max-conn exceeded, 0 no free modems in pool 
    
    

    The show line command shows that modem 5 is used.

    isdn2-2#show line 
     Tty Typ   Tx/Rx   A Modem Roty AccO AccI Uses  Noise  Overruns 
    * 0 CTY        -  -   -  -  -   0    0    0/0 
      1 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      2 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      3 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      4 TTY 115200/115200 - inout   -  -  -   1    0    0/0 
    * 5 TTY 115200/115200 - inout   -  -  -   1    0    0/0 
      6 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      7 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      8 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      9 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
     10 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
     11 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
     12 TTY 115200/115200 - inout   -  -  -   0    0    0/0
    
    [remaining output omitted]
    
  • Using the debug isdn q931 Command

    Notice the number dialed by the remote user. This number must match the number configured under modem-pool tito. The user's telephone number is not important in this scenario.

    *Mar 1 18:54:31.951:     Called Party Number i = 0xC1, '4085557528' 
    

    Note: Some of the following debug output lines are broken into multiple lines for printing purposes.

    isdn2-2# 
    *Mar 1 18:54:31.935: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2B 
    *Mar 1 18:54:31.939:     Bearer Capability i = 0x9090A2 
    *Mar 1 18:54:31.939:     Channel ID i = 0xA98393 
    *Mar 1 18:54:31.943:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,
       may have in-band info 
    *Mar 1 18:54:31.947:     Calling Party Number i = '!', 0x83, '4085559486' 
    *Mar 1 18:54:31.951:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 18:54:31.963: ISDN Se0:23: Incoming call id = 0xA 
    *Mar 1 18:54:31.987: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x802B 
    *Mar 1 18:54:31.991:     Channel ID i = 0xA98393 
    *Mar 1 18:54:32.023: ISDN Se0:23: TX -> ALERTING pd = 8 callref = 0x802B 
    *Mar 1 18:54:33.067: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x802B 
    *Mar 1 18:54:33.143: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x2B 
    isdn2-2# 
    
    
  • Output of debug isdn Q931 and debug modem csm

    The user is connected to Line 5 or Modem 5 modem (slot/port)=0/4. Call processing is round robin. The first modem used is 3, the next is 4, and the last is 5. It does not matter whether the first modem is available.

    isdn2-2# show line 5 
         
     TTY Typ   TX/Rx   A Modem Roty AccO AccI Uses  Noise  Overruns 
    * 5 TTY 115200/115200 - inout   -  -  -   1    0    0/0 
     
    Line 5, Location: "", Type: "" 
    Length: 24 lines, Width: 80 columns 
    Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits 
    Status: Ready, Active, No Exit Banner 
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out 
     Modem Callout, Modem RI is CD 
    Modem state: Ready 
     modem(slot/port)=0/4, state=CONNECTED 
     dsx1(slot/unit/channel)=2/0/18, status=VDEV_STATUS_ACTIVE_CALL. 
    Modem hardware state: CTS DSR DTR RTS 
    Special Chars: Escape Hold Stop Start Disconnect Activation 
            ^^x  none  -   -    none 
    Timeouts:   Idle EXEC  Idle Session  Modem Answer Session  Dispatch 
            00:10:00    never            none   not set 
                  Idle Session Disconnect Warning 
                   never 
    Modem type is unknown. 
    Session limit is not set. 
    Time since activation: 00:01:35 
    Editing is enabled. 
    History is enabled, history size is 10. 
    DNS resolution in show commands is enabled 
    Full user help is disabled 
    Allowed transports are pad telnet rlogin mop. Preferred is telnet. 
    Automatically execute command "telnet 10.1.1.1" 
    No output characters are padded 
    No special data dispatching characters 
    isdn2-2# 
    
    
  • Debug Output

    isdn2-2# 
    %SYS-5-CONFIG_I: Configured from console by console 
    *Mar 1 19:00:07.227: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2D 
    *Mar 1 19:00:07.227:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:00:07.231:     Channel ID i = 0xA98393 
    *Mar 1 19:00:07.235:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,
       may have in-band info 
    *Mar 1 19:00:07.239:     Calling Party Number i = '!', 0x83, '4085559444' 
    *Mar 1 19:00:07.243:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:00:07.255: ISDN Se0:23: Incoming call id = 0xC 
    *Mar 1 19:00:07.259: EVENT_FROM_ISDN::dchan_idb=0x25B660, call_id=0xC, ces=0x1 
      bchan=0x12, event=0x1, cause=0x0 
    *Mar 1 19:00:07.263: VDEV_ALLOCATE: slot 0 and port 4 is allocated. 
    *Mar 1 19:00:07.263: EVENT_FROM_ISDN:(000C): DEV_INCALL at slot 0 and port 4 
    *Mar 1 19:00:07.267: CSM_PROC_IDLE: CSM_EVENT_ISDN_CALL at slot 0, port 4 
    *Mar 1 19:00:07.267: Fast Ringing On at modem slot 0, port 4 
    *Mar 1 19:00:07.291: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x802D 
    *Mar 1 19:00:07.291:     Channel ID i = 0xA98393 
    *Mar 1 19:00:07.343: ISDN Se0:23: TX -> ALERTING pd = 8 callref = 0x802D 
    *Mar 1 19:00:08.367: Fast Ringing Off at modem slot 0, port 4 
    *Mar 1 19:00:08.367: CSM_PROC_IC1_RING: CSM_EVENT_MODEM_OFFHOOK at slot 0, port 4 
    *Mar 1 19:00:08.379: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x802D 
    *Mar 1 19:00:08.451: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x2D 
    *Mar 1 19:00:08.463: EVENT_FROM_ISDN::dchan_idb=0x25B660, call_id=0xC, ces=0x1 
       bchan=0x12, event=0x4, cause=0x0 
    *Mar 1 19:00:08.467: EVENT_FROM_ISDN:(000C): DEV_CONNECTED at slot 0 and port 4 
    *Mar 1 19:00:08.471: CSM_PROC_IC4_WAIT_FOR_CARRIER: CSM_EVENT_ISDN_CONNECTED at
       slot 0, port 4 
    *Mar 1 19:00:20.939: TTY5: DSR came up 
    *Mar 1 19:00:20.947: tty5: Modem: IDLE->READY 
    *Mar 1 19:00:20.951: TTY5: EXEC creation  
    
  • show modem-pool With No Modems Free

    The following output shows all modems busy and a call refused by the ISDN call-setup.

    modem-pool: System-def-Mpool 
    modems in pool: 21 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 3 active conn: 0 
         3 no free modems in pool
    
    !--- This number is the number of times it has failed to allocate a modem 
    !--- from the pool. It is not the number of modems in the pool.) 
    
    called_party_number: 5557528 
         max conn allowed: 3, active conn: 0
    
    !--- 3 is the number of modems configured in the pool tito. 
    !--- None are active.
    
    0 max-conn exceeded, 3 no free modems in pool 
    
    !--- failed 3 times to allocate a modem from the pool
    
    
    isdn2-2#debug isdn events 
    ISDN events debugging is on 
    isdn2-2# 
    *Mar 1 19:11:26.471: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2F 
    *Mar 1 19:11:26.475:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:11:26.479:     Channel ID i = 0xA98393 
    *Mar 1 19:11:26.479:     Progress Ind i = 0x8381 
    - Call not end-to-end ISDN, may have in-band info 
    *Mar 1 19:11:26.483:     Calling Party Number i = '!', 0x83, '4085559445' 
    *Mar 1 19:11:26.487:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:11:26.499: ISDN Se0:23: Incoming call id = 0xE 
    *Mar 1 19:11:26.503: CCPRI, state = 0, serv = 0, int_id = 0, 
    lo_chan = 19, type = 3, Dsl_Id = 0, callid = E 
    *Mar 1 19:11:26.507: CCPRI in a Glare situation state 0 serv 0 
    *Mar 1 19:11:26.511: ISDN Se0:23: received CALL_INCOMING 
    *Mar 1 19:11:26.511:  extracted channel ie[0-8]= 18 3 A9 83 93 38 34 33 32 
    *Mar 1 19:11:26.515: 
    *Mar 1 19:11:26.519: ISDN Se0:23: Event: 
    Received a Voice call from 4085559445 on B19 at 64 Kb/s 
    *Mar 1 19:11:26.519: ISDN Se0:23: 
    CALL_INCOMING: MODEM ERROR 2C: bchan 18, call id E 
    *Mar 1 19:11:26.535: in CCPRI_ReleaseCall bchan is 13 dsl is 0 
    *Mar 1 19:11:26.539: leaving CCPRI_ReleaseCall, Allocated CCBs = 0 
    *Mar 1 19:11:26.543: ISDN Se0:23: entering process_rxstate, CALL_CLEARED 
    *Mar 1 19:11:26.615: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x802F 
    *Mar 1 19:11:26.615:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    

Configuration 2: One Modem in a Pool

One Modem in a Pool
enable password 7 XXXXXXXXXX 
! 
username cisco password 7 xxxxxxxxxxxx 
! 
modem-pool tito 
 pool-range 3

! -- only modem #3 is configured

 called-number 5557528 max-conn 1       
ip domain-name cisco.com 
isdn switch-type primary-5ess 
clock timezone PST -8 
clock summertime PDT recurring 
! 
!

Debug and Verification Tips

To ensure that your configuration is working properly, use the show command. Output from this command should be similar to the output that follows.

  • show modem-pool With One Modem

    The following output shows a modem pool configured with one modem. Two users dial in at the same time and one user is connected.

    isdn2-2# show modem-pool 
     modem-pool: System-def-Mpool 
      modems in pool: 23 active conn: 0 
      3 no free modems in pool 
         
     modem-pool: tito 
      modems in pool: 1 active conn: 1 
      4 no free modems in pool 
      called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      0 max-conn exceeded, 1 no free modems in pool 
    
    isdn2-2# show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 1 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      0 max-conn exceeded, 1 no free modems in pool 
     
    isdn2-2#  
    

    In the following output, the first user remains connected and a second user dials in once and the call fails.

    isdn2-2# 
    isdn2-2# 
    *Mar 1 19:38:57.103: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x33 
    *Mar 1 19:38:57.107:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:38:57.111:     Channel ID i = 0xA98394 
    *Mar 1 19:38:57.111:     Progress Ind i = 0x8381 
    - Call not end-to-end ISDN, may have in-band info 
    *Mar 1 19:38:57.115:     Calling Party Number i = '!', 0x83, '4085559474' 
    *Mar 1 19:38:57.119:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:38:57.135: ISDN Se0:23: Incoming call id = 0x12 
    *Mar 1 19:38:57.139: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 19, 
    call id 12 
    *Mar 1 19:38:57.235: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8033 
    *Mar 1 19:38:57.239:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 1 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      1 max-conn exceeded, 1 no free modems in pool 
    isdn2-2# 
    
    

    A second user attempts to dial in again and fails. Notice the 2 max-conn exceeded statement.

    isdn2-2# 
    *Mar 1 19:40:34.143: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x34 
    *Mar 1 19:40:34.147:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:40:34.147:     Channel ID i = 0xA98394 
    *Mar 1 19:40:34.151:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,
       may have in-band info 
    *Mar 1 19:40:34.155:     Calling Party Number i = '!', 0x83, '4085559486' 
    *Mar 1 19:40:34.159:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:40:34.171: ISDN Se0:23: Incoming call id = 0x13 
    *Mar 1 19:40:34.179: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 19,
       call id 13 
    *Mar 1 19:40:34.267: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8034 
    *Mar 1 19:40:34.271:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 1 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      2 max-conn exceeded, 1 no free modems in pool  
    isdn2-2# 
  • show modem-pool When the First User Timed Out Due to Inactivity

    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 0 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 0 
      2 max-conn exceeded, 1 no free modems in pool 
    
    modem-pool: System-def-Mpool 
    
     !--- This is the default modem pool 
    
    modems in pool: 23 active conn: 0 
    
     !--- There are 24 modems installed on this access server, 
     !--- 23 are available to the default pool, the other 
     !--- modem is available only to modem-pool tito 
    
     3 no free modems in pool 
    
     !--- Three failures to allocate a modem from a pool for a user dialing in
    
    
    modem-pool: tito 
    
    !--- Pool named tito 
    
    modems in pool: 1 active conn: 0 
    
    !--- One modem configured in this pool, 0 active connections to
    !--- modems in this pool 
    
     4 no free modems in pool 
    
     !--- Four failed attempts to allocate a modem to a user that dialed in. 
    
    called_party_number: 5557528 
    
    !--- This is the number of the Cisco access-server that the remote user dialed.
    
     max conn allowed: 1, active conn: 0 
    
     !--- Max connection allowed per pool, 0 active 
    
     2 max-conn exceeded, 1 no free modems in pool 
    
     !--- Failed twice to allocate a modem to the user because the 
     !--- number of connections was exceeded for that pool) 
    
     
    isdn2-2# 
    

Configuration 3: Modem Pooling Without a Pool-Range

Except for the pool-range 3-5 command and the max-conn argument, this configuration is the same as the Multiple Modems in Pool-Range configuration.

Modem Pooling Without a Pool-Range
! 
modem-pool tito 
 called-number 5557528 max-conn 0 
ip domain-name cisco.com 
isdn switch-type primary-5ess 
!

Debug and Verification Tips

To ensure that your configuration is working properly, use the show command. Output from this command should be similar to the output that follows.

  • show modem-pool Before First Dial

    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 24 active conn: 1 
     3 no free modems in pool 
      
    modem-pool: tito 
    modems in pool: 0 active conn: 0 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 0, active conn: 0 
      0 max-conn exceeded, 0 no free modems in pool 
    
    
  • show modem-pool and debug After User Dials and Fails to Connect

    isdn2-2#debug isdn q931 
    ISDN Q931 packets debugging is on 
    isdn2-2#debug modem 
    Modem control/process activation debugging is on 
    isdn2-2# 
    *Mar 1 19:56:50.827: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x38 
    *Mar 1 19:56:50.827:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:56:50.831:     Channel ID i = 0xA98393 
    *Mar 1 19:56:50.835:     Progress Ind i = 0x8381 - Call not end-to-end
       ISDN, may have in-band info 
    *Mar 1 19:56:50.839:     Calling Party Number i = '!', 0x83, '4085559474' 
    *Mar 1 19:56:50.843:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:56:50.851: ISDN Se0:23: Incoming call id = 0x17 
    *Mar 1 19:56:50.859: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 18,
       call id 17 
    *Mar 1 19:56:50.947: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8038 
    *Mar 1 19:56:50.951:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    
    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 24 active conn: 0 
     3 no free modems in pool 
      
    modem-pool: tito 
    modems in pool: 0 active conn: 0 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 0, active conn: 0 
      1 max-conn exceeded, 0 no free modems in pool 
    

Verify

Please refer to the configuration examples above for specific verification information.

Troubleshoot

Please refer to the configuration examples above for specific verification information.

Related Information

Updated: Sep 09, 2005
Document ID: 10383