Modem-Router Connection Guide or Access-Dial Technology Support." /> Modem-Router Connection Guide or Access-Dial Technology Support." />
Guest

Asynchronous Connections

Connecting Routers Back-to-Back Through the AUX Ports

Cisco - Connecting Routers Back-to-Back Through the AUX Ports

Document ID: 10365

Updated: Feb 04, 2010

   Print

Introduction

This sample configuration shows you how to directly connect two routers, without a modem or other data communication equipment (DCE) devices. For more information on how to configure modems on auxiliary (AUX) or console ports, see Modem-Router Connection Guide or Access-Dial Technology Support.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Background Information

In this configuration, two Cisco routers are connected back-to-back through the asynchronous AUX ports with the help of a null modem cable (rollover cable). The AUX ports of the two routers are directly connected with the help of a rollover cable with Point-to-Point Protocol (PPP) running on the link. The AUX ports are data terminal equipment (DTE) devices. You will require a null modem cable (rollover cable) to connect DTE to DTE devices.

A flat-satin rollover (null modem) cable (part number CAB-500RJ= ) is usually provided with every Cisco router to allow for RJ-45 console connectivity. If the AUX port is a DB-25, use a RJ-45-to-DB-25 adapter marked "terminal" with the null modem cable (rollover cable).

Note: Ensure that the length of the cable is less than 50 feet due to EIA/TIA-232 (formerly known as RS-232) limitations.

For more information on cabling, refer to Cabling Guide for RJ-45 Console and AUX Ports and RJ-45 cables.

Routers with DB-25 AUX Ports

For routers with a DB-25 AUX port (for example, Cisco 4500, 7200 and 7500), you need a DB-25-to-DB-25 Null Modem cable. This cable can be purchased from most retail electronic outlet stores.

Note: Due to incorrect signal pairs, you CANNOT use a rolled RJ-45-to-RJ-45 flat satin cable with RJ-45-to-DB-25 adapters (part number CAB-25AS-MMOD) on both ends.

Verify whether your DB-25-to-DB-25 null modem cable has the pin connections indicated in table 1.

Table 1 – DB-25-to-DB-25 Null Modem Cable Pin Connections

DB-25 DB-25
RxD 2 3 TXD
TxD 3 2 RxD
CTS 4 5 RTS
RTS 5 4 CTS
DTR 6 20 CD
DSR 8
CD 20 6 DTR
8 DSR
GND 7 7 GND

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

auxback.gif

Configurations

This document uses these configurations:

  • Router 1

  • Router 2

Note: This connection has been configured with IP addresses on the AUX ports for a permanent ("nailed up") connection.

Router 1
version 11.1
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router1
 !
 interface Ethernet0
  no ip address
  shutdown
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX port.

  ip address 192.168.10.1 255.255.255.0

 !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

 !--- Set PPP as the encapsulation.

  async default routing 

 !--- This allows routing protocols on the link. 

  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Async1

 !--- The default route points to the Async1 (AUX port) interface.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

  !--- This allows all protocols to use the line.

  rxspeed 38400

  !--- Set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

  !--- Set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Router 2
version 11.1

 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router2
 !
 interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX Port.

  ip address 192.168.10.2 255.255.255.0

  !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

  !--- Set PPP as encapsulation.

  async default routing 
  
!--- This allows routing protocols on the link.
 
  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Ethernet0
 
!--- This default route points to interface Ethernet0.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

 !--- This allows all protocols to use the line.

  rxspeed 38400

 !--- set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

 !--- set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Procedure

Before issuing debug commands, please see Important Information on Debug Commands.

Complete these steps:

  1. Use the show line command to determine the asynchronous interface of the AUX ports.

    Though most routers have the AUX port as interface async 1, Access servers have the AUX port interface after the tty lines. For example, if your router has 16 async/modem lines, the AUX port is line 17. In such a case, the AUX port must be configured on interface async 17. Configure the AUX port based on the show line outputs. Here is an example to verify that the AUX port configuration is on interface Async1 on your routers:

    Router1#show line
     Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
    *  0 CTY              -    -     -    -    -    0      0       0/0
    A  1 AUX  38400/38400 - inout    -    -    -    0      0       0/0
       2 VTY              -    -     -    -    -    0      0       0/0
       3 VTY              -    -     -    -    -    0      0       0/0
       4 VTY              -    -     -    -    -    0      0       0/0
       5 VTY              -    -     -    -    -    0      0       0/0
       6 VTY              -    -     -    -    -    0      0       0/0
  2. Issue the show line aux 0 command.

  3. Verify that all signals are up (for example, Clear To Send (CTS), Request To Send (RTS), data terminal ready (DTR), and Carrier Detect (CD)).

    If nothing appears next to them, they are up. If a "No" appears next to them (for example, No-CTS), it means they are down. If they are down, verify the configuration on each side. Verify that you have the asynchronous interface and the line of the AUX port configured (as shown above).

    Note: If the show line command output indicates that DSR is not up (noDSR), you must verify that the each end on the DB-25-to-DB-25 null modem cable has pins 6 and 8 physically wired to pin 20 on the other end. Refer to table 1 for the correct pinouts.

    Router1#show line aux 0
     Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
    A  1 AUX 38400/38400  - inout    -    -    -    0      0       0/0
    
    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    Status: Ready, Active, Async Interface Active
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Line is permanent async interface
    Modem state: Ready
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none         
    Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
               00:10:00      never                       none   not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:00:30
    Editing is enabled.
    History is enabled, history size is 10.
    Full user help is disabled
    Allowed transports are pad v120 telnet.  Preferred is telnet.
    No output characters are padded
    No special data dispatching characters
    Line is running PPP for address 192.168.10.2.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS 
    
  4. If the configuration appears correct, replace the rollover cable between the router.

  5. Use shutdown and no shutdown commands on the async interface to reset the connection.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Use these debug commands to verify that the link comes up correctly.

Note: Before issuing debug commands, refer to Important Information on Debug Commands.

  • debug ppp negotiation—displays information on PPP traffic and exchanges as the negotiation of Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP) is in progress. A successful PPP negotiation will first open the LCP state, then Authenticate, and finally negotiate NCP. If CONFREQs are sent out, but no CONFACKs are received, check whether the cabling is correct, and whether the correct line is configured (issue the interface async x command for this).

  • debug ppp authentication—displays PPP authentication protocol messages(if authentication is configured), and includes Challenge Handshake Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges. In this configuration authentication is not configured. Therefore, this debug command is not necessary.

  • debug ppp error—displays protocol errors and error statistics associated with PPP connection negotiation and operation.

Related Information

Updated: Feb 04, 2010
Document ID: 10365