Guest

Product Support

Identifying and Mitigating Exploitation of the Voice Vulnerabilities in Cisco IOS and Cisco Unified Communications Manager

Advisory ID: cisco-amb-20070808-IOS-voice

http://tools.cisco.com/security/center/content/CiscoAppliedMitigationBulletin/cisco-amb-20070808-IOS-voice

Revision 1.2

For Public Release 2007 August 8 16:00  UTC (GMT)


Contents

Cisco Response
Device Specific Mitigation and Identification
Additional Information
Revision History
Cisco Security Procedures
Related Information

Cisco Response

This Applied Mitigation Bulletin is a companion document to the PSIRT Security Advisory Voice Vulnerabilities in Cisco IOS and Cisco Unified Communications Manager and provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

There are multiple vulnerabilities in voice component of Cisco IOS. One of the Session Initiation Protocol vulnerabilities also affects the Cisco Unified Call Manager. These vulnerabilities are summarized in the following subsections:

Session Initiation Protocol related vulnerabilities: These vulnerabilities can be exploited remotely without authentication and without user interaction. Successful exploitation of these vulnerabilities may cause the affected device to crash and may allow arbitrary code execution. Repeated attempts to exploit these vulnerabilities could result in a sustained denial of service (DoS) condition. The attack vector is the Session Initiation Protocol (SIP) using TCP and UDP ports 5060 and 5061 packets. These vulnerabilities have been assigned CVE ID numbers CVE-2007-4292, CVE-2007-4294 and CVE-2007-4295.

Media Gateway Control Protocol related vulnerabilities: These vulnerabilities can be exploited remotely without authentication and without user interaction. Successful exploitation of these vulnerabilities may cause the affected device to crash. Repeated attempts to exploit these vulnerabilities could result in a sustained denial of service (DoS) condition. The attack vector is the Media Gateway Control Protocol (MGCP) using UDP port 2427 packets. These vulnerabilities are susceptible to exploitation through spoofed attacks. This vulnerabilitiy has been assigned CVE ID number CVE-2007-4293.

H.323 signaling related vulnerabilities: These vulnerabilities can be exploited remotely without authentication and without user interaction. Successful exploitation of these vulnerabilities may cause the affected device to crash. Repeated attempts to exploit these vulnerabilities could result in a sustained denial of service (DoS) condition. The attack vector is the H.323 protocol using TCP port 1720 and 11720 packets and UDP port 2517 packets. These vulnerabilities are susceptible to exploitation through spoofed attacks. At the time of publication, there was no CVE ID associated with these vulnerabilities.

Real-Time Transport Protocol related vulnerabilities: These vulnerabilities can be exploited remotely without authentication and without user interaction. Successful exploitation of these vulnerabilities may cause the affected device to crash. Repeated attempts to exploit these vulnerabilities could result in a sustained denial of service (DoS) condition. The attack vector is the Real-time Transport Protocol (RTP) using UDP packets from ports 16384 through 32767. These vulnerabilities are susceptible to exploitation through spoofed attacks. This vulnerabilitiy has been assigned CVE ID number CVE-2007-4291.

Facsimile reception vulnerability: This vulnerability can be exploited remotely without authentication and without user interaction. Successful exploitation of this vulnerability may cause the affected device to crash. Repeated attempts to exploit this vulnerability could result in a sustained denial of service (DoS) condition. The attack vector is the T.38/Internet Fax Protocol over RTP using UDP packets from ports 16384 through 32767. This vulnerability is susceptible to exploitation through spoofed attacks. At the time of publication, there was no CVE ID associated with this vulnerability.

Information about vulnerable, unaffected, and fixed software is available in this PSIRT Security Advisory: http://www.cisco.com/warp/customer/707/cisco-sa-20070808-IOS-voice.shtml.

Mitigation Technique Overview

Cisco IOS Software can provide effective means of exploit prevention using the following methods:

  • Infrastructure access control lists (iACLs)
  • Transit access control lists (tACLs)
  • Unicast Reverse Path Forwarding (Unicast RPF)

These protection mechanisms filter and drop, as well as verify the source IP address of, packets attempting to exploit the multiple Cisco IOS voice vulnerabilities described in this document.

The proper deployment and configuration of Unicast RPF provides the most effective means of spoofing protection against attacks with spoofed source IP addresses. Deployment as close to all traffic sources as possible provides maximum effectiveness.

Effective means of exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance, the Cisco PIX 500 Series Security Appliance, and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers using the following methods:

  • tACLs
  • Unicast RPF

These protection mechanisms filter and drop, as well as verify the source IP address of, packets attempting to exploit the multiple Cisco IOS voice vulnerabilities described in this document.

The proper deployment and configuration of Unicast RPF provides the most effective means of protection against attacks that use packets with spoofed source IP addresses. Unicast RPF should be deployed as close to all traffic sources as possible.

Cisco IOS NetFlow can provide visibility into these exploitation attempts using flow records.

Cisco IOS Software, Cisco ASA, Cisco PIX security appliances, and FWSM firewalls can provide visibility through syslog messages and the counter values displayed in the output from show commands.

Risk Management

Organizations should follow their standard risk evaluation and mitigation processes to determine the potential impact of this vulnerability. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping in Information Security Engagements can help organizations develop repeatable security evaluation and response processes.

Device-specific Mitigation and Identification

caution Caution: The effectiveness of any mitigation technique is dependent on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Infrastructure Access Control Lists

In an effort to protect infrastructure devices and minimize the risk, impact, and effectiveness of direct infrastructure attacks, administrators should deploy infrastructure access control lists (iACLs) to perform policy enforcement of traffic sent to infrastructure equipment. Administrators can construct an iACL by explicitly permitting only authorized traffic sent to infrastructure devices in accordance with existing security policies and configurations. For the maximum protection of infrastructure devices, deployed iACLs should be applied in the ingress direction on all interfaces to which an IP address has been configured.

In the following example, the address block 192.168.1.0/24 is the infrastructure address space and the host at 192.168.100.1 is considered a trusted endpoint. The iACL policy denies SIP packets on TCP and UDP ports 5060 and 5061, MGCP packets on UDP port 2427, H.323 packets on TCP ports 1720 and 11720 and UDP port 2517, and RTP packets on UDP ports from 16384 through 32767 sent to addresses that are part of the infrastructure address space. Care should be taken to allow required traffic for routing and administrative access prior to denying all traffic sent directly to infrastructure devices. Whenever possible, infrastructure address space should be distinct from the address spaced used for user and services segments. Using this addressing methodology will assist with the construction and deployment of iACLs.

Additional information about iACLs is available in Protecting Your Core: Infrastructure Protection Access Control Lists.

ip access-list extended Infrastructure-ACL-Policy
  
 ! !-- When applicable, include explicit permit statements for trusted !-- sources that require access on the vulnerable ports !

  permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
  permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
  permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
  permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
  permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 2427
  permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 1720
  permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 11720
  permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 2517
  permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 range 16384 32767
  
 ! !-- The following vulnerability-specific access control entries !-- (ACEs) can aid in identification of attacks !

  deny tcp any 192.168.1.0 0.0.0.255 eq 5060
  deny tcp any 192.168.1.0 0.0.0.255 eq 5061
  deny udp any 192.168.1.0 0.0.0.255 eq 5060
  deny udp any 192.168.1.0 0.0.0.255 eq 5061
  deny udp any 192.168.1.0 0.0.0.255 eq 2427
  deny tcp any 192.168.1.0 0.0.0.255 eq 1720
  deny tcp any 192.168.1.0 0.0.0.255 eq 11720
  deny udp any 192.168.1.0 0.0.0.255 eq 2517
  deny udp any 192.168.1.0 0.0.0.255 range 16384 32767
  
 ! !-- Explicit deny ACE for traffic sent to addresses configured within !-- the infrastructure address space !

  deny ip any 192.168.1.0 0.0.0.255
  
 ! !-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance !-- with existing security policies and configurations !


!-- Apply iACL to interface(s) in the ingress direction

interface GigabitEthernet0/0
 ip access-group Infrastructure-ACL-Policy in

!

Mitigation: Transit Access Control Lists

In an effort to protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators should deploy transit access control lists (tACLs) to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations.

The tACL policy denies unauthorized SIP packets on TCP ports 5060 and 5061 and UDP ports 5060 and 5061 sent to affected devices. In the following example, 192.168.1.0/24 is the network IP address space used by the Cisco Unified Communications Manager and the host at 192.168.100.1 is considered a trusted source that requires access to the Cisco Unified Communications Manager. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is available in Transit Access Control Lists: Filtering at Your Edge.


 !-- Include any explicit permit statements for trusted sources !-- that require access on the vulnerable ports !

    access-list 150 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
    access-list 150 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
    access-list 150 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
    access-list 150 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
    
 ! !-- The following vulnerability-specific access control entries !-- (ACEs) can aid in identification of attacks !

    access-list 150 deny tcp any 192.168.1.0 0.0.0.255 eq 5060
    access-list 150 deny tcp any 192.168.1.0 0.0.0.255 eq 5061
    access-list 150 deny udp any 192.168.1.0 0.0.0.255 eq 5060
    access-list 150 deny udp any 192.168.1.0 0.0.0.255 eq 5061
    
 ! !-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance !-- with existing security policies and configurations ! !-- Explicit deny for all other IP traffic !

    access-list 150 deny ip any any
    
 ! !-- Apply tACL to interface(s) in the ingress direction

    interface GigabitEthernet0/0
     ip access-group 150 in
    
 !

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. This could have the undesired effect of increasing CPU utilization because the device needs to generate these ICMP unreachable messages. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration command no icmp unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration command ip icmp rate-limit unreachable interval-in-ms .

Mitigation: Spoofing Protection Using Unicast Reverse Path Forwarding

The multiple Cisco IOS voice vulnerabilities described in this document can be exploited by spoofed IP packets. Protection mechanisms for spoofing exist through the proper deployment and configuration of Unicast Reverse Path Forwarding (Unicast RPF). Unicast RPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on Unicast RPF to provide 100 percent spoofing protection because spoofed packets may enter the network through a Unicast RPF-enabled interface if an appropriate return route to the source IP address exists. Administrators should take care to ensure that the appropriate Unicast RPF mode (loose or strict) is configured during the deployment of this feature because it can drop legitimate traffic transiting the network. In an enterprise environment, Unicast RPF might be enabled at the Internet edge and the internal access layer on the user-supporting Layer 3 interfaces.

Additional information is available in the Unicast Reverse Path Forwarding Loose Mode Feature Guide.

For additional information about the configuration and use of Unicast RPF, reference the Understanding Unicast Reverse Path Forwarding Applied Intelligence white paper.

Identification: Infrastructure Access Control Lists

After the administrator applies the Infrastructure iACL to an interface, the show ip access-lists command will identify the number of SIP packets on TCP and UDP ports 5060 and 5061, MGCP packets on UDP port 2427, H.323 packets on TCP ports 1720 and 11720 and UDP port 2517, RTP packets on UDP ports 16384 through 32767, and Facsimile packets on UDP ports 16384 through 32767 that have been filtered on interfaces on which the iACL is applied. Administrators should investigate filtered packets to determine whether they are attempts to exploit this vulnerability. Example output for show ip access-lists Infrastructure-ACL-Policy follows:

router#show ip access-lists Infrastructure-ACL-Policy
Extended IP access list Infrastructure-ACL-Policy
    10 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
    20 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
    30 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
    40 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
    50 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 2427
    60 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 1720
    70 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 11720
    80 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 2517
    90 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 range 16384 32767
    100 deny tcp any 192.168.1.0 0.0.0.255 eq 5060 (10 matches)
    110 deny tcp any 192.168.1.0 0.0.0.255 eq 5061 (8 matches)
    120 deny udp any 192.168.1.0 0.0.0.255 eq 5060 (18 matches)
    130 deny udp any 192.168.1.0 0.0.0.255 eq 5061 (4 matches)
    140 deny udp any 192.168.1.0 0.0.0.255 eq 2427 (6 matches)
    150 deny tcp any 192.168.1.0 0.0.0.255 eq 1720 (7 matches)
    160 deny tcp any 192.168.1.0 0.0.0.255 eq 11720 (4 matches)
    170 deny udp any 192.168.1.0 0.0.0.255 eq 2517 (3 matches)
    180 deny udp any 192.168.1.0 0.0.0.255 range 16384 32767 (15 matches)
    190 deny ip any 192.168.1.0 0.0.0.255
router#

In the preceding example, the access list Infrastructure-ACL-Policy has dropped 10 SIP packets on TCP port 5060 for ACE sequence ID 100, 8 SIP packets on TCP port 5061 for ACE sequence ID 110, 18 SIP packets on UDP port 5060 for ACE sequence ID 120, 4 SIP packets on UDP port 5061 for ACE sequence ID 130, 6 MGCP packets on UDP port 2427 for ACE sequence ID 140, 7 H.323 packets on TCP port 1720 for ACE sequence ID 150, 4 H.323 packets on TCP port 11720 for ACE sequence ID 160, 3 H.323 packets on UDP port 2517 for ACE sequence ID 170 and 15 RTP packets on UDP ports 16384 through 32767 for ACE sequence ID 180.

Identification: Transit Access Control Lists

After the administrator applies the tACL to an interface, the show ip access-lists command will identify the number of SIP packets on TCP and UDP ports 5060 and 5061 that have been filtered. Administrators should investigate filtered packets to determine whether they are attempts to exploit this vulnerability. Example output for show ip access-lists 150 follows:

router#show ip access-lists 150
Extended IP access list 150
    10 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
    20 permit tcp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
    30 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5060
    40 permit udp host 192.168.100.1 192.168.1.0 0.0.0.255 eq 5061
    50 deny tcp any 192.168.1.0 0.0.0.255 eq 5060 (2 matches)
    60 deny tcp any 192.168.1.0 0.0.0.255 eq 5061 (11 matches)
    70 deny udp any 192.168.1.0 0.0.0.255 eq 5060 (7 matches)
    80 deny udp any 192.168.1.0 0.0.0.255 eq 5061 (9 matches)
    90 deny ip any any
router#

In the preceding example, access list 150 has dropped 2 SIP packets on TCP port 5060 for ACE sequence ID 50, 11 SIP packets on TCP port 5061 for ACE sequence ID 60, 7 SIP packets on UDP port 5060 for ACE sequence ID 70 and 9 SIP packets on UDP port 5061 for ACE sequence ID 80.

Identification: Access List Logging

The log or log-input ACL option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

caution Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

The CPU impact from ACL logging can be addressed in hardware on the Catalyst 6500 Series switches and Cisco 7600 Series routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging. The ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by ACL logging. The logging rate-limit rate-per-second [except loglevel] command limits the impact of log generation and transmission.

For additional information about the configuration and use of ACL logging, reference the Understanding Access Control List Logging Applied Intelligence white paper.

Identification: Spoofing Protection Using Unicast RPF

With Unicast RPF properly deployed and configured throughout the network infrastructure, administrators can use the show ip interface, show cef drop, show cef interface type slot/port internal, and show ip traffic commands to identify the number of packets that Unicast RPF has dropped.

Note: The show command | begin regexp , and show command | include regexp command modifiers are used in the following examples to minimize the amount of output that administrators will need to parse to view the desired information. Additional information about command modifiers is available in the "show command" sections of the Cisco IOS Configuration Fundamentals Command Reference.

Note:  show cef interface type slot/port internal is a hidden command that must be fully entered at the command-line interface. Command completion is not available for it.

router#show ip interface GigabitEthernet 0/0 | begin verify
    --      CLI Output Truncated       --  
        IP verify source reachable-via RX, allow default, allow self-ping
  18 verification drops
  0 suppressed verification drops
router#
router#show cef drop
CEF Drop Statistics
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj  ChkSum_Err
RP            27           0           0          18           0           0
IPv6 CEF Drop Statistics
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj
RP             0           0           0           3           0
router#
router#show cef interface GigabitEthernet 0/0 internal | include drop
      --      CLI Output Truncated       --
  ip verify: via=rx (allow default), acl=0, drop=18, sdrop=0, allow self-ping
router#
router#show ip traffic

IP statistics:
  Rcvd:  68051015 total, 2397325 local destination
         43999 format errors, 0 checksum errors, 33 bad hop count
         2 unknown protocol, 929 not a gateway
         21 security failures, 190123 bad options, 542768 with options
  Opts:  352227 end, 452 nop, 36 basic security, 1 loose source route
         45 timestamp, 59 extended security, 41 record route
         53 stream ID, 3 strict source route, 40 alert, 45 cipso, 0 ump
         361634 other
  Frags: 0 reassembled, 10008 timeouts, 56866 couldn't reassemble
         0 fragmented, 0 fragments, 0 couldn't fragment
  Bcast: 64666 received, 0 sent
  Mcast: 1589885 received, 2405454 sent
  Sent:  3001564 generated, 65359134 forwarded
  Drop:  4256 encapsulation failed, 0 unresolved, 0 no adjacency
         18 no route, 18 unicast RPF, 0 forced drop
         0 options denied
  Drop:  0 packets with source IP address zero
  Drop:  0 packets with internal loop back IP address 
    --      CLI Output Truncated       --
router#

In the preceding examples, Unicast RPF has dropped a total of 18 IP packets received globally on all interfaces with Unicast RPF configured because of the inability to verify the source address of the IP packets within the Cisco Express Forwarding Forwarding Information Base.

Cisco IOS NetFlow

Identification: Traffic Flow Identification Using NetFlow Records

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of traffic flows that may be potential attempts to exploit the vulnerabilities described in this document. Administrators should investigate flows to determine whether they are attempts to exploit this vulnerability or whether they are legitimate traffic flows.

router#show ip cache flow
IP packet size distribution (90784136 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .698 .011 .001 .004 .005 .000 .004 .000 .000 .003 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .001 .256 .000 .010 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  1885 active, 63651 inactive, 59960004 added
  129803821 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  0 active, 16384 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet    11393421      2.8         1    48      3.1       0.0       1.4
TCP-FTP            236      0.0        12    66      0.0       1.8       4.8
TCP-FTPD            21      0.0     13726  1294      0.0      18.4       4.1
TCP-WWW          22282      0.0        21  1020      0.1       4.1       7.3
TCP-X              719      0.0         1    40      0.0       0.0       1.3
TCP-BGP              1      0.0         1    40      0.0       0.0      15.0
TCP-Frag         70399      0.0         1   688      0.0       0.0      22.7
TCP-other     47861004     11.8         1   211     18.9       0.0       1.3
UDP-DNS            582      0.0         4    73      0.0       3.4      15.4
UDP-NTP         287252      0.0         1    76      0.0       0.0      15.5
UDP-other       310347      0.0         2   230      0.1       0.6      15.9
ICMP             11674      0.0         3    61      0.0      19.8      15.5
IPv6INIP            15      0.0         1  1132      0.0       0.0      15.4
GRE                  4      0.0         1    48      0.0       0.0      15.3 
Total:        59957957     14.8         1   196     22.5       0.0       1.5

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.1.102   11 0984 09D5     1
Gi0/0         192.168.11.54   Gi0/1         192.168.1.158   11 0911 097B     3
Gi0/1         192.168.150.60  Gi0/0         192.168.1.226   06 2816 13C5     1
Gi0/1         192.168.150.60  Gi0/0         192.168.1.226   06 10A6 2DC8     1
Gi0/0         192.168.13.97   Gi0/1         192.168.1.28    11 0B3E 13C4     5
Gi0/0         192.168.10.17   Gi0/1         192.168.1.97    11 0B89 4B5C     1
Gi0/0         10.88.226.1     Gi0/1         192.168.202.22  11 007B 13C5     1
Gi0/0         192.168.12.185  Gi0/1         192.168.1.239   11 0BD7 55A1     1
Gi0/0         10.89.16.226    Gi0/1         192.168.150.60  06 12CA 06B8     1
router#

In the preceding example, there are multiple flows for SIP on TCP and UDP ports 5060 and 5061 (hex values 13C4 and 13C5), MGCP on UDP port 2427 (hex value 097B), H.323 on TCP port 1720 (hex value 06B8) and TCP port 11720 (hex value 2DC8) and UDP port 2517 (hex value 09D5), and RTP on UDP ports 16384 through 32767 (hex values 4000 to 7FFF). This traffic is sourced from and sent to addresses within the 192.168.1.0/24 address block, which is used for infrastructure devices. The packets in these flows may be spoofed and may indicate an attempt to exploit the vulnerabilities described in this document. Administrators should compare these flows to baseline utilization for SIP on TCP and UDP ports 5060 and 5061 (hex values 13C4 and 13C5), MGCP on UDP port 2427 (hex value 097B), H.323 on TCP port 1720 (hex value 06B8) and TCP port 11720 (hex value 2DC8) and UDP port 2517 (hex value 09D5), and RTP on UDP ports 16384 through 32767 (hex values 4000 to 7FFF) and also investigate the flows to determine whether they are sourced from untrusted hosts or networks. Note that, because the RTP protocol uses a wide range of ports, these NetFlow results may not be enough to indicate an attack on a vulnerable device.

To view only the traffic flows for SIP packets on TCP and UDP ports 5060 and 5061 (hex values 13C4 and 13C5), MGCP packets on UDP port 2427 (hex value 097B), H.323 packets on TCP port 1720 (hex value 06B8) and TCP port 11720 (hex value 2DC8) and UDP port 2517 (hex value 09D5), and RTP packets on UDP ports 16384 through 32767 (hex values 4000 to 7FFF), the commands show ip cache flow | include SrcIf|_11_.*(13C4|13C5|097B|09D5|( [4-7]...)) and show ip cache flow | include SrcIf|_06_.*(13C4|13C5|06B8|2DC8) will display the related NetFlow records as shown here:

router#show ip cache flow | include SrcIf|_11_.*(13C4|13C5|097B|09D5|( [4-7]...))
SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.1.102   11 0984 09D5     1
Gi0/0         192.168.11.54   Gi0/1         192.168.1.158   11 0911 097B     3
Gi0/0         192.168.13.97   Gi0/1         192.168.1.28    11 0B3E 13C4     5
Gi0/0         192.168.10.17   Gi0/1         192.168.1.97    11 0B89 4B5C     1
Gi0/0         10.88.226.1     Gi0/1         192.168.1.22    11 007B 13C5     1
Gi0/0         192.168.12.185  Gi0/1         192.168.1.239   11 0BD7 55A1     1
router#
router#show ip cache flow | include SrcIf|_06_.*(13C4|13C5|06B8|2DC8)
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/1         192.168.150.60   Gi0/0         192.168.1.226   06 2816 13C5     5
Gi0/1         192.168.150.60   Gi0/0         192.168.1.226   06 10A6 2DC8     1
Gi0/0         192.168.1.226    Gi0/1         192.168.150.60  06 12CA 06B8     7
router#

Cisco ASA, PIX, and FWSM Firewalls

Mitigation: Transit Access Control Lists

In an effort to protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators should deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations.

The tACL policy denies unauthorized SIP packets on TCP and UDP ports 5060 and 5061, MGCP packets on UDP port 2427, H.323 packets on TCP ports 1720 and 11720 and UDP port 2517, and RTP packets on UDP ports from 16384 through 32767 sent to affected devices. In the following example, 192.168.1.0/24 is the network IP address space used by the affected devices and the host at 192.168.100.1 is considered a trusted source that requires access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is available in Transit Access Control Lists: Filtering at Your Edge.


 ! !-- Include any explicit permit statements for trusted sources !-- that require access on the vulnerable ports !

    access-list Transit-ACL-Policy extended permit TCP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 5060
    access-list Transit-ACL-Policy extended permit TCP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 5061
    access-list Transit-ACL-Policy extended permit UDP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 5060
    access-list Transit-ACL-Policy extended permit UDP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 5061
    access-list Transit-ACL-Policy extended permit UDP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 2427
    access-list Transit-ACL-Policy extended permit TCP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 1720
    access-list Transit-ACL-Policy extended permit TCP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 11720
    access-list Transit-ACL-Policy extended permit UDP host 
    192.168.100.1 192.168.1.0 255.255.255.0 eq 2517
    access-list Transit-ACL-Policy extended permit UDP host 
    192.168.100.1 192.168.1.0 255.255.255.0 range 16384 32767
    
 ! !-- The following vulnerability-specific access control entries !-- (ACEs) can aid in identification of attacks !

    access-list Transit-ACL-Policy extended deny TCP any 192.168.1.0 
      255.255.255.0 eq 5060
    access-list Transit-ACL-Policy extended deny TCP any 192.168.1.0 
      255.255.255.0 eq 5061
    access-list Transit-ACL-Policy extended deny UDP any 192.168.1.0 
      255.255.255.0 eq 5060
    access-list Transit-ACL-Policy extended deny UDP any 192.168.1.0 
      255.255.255.0 eq 5061
    access-list Transit-ACL-Policy extended deny UDP any 192.168.1.0 
      255.255.255.0 eq 2427
    access-list Transit-ACL-Policy extended deny TCP any 192.168.1.0 
      255.255.255.0 eq 1720
    access-list Transit-ACL-Policy extended deny TCP any 192.168.1.0 
      255.255.255.0 eq 11720
    access-list Transit-ACL-Policy extended deny UDP any 192.168.1.0 
      255.255.255.0 eq 2517
    access-list Transit-ACL-Policy extended deny UDP any 192.168.1.0 
      255.255.255.0 range 16384 32767
    
 ! !-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance !-- with existing security policies and configurations ! !-- Explicit deny for all other IP traffic !

    access-list Transit-ACL-Policy extended deny ip any any
    
 ! !-- Apply tACL to interface(s) in the ingress direction !

    access-group Transit-ACL-Policy in interface outside
    
 !

Mitigation: Spoofing Protection Using Unicast Reverse Path Forwarding

The multiple Cisco IOS voice vulnerabilities described in this document can be exploited by spoofed IP packets. Protection mechanisms for spoofing exist through the proper deployment and configuration of Unicast Reverse Path Forwarding (Unicast RPF). Unicast RPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on Unicast RPF to provide 100 percent spoofing protection because spoofed packets may enter the network through a Unicast RPF-enabled interface if an appropriate return route to the source IP address exists. Administrators should take care to ensure that the appropriate Unicast RPF mode (loose or strict) is configured during the deployment of this feature because it can drop legitimate traffic transiting the network. In an enterprise environment, Unicast RPF might be enabled at the Internet edge and the internal access layer on the user-supporting Layer 3 interfaces.

For additional information about the configuration and use of Unicast RPF, reference the Cisco Security Appliance Command Reference for ip verify reverse-path.

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the number of SIP packets on TCP and UDP ports 5060 and 5061, MGCP packets on UDP port 2427, H.323 packets on TCP ports 1720 and 11720 and UDP port 2517, and RTP packets on UDP ports from 16384 through 32767 that have been filtered. Administrators should investigate filtered packets to determine whether they are attempts to exploit this vulnerability. Example output for show access-list Transit-ACL-Policy follows:

firewall#show access-list Transit-ACL-Policy
access-list Transit-ACL-Policy; 17 elements
access-list Transit-ACL-Policy line 1 extended permit tcp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 5060 (hitcnt=2)
access-list Transit-ACL-Policy line 2 extended permit tcp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 5061 (hitcnt=3)
access-list Transit-ACL-Policy line 3 extended permit udp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 5060 (hitcnt=2)
access-list Transit-ACL-Policy line 4 extended permit udp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 5061 (hitcnt=4)
access-list Transit-ACL-Policy line 5 extended permit udp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 2427 (hitcnt=17)
access-list Transit-ACL-Policy line 6 extended permit tcp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 1720 (hitcnt=8)
access-list Transit-ACL-Policy line 7 extended permit tcp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 11720 (hitcnt=6)
access-list Transit-ACL-Policy line 8 extended permit udp host 192.168.100.1
   192.168.1.0 255.255.255.0 eq 2517 (hitcnt=2)
access-list Transit-ACL-Policy line 9 extended permit udp host 192.168.100.1
   192.168.1.0 255.255.255.0 range 16384 32767 (hitcnt=27)
access-list Transit-ACL-Policy line 10 extended deny tcp any 192.168.1.0
   255.255.255.0 eq 5060 (hitcnt=5)
access-list Transit-ACL-Policy line 11 extended deny tcp any 192.168.1.0
   255.255.255.0 eq 5061 (hitcnt=9)
access-list Transit-ACL-Policy line 12 extended deny udp any 192.168.1.0
   255.255.255.0 eq 5060 (hitcnt=24)
access-list Transit-ACL-Policy line 13 extended deny udp any 192.168.1.0
   255.255.255.0 eq 5061 (hitcnt=9)
access-list Transit-ACL-Policy line 14 extended deny udp any 192.168.1.0
   255.255.255.0 eq 2427 (hitcnt=18)
access-list Transit-ACL-Policy line 15 extended deny tcp any 192.168.1.0
   255.255.255.0 eq 1720 (hitcnt=3)
access-list Transit-ACL-Policy line 16 extended deny tcp any 192.168.1.0
   255.255.255.0 eq 11720 (hitcnt=2)
access-list Transit-ACL-Policy line 17 extended deny udp any 192.168.1.0
   255.255.255.0 eq 2517 (hitcnt=20)
access-list Transit-ACL-Policy line 18 extended deny udp any 192.168.1.0
   255.255.255.0 range 16384 32767 (hitcnt=40)
access-list Transit-ACL-Policy line 19 extended deny ip any any
firewall#

In the preceding example, the access list Transit-ACL-Policy has dropped 5 SIP packets on TCP port 5060, 9 SIP packets on TCP port 5061, 24 SIP packets on UDP port 5060, 9 SIP packets on UDP port 5061, 18 MGCP packets on UDP port 2427, 3 H.323 packets on TCP port 1720, 2 H.323 packets on TCP port 11720, 20 H.323 packets on UDP port 2517, and 40 RTP packets on the UDP port range of 16384 through 32767. In addition, syslog message 106023 can provide valuable information, which includes the source and destination IP address, the source and destination port numbers, and the IP protocol for the denied packet.

Identification: Firewall Access-list Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an ACE that does not have the log keyword present. Additional information about this syslog message is available in Cisco Security Appliance System Log Message - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance or the Cisco PIX 500 Series Security Appliance is available in Configuring Logging on the Cisco Security Appliance. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is available in Configuring Monitoring and Logging on the Cisco FWSM.

In the following example, the show logging | grep regexp command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is available in Using the Command Line Interface.

firewall#show logging | grep 106023
Feb 21 2007 00:15:13: %ASA-4-106023: Deny udp src outside:192.168.2.18/5060 
   dst inside:192.168.1.191/5060 by access-group "Transit-ACL-Policy"
Feb 21 2007 00:15:13: %ASA-4-106023: Deny udp src outside:192.168.3.200/18501 
   dst inside:192.168.1.33/21921 by access-group "Transit-ACL-Policy"
Feb 21 2007 00:15:13: %ASA-4-106023: Deny udp src outside:192.168.2.99/5061 
   dst inside:192.168.1.240/5061 by access-group "Transit-ACL-Policy"
Feb 21 2007 00:15:13: %ASA-4-106023: Deny udp src outside:192.168.2.100/2427 
   dst inside:192.168.1.115/2427 by access-group "Transit-ACL-Policy"
Feb 21 2007 00:15:13: %ASA-4-106023: Deny udp src outside:192.168.4.88/25401 
   dst inside:192.168.1.38/16488 by access-group "Transit-ACL-Policy"
firewall#

In the preceding example, the messages logged for the tACL Transit-ACL-Policy show potentially spoofed SIP packets for UDP ports 5060 and 5061, RTP packets for UDP ports 21921 and 16488, and MGCP packets for UDP port 2427 sent to the address block assigned to the network infrastructure.

Additional information about syslog messages for ASA and PIX security appliances is available in Cisco Security Appliance System Log Messages. Additional information about syslog messages for the FWSM is available in Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Logging Configuration and System Log Messages.

Identification: Spoofing Protection Using Unicast Reverse Path Forwarding

Firewall syslog message 106021 will be generated for packets denied by Unicast RPF. Additional information about this syslog message is available in Cisco Security Appliance System Log Message - 106021.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance or the Cisco PIX 500 Series Security Appliance is available in Configuring Logging on the Cisco Security Appliance. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is available in Configuring Monitoring and Logging on the Cisco FWSM.

In the following example, the show logging | grep regexp command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is available in Using the Command Line Interface.

firewall#show logging | grep 106021
Feb 21 2007 00:15:13: %ASA-1-106021: Deny UDP reverse path check from
   192.168.0.1 to 192.168.0.100 on interface outside
Feb 21 2007 00:15:13: %ASA-1-106021: Deny UDP reverse path check from
   192.168.0.1 to 192.168.0.100 on interface outside
Feb 21 2007 00:15:13: %ASA-1-106021: Deny TCP reverse path check from
   192.168.0.1 to 192.168.0.100 on interface outside
firewall#

The show asp drop command can also identify the number of packets that Unicast RPF has dropped, as shown in the following example:

firewall#show asp drop

Frame drop:
  Reverse-path verify failed                                 11
  Flow is denied by configured rule                         855
  Expired flow                                                1
  Interface is down                                           2

Flow drop:

firewall#

In the preceding example, Unicast RPF has dropped 11 IP packets received on interfaces with Unicast RPF configured.

For additional information about the configuration and use of Unicast RPF, reference the Cisco Security Appliance Command Reference for show asp drop.

Cisco Intrusion Prevention System

Identification

The Cisco Intrusion Prevention System (IPS) appliances and service modules can be used to provide threat detection and prevention for attempts to exploit the Session Initiation Protocol related vulnerabilities described in this document.

Beginning with signature update S295, IPS signatures 5684.0, 5684.1, 5684.2, 5684.3, 5684.4, 5684.5 and 5684.6 (Signature Name: Malformed SIP Packet) will trigger a medium-severity or a high-severity alarm on potential attempts to exploit the Session Initiation Protocol related vulnerabilities. The following medium-severity event was triggered on a Cisco IPS Sensor deployed in promiscuous mode.

R4-IPS4240a#show events alert

evIdsAlert: eventId=1184072489279138303  vendor=Cisco  severity=medium
   originator:
     hostId: sensor6x
     appName: sensorApp
     appInstanceId: 395
   time: August 9, 2007 5:23:33 PM UTC  offset=-300  timeZone=CDT
   signature:   description=Malformed SIP Packet  id=5684  version=S295
     subsigId: 5
     sigDetails: Malformed SIP Packet
     marsCategory: DoS/NetworkDevice
     marsCategory: Info/Misc
   interfaceGroup: vs0
   vlan: 0
   participants:
     attacker:
       addr: 10.68.36.114  locality=OUT
       port: 32769
     target:
       addr: 10.66.89.10  locality=OUT
       port: 5060
       os:   idSource=unknown  type=unknown  relevance=unknown
      
!-- Output suppressed

       triggerPacket:
     
!-- Output suppressed

   riskRatingValue: 33  targetValueRating=medium
   threatRatingValue: 33
   interface: ge0_0
   protocol: udp

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Revision History

Revision 1.2

2007-August-16

Added new CVE IDs to the Vulnerability Characteristics section.

Revision 1.1

2007-August-09

Added Cisco Intrusion Prevention System section.

Revision 1.0

2007-August-08

Initial public release.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information