Guest

CiscoWorks Resource Manager Essentials

Configuring RCP as Transport Protocol in Cisco Resource Manager Essentials

Document ID: 8535

Updated: Oct 26, 2005

   Print

Introduction

This document explains the interactions between Resource Manager Essentials (RME) and the remote copy protocol (rcp). The document provides an example configuration of the network devices and the CiscoWorks server for the setup of rcp as transport protocol for some RME applications.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software versions:

  • RME versions 2.x and 3.0–3.5

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

What Is rcp?

The rcp is a subset of the UNIX rshell service, which allows UNIX users to issue shell commands on remote UNIX systems. The rcp is a UNIX built-in service. This service uses Transmission Control Protocol (TCP) as the transport protocol and listens for requests at TCP port 514. Cisco implements the rshell service, which also has the name "remote command" (rcmd), in most Cisco devices that run Cisco IOS® Software. Cisco IOS devices that do not support rcp include:

  • The Cisco 7000 series, Route Processor (RP)-based 7000 only

  • The MC3810

  • The Catalyst 2900XL/3500XL series switches

All other Cisco IOS devices support the rcp.

Which RME Applications Use rcp?

You can use rcp as transport protocol in these RME applications:

  • Configuration Management—You can use rcp only to pull configurations from the network devices to the archive. You never use rcp as a transport protocol for Config Editor or NetConfig, which is a common misunderstanding. To configure rcp as transport protocol in order to add configurations to the archive, choose Resource Manager Essentials > Administration > Configuration Management > General Setup > Transport Setup. Then, make a choice such as this one:

    rcp1.gif

  • Software Management—You can use rcp to transfer images from the network device to the RME library. Or, you can use rcp to upload images from the CiscoWorks server to the device. In order to configure rcp as transport protocol for Software Management, choose Resource Manager Essentials > Administration > Software Management > Edit Preferences. Then, check the Use rcp for image transfer (when applicable) check box.

    rcp2.gif

Configuration Example

In order to use rcp, complete these configuration steps:

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Enable rcp as Transport Protocol for Software Management or Configuration Management

See the Which RME Applications Use rcp? section of this document.

Configure the Cisco IOS Software Device to Allow rcp Transactions

Here is a basic configuration in a router that can handle rcp transactions from the CiscoWorks server. The lines in boldface are the lines that you need specifically for this purpose:

calvi# show running configuration
Building configuration... 

Current configuration: 
! 
version 11.3 service timestamps debug uptime 
service timestamps log uptime 
service password-encryption    
! 
hostname calvi 
! 
boot system c2500-is-l.113-11a.T1.bin 255.255.255.255 
enable password 7 1106170043130700 
! 
username cwuser password 7 000C1C0A05 
ip rcmd rcp-enable 
ip rcmd remote-host cwuser 172.17.246.221 cwuser enable 
ip rcmd remote-username cwuser 
! 
! 
process-max-time 200 
! 
interface Loopback0 
 ip address 5.5.5.5 255.255.255.255    
 no ip directed-broadcast 
! 
interface Ethernet0 
 description Connection to Backbone    
 ip address 172.17.246.4 255.255.255.0 
 no ip mroute-cache 
! 
interface Serial0    
 no ip address 
 no ip mroute-cache shutdown 
 no cdp enable 

! 
interface Serial1    
 no ip address 
 no ip mroute-cache shutdown 
 no cdp enable 
! 
interface Async1 
 no ip address 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.246.1 
! 
logging monitor informational 
snmp-server community private RW 
snmp-server community public RO 
snmp-server enable traps snmp 
snmp-server host 172.17.246.117 traps public    

! 
line con 0 
 exec-timeout 0 0 
 password 7 0504080A754D4205 
 login 
line 1 8 
 exec-timeout 0 0 
 login 
 transport input all 
line aux 0 
 password 7 06090124184F0515 
 login 
line vty 0 4 
 exec-timeout 0 0 
 password 7 06090124184F0515 
 login 
! 
end

The comments for the commands in boldface are:

  • username cwuser password 7 000C1C0A05: Creation of the username "cwuser" is necessary on the router. You must choose a password for this user.

  • ip rcmd rcp-enable: You enable the rcp service on the device.

  • ip remote-host cwuser 172.17.246.221 cwuser enable: The remote system where you install CiscoWorks has the IP address 172.17.246.221 and the local definition of the user, "cwuser." This command allows "cwuser" to issue the copy command on the network device.

  • ip rcmd remote-username cwuser: This command configures use of the remote user name at the request of a remote copy. At the initiation of the remote copy operation in the network device, for example, in Add Images to Library, the device uses the "cwuser" name to authenticate against the CiscoWorks server.

Configure the Server to Allow rcp Transactions

UNIX

As the What Is rcp? section of this document mentions, the rshell service is a built-in service in UNIX systems. In continuation of the configuration example, these are necessary in the UNIX server:

  • In the /etc/inetd.conf file, a line must exist that invokes in.rshd, which is the remote shell daemon. Typically in Solaris systems, this line is:

    shell stream tcp nowait root /usr/sbin/in.rshd in.rshd
    

    If /etc/inetd.conf does not contain the line, edit the file as superuser, and add the line.

  • A "cwuser" user must exist in the system.

  • Under the home directory of the "cwuser" user, an .rhosts file must exist. This file must have read and write permissions for:

    • The "bin" user in RME 3.0, RME 3.1, and RME 3.2. To achieve the permissions, in the UNIX command line, enter:

      # chown cwuser:bin .rhosts
      # chmod 664 .rhosts
      
    • The "casuser" user in RME 3.3. In the UNIX command line, enter:

      # chown cwuser:casusers .rhosts 
      # chmod 664 .rhosts
      

Windows

Windows OS does not implement a built-in rshell service. During installation of CiscoWorks on any of the Windows platforms with support, installation of an rshell service occurs as well. No additional configuration steps in the Windows server are necessary.

Configure Users in CiscoWorks

You must specify the "cwuser" user as the one to carry out rcp transfers in the CiscoWorks servers. This setup is the default. To configure or double-check the user, choose Resource Manager Essentials > Administration > System Configuration, and choose the RCP tab. The "cwuser" must be present there, as this window shows:

rcp3.gif

Debug and Troubleshoot

Some troubleshoot tips to keep in mind if rcp fails as transport protocol are:

  • If you use RME 3.2, the "Add Images to Library" operation only works correctly if you have installed patch 1 for RME 3.2.

  • To enable rcmd debug in the network device, issue the debug ip tcp rcmd command. Sometimes, this debug output can help you locate the cause of the problem.

  • To enable debug for Software Management, go to Resource Manager Essentials > Administration > Software Management > Edit Preferences, and choose the Turn Debugging On option. To generate the debug files, go to Resource Manager Essentials > Software Management > Job Management > Mail or Copy log file.

If you still need assistance after you complete the troubleshoot tips, create a Cisco Technical Support service request. Before you create the service request, obtain the debug information as this Debug and Troubleshoot section indicates.

Related Information

Updated: Oct 26, 2005
Document ID: 8535