Guest

nGenius Real-Time Monitor

nGenius Real-Time Monitor (RTM): Frequently Asked Questions

Cisco - nGenius Real-Time Monitor (RTM): Frequently Asked Questions

Document ID: 21393

Updated: Nov 15, 2005

   Print

Contents

Introduction

This document provides answers to some of the most frequently asked questions about nGenius Real-Time Monitor (RTM).

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Q. How do I integrate the desktops of RTM with CiscoWorks2000?

A. This answer assumes that you have installed RTM as shown:

  • For Solaris: /opt/nGenius

  • For Windows: C:\Program Files\nGenius

In the RTM bin directory, there are four *.lf files. These files are the integration files necessary to add the components of RTM to the CiscoWorks2000 Management Connection.

Note: This process does not integrate the two applications or their respective databases together.

  1. Copy these four files to the temp directory of the system, and make sure the user casuser can read these files.
  2. Log in to CiscoWorks2000 as admin. Choose Management Connection > Administration > Import from the menu.
  3. Select Local File System and click Next.
  4. Enter the full path to one of the *.lf files. (In Windows, you must use DOS filenames [in the 8.3 filename format].) Click Next.
  5. Click Next again.
  6. Repeat these steps until all the management files are imported.

Note: The .lf file nGeniusP is for the Performance Monitor piece. Cisco does not sell this component, and thus you receive a licensing error when you try to launch it. If you wish to purchase this component, please contact NetScout Systems leavingcisco.com.

Q. How do I import devices from CiscoWorks2000 into RTM?

A. If you currently use CiscoWorks2000, you can import the devices into the nGenius RTM server. The Import utility automates the process of conversion of all device configuration files that exist in another network management system, and then adds these files to the RTM database. The Import utility eliminates the need to manually add these devices.

The Import utility extracts and imports this information about a probe or switch:

  • Device type, media, and speed

  • Physical interfaces configured on the device

  • Device IP address

  • Device name, unless it is a probe. For probes, the Import utility adds the letter P to the device IP address to create a device name. For example, P123.45.678.90.

Note: You can rename the device and interface assigned by the Import utility later through the Device Configuration window in the nGenius server.

caution Caution: To avoid undesirable results, use the Import utility only once. The Import utility does not support distributed databases. Before you use it, verify that the latest software patches have been applied to the operating system where the CiscoWorks2000 application is installed. You must apply the latest patches to use the Java Runtime Environment (JRE). Check with your operating system vendor to verify that you have the latest patches.

Before using the Import utility, you must first export the configuration files from CiscoWorks2000. After these files are exported, you can import them into nGenius.

Export Files from CiscoWorks2000

To export the configuration files from CiscoWorks2000, complete these steps:

  1. Log in to CiscoWorks2000.
  2. Choose Resource Manager Essentials > Administration > Inventory > Export to File from the menu. The Export to File dialog box appears.
  3. Complete these steps:
    1. In the Filename field, enter ciscoexport.
    2. Choose Comma Separated Value Format (CVF) as the Output File Format.
    3. Choose Version 2.0 as the Output File Version.
    4. Click Next.
  4. Choose Resource Manager Essentials > Inventory > Hardware Report from the menu. The Hardware Report dialog box appears.
  5. Complete these steps:
    1. In the Views column, choose a view that contains all the devices you want to import into RTM.
    2. In the Devices column, choose the device you want to import into RTM and click Add.
    3. Repeat Steps a and b until all the devices you want to import into RTM are displayed in the Selected Devices column.
    4. Click Finish. The Hardware Report appears in a separate browser window.
  6. In the Hardware Report window, complete these steps:
    1. Verify that CSV Format is selected.
    2. Click Save As. The Save As dialog box appears.
    3. In the Filename field, enter hwreport.dat.
    4. Click Save. The file hwreport.dat is saved on the the client system as hwreport.dat..pl.

      Note: You must rename the file hwreport.dat..pl to hwreport.dat.

  7. Go to the directory where you saved the ciscoexport.dat and the hwreport.dat files.
  8. Copy or move these files to the \bin directory on the nGenius server.

Import Devices from CiscoWorks2000 into nGenius

To import the CiscoWorks2000 device configuration files into nGenius, complete these steps:

  1. Start the nGenius server. The nGenius server must be active before you run the Import utility.
  2. On the CiscoWorks2000 system, open an MS DOS command window or UNIX terminal window.
  3. Perform the appropriate action:
    • Windows NT—Change directory to nGenius\bin and run nGeniusCiscoImport.bat.

    • UNIX—Change directory to nGenius\bin and run GeniusCiscoImport.sh.

  4. Stop and restart the nGenius server when the import and conversion are complete.
  5. Review the status report (cisco_status.html) located in the same directory as the ciscoexport.dat and hwreport.dat files. This report summarizes how many devices and interfaces were imported to the nGenius database, and also identifies the names of the devices and interfaces that failed to import.

    Note: The location of the ciscoexport.dat and hwreport.dat files is export_file_location.

  6. Check for any error messages. This table lists the errors you may encounter:
    Error Description
    Virtual An interface was encountered in the agent.lst file that did not have a physical interface.
    Exists A switch with the same IP address already exists. Only the first one is converted.
    No_Parent A data-link connection identifier (DLCI), Fast EtherChannel (FEC), VLAN, or switch port interface was in a file with no corresponding parent interface or device.
    No_IFN No interface number was provided in the configuration file for a VLAN interface.

  7. In the nGenius server window, choose File > Run Conversion Relearn from the menu.

    Note: The relearn process can take from ten seconds to one minute for each device imported into nGenius successfully.

When the relearn process completes, you see these results:

  • The names of each imported device display in the Device Configuration window of the nGenius server. If the names are missing, click Refresh.

  • The names of each imported monitored element display in the Traffic Monitor Navigation tree. To update the Navigation tree with the names of these monitored elements, click Refresh.

  • A status report about the import operation is stored in HTML format in the same directory as the ciscoexport.dat and hwreport.dat files. This report identifies the names of the devices and interfaces that failed to import.

Q. Why do some devices fail to import into RTM from CiscoWorks2000?

A. This issue is related to Cisco bug ID CSCdt88076 ( registered customers only) . This issue has been known to occur with Catalyst 2820 switches, but could occur with any device.

As a workaround, determine which device causes the problem and remove it from the hwreport.dat file before you import into RTM.

Q. How do I reinitialize my RTM database?

A. Follow the platform-specific steps to reinitialize your RTM database. The instructions assume that you have installed RTM as shown here:

  • For Solaris: /opt/nGenius

  • For Windows: C:\Program Files\nGenius

Windows

Note: You must be logged in as a local administrator, not a domain administrator.

  1. Go to Start- > Programs -> NetScout nGenius Server -> Stop nGenius Server and shut down any active RTM processes.
  2. Delete the C:\Program Files\nGenius\database\stealth.db file.
  3. Delete the C:\Program Files\nGenius\database\stealth.log file (if it exists).
  4. Go to Start > Programs > Netscout nGenius Server > Start nGenius Server and restart the nGenius server. Do not reboot before you restart the nGenius server.

Solaris

Note: You must complete these steps as root.

  1. Issue the /opt/nGenius/bin/S81Stealth stop command to shut down any active RTM processes.
  2. Delete the /opt/nGenius/database/stealth.db file.
  3. Delete the /opt/nGenius/database/stealth.log file (if it exists).
  4. Issue the /opt/nGenius/bin/S81Stealth start command to restart the nGenius processes.

Q. Why did my RTM database crash?

A. An apparent crash of the Sybase database, and subsequently of the RTM server, on a UNIX system may occur if you do not have support for large files configured for your filesystem mounts.

On Solaris systems, filesystems created by Solaris are by default mounted with support for large files (files larger than 2 GB). However, if large file support is disabled for any reason, or Veritas Volume Manager is used to manage filesystems, this support may not be enabled.

What happens:

RTM continues to log data until the database file (stealth.db) reaches the maximum size (2 GB). The Sybase database engine then stops abruptly because it runs out of available disk space and cannot continue to log data.

The resolution:

The system administrator must use Veritas Volume Manager to reconfigure the filesystem to support large files. You can then restart RTM and continue to log data as normal.

Q. How do I back up the RTM database?

A. Back up the RTM database with one of these methods:

  • Method One:

    1. Stop the database server.

    2. Copy the nGenius/database/stealth.db file to a backup location.

  • Method Two:

    1. Obtain a Sybase backup utility that uses the Sybase utility dbbackup, which is provided by the nGenius installation.

    2. Make a backup of the database while it runs. For example:

      dbbackup -c "uid=netscout;pwd=mydbpassword;dbf=stealth.db" 
      backup_dir_name
      

      Note: This command should be on one line.

Note: It is essential that you use precise and proper path names in Sybase command-line utility syntax. If a command does not work, verify your syntax.

These are sample dbbackup commands for Windows and Solaris:

Windows:

From the D:\nGenius\database directory, issue the ..\sybase\win32\dbbackup -c "uid=netscout;pwd=dbpass;dbf=stealth.db" ..\backup command. This example command assumes that:

  • RTM is installed in D:\nGenius.

  • The database password is dbpass .

  • The database is copied to the D:\nGenius\backup directory.

Solaris:

From the /opt/nGenius/database directory, issue the ../sybase/bin/dbbackup -c "uid=netscout;pwd=dbpass;dbf=stealth.db" ../backup command. This example command assumes that:

  • RTM is installed in /opt/nGenius.

  • The database password is dbpass .

  • The database is copied to the /opt/nGenius/backup directory.

  • These environment variables have been set and exported:

    LD_LIBRARY_PATH=/opt/nGenius/sybase/lib 
    ASTMP=/opt/nGenius/.SQLAnywhere

Q. How do I recover if I reboot my Windows machine, without first starting RTM, after installation?

A. If this happens, Windows will not start the RTM services, and you will get an error every time Windows boots up. To correct this, you must reinitialize your RTM database. See the question How do I reinitialize my RTM database?

Q. How do I recover after I answer No to the Add Registry Key or CACLS dialogs when installing RTM on Windows?

A. You must respond with Yes to these dialogs. If you responded with No to either, you must uninstall and reinstall RTM. Remember to do both operations as a local administrator (you cannot log in as a domain administrator). When you reinstall, remember to answer Yes when the Registry Key dialog appears and when the CACLS DOS shell window appears.

Q. How do I upgrade RTM 1.2 or 1.3 to RTM 1.4?

A. Complete these steps:

  1. Follow the installation instructions provided in the NetScout nGenius Real-Time Monitor 1.4 Installation Guide.
  2. Run the database upgrade script:
    1. To upgrade from RTM 1.2 to 1.4:
      • On Windows systems, run dbupgrade12_14.bat.

      • On Solaris systems, run dbupgrade12_14.sh.

    2. To upgrade from RTM 1.3 to 1.4:
      • On Windows systems, run dbupgrade13_14.bat.

      • On Solaris systems, run dbupgrade13_14.sh.

Q. What do I need to collect from my Solaris or Windows machine when I troubleshoot RTM?

A. If you have CiscoWorks2000 installed on the same machine, log in to CiscoWorks2000 as admin and choose Server Configuration > Diagnostics > Collect Server Info from the menu.

If you do not have CiscoWorks2000 installed on the RTM server, complete the appropriate procedure:

Windows NT

  1. Choose Start > Programs > Administrative Tools (Common) > Windows NT Diagnostics from the menu to get a detailed Windows NT diagnostic report.
  2. Select File > Save to save the report.
  3. Set the Detail Level to Complete.
  4. Complete the procedure for All Systems, below, in order to collect further information.

Windows 2000

  1. Choose Start > Programs > Accessories > System Tools > System Information from the menu.
  2. Choose Action > Save As System Information File from the menu.
  3. E-mail this .nfo file, along with the other debugging files you collect, to Cisco Technical Support.

Solaris

Note: This answer assumes you have RTM installed in /opt/nGenius.

  1. As root, issue these commands and collect the output:
    /usr/ucb/ps -auwwex
    
    vmstat
    
    swap -l
    
    df -k
    
    netstat -an
    
    showrev -a
    
    dmesg
    
    netstat -in
    
    cat /etc/hosts
    
    cat /etc/nsswitch.conf
    
    cat /etc/resolv.conf
    
    ls -alR /opt/nGenius
    
  2. Save the command output to a file.
  3. E-mail this file and the others you collect to Cisco Technical Support.

All Systems

  1. Collect the system-dependent information as described in the appropriate section.
  2. Collect data from RTM as shown. (This assumes that $RTM is /opt/nGenius on Solaris systems and C:\Program Files\nGenius on Windows systems.)
    $RTM/bin/debuglog-*.txt
    
    $RTM/bin/nohup.out 
    !--- This file is found on Solaris systems only.
    
    
    $RTM/bin/trapserver.out
    
    $RTM/bin/dengine*.out
    
    $RTM/bin/*.properties
    
    $RTM/bin/admin/serverpublic.properties
  3. Gather the Java Plug-in console output.
  4. Send all of the collected information to Cisco Technical Support.

Q. How do I clear the Java Plug-in cache?

A. If you clear the Java Plug-in cache on a regular basis, any corrupted applets cached from the Java Plug-in engine are cleared. Use one of these methods:

  • Method One:

    1. Make sure you run Java Plug-in version 1.3.1. You can download it from Software Downloads - Java Plug-ins ( registered customers only)

    2. Choose Control panel > Java plug-in 1.3.1 > Cache > Clear JAR Cache from the menu.

  • Method Two:

    1. Remove folders .java and java_plugin_AppletStore from your home directory:

      • Windows NT: c:\winnt\profile\your_user_id\

      • Windows 2000: C:\Documents and Settings\your_user_id\

      • UNIX: $HOME

      Note: These are default locations; change them accordingly.

    2. Clear your web browser cache.

Q. How can I improve my browser performance on an RTM client?

A. One way to improve the browser performance on an RTM client is to increase the initial Java Virtual Machine (JVM) memory allocation.

Note: The maximum memory value is based on the maximum memory in your system; therefore, if your system has 256 MB of RAM, the maximum value cannot exceed 256.

Windows

  1. On the client system, choose Start > Settings > Control Panel > Java Plug-in from the menu.
  2. In the Java Run Time Parameters field, enter the initial and maximum memory values. To change the minimum and maximum memory values, use this format:
    -XmsN -XmxN
    
    
    Replace the letter N with the memory value. For example:
    -Xms64M -Xmx128M
  3. Click Apply.

Solaris

  1. On the client system, open the Java Plug-in Control Panel.
  2. In the Java Run Time Parameters field, enter the initial or maximum memory values. To change the minimum or maximum memory values, use this format:
    -msN -mxN
    
    
    Replace the letter N with the memory value. For example:
    -ms64M -mx128M
  3. Click Apply.

Note: For more suggestions on how to improve browser performance, refer to the NetScout nGenius Real-Time Monitor 1.4 Installation Guide.

Q. Why is RTM client performance unpredictable after installation of a patch?

A. When you see errors such as these on the client side (especially after installation of RTM patches), try to clear the Java Archive (JAR) file cache on the client system:

  • java.lang.NoClassDefFound

  • java.lang.NullPointerException

Java 1.3 implements a caching mechanism that allows JAR files necessary for client operation to be downloaded when you first contact the server. These JAR files are then kept in cache to speed up future logins.

Note: Many RTM patches replace JAR files on the server, which means that all client systems must download and use these new files the next time they attempt to log in to the server. However, this caching and version-checking mechanism in the current version of Java is not 100 percent effective, and JAR mismatches between server and client have been known to occur.

To clear the JAR cache, go to How do I clear the Java Plugin cache?

Q. How do I access nGenius RTM through a VPN network?

A. Complete these steps to add a Java Runtime parameter to the Java Plug-in Control Panel of the client:

  1. Choose Start > Settings > Control Panel.

  2. Double-click the Java Plug-in.

  3. In the Java Runtime Parameters text field, enter this text:

    -Djava.rmi.server.hostname=client_addr
    
    

    Replace client_addr with the client IP address assigned by your VPN client connection software.

Q. Can I enable Simple Network Management Protocol (SNMP) version 1 on devices that cannot handle SNMP version 2?

A. Certain devices do not handle SNMP v2 properly, and some old devices do not handle SNMP v2 at all. It is possible to enable SNMP v1 on such devices.

RTM 1.3 and 1.4 have an "SNMP v1 escape" mechanism that allows you to configure a single device for communication with SNMP v1. For devices that do not perform properly with RTM using SNMP v2 (such as Cisco Catalyst 5000 Series switches) SNMP v1 might be required.

Complete these steps to enable SNMP v1 for a device:

  1. In the RTMROOT/rtm/bin directory, edit the snmpversion.dat file.

  2. Add an entry that contains the IP address of the device, followed by the SNMP version. For example, 172.20.100.53 1.

Q. How do I open data capture with the Sniffer file save type as the default option?

A. This requires installation of the RTM 1.4 patch 303 ( registered customers only) .

To set the Sniffer save type option, set the pa.capturefileformat.netscout property to false in the client.properties file. This property makes sure that the Sniffer file save type option is always selected when a user opens the data capture view. Complete these steps:

  1. Stop RTM server.
  2. Change the directory:
    • Windows: RTMROOT\rtm\html

    • Solaris: RTMROOT/rtm/html

  3. Edit the client.properties file.
  4. Add pa.capturefileformat.netscout=false to the client.properties file.
  5. Save the file.
  6. Restart the server.

Q. What should I do if Network Layer and Application Layer Viewers are not available for Catalyst 6000 series Network Analysis Module (NAM)?

A. To launch Network Layer and Application Layer Viewers, complete these steps:

  1. Log in to the NAM.
  2. From the NAM CLI, issue the config clear command.
  3. Reboot the NAM, and wait until the NAM module comes online.
  4. From the switch CLI, issue the span disable command.
  5. Add the switch back to the RTM server.
  6. Create a span session from the RTM server.
  7. Issue the snmpwalk command for protocolDisControlTable (.1.3.6.1.2.1.16.12.1) from RMON2-MIB, and make sure there are control entries created with active status.

Q. How do I recover the password for the Administrator account?

A. By default, RTM creates the Administrator user ID. If you forget the password, complete these steps to reinit the password to abc123.

  1. Open a text editor and copy these seven lines into it:
    -- This sets the Administrator password to "abc123"
    -- Copy this script to a text file and save it as password_reset.sql
    -- To run this script, type: nGeniusSQL.bat password_reset.sql
    Update Users
    set User_Password = '1985611DE8C72582DB101DD4BECBED095A5493'
    where user_name = 'Administrator' ;
    commit ;
  2. Save the file as password_reset.sql to the appropriate location:
    • Windows: \NetScout\nGeniusRTM\1.3.0\bin

    • UNIX: /opt/nGeniusRTM/1.3.0/bin

    Note: These are the default locations. Change them accordingly.

  3. To run the Structured Query Language (SQL) file, issue the appropriate command:
    • Windows: \NetScout\nGeniusRTM\1.3.0\bin\nGeniusSQL.bat password_reset.sql

    • UNIX: /opt/nGeniusRTM/1.3.0/bin/nGeniusSQL.sh password_reset.sql

The password for user Administrator is now abc123.

Q. What are the restrictions on passwords used in RTM installation?

A. During RTM installation, you are required to enter two passwords. One password is for the nGenius server user account login user (for which the default name is "administrator"), and the other password is a stealth database password.

  • nGenius user account password restrictions:

    1. 1 to 15 alphanumeric characters, or no password.

    2. No nonprinting characters, such as spaces or tabs.

  • Database password restrictions:

    1. 1 to 15 alphanumeric characters (the first character must not be a number).

    2. No nonprinting characters, such as spaces or tabs.

    3. No Sybase keywords.

    4. Must meet certain security requirements on Windows system. For example, the administrator may set security settings that require all user passwords to have a minimum number of characters, or to contain special characters, such as *, #, $, or %.

Q. How do I get RTM to start up as the secured user after I have started it once as root?

A. This answer assumes that:

  • You have installed RTM in /opt/nGenius on your Solaris machine.

  • The secured username is ngenius.

  • The secured group name is ngenius.

To make sure RTM starts as the secured user, complete these steps:

  1. Issue the /opt/nGenius/bin/stop command to stop all RTM processes.
  2. As root, issue these commands:
    chown ngenius:ngenius /opt/nGenius/bin/nohup.out
    chown ngenius:ngenius /opt/nGenius/bin/createAll.sql
    chown ngenius:ngenius /opt/nGenius/bin/debuglog-*.txt
    chown ngenius:ngenius /opt/nGenius/bin/ChangePAOwner.sh
    chown -R ngenius:ngenius /opt/nGenius/.SQLAnywhere
    chown ngenius:ngenius /opt/nGenius/database/stealth.*
    chown ngenius:ngenius /opt/nGenius/apache/jserv/logs/mod_jserv.log
    chown ngenius:ngenius /opt/nGenius/apache/logs/error_log
    chown ngenius:ngenius /opt/nGenius/apache/logs/access_log
    
  3. As root, issue the /opt/nGenius/bin/S81Stealth start command to restart the RTM processes. This script runs the processes as the correct user.

This is the proper way to start RTM.

Note: To correctly stop RTM, issue the /opt/nGenius/bin/S81Stealth stop command.

Q. Why was a secured user not created when I installed RTM 1.4 on a Windows system?

A. If an error message indicates that a problem occurred during installation on Windows while the secured user is created, the problem might be a result of Windows security settings for user passwords. A Windows system administrator can use security settings to specify that user passwords must meet certain requirements.

For example, the administrator might set security settings that require all user passwords to contain a minimum number of characters, or contain special characters such as *, #, $, or %.

A secured user is created automatically during RTM installation. This user is granted minimum rights and is automatically assigned the same user password as the database password you entered manually during installation. If Windows security settings are in effect, the database password you enter during RTM installation must meet the Windows user password requirements.

Note: The first character in your database password must not be a number (Sybase requirement).

If the database password does not meet the Windows security requirements for user passwords, an error message indicates that there was a problem with creation of the secured user. If you have already encountered this error, complete these steps from an account with administrator privileges:

  1. From the Windows NT or Windows 2000 user management settings, set the password of the nGenius user to an acceptable value.
  2. From the local security settings, add the nGenius user to these policies:
    • Log on as a service

    • Log on locally

    • Log on as a batch job

  3. Access the nGenius installation directory Security Settings.
  4. If it does not already exist, add the nGenius user to the list of users, then assign full control to the user.
  5. To access the advanced security settings, click Advanced.
  6. Select Reset permissions on all child objects.
  7. To propagate permissions through the entire directory structure, click Apply.
  8. Open a DOS command window and navigate to the nGenius\bin directory.
  9. Issue these commands:
    nGeniusService.exe /uninstall
    InstallnGeniusService.bat
    
  10. Reboot the system.

If you have not yet installed RTM, the best remedy is avoidance. Verify the Windows security settings for user passwords before you install RTM.

Q. Why does RTM stop working when I log out of Windows?

A. This is a bug in the Java Virtual Machine 1.3.0. This will be fixed in an upcoming patch release to RTM. To work around this problem, do not log out of Windows after you start the RTM services. Refer to Cisco bug ID CSCdt90215 ( registered customers only) for more information.

Q. Why does RTM flood the network with Windows Internet Name System (WINS) requests?

A. RTM does not do this; the underlying Windows NT system is what causes this to happen. Windows NT tries to respond to requests for name resolution by RTM using its resolver. The UDP 137 traffic results when the Windows NT operating system receives a Hostname Resolution request. Windows NT uses Domain Name System (DNS) and WINS for host name resolution. Refer to the Microsoft Knowledge Base article Q119493 NetBIOS over TCP/IP Name Resolution and WINS leavingcisco.com for an explanation in further detail. Apparently, Microsoft does not allow the UDP 137 traffic resulting from IP to hostname resolution to be disabled. Instead, they recommend that the traffic be filtered.

In RTM, the name resolution function can be disabled in $NSHOME\bin\serverprivate.properties with the line dns.disable=true.

Q. I've changed the IP address or hostname on my RTM server. What do I need to do within RTM?

A. On a Solaris system, verify that the change has propagated. Solaris runs a name server caching daemon (nscd) that caches (sometimes old) resolver data. When RTM does a gethostbyname(), it could still find the old address or hostname. It is best to send a SIGHUP to this daemon before you do anything else in RTM:

kill -HUP pid of nscd

Once you are sure the name or address change has propagated, go to the directory where RTM is installed (hereafter referred to as $NSHOME). You must edit a number of files if you change the hostname of the machine.

In Solaris:

$NSHOME/bin/cfgNam.sh
$NSHOME/bin/dbinit.sh
$NSHOME/bin/dbupgrade.sh
$NSHOME/bin/nGeniusCiscoImport.sh
$NSHOME/bin/nGeniusSQL.sh
$NSHOME/bin/serverprivate.properties
$NSHOME/bin/start
$NSHOME/bin/stop
$NSHOME/bin/webstart
$NSHOME/bin/webstart1
$NSHOME/bin/webstop
$NSHOME/bin/webstop1

In Windows:

$NSHOME\bin\cfgNam.bat
$NSHOME\bin\dbinit.bat
$NSHOME\bin\dbupgrade.bat
$NSHOME\bin\nGeniusCiscoImport.bat
$NSHOME\bin\nGeniusSQL.bat
$NSHOME\bin\serverprivate.properties
$NSHOME\bin\start.bat
$NSHOME\bin\stop.bat
$NSHOME\bin\webstart.bat
$NSHOME\bin\webstart1.bat
$NSHOME\bin\webstop.bat
$NSHOME\bin\webstop1.bat

If you change the IP address of the server, change these files:

In Solaris:

$NSHOME/bin/nGeniusK.lf
$NSHOME/bin/nGeniusS.lf
$NSHOME/bin/nGeniusT.lf
$NSHOME/bin/serverprivate.properties
$NSHOME/html/client.properties

In Windows:

$NSHOME\bin\nGeniusK.lf
$NSHOME\bin\nGeniusS.lf
$NSHOME\bin\nGeniusT.lf
$NSHOME\bin\serverprivate.properties
$NSHOME\html\client.properties

Note: If you have integrated RTM into CiscoWorks2000, you must reintegrate if the IP address of the RTM server has changed. Refer to Integrating RTM with the CiscoWorks2000 Desktop for instructions.

Once the modifications have been made to RTM, you should restart RTM or reboot the RTM server.

Q. When I change the IP address of my RTM server, do I need to update any RTM files to reflect this change?

A. When you change the IP address of an RTM system, make these modifications:

  • From the RTMROOT/rtm/html directory, find the client.properties file and change the serveraddress.

  • From the RTMROOT/rtm/bin directory, locate the serverprivate.properties file. Change the serveraddress and java.rmi.server.hostname entries.

After making these changes, stop and start the nGenius server.

If you integrate RTM with CiscoWorks Management Connection, you must also modify:

  • IP address for SERVER=http://IP-Address:port

  • HREF=http://IP-Address:port

in these files:

  • nGeniusS.lf—For nGenius Server

  • nGeniusT.lf—For Traffic Monitor

  • nGeniusK.lf—For Packet Analyzer

  • nGeniusV.lf-For Voice Monitor

Those files are located at:

  • On Windows systems: $NMSROOT\htdocs\xml\public\maintree

  • On Solaris systems: $NMSROOT/htdocs/XML/Public/maintree

Q. Which processes start when I start the RTM 1.3 Server?

A. These processes start when you start the RTM 1.3 server:

Solaris

  • java -Xmx448m

  • java org.apache.jse

  • java -classpath

  • dbsrv7 -ud -q

  • dengine 1966

  • dengine 1967

  • /apache/bin/httpd -R

Windows

  • Apache.exe

  • java.exe

  • dbsrv7.exe

  • nGeniusJava.exe

  • nGeniusService.exe

Q. Which processes start when I start the RTM 1.4 Server?

A. These processes start when you start the RTM 1.4 server:

Solaris

  • dbsrv7

  • dengine

  • Several httpd processes (minimum of two)

  • NSnGeniusNative

  • NSRmiregistry

  • NSServer

  • NSTomcat

  • NSWatchdog

Windows

  • Apache.exe

  • java.exe

  • dbsrv7.exe

  • nGeniusNativeService

  • nGeniusService

  • NSnGeniusNative.exe

  • NSRmiregistry.exe

  • NSServer.exe

  • NSTomcat.exe

  • NSWatchdog.exe

Q. Why does the nGenius server try to access the Internet over ports 137 and 139?

A. On Windows NT and Windows 2000 systems:

When it responds to requests for name resolution by nGenius, the Windows system itself attempts to contact a DNS server for resolution. The UDP 137 traffic results when Windows receives a Host Name Resolution request.

Windows NT and 2000 use Domain Name System (DNS) and NetBIOS Name Service for host name resolution. Microsoft recommends that you filter the traffic. In RTM, the function of Name Resolution can be disabled in the RTMROOT/rtm/bin/serverprivate.properties file with this line:

dns.disable=true

Q. How do I resolve port conflicts between the RTM server and other applications that attempt to bind to the same port?

A. If nGenius RTM is installed on a system where no other applications use RMI port 1099, then port 1099 is used by RTM. If another application tries to bind to port 1099 while nGenius uses this port, the application fails to bind to port 1099 and the nGenius server continues working properly. However, if the nGenius server is not active when another application binds to port 1099, then the application continues to work successfully, but the nGenius Server is unable to start.

To change the RMI port that RTM uses:

  • Manually edit RTMROOT/rtm/bin/serverprivate.properties and RTMROOT/rtm/html/client.properties files.

  • Set the RMIRegistryPort=11099 (or the next available TCP port.) The default is 1099.

Q. How do I deal with third-party port conflicts?

A. By default, RTM 1.4 uses port number 8080 for the client HTTP connection. If you install RTM on a system where a third-party product has already been installed, verify that this product does not use the same port number as RTM. If another product uses the same port number as RTM 1.4, conflicts arise, and the third-party products do not operate properly.

Complete these steps to change the RTM port number during the installation process or after installation:

Windows:

  1. Go to the RTMROOT\rtm\bin directory.

  2. Open the webstart.bat file.

  3. Modify the NSAPACHEPORT variable to an unused port number.

  4. Save and close the file.

UNIX:

  1. Go to the RTMROOT/rtm/bin directory.

  2. Open the start1 file.

  3. Modify the NSAPACHEPORT variable to an unused port number.

  4. Save and close the file.

After you change the port number, specify this new number in the URL when you first launch RTM 1.4.

Q. How do I improve performance for RTM 1.4?

A. Refer to the NetScout nGenius Real-Time Monitor Release 1.4 Installation Guide for system hardware requirements.

Note: You must install nGenius RTM 1.4 on a dedicated system. Failure to install nGenius RTM on a dedicated system severely impacts performance.

To improve the performance, tune these parameters:

  1. Raise the setting of the Xmx value in the RTMROOT/rtm/bin/start1 script to 1200. It is set to 448 by default. The default setting is:
    nohup $NSJRE/bin/NSServer -server -Xmx448m -Ddebug.logtofile=true
    -Djava.security.policy=.java.policy com.netscout.frameworks.servicex.
     NSServer /DAEMON
    Change the setting to:
    nohup $NSJRE/bin/NSServer -server -Xmx1200m -Ddebug.logtofile=true 
    -Djava.security.policy=.java.policy com.netscout.frameworks.servicex.
     NSServer /DAEMON &
  2. Turn up the dbsrv7 mem usage from 64 M to 384 M in RTMROOT/rtm/bin/start1 script. The default setting is:
    dbsrv7 -ud -q -c 64M -ch 64M -m -gc 15 -x "tcpip(ServerPort=2639)" -n 
     $NSAPACHEHOST $NSDATABASE &
    Change the setting to:
    dbsrv7 -ud -q -c 384M -ch 384M -m -gc 15 -x "tcpip(ServerPort=2639)" -n $

Q. How do I uninstall RTM?

A. To uninstall RTM, complete these steps:

  1. Reinsert your RTM installation CD.
  2. Shut down the RTM processes.
  3. Complete the appropriate steps for your platform:
      Windows:
    1. Log in as local administrator and open a command prompt (DOS shell). Change to the directory in which RTM is installed (for example, C:\Program Files\nGenius).

      Note: If you do not have the RTM Packet Analyzer installed, skip to Step c.

    2. If you have the RTM Packet Analyzer installed, issue this command:
      
      Z:\windowsjre\bin\jre.exe -cp .;Z:\windowsjre\lib\rt.jar uninstallpa
      
      Replace Z with the letter of your CD-ROM.
    3. To uninstall the core RTM components, issue this command:
      
      Z:\windowsjre\bin\jre.exe -cp .;Z:\windowsjre\lib\rt.jar uninstall
      
      Replace Z with the letter of your CD-ROM.
    4. After all of the RTM components have been uninstalled, manually remove the nGenius directory.
      Solaris:
    1. Log in as root and change the directory to the location in which nGenius is installed (for example, /opt/nGenius).

      Note: If you do not have the RTM Packet Analyzer installed, skip to Step c.

    2. If you have the RTM Packet Alayzer installed, issue this command:
      /cdrom/cdrom0/solarisjre/bin/jre -cp .:/cdrom/cdrom0/solarisjre/lib/
       rt.jar uninstallpa
      

      Note: This command should be on one line.

      Replace cdrom with the location of your CD-ROM.
    3. To uninstall the core nGenius components, issue this command:
      /cdrom/cdrom0/solarisjre/bin/jre -cp .:/cdrom/cdrom0/solarisjre/lib/
       rt.jar uninstall
      

      Note: This command should be on one line.

      Replace cdrom with the location of your CD-ROM.
    4. After all of the RTM components have been uninstalled, manually remove the nGenius directory.

Q. Why do I get an error when I try to uninstall RTM in Windows?

A. Sometimes, even after you stop nGenius services, uninstall fails in Windows platforms. The error message states that some files are in use by another process and could not be removed. This occurs when some nGenius-related processes fail to stop completely. Refer to Cisco bug ID CSCdt36673 ( registered customers only) for more information.

Complete these steps for a workaround:

  1. Log in as local administrator and disable the nGeniusService.
    • NT: Control Panel > Services

    • Windows 2000: Control Panel > Administrative tools > Services

  2. Select nGeniusService and change the startup type from automatic to disable.
  3. Reboot the server.
  4. The nGenius related services do not start automatically. Run the uninstall again, packet analyzer first, and then the server itself.
  5. Go to the registry editor and delete this entry: HKEY_LOCAL_MACHINE -> SOFTWARE -> NetScout.
  6. Delete the directory in which RTM was originally installed, and reboot the server.

Related Information

Updated: Nov 15, 2005
Document ID: 21393