Guest

Cisco Building Broadband Service Manager

Configuring Cisco 2900XL/3500XL Switches with VLANs to Use Cisco BBSM 5.0

Cisco - Configuring Cisco 2900XL/3500XL Switches with VLANs to Use Cisco BBSM 5.0

Document ID: 12546

Updated: Oct 26, 2005

   Print

Introduction

This document describes how to configure VLANs on a Cisco Catalyst 2900XL/3500XL switch to use with Cisco Building Broadband Service Manager (BBSM). Catalyst 2900XL and Catalyst 3500XL switches with VLANs provide end users the best in-room security in a BBSM network. But, you need to perform additional configuration so that the switch works correctly with BBSM.

When a switch does not have configuration with VLANs, BBSM queries the switch MAC address table to determine the port to which an end user connects. When a Catalyst 2900XL/3500XL switch has a configuration with VLANs, BBSM cannot access the MAC address table for VLANs beyond VLAN 1. To allow BBSM to determine the port to which an end user connects, you must create a user account on the switch.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • BBSM version 5.0

  • Catalyst 2900XL/3500XL switch that supports VLANs and runs Cisco IOS® System Software

This solution does not apply to Catalyst switches that run Catalyst OS (CatOS). This solution does not apply to Catalyst 2950 and 3550 switches that run Cisco IOS Software; the Cisco IOS Port Protected feature replaces the software on the newer switch platforms.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

bbsm_vlan.gif

Configurations

This document uses this configuration:

The configuration shows a Catalyst 2924XL with the enable of VLANs.

Note: These are three important points about this configuration:

  • Spanning tree is off.

    All switches have direct wire to guest rooms, so there is no chance of a spanning tree loop occurrence. Multiple backbone links in your network configuration can require you to enable spanning tree on those interfaces. If you disable the spanning tree, you can also decrease the connection time between the switch and the end user computer.

  • For security reasons, the configuration does not include any passwords or IP addresses.

  • This configuration configures all switches in the network. The only difference is the IP address of each switch.

Catalyst 2924XL
version 12.0

no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname <hostname>

!--- Use the host name for the switch.

enable secret <password>

!--- Enter the password for the switch.

!
username getmac privilege 15 password 0 admin

!--- "getmac" is the name that you must use for
!--- the user. "getmac" is the name that BBSM attempts
!--- to access. Another name does not work.

!
!
!
!
no spanning-tree vlan 1
no spanning-tree vlan 2
no spanning-tree vlan 3
no spanning-tree vlan 4
no spanning-tree vlan 5
no spanning-tree vlan 6
no spanning-tree vlan 7
no spanning-tree vlan 8
no spanning-tree vlan 9
no spanning-tree vlan 10
no spanning-tree vlan 11
no spanning-tree vlan 12
no spanning-tree vlan 13
no spanning-tree vlan 14
no spanning-tree vlan 15
no spanning-tree vlan 16
no spanning-tree vlan 17
no spanning-tree vlan 18
no spanning-tree vlan 19
no spanning-tree vlan 20
no spanning-tree vlan 21
no spanning-tree vlan 22
no spanning-tree vlan 23
ip subnet-zero
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host getmac <IP_of_BBSM_Internal_NIC> Administrator enable

!--- <IP_of_BBSM_Internal_NIC> is the IP address of the BBSM internal 
!--- network interface card (NIC).

ip rcmd remote-host getmac <IP_of_BBSM_Internal_NIC> IWAM_<BBSM_Server_Name> enable

!--- <BBSM_Server_Name> is the computer name of the server. 
!--- If the computer name of the BBSM server is BBSM1, this last statement reads:
!--- ip rcmd remote-host getmac <IP_of_BBSM_Internal_NIC> IWAM_BBSM1 enable.

!
!
!
interface FastEthernet0/1
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 4
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 5
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 6
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 7
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 8
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 9
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 11
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 12
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 13
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 14
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 15
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 16
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 17
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 18
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 19
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 20
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 21
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 22
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 23
spanning-tree portfast
!
interface FastEthernet0/24
port network
switchport multi vlan 1-23
switchport mode multi
spanning-tree portfast
!
interface VLAN1
ip address <IP_of_Switch> <Subnet_Mask_of_Network>

!--- Use the IP address and subnet mask of the switch.

no ip directed-broadcast
no ip route-cache
!
ip default-gateway <IP_of_BBSM_Internal_NIC>

!--- Use the IP address of the BBSM internal NIC.

snmp-server engineID local 00000009020000B064B14540
snmp-server community <RW_password> RW
snmp-server community <RO_password> RO
snmp-server chassis-id 0x0E
!
line con 0
transport input none
stopbits 1
line vty 0 4
password <password>
login
line vty 5 9
login
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Oct 26, 2005
Document ID: 12546