Guest

Data-over-Cable Service Interface Specifications (DOCSIS)

Using the max-cpe Command in the DOCSIS and CMTS

Cisco - Using the max-cpe Command in the DOCSIS and CMTS

Document ID: 22177

Updated: Oct 04, 2005

   Print

Introduction

This document explains the relationship between the new cable modem max-cpe n command and the MAX-CPE parameter specified in the Data-over-Cable Service Interface Specifications (DOCSIS) configuration file. The DOCSIS configuration file is loaded into the cable modem, and can be coded on the uBR7200 series routers running Cisco IOS® Software Release 12.1(2)EC1 or higher.

Before You Begin

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Prerequisites

Cisco recommends that you have knowledge of these topics:

  • The information in this document is based on Cisco hardware uBR7246 (NPE150) processor (revision B) and Cisco IOS Software (UBR7200-IST-M), Version 12.1(2)EC1.

  • This document refers to cable modems in bridging mode only.

Components Used

This document is not restricted to specific software and hardware versions.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Background Information

There is a demand from cable customers for the Cable Modem Termination System (CMTS) to permit more CPEs to connect to the cable modem, despite the fact that the value in the cable modems configuration file limits the number of hosts. The change to permit more CPEs to connect to the cable modem was introduced with CSCdp52029 (registered customers only) in Cisco IOS Software Release12.0(9.5)SC and Cisco IOS Software Release 12.1(1.0.3)EC1 IOS trains.

This demand was created due to the cable modem being unable to keep the count of CPEs allocated in synch with the CMTS count. When the cable modem initializes, the only time it can synchronize MAX-CPE with the CMTS is when it sends the MAX-CPE count to the CMTS in the registration request flow.

If the cable modem is reloaded, there is no flow to the CMTS to inform it to reduce the CPE's allocated count to zero. The cable modem, however, will start again from zero. If a new CPE behind the cable modem requests to come online, the cable modem will permit it to as its MAX-CPE count is now zero. The CMTS with a non zero MAX-CPE count , however, will fail the request, and the following message appears on the CMTS:

 
%UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
 and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

This is intensified by the fact that, if unspecified, the default MAX-CPE entry in the DOCSIS configuration file is set to one.

An example of this is when the cable modem informs the CMTS that it has a MAX-CPE count of one in its registration request. A cable customer wants the functionality of power cycling the cable modem to allow their installer's laptop to be removed, and the end user's PC put back on the cable modem. This will fail because. After the reload the cable modem will have the MAX-CPE count set to zero, however, the CMTS will still remember the installer's laptop entry, and which equals the MAX-CPE count of one.

There is a workaround available by issuing the clear cable host x.x.x.x command, where x.x.x.x equals either the IP or MAC address of the host to be cleared on the CMTS. This workaround, however, is unpopular to cable customers.

Implementation

A new configuration command has been added to the CMTS. To specify a maximum number of permitted hosts per modem (overriding the MAX-CPE value in the cable modem configuration file), issue the cable modem max-cpe n command in cable interface configuration mode. n equals 1 to 255.

The CMTS enables up to n number of hosts for a cable modem. When set to unlimited, or n is larger than the MAX-CPE value in the configuration file of a cable modem, this command overrides the configuration file value. The DHCP server controls the number of IP addresses assigned to hosts behind a single cable modem.

If the cable modem's configuration file specifies a number of hosts larger than n , the configuration file-setting will take precedence. It is up to the cable modem to control the number of active hosts.

By issuing the cable modem max-cpe unlimited command, the CMTS will not enforce a limit on the number of CPEs connected to a single cable modem. With this setting, it is up to the cable modem to control the maximum number of CPEs, and up to the DHCP server to control the number of IP addresses assigned to CPEs behind a single cable modem.

caution Caution: Use of the cable modem max-cpe unlimited command, if used without caution, may open a security hole in the system by enabling denial of service attacks. Specifically, it may enable a user to obtain a large number of IP addresses, thereby taking down the entire network after all available IP addresses have been reserved by this single user. It is therefore recommended that, if the cable modem max-cpe unlimited command is enabled, the number of IP addresses assigned to CPEs behind a single cable modem be strictly controlled by the DHCP server.

By issuing the no cable modem max-cpe command, the default setting is enabled. The MAX-CPE value provided in the configuration file will be used by the CMTS to limit the number of CPEs connected to a single cable modem.

The show cable modem detail command displays the MAX-CPE value as configured in the DOCSIS configuration file for the cable modem, and if possible, the value configured when the cable modem max-cpe n is issued.

Refer to the sample log output below. CMTS is configured for MAX-CPE equal to four, and MAX-CPE equal to unlimited.

test-cmts#show cable modem detail 
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe 4
test-cmts(config)#end
test-cmts#
00:05:11: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe unli
test-cmts(config)#cable modem max-cpe unlimited 
test-cmts(config)#^Z 
test-cmts#
00:06:06: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95

test-cmts#wr t
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test-cmts
!
boot system flash ubr7200-ist-mz.121-2.EC1
no logging buffered
!
cable modem max-cpe 4
ip subnet-zero 
!
interface FastEthernet0/0
ip address 10.200.68.4 255.255.255.0
half-duplex
!
interface Cable4/0
ip address 10.200.69.49 255.255.255.240 secondary
ip address 10.200.69.33 255.255.255.240
ip accounting precedence input
ip accounting precedence output
no keepalive
cable max-hosts 10
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 rate-limit
cable upstream 5 shutdown
cable dhcp-giaddr policycable
helper-addrress 10.200.68.11
! 
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
ip route 10.200.32.0 255.255.224.0 10.200.68.2
no ip http server
!
line con 0
exec-timeout 0 0
password ww
login
transport input none
line aux 0
line vty 0 4
password ww
login
!
end

test-cmts#

Note: Although the CMTS, permits the specified number of hosts through cable modems, the cable modems themselves will still be restricted to allow only the number of CPEs permitted in the DOCSIS configuration file.

Related Information

Updated: Oct 04, 2005
Document ID: 22177