Guest

Cable Modems

How to Configure a Cisco Router Behind a Non-Cisco Cable Modem

Cisco - How to Configure a Cisco Router Behind a Non-Cisco Cable Modem

Document ID: 19268

Updated: May 23, 2006

   Print

Introduction

In certain environments where a non-Cisco cable modem (CM) is used, and the CM is only capable of bridging, a Cisco router, such as the Cisco 806, can be connected to the CM via the Ethernet interface. The routing is then performed by the router behind the CM. The next step is connecting the client PC or Customer Premises Equipment (CPE) to the router. After making this connection, the Network Address Translation (NAT) is configured on the router.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • 806 series router running Cisco IOS® release 12.2(2)XI

  • CM router acting as a bridge

  • PC running Windows 2000 acting as the CPE

  • uBR7246VXR Cable Modem Termination System (CMTS)

Note: Only the Cisco 806 router configurations are shown in this document. For more information on configuring the CMTS, refer to Cable Technology Configuration Examples and Tech Notes.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

router_behind_cm_19268.gif

Configurations

This document uses the 806 router configuration:

806 Router Configuration
Building configuration...
Current configuration : 1673 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.
!
username Router password 7 08325C5C00170247425D5506382E2523
username Cisco privilege 15 password 7
134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416
ip subnet-zero
ip name-server 24.29.99.81
ip name-server 24.29.99.82
ip dhcp excluded-address 10.10.10.1 


!--- Issue the ip dhcp excluded-address command to exclude IP 
!--- addresses from being assigned by the DHCP server. This excludes 
!--- E0 IP address.

ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 10.10.10.10
ip dhcp excluded-address 10.10.10.3
ip dhcp excluded-address 10.10.10.4
ip dhcp excluded-address 10.10.10.5
ip dhcp excluded-address 10.10.10.6
ip dhcp excluded-address 10.10.10.7
ip dhcp excluded-address 10.10.10.8
ip dhcp excluded-address 10.10.10.9
!
ip dhcp pool CLIENT 

!--- Configures a DHCP address pool.

import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 24.29.99.82
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0 

!--- This interface connects to the internal network, including CPE.

ip address 10.10.10.1 255.255.255.0
ip nat inside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
interface Ethernet1 

!--- This interface connects to the same Ethernet segment as the CM.
 
ip address dhcp 

!--- This command allows the router to obtain IP address dynamically.

ip nat outside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload 

!--- IP NAT configuration.

ip classless
ip route 0.0.0.0 0.0.0.0 66.108.112.1

!--- IP address 66.108.112.1 is the next hop IP address, also called 
!--- the default gateway. Your Internet service provider (ISP) can tell you what IP address to 
!--- configure as the next hop address.

ip http server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Router#

                     

                      
                     

                     

Verify

To verify that the router obtained an IP address on its Ethernet E1 dynamically, use the show ip interface brief command.

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up    up

Ensure that your routing table has the correct entries. For example, in this display, the default route is to 66.108.112.1. This is installed through the DHCP process when the router receives the IP address on the Ethernet interface.

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

Troubleshoot

When the router is connected behind the CM, the first problem that might occur is not obtaining an IP address dynamically on the Ethernet interface of the router. Most ISPs allow only one host or PC behind the CM. Some ISPs assign an IP address to the PC based on the host name. Therefore, if you have a router behind the CM, then the host name for the router configured using the hostname command should be the same host name given by the ISP.

If the router is not obtaining an IP address dynamically, the first thing to check is if the interface configuration command ip address dhcp exists. This command is under the Ethernet interface connected to the CM. The command was introduced in IOS software release 12.1(2)T.

If the ip address dhcp command exists, but the router behind the CM is still not obtaining an IP address, connect a PC behind the CM to detect if it is receiving an IP address. This verifies that DHCP services are working properly. ISPs typically allow only one host behind the CM, therefore connecting a PC behind the CM counts as the first host. This entry remains in the ISP database for 24 hours. Consequently, if you connect the router behind the CM, the ISP thinks that the router is a second host and rejects it. If this occurs, release the IP address of your PC by completing these steps on your Windows 2000 PC:

  1. From the start Menu choose Run.

  2. Type cmd then press carriage return.

  3. At the prompt, type ipconfig/release.

  4. After releasing the IP address of the PC, reboot your CM and try again.

If this does not work, you need to call your ISP and ask them to clear the first host entry on their CMTS.

Another method is to configure the Ethernet interface of the router. This connects to the CM with the MAC address of the PC using the command mac-address ieee-address.

By using the same MAC address on the Ethernet interface that connects to the CM as the PC, the ISP only learns about one host and one IP address. The PC does not get rejected once connected behind the router. NAT has to be configured on the router to accept IP address translations.

Troubleshooting Commands

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Note: Refer to Important Information on Debug Commands before you use debug commands.

  • debug dhcp detail — Use the debug dhcp detail command to display DHCP debugging information. This is used to troubleshoot why the Cisco router failed to obtain an IP address for the Ethernet interface.

  • debug ip dhcp server [events] [linkage] [packet] — Use the debug ip dhcp server command to display DHCP Server debugging. This helps to determine why the PC, which is connected to the router, failed to obtain an IP address.

Related Information

Updated: May 23, 2006
Document ID: 19268