Guest

Cable Modems

Cable Modem Configuration FAQ

Cisco - Cable Modem Configuration FAQ

Document ID: 12178

Updated: Oct 04, 2005

   Print

Introduction

This document addresses frequently asked questions (FAQ) associated with Cisco cable modem configurations.

Q. What does the default bridging configuration look like in a Cisco cable modem?

A. When the uBR9xx is pulled out of the box and powered up, it performs as a bridge. Remember that the default gateway for hosts behind the bridge must be the cable secondary IP address of the Cable Modem Termination System (CMTS). In this example, a uBR924 running Cisco IOS® Software Release 12.1(1)T is used.

This is what the default configuration looks like as a bridge once the uBR924 comes online:

Router#show run
Building configuration...

Current configuration:
!
! No configuration change since last restart
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
clock timezone - -8
ip subnet-zero
no ip routing
!
!
voice-port 0
 input gain -2
!
voice-port 1
 input gain -2
!
!
interface Ethernet0
 ip address 10.2.3.6 255.255.255.0
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address negotiated
 no ip route-cache
 cable-modem downstream saved channel 525000000 7 1
 cable-modem Mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!         
ip default-gateway 10.2.3.1
ip classless
no ip http server
!
snmp-server engineID local 00000009020000021685B644
snmp-server packetsize 2048
snmp-server manager
!
line con 0
 transport input none
line vty 0 4
!
end

Router#

For more detailed information about routing and bridging configurations, refer to Bridging Cable Modem Sample Configuration and Verification.

Q. How do I configure a Cisco cable modem for routing?

cable_faq_cm_config.gif

A. The uBR9xx has a four port Ethernet hub on the back of the unit (the 4 in uBR904). The cable modems are bridge devices out of the box. Complete these steps to configure the uBR9xx as a router:

  1. Remove the default commands bridge-group 59 and bridge-group 59 spanning-disabled from the Ethernet 0 (e0) and cable-modem 0 interfaces of the cable modem.
  2. Issue the command no cable-modem compliant-bridge on the uBR9xx under the cable 0 interface.
    Router#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#interface e0
    Router(config-if)#no bridge-group 59
    
    Router(config-if)#no bridge-group 59 spanning-disabled 
    Router(config-if)#interface cable 0
    Router(config-if)#no bridge-group 59 spanning-disabled 
    Router(config-if)#no bridge-group 59                   
    Router(config-if)#no cable-modem compliant bridge
    Router(config-if)#exit
    Router(config)#ip routing
    Router(config)#^Z
    Router#

    Note: The default gateway for PCs behind the uBR9xx or Cable Voice Adapter 120 (CVA120) bridge must be set to the cable secondary IP address on the CMTS. When the cable modem is configured as a router, the default gateway of the host corresponds to the e0 interface of the cable modem. This is what the configuration of a uBR904 as a router looks like:

     no service pad
     service timestamps debug uptime
     service timestamps log uptime
     no service password-encryption
     !
     hostname Router
     !
     clock timezone - 0
     ip subnet-zero
     !
     interface Ethernet0
      ip address 100.1.1.1 255.255.255.0
      no ip directed-broadcast
      ip rip send version 2
      ip rip receive version 2
     !
     interface cable-modem0
      ip address negotiated
      no ip directed-broadcast
      ip rip send version 2
      ip rip receive version 2
      cable-modem downstream saved channel 453000000 28 1
      cable-modem Mac-timer t2 40000
      no cable-modem compliant bridge
     !
     router rip
      version 2
      network 10.0.0.0
      network 100.0.0.0
     !         
     ip classless
     ip route 0.0.0.0 0.0.0.0 10.1.1.10
     no ip http server
     !
     !
     line con 0
      transport input none
     line vty 0 4
     !
     end

You also need to understand the limitations of the uBR9xx in bridging mode. For more detailed information about routing and bridging configurations, refer toBridging Cable Modem Sample Configuration and Verification and Sample Configuration and Verification for Cable in Routing Mode.

Q. How do I configure the cable modem as a router doing Network Address Translation (NAT)?

A. Refer to The Use of cable-modem dhcp-proxy Command on Cisco's Cable Modems.

Q. How do I configure cable gateways to do VoIP statically without a gatekeeper?

A. Refer to Cable Modem Voice Configuration using H323v2 Static Mapping.

Q. How do I configure H.323 RAS VoIP in the Cable environment?

A. Refer to Cable Modem Voice Configuration using H323v2 Dynamic Mapping with Gatekeeper.

Q. How do I configure IPSec on a cable modem?

A. Refer to IPSec Over Cable Sample Configurations and Debugs.

Q. How do I configure GRE on a Cable Modem?

A. Refer to GRE Tunnel Over Cable Sample Configuration and Verification.

Q. What are the meanings of the commands cable-modem boot admin 2 and cable-modem boot oper 5 , which appear under the cable interface in some cable modems?

A. The Cisco IOS commands cable-modem boot admin 2 and cable-modem boot oper 5 were added under the cable interface for cable modems to support a DOCSIS Engineering Change Notice regarding recovering from failed software upgrades. Those commands should not be changed or removed under any circumstances. As of Cisco IOS Software Release 12.1(3)T, these commands have been hidden from the configuration, which explains why some cable modems show these commands, and some do not.

Q. What cable modems are DOCSIS 1.1 compliant?

A. Refer to CableHome™ -DOCSIS® -Packet Cable® Certified Products leavingcisco.com.

Related Information

Updated: Oct 04, 2005
Document ID: 12178