Guest

Cable Modem Termination Systems (CMTS)

High Availability N+1 Sample Configurations

Document ID: 49776

Updated: Oct 04, 2005

   Print

Introduction

This document provides configuration samples and information for several N+1 scenarios.

Note: Keep in mind that like cards must back-up like cards.

Scenario 1

Sample configurations of high availability (HA) with two RF Switches (3x10 configuration) in 4+1 mode, five VXRs, twenty MC28C line cards, and three VCom HD4040 chassis, which contain forty modules.

The physical layout is shown in Figure 1. Refer to Cabling the Cisco RF Switch to the Cisco uBR7246VXR.

Figure 1 – 4+1 with MC28C Cards and 2 RF Switches

ha_mc5x20_a.gif

This physical stacking is assumed, with IP assignments that start with 192.168.1.2 at the top and continue down. Because it will be in the 4+1 mode, RF Switch 1 is considered to be two switches: a and b, where a is slots 1 through 4 and b is slots 5 through 8. RF Switch 2 is also considered two switches: a and b.

Working VXR1 Configuration
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname "WorkingVXR1"
!
boot system disk0:ubr7200-ik8s-mz.BC.28July03
no logging console
enable secret 5 $1$5YHG$mquxbcqzFoUUKhp/c9WT4/
!
cab modem remote-query 10 public
cab modulation-prof 2 request 0 16  0 8  qpsk  scrambler 152 no-diff 64  fixed uw8
cab modulation-prof 2 initial 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 2 station 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 2 short   4 76  6 8  qpsk  scrambler 152 no-diff 72  short uw8
cab modulation-prof 2 long    8 220 0 8  qpsk  scrambler 152 no-diff 80  short uw8
cab modulation-prof 3 request 0 16  0 8  qpsk  scrambler 152 no-diff 64  fixed uw16
cab modulation-prof 3 initial 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 3 station 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 3 short   7 76  7 8  16qam scrambler 152 no-diff 144 short uw16
cab modulation-prof 3 long    9 220 0 8  16qam scrambler 152 no-diff 160 short uw16
no cable qos permission create
no cable qos permission update
cable qos permission modems
no cable clock source-midplane
no cable clock force primary
no cable clock force secondary
!
cable config-file docsis.cm
 frequency 453000000
 service-class 1 max-upstream 10000
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1522
!
ip subnet-zero
ip cef
!
ip host protect 192.168.1.7
ip host work2 192.168.1.6
ip name-server 171.68.226.120
!
ip dhcp pool MODEMS1
   network 192.168.3.0 255.255.255.0
   bootfile docsis.cm
   next-server 192.168.3.5
   default-router 192.168.3.5
   option 7 ip 192.168.3.5
   option 4 ip 192.168.3.5
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp pool PC
   network 10.11.12.0 255.255.255.0
   default-router 10.11.12.1
   dns-server 171.68.226.120
   lease 10 1 11
!
packetcable element_id 35417
!
interface FastEthernet0/0
 ip address 192.168.1.7 255.255.255.0
 no keepalive
 speed auto
 full-duplex

!--- This interface is used for Hot Standby Connection-to-Connection Protocol (HCCP)
!--- traffic.

!
interface FastEthernet0/1
 ip address 192.168.2.7 255.255.255.0
 keepalive 1

!--- This is set to 1 second so that, if the cable is disconnected, then this
!--- interface will failover within 3 seconds.

 speed auto
 full-duplex
!
interface Cable3/0
 ip address 10.11.12.1 255.255.255.0
 secondary ip address 192.168.3.5 255.255.255.0
 load-interval 30
 keepalive 1

!--- The keepalive time is in seconds, and the default is 10 seconds for HCCP code.

 load-interval 30
 cable downstream channel-id 0
 cable bundle 1 master

!--- Interface bundling is supported, as are subinterfaces.
!--- Note: Bundles failover together.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000

!--- This is the downstream (DS) frequency, which used to be informational only when
!--- you are using an external UPx. This must be set when you are using the MC28U cards
!--- with internal UPxs or when you are doing N+1 with MC28C cards, so that the Protect
!--- UPx knows what frequency to use.

 cable upstream 0 frequency 24000000

!--- If you are doing dense mode combining, the upstream (US) frequencies must be
!--- different. If no two US ports are shared, then the same frequency can be used.

 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000
 cable upstream 0 minislot-size 2
 cable upstream 0 data-backoff automatic
 cable upstream 0 modulation-profile 3
 no cable upstream 0 shutdown
 cable dhcp-giaddr policy

!--- This tells the cable modems (CMs) to get an IP address from the primary scope, and
!--- it tells the customer premises equipment (CPE) to use the secondary scope.

 hccp 1 working 1

!--- This is the Working first group, member 1.

 hccp 1 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 44440400 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- left side of Switch slot 1.

 hccp 1 channel-switch 1 uc31 wavecom-hd 192.168.1.2 1 192.168.1.4 1

!--- This is the IP address of the upconverter, and it is module 1 (A) that is backing
!--- module 1 (A) of another upconverter. This shows that one upconverter could have
!--- a module that backs up a module in a different chassis with a different IP address,
!--- if need be. If this statement is not present when you are using Cisco IOS® Software
!--- Release 15(BC2) or later, then IF-Muting is assumed, and an external upconverter
!--- with Simple Network Management Protocol (SNMP) capability is not needed.

 hccp 1 track FastEthernet0/1

!--- Tracking is enabled for the egress port, in the event that the WAN-backhaul is 
!--- disrupted. This cable interface will failover to the Protect.

 hccp 1 reverttime 120

!--- This is the time in minutes (plus a 2 minute suspend) for the card to switch back
!--- to normal mode, if the fault has cleared. If there is a fault on the Protect card,
!--- then it will revert back after the suspend time, and it will not wait for the full
!--- revert time. The default setting is 30 minutes.

!
interface Cable3/1
 hccp 2 working 1
 hccp 2 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 11110100 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- right side of Switch slot 1.

 hccp 2 channel-switch 1 uc31 wavecom-hd 192.168.1.2 2 192.168.1.4 2
 hccp 2 reverttime 120
!
interface Cable4/0
 hccp 3 working 1 hccp 3 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 88880800 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- left side of Switch slot 5. Because the RF Switch is in 4+1 mode, slot 5 is 
!--- considered to be slot 1 again.

 hccp 3 channel-switch 1 uc31 wavecom-hd 192.168.1.2 3 192.168.1.4 3
 hccp 3 reverttime 120
!
interface Cable 4/1
 hccp 4 working 1
 hccp 4 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 22220200 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- right side of Switch slot 5. Because the RF Switch is in 4+1 mode, slot 5 is
!--- considered to be slot 1 again.

 hccp 4 channel-switch 1 uc31 wavecom-hd 192.168.1.2 4 192.168.1.4 4
 hccp 4 reverttime 120
!
interface Cable5/0
 hccp 5 working 1
 hccp 5 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 44440400 1
 hccp 5 channel-switch 1 uc31 wavecom-hd 192.168.1.2 5 192.168.1.4 5
 hccp 5 reverttime 120
!
interface Cable 5/1
 hccp 6 working 1
 hccp 6 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 11110100 1
 hccp 6 channel-switch 1 uc31 wavecom-hd 192.168.1.2 6 192.168.1.4 6
 hccp 6 reverttime 120
!
interface Cable 6/0
 hccp 7 working 1
 hccp 7 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 88880800 1
 hccp 7 channel-switch 1 uc31 wavecom-hd 192.168.1.2 7 192.168.1.4 7
 hccp 7 reverttime 120
!
interface Cable 6/1
 hccp 8 working 1
 hccp 8 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 22220200 1
 hccp 8 channel-switch 1 uc31 wavecom-hd 192.168.1.2 8 192.168.1.4 8
 hccp 8 reverttime 120
!
router eigrp 2500
 network 10.11.12.0 0.0.0.255
 network 192.168.1.0
 network 192.168.3.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
no ip http server
!
cdp run
!
snmp-server community private RW

!--- Unless it is deleted, this does not affect the HCCP communications between
!--- the upconverter, the Switch, and the 7200.

snmp-server community public RO
snmp-server enable traps tty
snmp-server manager
tftp-server disk0:
tftp-server disk1:
alias exec shb show hccp brief
alias exec shd show hccp detail
alias exec scm show cable modem
alias exec scr show cable modem remote
alias exec sm show cab modu
alias exec sch show cab hop
alias exec sc300 show cont c3/0 u0
alias exec sint300 show int c3/0 u0
alias exec scs show cable spec

Protect VXR Configuration
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname "ProtectVXR"
!
boot system disk0:ubr7200-ik8s-mz.BC.28July03
no logging console
enable secret 5 $1$5YHG$mquxbcqzFoUUKhp/c9WT4/
!
cab modem remote-query 10 public
cab modulation-prof 2 request 0 16  0 8  qpsk  scrambler 152 no-diff 64  fixed uw8
cab modulation-prof 2 initial 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 2 station 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 2 short   4 76  6 8  qpsk  scrambler 152 no-diff 72  short uw8
cab modulation-prof 2 long    8 220 0 8  qpsk  scrambler 152 no-diff 80  short uw8
cab modulation-prof 3 request 0 16  0 8  qpsk  scrambler 152 no-diff 64  fixed uw16
cab modulation-prof 3 initial 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 3 station 5 34  0 48 qpsk  scrambler 152 no-diff 128 fixed uw16
cab modulation-prof 3 short   7 76  7 8  16qam scrambler 152 no-diff 144 short uw16
cab modulation-prof 3 long    9 220 0 8  16qam scrambler 152 no-diff 160 short uw16

!--- Be sure to pre-configure all global configurations on the Protect, such as
!--- modulation profiles, spectrum groups, load balancing, and so forth.

no cable qos permission create
no cable qos permission update
cable qos permission modems
no cable clock source-midplane
no cable clock force primary
no cable clock force secondary
!
cable config-file docsis.cm
 frequency 453000000
 service-class 1 max-upstream 10000
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1522
!
ip subnet-zero
ip cef
!
ip host protect 192.168.1.7
ip host work2 192.168.1.6
ip name-server 171.68.226.120
!
ip dhcp pool MODEMS1
   network 192.168.3.0 255.255.255.0
   bootfile docsis.cm
   next-server 192.168.3.5
   default-router 192.168.3.5
   option 7 ip 192.168.3.5
   option 4 ip 192.168.3.5
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp pool PC
   network 10.11.12.0 255.255.255.0
   default-router 10.11.12.1
   dns-server 171.68.226.120
   lease 10 1 11
!
packetcable element_id 35417
!
interface FastEthernet0/0
 ip address 192.168.1.11 255.255.255.0
 no keepalive
 speed auto
 full-duplex
 no cdp enable
!
interface FastEthernet0/1
 ip address 192.168.2.11 255.255.255.0
 keepalive 1
 speed auto
 full-duplex
 no cdp enable
!
interface Cable3/0
 no ip address

!--- There is no need to set the IP address, because it will come from the Working card
!--- via SNMP.

 no keepalive

!--- This defaults to 10 seconds with the N+1 Cisco IOS code, but it is recommended that
!--- you disable it on the Protect interface or set it to a relatively high value.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32

!--- The DS modulation, annex mode, and interleave must be same on the Protect and on
!--- the Working of the same group.

 no shut

!--- The interface must be activated to start HCCP functionality. Do this last.

 cable upstream 0 shutdown

!--- This will automatically become "no shut" when a failover occurs.

 hccp 1 protect 1 192.168.1.7

!--- This is the Protect for the first group. Remember to configure the Protect
!--- interface(s) last, after the Working interfaces are configured. This is the HCCP
!--- first group and it is protecting member 1 with member 1’s FastEthernet (FE) IP
!--- address.

 hccp 1 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 44440400 1

!--- This is the IP address of the Switch, and it is protecting member 1, which has a
!--- bitmap of 44440400 in Switch slot 1.

 hccp 1 channel-switch 1 uc31 wavecom-hd 192.168.1.2 1 192.168.1.4 1

!--- This is the IP address of the upconverter, and it is module 1 (A) that is backing
!--- module 1 (A) of another upconverter. This shows that one upconverter could have
!--- a module that backs up a module in a different chassis with a different IP address,
!--- if need be. If this statement is not present when you are using Cisco IOS Software
!--- Release 15(BC2) or later, then IF-Muting is assumed, and an external upconverter
!--- with SNMP capability is not needed.

 hccp 1 protect 2 192.168.1.8

!--- This is the HCCP first group, and it is protecting member 2 with its IP address.

 hccp 1 channel-switch 2 rfsw1a rfswitch-group 192.168.1.5 44440400 2
 hccp 1 channel-switch 2 uc31 wavecom-hd 192.168.1.2 1 192.168.1.4 9
 hccp 1 protect 3 192.168.1.9
 hccp 1 channel-switch 3 rfsw1a rfswitch-group 192.168.1.5 44440400 3
 hccp 1 channel-switch 3 uc32 wavecom-hd 192.168.1.2 1 192.168.1.3 1
 hccp 1 protect 4 192.168.1.10
 hccp 1 channel-switch 4 rfsw1a rfswitch-group 192.168.1.5 44440400 4
 hccp 1 channel-switch 4 uc32 wavecom-hd 192.168.1.2 1 192.168.1.3 9
 hccp 1 timers 666 2000

!--- hccp 1 timers <hellotime> <holdtime>
!--- This is for inter-chassis communication.

!
interface Cable3/1
 hccp 2 protect 1 192.168.1.7
 hccp 2 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 11110100 1
 hccp 2 channel-switch 1 uc31 wavecom-hd 192.168.1.2 2 192.168.1.4 2
 hccp 2 protect 2 192.168.1.8
 hccp 2 channel-switch 2 rfsw1a rfswitch-group 192.168.1.5 11110100 2
 hccp 2 channel-switch 2 uc31 wavecom-hd 192.168.1.2 2 192.168.1.4 10
 hccp 2 protect 3 192.168.1.9
 hccp 2 channel-switch 3 rfsw1a rfswitch-group 192.168.1.5 11110100 3
 hccp 2 channel-switch 3 uc32 wavecom-hd 192.168.1.2 2 192.168.1.3 2
 hccp 2 protect 4 192.168.1.10
 hccp 2 channel-switch 4 rfsw1a rfswitch-group 192.168.1.5 11110100 4
 hccp 2 channel-switch 4 uc32 wavecom-hd 192.168.1.2 2 192.168.1.3 10
 hccp 2 timers 666 2000
!
interface Cable4/0
 hccp 3 protect 1 192.168.1.7
 hccp 3 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 88880800 1
 hccp 3 channel-switch 1 uc31 wavecom-hd 192.168.1.2 3 192.168.1.4 3
 hccp 3 protect 2 192.168.1.8
 hccp 3 channel-switch 2 rfsw1b rfswitch-group 192.168.1.5 88880800 2
 hccp 3 channel-switch 2 uc31 wavecom-hd 192.168.1.2 3 192.168.1.4 11
 hccp 3 protect 3 192.168.1.9
 hccp 3 channel-switch 3 rfsw1b rfswitch-group 192.168.1.5 88880800 3
 hccp 3 channel-switch 3 uc32 wavecom-hd 192.168.1.2 3 192.168.1.3 3
 hccp 3 protect 4 192.168.1.10
 hccp 3 channel-switch 4 rfsw1b rfswitch-group 192.168.1.5 88880800 4
 hccp 3 channel-switch 4 uc32 wavecom-hd 192.168.1.2 3 192.168.1.3 11
 hccp 3 timers 666 2000
!
interface Cable4/1
 hccp 4 protect 1 192.168.1.7
 hccp 4 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 22220200 1
 hccp 4 channel-switch 1 uc31 wavecom-hd 192.168.1.2 4 192.168.1.4 4
 hccp 4 protect 2 192.168.1.8
 hccp 4 channel-switch 2 rfsw1b rfswitch-group 192.168.1.5 22220200 2
 hccp 4 channel-switch 2 uc31 wavecom-hd 192.168.1.2 4 192.168.1.4 12
 hccp 4 protect 3 192.168.1.9
 hccp 4 channel-switch 3 rfsw1b rfswitch-group 192.168.1.5 22220200 3
 hccp 4 channel-switch 3 uc32 wavecom-hd 192.168.1.2 4 192.168.1.3 4
 hccp 4 protect 4 192.168.1.10
 hccp 4 channel-switch 4 rfsw1b rfswitch-group 192.168.1.5 22220200 4
 hccp 4 channel-switch 4 uc32 wavecom-hd 192.168.1.2 4 192.168.1.3 12
 hccp 4 timers 666 2000
!
interface Cable5/0
 hccp 5 protect 1 192.168.1.7
 hccp 5 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 44440400 1
 hccp 5 channel-switch 1 uc31 wavecom-hd 192.168.1.2 5 192.168.1.4 5
 hccp 5 protect 2 192.168.1.8
 hccp 5 channel-switch 2 rfsw2a rfswitch-group 192.168.1.6 44440400 2
 hccp 5 channel-switch 2 uc31 wavecom-hd 192.168.1.2 5 192.168.1.4 13
 hccp 5 protect 3 192.168.1.9
 hccp 5 channel-switch 3 rfsw2a rfswitch-group 192.168.1.6 44440400 3
 hccp 5 channel-switch 3 uc32 wavecom-hd 192.168.1.2 5 192.168.1.3 5
 hccp 5 protect 4 192.168.1.10
 hccp 5 channel-switch 4 rfsw2a rfswitch-group 192.168.1.6 44440400 4
 hccp 5 channel-switch 4 uc32 wavecom-hd 192.168.1.2 5 192.168.1.3 13
 hccp 5 timers 666 2000
!
interface Cable5/1
 hccp 6 protect 1 192.168.1.7
 hccp 6 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 11110100 1
 hccp 6 channel-switch 1 uc31 wavecom-hd 192.168.1.2 6 192.168.1.4 6
 hccp 6 protect 2 192.168.1.8
 hccp 6 channel-switch 2 rfsw2a rfswitch-group 192.168.1.6 11110100 2
 hccp 6 channel-switch 2 uc31 wavecom-hd 192.168.1.2 6 192.168.1.4 14
 hccp 6 protect 3 192.168.1.9
 hccp 6 channel-switch 3 rfsw2a rfswitch-group 192.168.1.6 11110100 3
 hccp 6 channel-switch 3 uc32 wavecom-hd 192.168.1.2 6 192.168.1.3 6
 hccp 6 protect 4 192.168.1.10
 hccp 6 channel-switch 4 rfsw2a rfswitch-group 192.168.1.6 11110100 4
 hccp 6 channel-switch 4 uc32 wavecom-hd 192.168.1.2 6 192.168.1.3 14
 hccp 6 timers 666 2000
!
interface Cable6/0
 hccp 7 protect 1 192.168.1.7
 hccp 7 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 88880800 1
 hccp 7 channel-switch 1 uc31 wavecom-hd 192.168.1.2 7 192.168.1.4 7
 hccp 7 protect 2 192.168.1.8
 hccp 7 channel-switch 2 rfsw2b rfswitch-group 192.168.1.6 88880800 2
 hccp 7 channel-switch 2 uc31 wavecom-hd 192.168.1.2 7 192.168.1.4 15
 hccp 7 protect 3 192.168.1.9
 hccp 7 channel-switch 3 rfsw2b rfswitch-group 192.168.1.6 88880800 3
 hccp 7 channel-switch 3 uc32 wavecom-hd 192.168.1.2 7 192.168.1.3 7
 hccp 7 protect 4 192.168.1.10
 hccp 7 channel-switch 4 rfsw2b rfswitch-group 192.168.1.6 88880800 4
 hccp 7 channel-switch 4 uc32 wavecom-hd 192.168.1.2 7 192.168.1.3 15
 hccp 7 timers 666 2000
!
interface Cable6/1
 hccp 8 protect 1 192.168.1.7
 hccp 8 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 22220200 1
 hccp 8 channel-switch 1 uc31 wavecom-hd 192.168.1.2 8 192.168.1.4 8
 hccp 8 protect 2 192.168.1.8
 hccp 8 channel-switch 2 rfsw2b rfswitch-group 192.168.1.6 22220200 2
 hccp 8 channel-switch 2 uc31 wavecom-hd 192.168.1.2 8 192.168.1.4 16
 hccp 8 protect 3 192.168.1.9
 hccp 8 channel-switch 3 rfsw2b rfswitch-group 192.168.1.6 22220200 3
 hccp 8 channel-switch 3 uc32 wavecom-hd 192.168.1.2 8 192.168.1.3 8
 hccp 8 protect 4 192.168.1.10
 hccp 8 channel-switch 4 rfsw2b rfswitch-group 192.168.1.6 22220200 4
 hccp 8 channel-switch 4 uc32 wavecom-hd 192.168.1.2 8 192.168.1.3 16
 hccp 8 timers 666 2000
!
router eigrp 2500
 network 10.11.12.0 0.0.0.255
 network 10.11.13.0 0.0.0.255
 network 192.168.1.0
 network 192.168.3.0
 network 192.168.5.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
no ip http server
!
cdp run
!
snmp-server community private RW
snmp-server community public RO
snmp-server enable traps tty
snmp-server enable traps cable
snmp-server manager
alias exec shb show hccp brief
alias exec shd show hccp detail
alias exec scm show cable modem
alias exec scr show cable modem remote

Scenario 2

Sample configurations of high availability with two RF Switches (3x10 configuration) in 4+1 mode, five VXRs, and twenty MC28U line cards.

The physical layout is shown in Figure 1, but ignore the upconverters on the top. Refer to Cabling the Cisco RF Switch to the Cisco uBR7246VXR for a cabling document that uses 28C line cards. The cabling for MC28U line cards consists of a bundle of ten cables that go from each line card to each header of the RF Switch. Refer to the HA document that pertains to this N+1 solution.

This physical stacking is assumed, with IP assignments that start with 192.168.1.5 at the top and continue down. Because it will be in the 4+1 mode, RF Switch 1 is considered to be two switches: a and b, where a is slots 1 through 4 and b is slots 5 through 8. RF Switch 2 is also considered two switches: a and b.

Working VXR1 Configuration
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname "WorkingVXR1"
!
boot system disk0:ubr7200-ik8s-mz.BC....
no logging console
enable secret 5 $1$5YHG$mquxbcqzFoUUKhp/c9WT4/
!
cab modem remote-query 10 public

!--- This is an easy way to track modem transmit and receive levels, especially after a
!--- failover. You might want to increase the time period or remove this command, after
!--- you have confirmed that everything is OK.

cable modulation-profile 41 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 41 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 41 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 41 short 3 78 35 25 qpsk scrambler 152 no-diff 100 short
cable modulation-profile 41 long 9 232 0 137 qpsk scrambler 152 no-diff 80 short
cable modulation-profile 42 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 42 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 42 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 42 short 3 78 17 10 16qam scrambler 152 no-diff 136 short
cable modulation-profile 42 long 9 232 0 77 16qam scrambler 152 no-diff 216 short
no cable qos permission create
no cable qos permission update
cable qos permission modems
no cable clock source-midplane
no cable clock force primary
no cable clock force secondary
!
cable config-file docsis.cm
 frequency 453000000
 service-class 1 max-upstream 10000
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1522
!
ip subnet-zero
ip cef
!
ip name-server 171.68.226.120
!
ip dhcp pool MODEMS1
   network 192.168.3.0 255.255.255.0
   bootfile docsis.cm
   next-server 192.168.3.5
   default-router 192.168.3.5
   option 7 ip 192.168.3.5
   option 4 ip 192.168.3.5
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp pool PC
   network 10.11.12.0 255.255.255.0
   default-router 10.11.12.1
   dns-server 171.68.226.120
   lease 10 1 11
!
packetcable element_id 35417
!
interface FastEthernet0/0
 ip address 192.168.1.7 255.255.255.0
 no keepalive
 speed auto
 full-duplex

!--- This interface is used for HCCP traffic.

!
interface FastEthernet0/1
 ip address 192.168.2.7 255.255.255.0
 keepalive 1

!--- This is set to 1 second so that, if the cable is disconnected, this interface
!--- will failover within 3 seconds.

 speed auto
 full-duplex
!
interface Cable3/0
 ip address 10.11.12.1 255.255.255.0 secondary
 ip address 192.168.3.5 255.255.255.0
 load-interval 30
 cable dynamic-secret mark nocrypt
 cable map-advance dynamic 500 1000
 keepalive 1

!--- The keepalive time is in seconds, and the default is 10 seconds for HCCP code.

 cable downstream channel-id 0
 cable bundle 1 master

!--- Interface bundling is supported, as are subinterfaces.
!--- Note: Bundles failover together.

 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 no cable downstream rf-shutdown
 cable downstream frequency 453000000

!--- This is the DS frequency, which used to be informational only when you are using
!--- an external UPx. This must be set when using the MC28U cards with internal UPxs.

 cable upstream 0 frequency 24000000

!--- If you are doing dense mode combining, the US frequencies must be different.
!--- If no two US ports are shared, the same frequency can be used.

 cable upstream 0 ingress-noise-cancellation 200
 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000 3200000
 cable upstream 0 minislot-size 4
 cable upstream 0 fragment-force 3500 3
 cable upstream 0 range-backoff 2 6
 cable upstream 0 data-backoff 3 5
 cable upstream 0 modulation-profile 42
 no cable upstream 0 shutdown
 cable dhcp-giaddr policy

!--- This tells the CMs to get an IP address from the primary scope, and it tells the
!--- CPE to use the secondary scope.

 hccp 1 working 1

!--- This is the Working first group, member 1.

 hccp 1 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 44440400 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- left side of Switch slot 1.

 hccp 1 track FastEthernet0/1

!--- Tracking is enabled for the egress port, in the event that the WAN-backhaul is
!--- disrupted. This cable interface will failover to the Protect.

 hccp 1 reverttime 120

!--- This is the time in minutes (plus a 2 minute suspend) for the card to switch back
!--- to normal mode, if the fault has cleared. If there is a fault on the Protect card,
!--- then it will revert back after the suspend time, and it will not wait for the full
!--- revert time.

!
interface Cable3/1
 hccp 2 working 1
 hccp 2 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 11110100 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- right side of Switch slot 1.

 hccp 2 reverttime 120
!
interface Cable4/0
 hccp 3 working 1
 hccp 3 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 88880800 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- left side of Switch slot 5. Because the RF Switch is in 4+1 mode, slot 5 is
!--- considered to be slot 1 again.

 hccp 3 reverttime 120
!
interface Cable 4/1
 hccp 4 working 1
 hccp 4 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 22220200 1

!--- This is the IP address of the Switch, and it is protecting member 1 in the
!--- right side of Switch slot 5. Because the RF Switch is in 4+1 mode, slot 5 is
!--- considered to be slot 1 again.

 hccp 4 reverttime 120
!
interface Cable5/0
 hccp 5 working 1
 hccp 5 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 44440400 1
 hccp 5 reverttime 120
!
interface Cable 5/1
 hccp 6 working 1
 hccp 6 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 11110100 1
 hccp 6 reverttime 120
!
interface Cable 6/0
 hccp 7 working 1
 hccp 7 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 88880800 1
 hccp 7 reverttime 120
!
interface Cable 6/1
 hccp 8 working 1
 hccp 8 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 22220200 1
 hccp 8 reverttime 120
!
router eigrp 2500
 network 10.11.12.0 0.0.0.255
 network 192.168.1.0
 network 192.168.3.0
 no auto-summary
 no eigrp log-neighbor-changes

!--- Open Shortest Path First (OSPF) may be the best routing protocol, with its new
!--- fast-hellos.

ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
no ip http server
!
cdp run
!
snmp-server community private RW

!--- This does not affect the HCCP communications between the Switch and the VXR, but
!--- it must be set to Private on the RF Switch.

snmp-server community public RO
snmp-server enable traps tty
snmp-server manager
tftp-server disk0:
tftp-server disk1:
tftp-server disk1:rfsw250-fl-1935030e
tftp-server disk1:rfsw250-bf-1935022d
alias exec shb show hccp brief
alias exec shd show hccp detail
alias exec scm show cable modem
alias exec scr show cable modem remote
alias exec sm show cab modu
alias exec sch show cab hop
alias exec sc300 show cont c3/0 u0
alias exec sint300 show int c3/0 u0
alias exec scs show cable spec

Protect VXR Configurations
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname "ProtectVXR"
!
boot system disk0:ubr7200-ik8s-mz.BC.28July03
no logging console
enable secret 5 $1$5YHG$mquxbcqzFoUUKhp/c9WT4/
!
cab modem remote-query 10 public
cable modulation-profile 41 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 41 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 41 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 41 short 3 78 35 25 qpsk scrambler 152 no-diff 100 short
cable modulation-profile 41 long 9 232 0 137 qpsk scrambler 152 no-diff 80 short
cable modulation-profile 42 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 42 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 42 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed
cable modulation-profile 42 short 3 78 17 10 16qam scrambler 152 no-diff 136 short
cable modulation-profile 42 long 9 232 0 77 16qam scrambler 152 no-diff 216 short

!--- Be sure to pre-configure all global configurations on the Protect, such as
!--- modulation profiles, spectrum groups, load balancing, and so forth.

no cable qos permission create
no cable qos permission update
cable qos permission modems
no cable clock source-midplane
no cable clock force primary
no cable clock force secondary
!
cable config-file docsis.cm
 frequency 453000000
 service-class 1 max-upstream 10000
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1522
!
ip subnet-zero
ip cef
!
ip name-server 171.68.226.120
!
ip dhcp pool MODEMS1
   network 192.168.3.0 255.255.255.0
   bootfile docsis.cm
   next-server 192.168.3.5
   default-router 192.168.3.5
   option 7 ip 192.168.3.5
   option 4 ip 192.168.3.5
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp pool PC
   network 10.11.12.0 255.255.255.0
   default-router 10.11.12.1
   dns-server 171.68.226.120
   lease 10 1 11
!
packetcable element_id 35417
!
interface FastEthernet0/0
 ip address 192.168.1.11 255.255.255.0
 no keepalive
 speed auto
 full-duplex
 no cdp enable

!--- This interface is used for HCCP traffic.

!
interface FastEthernet0/1
 ip address 192.168.2.11 255.255.255.0
 keepalive 1
 speed auto
 full-duplex
 no cdp enable
!
interface Cable3/0
 no ip address

!--- There is no need to set the IP address, because it will come from the Working card
!--- via SNMP.

 no keepalive

!--- This defaults to 10 seconds with the N+1 Cisco IOS code, but it is recommended that
!--- you disable it on the Protect interface or set it to a relatively high value.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32

!--- The DS modulation, annex mode, and interleave must be pre-configured and must be 
!--- the same on the Protect and on the Working of the same group.

 no shut

!--- The interface must be activated to start HCCP functionality. Do this last.

 cable upstream 0 shutdown

!--- This will automatically become "no shut" when a failover occurs.

 hccp 1 protect 1 192.168.1.7

!--- This is the Protect for the first group. Remember to configure the Protect
!--- interface(s) last, after the Working interfaces are configured. This is the HCCP
!--- first group, and it is protecting member 1 with member 1’s FE IP address.

 hccp 1 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 44440400 1

!--- This is the IP address of the Switch, and it is protecting member 1, which has a
!--- bitmap of 44440400 in Switch slot 1.

 hccp 1 protect 2 192.168.1.8

!--- This is the HCCP first group, and it is protecting member 2 with its IP address.

 hccp 1 channel-switch 2 rfsw1a rfswitch-group 192.168.1.5 44440400 2
 hccp 1 protect 3 192.168.1.9
 hccp 1 channel-switch 3 rfsw1a rfswitch-group 192.168.1.5 44440400 3
 hccp 1 protect 4 192.168.1.10
 hccp 1 channel-switch 4 rfsw1a rfswitch-group 192.168.1.5 44440400 4
 hccp 1 timers 666 2000

!--- hccp 1 timers <hellotime> <holdtime>
!--- This is for inter-chassis communication.

!
interface Cable3/1
 hccp 2 protect 1 192.168.1.7
 hccp 2 channel-switch 1 rfsw1a rfswitch-group 192.168.1.5 11110100 1
 hccp 2 protect 2 192.168.1.8
 hccp 2 channel-switch 2 rfsw1a rfswitch-group 192.168.1.5 11110100 2
 hccp 2 protect 3 192.168.1.9
 hccp 2 channel-switch 3 rfsw1a rfswitch-group 192.168.1.5 11110100 3
 hccp 2 protect 4 192.168.1.10
 hccp 2 channel-switch 4 rfsw1a rfswitch-group 192.168.1.5 11110100 4
 hccp 2 timers 666 2000
!
interface Cable4/0
 hccp 3 protect 1 192.168.1.7
 hccp 3 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 88880800 1
 hccp 3 protect 2 192.168.1.8
 hccp 3 channel-switch 2 rfsw1b rfswitch-group 192.168.1.5 88880800 2
 hccp 3 protect 3 192.168.1.9
 hccp 3 channel-switch 3 rfsw1b rfswitch-group 192.168.1.5 88880800 3
 hccp 3 protect 4 192.168.1.10
 hccp 3 channel-switch 4 rfsw1b rfswitch-group 192.168.1.5 88880800 4
 hccp 3 timers 666 2000
!
interface Cable4/1
 hccp 4 protect 1 192.168.1.7
 hccp 4 channel-switch 1 rfsw1b rfswitch-group 192.168.1.5 22220200 1
 hccp 4 protect 2 192.168.1.8
 hccp 4 channel-switch 2 rfsw1b rfswitch-group 192.168.1.5 22220200 2
 hccp 4 protect 3 192.168.1.9
 hccp 4 channel-switch 3 rfsw1b rfswitch-group 192.168.1.5 22220200 3
 hccp 4 protect 4 192.168.1.10
 hccp 4 channel-switch 4 rfsw1b rfswitch-group 192.168.1.5 22220200 4
 hccp 4 timers 666 2000
!
interface Cable5/0
 hccp 5 protect 1 192.168.1.7
 hccp 5 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 44440400 1
 hccp 5 protect 2 192.168.1.8
 hccp 5 channel-switch 2 rfsw2a rfswitch-group 192.168.1.6 44440400 2
 hccp 5 protect 3 192.168.1.9
 hccp 5 channel-switch 3 rfsw2a rfswitch-group 192.168.1.6 44440400 3
 hccp 5 protect 4 192.168.1.10
 hccp 5 channel-switch 4 rfsw2a rfswitch-group 192.168.1.6 44440400 4
 hccp 5 timers 666 2000
!
interface Cable5/1
 hccp 6 protect 1 192.168.1.7
 hccp 6 channel-switch 1 rfsw2a rfswitch-group 192.168.1.6 11110100 1
 hccp 6 protect 2 192.168.1.8
 hccp 6 channel-switch 2 rfsw2a rfswitch-group 192.168.1.6 11110100 2
 hccp 6 protect 3 192.168.1.9
 hccp 6 channel-switch 3 rfsw2a rfswitch-group 192.168.1.6 11110100 3
 hccp 6 protect 4 192.168.1.10
 hccp 6 channel-switch 4 rfsw2a rfswitch-group 192.168.1.6 11110100 4
 hccp 6 timers 666 2000
!
interface Cable6/0
 hccp 7 protect 1 192.168.1.7
 hccp 7 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 88880800 1
 hccp 7 protect 2 192.168.1.8
 hccp 7 channel-switch 2 rfsw2b rfswitch-group 192.168.1.6 88880800 2
 hccp 7 protect 3 192.168.1.9
 hccp 7 channel-switch 3 rfsw2b rfswitch-group 192.168.1.6 88880800 3
 hccp 7 protect 4 192.168.1.10
 hccp 7 channel-switch 4 rfsw2b rfswitch-group 192.168.1.6 88880800 4
 hccp 7 timers 666 2000
!
interface Cable6/1
 hccp 8 protect 1 192.168.1.7
 hccp 8 channel-switch 1 rfsw2b rfswitch-group 192.168.1.6 22220200 1
 hccp 8 protect 2 192.168.1.8
 hccp 8 channel-switch 2 rfsw2b rfswitch-group 192.168.1.6 22220200 2
 hccp 8 protect 3 192.168.1.9
 hccp 8 channel-switch 3 rfsw2b rfswitch-group 192.168.1.6 22220200 3
 hccp 8 protect 4 192.168.1.10
 hccp 8 channel-switch 4 rfsw2b rfswitch-group 192.168.1.6 22220200 4
 hccp 8 timers 666 2000
!
router eigrp 2500
 network 10.11.12.0 0.0.0.255
 network 10.11.13.0 0.0.0.255
 network 192.168.1.0
 network 192.168.3.0
 network 192.168.5.0
 no auto-summary
 no eigrp log-neighbor-changes

!--- OSPF may be the best routing protocol, with its new fast-hellos.

!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
no ip http server
!
cdp run
!
snmp-server community private RW
snmp-server community public RO
snmp-server enable traps tty
snmp-server enable traps cable
snmp-server manager
alias exec shb show hccp brief
alias exec shd show hccp detail
alias exec scm show cable modem
alias exec scr show cable modem remote

Scenario 3

uBR10K N+1 sample configuration with MC28C line cards.

Figure 2 – Belden 1855A (mini-RG-59 Coax) with f or BNC Connectors

ha_mc5x20_b.gif

uBR10k Configuration
uBR10012-1# show run

Current configuration : 8567 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname uBR10k
!
boot system flash slot0: ubr10k-k8p6-mz.122-4.BC1b
logging rate-limit console all 10 except critical
enable secret 5 $1$.Dvy$fcPOhshUNjyfePH73FHRG.
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file docsis.cm
 frequency 453000000
 service-class 1 max-upstream 10000
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1522
!
redundancy
  main-cpu
    auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1gigethernet-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 2/1 2cable-tccplus
card 5/0 2cable-mc28c
card 5/1 2cable-mc28c
card 6/0 2cable-mc28c
card 6/1 2cable-mc28c
card 7/0 2cable-mc28c
card 7/1 2cable-mc28c
card 8/0 2cable-mc28c
card 8/1 2cable-mc28c
ip subnet-zero
ip host rfswitch 2001 10.10.10.1

!--- This is set for console access from the 10K to the Switch. The IP address is for
!--- Loopback0.

ip dhcp pool MODEMS1
   network 172.25.1.0 255.255.255.0
   bootfile docsis.cm
   next-server 172.25.1.1
   default-router 172.25.1.1
   option 7 ip 172.25.1.1
   option 4 ip 172.25.1.1
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp pool MODEMS2
   network 172.25.2.0 255.255.255.0
   bootfile docsis.cm
   next-server 172.25.2.1
   default-router 172.25.2.1
   option 7 ip 172.25.2.1
   option 4 ip 172.25.2.1
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp-client network-discovery informs 2 discovers 2 period 15

!--- An internal DHCP server was used for testing, instead of external servers (cable
!--- helper, Time-of-Day [ToD], TFTP, and so forth). External servers are recommended
!--- in a "real" production network.

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.252
!
interface FastEthernet0/0/0
 ip address 10.97.1.8 255.255.255.0
 ip rip receive version 2
 no ip split-horizon
 no keepalive
!
interface GigabitEthernet1/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto
!
interface Cable5/1/0

!--- This is the Protect for the first group. Remember to configure the Protect
!--- interface(s) last, after the Working interfaces are configured.

 no ip address

!--- There is no need to set the IP address because it will come from the Working card
!--- via SNMP.

 no keepalive

!--- This defaults to 10 seconds with the N+1 Cisco IOS code, but it is recommended
!--- that you disable it on the Protect interface or set it to a relatively high value.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32

!--- The DS modulation, annex mode, and interleave must be same on the Protect and on
!--- the Working of the same group.

 cable upstream 0 shutdown

!--- This will automatically become "no shut" when a failover occurs.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable dhcp-giaddr policy
 hccp 1 protect 1 10.10.10.1

!--- This is the HCCP first group, and it is protecting member 1 with member 1’s FE IP
!--- address. If it is intra-chassis, you can use the Loopback0 IP address.

 hccp 1 channel-switch 1 uc wavecom-hd 10.97.1.21 2 10.97.1.21 16

!--- This is the IP address of the upconverter, and it is module 2 (B) that is backing
!--- module 16 (P) of the upconverter. This shows that one upconverter could have a
!--- module that backs up a module in a different chassis with a different IP address,
!--- if need be. If this statement is not present when you are using Cisco IOS Software
!--- Release 15(BC2) or later, then IF-Muting is assumed, and an external upconverter
!--- with SNMP capability is not needed.

 hccp 1 channel-switch 1 rfswitch rfswitch-group 10.97.1.20 AA200000 1

!--- This is the IP address of the Switch, and it is protecting member 1, which has a
!--- bitmap of AA200000 in Switch slot 1.

 hccp 1 protect 2 10.10.10.1

!--- This is the HCCP first group, and it is protecting member 2 with its IP address.

 hccp 1 channel-switch 2 uc wavecom-hd 10.97.1.21 2 10.97.1.21 14

!--- This is the IP address of the upconverter, and it is module 2 (B) that is backing
!--- module 14 (N).

 hccp 1 channel-switch 2 rfswitch rfswitch-group 10.97.1.20 AA200000 2

!--- This is the IP address of the Switch, and it is protecting member 2, with a bitmap
!--- of AA200000 in Switch slot 2.

 hccp 1 protect 3 10.10.10.1
 hccp 1 channel-switch 3 uc wavecom-hd 10.97.1.21 2 10.97.1.21 12
 hccp 1 channel-switch 3 rfswitch rfswitch-group 10.97.1.20 AA200000 3
 hccp 1 protect 4 10.10.10.1
 hccp 1 channel-switch 4 uc wavecom-hd 10.97.1.21 2 10.97.1.21 10
 hccp 1 channel-switch 4 rfswitch rfswitch-group 10.97.1.20 AA200000 4
 hccp 1 protect 5 10.10.10.1
 hccp 1 channel-switch 5 uc wavecom-hd 10.97.1.21 2 10.97.1.21 8
 hccp 1 channel-switch 5 rfswitch rfswitch-group 10.97.1.20 AA200000 5
 hccp 1 protect 6 10.10.10.1
 hccp 1 channel-switch 6 uc wavecom-hd 10.97.1.21 2 10.97.1.21 6
 hccp 1 channel-switch 6 rfswitch rfswitch-group 10.97.1.20 AA200000 6
 hccp 1 protect 7 10.10.10.1
 hccp 1 channel-switch 7 uc wavecom-hd 10.97.1.21 2 10.97.1.21 4
 hccp 1 channel-switch 7 rfswitch rfswitch-group 10.97.1.20 AA200000 7
 hccp 1 timers 5000 15000

!--- hccp 1 timers <hellotime> <holdtime>
!--- This is for inter-chassis communication, so set high for the 10K.

!
interface Cable5/1/1

!--- This is the Protect for the second group.

 no ip address
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable dhcp-giaddr policy
!
 hccp 2 protect 1 10.10.10.1
 hccp 2 channel-switch 1 uc wavecom-hd 10.97.1.21 1 10.97.1.21 15
 hccp 2 channel-switch 1 rfswitch rfswitch-group 10.97.1.20 55100000 1

!--- Because this MAC domain is on right side of header, the bitmap in hexadecimal code
!--- is 55100000.

 hccp 2 protect 2 10.10.10.1
 hccp 2 channel-switch 2 uc wavecom-hd 10.97.1.21 1 10.97.1.21 13
 hccp 2 channel-switch 2 rfswitch rfswitch-group 10.97.1.20 55100000 2
 hccp 2 protect 3 10.10.10.1
 hccp 2 channel-switch 3 uc wavecom-hd 10.97.1.21 1 10.97.1.21 11
 hccp 2 channel-switch 3 rfswitch rfswitch-group 10.97.1.20 55100000 3
 hccp 2 protect 4 10.10.10.1
 hccp 2 channel-switch 4 uc wavecom-hd 10.97.1.21 1 10.97.1.21 9
 hccp 2 channel-switch 4 rfswitch rfswitch-group 10.97.1.20 55100000 4
 hccp 2 protect 5 10.10.10.1
 hccp 2 channel-switch 5 uc wavecom-hd 10.97.1.21 1 10.97.1.21 7
 hccp 2 channel-switch 5 rfswitch rfswitch-group 10.97.1.20 55100000 5
 hccp 2 protect 6 10.10.10.1
 hccp 2 channel-switch 6 uc wavecom-hd 10.97.1.21 1 10.97.1.21 5
 hccp 2 channel-switch 6 rfswitch rfswitch- group 10.97.1.20 55100000 6
 hccp 2 protect 7 10.10.10.1
 hccp 2 channel-switch 7 uc wavecom-hd 10.97.1.21 1 10.97.1.21 3
 hccp 2 channel-switch 7 rfswitch rfswitch-group 10.97.1.20 55100000 7
 hccp 2 timers 5000 15000
!
interface Cable8/1/0

!--- This is the Working for the first group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.1.1 255.255.255.0

!--- Interface bundling is supported, as are subinterfaces.

 ip rip send version 2
 ip rip receive version 2
 keepalive 1

!--- The keepalive time is in seconds, and the default is 10 seconds for HCCP code.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000

!--- This is the DS frequency, which used to be informational only when you are using
!--- an external upconverter. This must be set when doing N+1, so the Protect
!--- upconverter knows what frequency to use.

 cable upstream 0 frequency 24000000

!--- If you are doing dense mode combining, the US frequencies must be different.
!--- If no two US ports are shared, the same frequency can be used.

 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 power-level 0
 cable upstream 1 shutdown
 cable upstream 2 power-level 0
 cable upstream 2 shutdown
 cable upstream 3 power-level 0
 cable upstream 3 shutdown
 cable dhcp-giaddr policy

!--- This tells the CMs to get an IP address from the primary scope, and it tells the
!--- CPE to use the secondary scope.

 hccp 1 working 1

!--- This is Working member 1 of HCCP Group 1.

 hccp 1 channel-switch 1 uc wavecom-hd 10.97.1.21 2 10.97.1.21 16

!--- This is the IP address of the upconverter, and it is module 2 (B) that is backing
!--- module 16 (P).

 hccp 1 channel-switch 1 rfswitch rfswitch-group 10.97.1.20 AA200000 1

!--- This is the IP address of the Switch and of member 1, which has a bitmap of
!--- AA200000 in Switch slot 1.

 hccp 1 reverttime 120

!--- This is the time in minutes (plus a 2 minute suspend) for the card to switch back
!--- to normal mode, if the fault has cleared. If a fault is initiated by a keepalive
!--- and you have a fault on the Protect card, then it will revert back after the
!--- suspend time, and it will not wait for the full revert time.

!
interface Cable8/1/1

!--- This is the Working interface for the second HCCP group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.2.1 255.255.255.0
 ip rip send version 2
 ip rip receive version 2
 keepalive 1
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000
 cable upstream 0 frequency 24000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 power-level 0
 cable upstream 1 shutdown
 cable upstream 2 power-level 0
 cable upstream 2 shutdown
 cable upstream 3 power-level 0
 cable upstream 3 shutdown
 cable dhcp-giaddr policy
 hccp 2 working 1

!--- This is Working member 1 of HCCP Group 2.

 hccp 2 channel-switch 1 uc wavecom-hd 10.97.1.21 1 10.97.1.21 15
 hccp 2 channel-switch 1 rfswitch rfswitch-group 10.97.1.20 55100000 1

!--- This is the IP address of the Switch and of member 1 of Group 2, which has a
!--- bitmap of 55100000 in Switch slot 1.

 hccp 2 reverttime 120
!
ip classless
no ip http server
!
no cdp run
snmp-server community private RW

!--- This does not affect the HCCP communications between the upconverter, the Switch,
!--- and the 10K.

snmp-server enable traps cable
no cdp run
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
line con 0
 logging synchronous
line aux 0
 no exec
 transport input all

!--- The previous three lines are used to console from the Auxiliary port of the 10K to
!--- the Switch.

line vty 0 4
 session-timeout 400
 password xx
 login
endBuilding configuration...

Scenario 4

Sample configuration for 5x20 line cards in 8+1 mode.

Figure 3 – Belden mini-RG-59 Coax with MCX Connectors

ha_mc5x20_c.gif

uBR10k Configuration
uBR10012-1# show run

Current configuration : 8567 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname uBR10k
!
boot system flash slot0: ubr10k-k8p6-mz.122-15.BC1
logging rate-limit console all 10 except critical
enable secret 5 $1$.Dvy$fcPOhshUNjyfePH73FHRG
cable modulation-profile 21 request 0 16 0 22 qpsk scrambler 152 no-diff 32 fixed
cable modulation-profile 21 initial 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 21 station 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 21 short 3 76 12 22 qpsk scrambler 152 no-diff 64 shortened
cable modulation-profile 21 long 7 231 0 22 qpsk scrambler 152 no-diff 64 shortened

!--- Advanced time division multiplex access (ATDMA) Cisco IOS has different
!--- modulation profiles and requirements.

!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file docsis.cm
 frequency 453000000
 service-class 1 max-upstream 10000
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1522
!
redundancy
  main-cpu
    auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1gigethernet-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 2/1 2cable-tccplus
card 5/0 5cable-mc520s-d
card 5/1 5cable-mc520s-d
card 6/0 5cable-mc520s-d
card 6/1 5cable-mc520s-d
card 7/0 5cable-mc520s-d
card 7/1 5cable-mc520s-d
card 8/0 5cable-mc520s-d
card 8/1 5cable-mc520s-d
ip subnet-zero
ip host rfswitch 2001 10.10.10.1

!--- This is set for console access from the 10K to the Switch. The IP address is for
!--- Loopback0.

ip dhcp pool MODEMS1
   network 172.25.1.0 255.255.255.0
   bootfile docsis.cm
   next-server 172.25.1.1
   default-router 172.25.1.1
   option 7 ip 172.25.1.1
   option 4 ip 172.25.1.1
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp pool MODEMS2
   network 172.25.2.0 255.255.255.0
   bootfile docsis.cm
   next-server 172.25.2.1
   default-router 172.25.2.1
   option 7 ip 172.25.2.1
   option 4 ip 172.25.2.1
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp-client network-discovery informs 2 discovers 2 period 15

!--- An internal DHCP server was used for testing instead of external servers (cable
!--- helper, ToD, TFTP, and so forth). External servers are recommended in a "real"
!--- production network.

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.252
!
interface FastEthernet0/0/0
 ip address 10.97.1.8 255.255.255.0
 ip rip receive version 2
 no ip split-horizon
 no keepalive
!
interface GigabitEthernet1/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto

!--- This assumes rfsw2 is on the top, as shown in the cable reference guide. Other
!--- interfaces will be the same, except they will have a different member number
!--- for each HCCP group.

interface Cable5/1/0

!--- This is the Protect for the first group. It may be best to configure the Protect
!--- interface(s) last, after the Working interfaces are configured, or keep the
!--- interface "shut" until you are finished with all configurations.

 no ip address

!--- There is no need to set the IP address, because it will come from the Working card
!--- via SNMP.

 no keepalive

!--- This defaults to 10 seconds with the N+1 Cisco IOS code, but it is recommended
!--- that you disable it on the Protect interface or set it to a relatively high value.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32

!--- The DS modulation and interleave must be the same on the Protect and on the
!--- Working of the same group. The Protect interface itself must be "no shut" for
!--- HCCP to activate.

 cable downstream rf-shutdown
 cable upstream 0 shutdown

!--- These will automatically become "no shut" when a failover occurs.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 hccp 1 protect 1 10.10.10.1

!--- This is the HCCP first group, and it is protecting member 1 with member 1’s FE IP
!--- address. If it is intra-chassis, you can use the Loopback0 IP address.

 hccp 1 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 AA200000 1

!--- This is the IP address of the Switch, and it is protecting member 1, which has a
!--- bitmap of AA200000 in Switch slot 1.

 hccp 1 protect 2 10.10.10.1

!--- This is the HCCP first group, and it is protecting member 2 with the loopback IP
!--- address.

 hccp 1 channel-switch 2 rfsw2 rfswitch-group 10.97.1.20 AA200000 2

!--- This is the IP address of the Switch, and it is protecting member 2, with a bitmap
!--- of AA200000 in Switch slot 2.

 hccp 1 protect 3 10.10.10.1
 hccp 1 channel-switch 3 rfsw2 rfswitch-group 10.97.1.20 AA200000 3
 hccp 1 protect 4 10.10.10.1
 hccp 1 channel-switch 4 rfsw2 rfswitch-group 10.97.1.20 AA200000 4
 hccp 1 protect 5 10.10.10.1
 hccp 1 channel-switch 5 rfsw2 rfswitch-group 10.97.1.20 AA200000 5
 hccp 1 protect 6 10.10.10.1
 hccp 1 channel-switch 6 rfsw2 rfswitch-group 10.97.1.20 AA200000 6
 hccp 1 protect 7 10.10.10.1
 hccp 1 channel-switch 7 rfsw2 rfswitch-group 10.97.1.20 AA200000 7

!--- These channel-switch configurations can be copied and pasted into their respective
!--- Working interfaces.

 hccp 1 timers 5000 15000

!--- hccp 1 timers <hellotime> <holdtime>
!--- This is mostly for inter-chassis communication, so set it high for the 10K, as
!--- this can create extra CPU load.

 no hccp 1 revertive
!
interface Cable5/1/1

!--- This is the Protect for the second group.

 no ip address
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream rf-shutdown
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
!
 hccp 2 protect 1 10.10.10.1
 hccp 2 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 55100000 1

!--- Because this MAC domain is on right side of header, the bitmap in hexadecimal code
!--- is 55100000.

 hccp 2 protect 2 10.10.10.1
 hccp 2 channel-switch 2 rfsw2 rfswitch-group 10.97.1.20 55100000 2
 hccp 2 protect 3 10.10.10.1
 hccp 2 channel-switch 3 rfsw2 rfswitch-group 10.97.1.20 55100000 3
 hccp 2 protect 4 10.10.10.1
 hccp 2 channel-switch 4 rfsw2 rfswitch-group 10.97.1.20 55100000 4
 hccp 2 protect 5 10.10.10.1
 hccp 2 channel-switch 5 rfsw2 rfswitch-group 10.97.1.20 55100000 5
 hccp 2 protect 6 10.10.10.1
 hccp 2 channel-switch 6 rfsw2 rfswitch-group 10.97.1.20 55100000 6
 hccp 2 protect 7 10.10.10.1
 hccp 2 channel-switch 7 rfsw2 rfswitch-group 10.97.1.20 55100000 7
 hccp 2 timers 5000 15000
 no hccp 2 revertive
!
interface Cable5/1/2

!--- This is the Protect for the third group.

 no ip address
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream rf-shutdown
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 hccp 3 protect 1 10.10.10.1
 hccp 3 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 00C80000 1
 hccp 3 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 00C00000 1

!--- Because the third MAC domain will traverse both Switches, two statements are
!--- needed. The 00 in front of the bitmaps will be dropped, when the running
!--- configuration is viewed.

 no hccp 3 revertive
!
interface Cable5/1/3

!--- This is the Protect for the fourth group.

 hccp 4 protect 1 10.10.10.1
 hccp 4 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 AA200000 1
 hccp 4 protect 2 10.10.10.1
 hccp 4 channel-switch 2 rfsw1 rfswitch-group 10.97.1.19 AA200000 2
 hccp 4 protect 3 10.10.10.1
 hccp 4 channel-switch 3 rfsw1 rfswitch-group 10.97.1.19 AA200000 3
 hccp 4 protect 4 10.10.10.1
 hccp 4 channel-switch 4 rfsw1 rfswitch-group 10.97.1.19 AA200000 4
 hccp 4 protect 5 10.10.10.1
 hccp 4 channel-switch 5 rfsw1 rfswitch-group 10.97.1.19 AA200000 5
 hccp 4 protect 6 10.10.10.1
 hccp 4 channel-switch 6 rfsw1 rfswitch-group 10.97.1.19 AA200000 6
 hccp 4 protect 7 10.10.10.1
 hccp 4 channel-switch 7 rfsw1 rfswitch-group 10.97.1.19 AA200000 7
 no hccp 4 revertive
!
interface Cable5/1/4

!--- This is the Protect for the fifth group.

 hccp 5 protect 1 10.10.10.1
 hccp 5 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 55100000 1
 hccp 5 protect 2 10.10.10.1
 hccp 5 channel-switch 2 rfsw1 rfswitch-group 10.97.1.19 55100000 2
 hccp 5 protect 3 10.10.10.1
 hccp 5 channel-switch 3 rfsw1 rfswitch-group 10.97.1.19 55100000 3
 hccp 5 protect 4 10.10.10.1
 hccp 5 channel-switch 4 rfsw1 rfswitch-group 10.97.1.19 55100000 4
 hccp 5 protect 5 10.10.10.1
 hccp 5 channel-switch 5 rfsw1 rfswitch-group 10.97.1.19 55100000 5
 hccp 5 protect 6 10.10.10.1
 hccp 5 channel-switch 6 rfsw1 rfswitch-group 10.97.1.19 55100000 6
 hccp 5 protect 7 10.10.10.1
 hccp 5 channel-switch 7 rfsw1 rfswitch-group 10.97.1.19 55100000 7

!--- Output suppressed.

!
interface Cable8/1/0

!--- This is the Working for the first group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.1.1 255.255.255.0

!--- Interface bundling is supported, as are subinterfaces.

 ip rip send version 2
 ip rip receive version 2
 keepalive 1

!--- The keepalive time is in seconds, and the default is 10 seconds for HCCP code.
!--- Only set this after the modems have stabilized.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000

!--- This is the DS frequency, which must be set for the internal upconverter to
!--- operate.

 cable downstream channel-id 0
 no cable downstream rf-shutdown

!--- This is needed to turn on the DS RF output.

 cable upstream 0 frequency 24000000

!--- If you are doing dense mode combining, the US frequencies must be different.
!--- If no two US ports are shared, the same frequency can be used.

 cable upstream 0 power-level 0
 cable upstream 0 connector 0

!--- This is a new command for virtual interfaces, where USs can be used for different
!--- DS MAC domains.

 cable upstream 0 channel-width 3200000
 cable upstream 0 minislot-size 2
 cable upstream 0 modulation-profile 22
 no cable upstream 0 shutdown

!--- Output suppressed.

 cable dhcp-giaddr policy

!--- This tells the the CMs to get an IP address from the primary scope, and it tells
!--- the CPE to use the secondary scope.

 hccp 1 working 1

!--- This is Working member 1 of HCCP Group 1.

 hccp 1 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 AA200000 1

!--- This is the IP address of the Switch and of member 1, which has a bitmap of
!--- AA200000 in Switch slot 1.

 hccp 1 reverttime 120

!--- This is the time in minutes (plus a 2 minute suspend) for the card to switch back
!--- to normal mode, if the fault has cleared. If a fault is initiated by a keepalive
!--- and you have a fault on the Protect card, then it will revert back after the
!--- suspend time, and it will not wait for the full revert time.

!
interface Cable8/1/1

!--- This is the Working interface for the second HCCP group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.2.1 255.255.255.0
 ip rip send version 2
 ip rip receive version 2
 keepalive 1
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000
 cable downstream channel-id 1
 no cable downstream rf-shutdown
 cable upstream 0 frequency 24000000
 cable upstream 0 power-level 0
 cable upstream 0 connector 4
 cable upstream 0 channel-width 3200000
 cable upstream 0 minislot-size 22
 cable upstream 0 modulation-profile 2
 no cable upstream 0 shutdown

!--- Output suppressed.

 cable dhcp-giaddr policy
 hccp 2 working 1

!--- This is Working member 1 of HCCP Group 2.

 hccp 2 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 55100000 1

!--- This is the IP address of the Switch and of member 1 of Group 2, which has a
!--- bitmap of 55100000 in Switch slot 1.

 hccp 2 reverttime 120
!
interface Cable8/1/2

!--- This is the Working interface for the third HCCP group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.3.1 255.255.255.0
 ip rip send version 2
 ip rip receive version 2
 keepalive 1
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000
 cable downstream channel-id 2
 no cable downstream rf-shutdown
 cable upstream 0 frequency 24000000
 cable upstream 0 power-level 0
 cable upstream 0 connector 8
 cable upstream 0 channel-width 3200000
 cable upstream 0 minislot-size 2
 cable upstream 0 modulation-profile 22
 no cable upstream 0 shutdown
 cable dhcp-giaddr policy

!--- Output suppressed.

 hccp 3 working 1

!--- This is Working member 1 of HCCP Group 3.

 hccp 3 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 00c80000 1
 hccp 3 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 00c00000 1
 hccp 3 reverttime 120
!
interface Cable8/1/3

!--- This is the Working interface for the fourth HCCP group.

 hccp 4 working 1
 hccp 4 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 AA200000 1
 hccp 4 reverttime 120
!
interface Cable8/1/4

!--- This is the Working interface for the fifth HCCP group.

 hccp 5 working 1
 hccp 5 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 55100000 1
 hccp 5 reverttime 120
!
ip classless
no ip http server
!
no cdp run
snmp-server community private RW

!--- This does not affect the HCCP communications between the Switch and 10K.

snmp-server enable traps cable
no cdp run
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
alias exec t configure terminal
alias exec scm show cable modem
alias exec scr sh cab mode remote
alias exec shb sh hccp br
alias exec shd sh hccp detail
alias exec shc sh hccp chan
!
line con 0
 logging synchronous
line aux 0
 no exec
 transport input all

!--- The three previous lines are used to console from the Auxiliary port of the 10K
!--- to the Switch.

line vty 0 4
 session-timeout 400
 password xx
 login
endBuilding configuration...

Scenario 5

Sample configuration for 5x20 line cards in 4+1 mode with one RF Switch.

Figure 4 – uBR10K with MC5x20 and 1 RF Switch (4+1)

ha_mc5x20_d.gif

RF Switch

IP Address 10.1.1.10
SNMP Community Private
Protection Mode 4
Bitmap Group1 0x44440400
Group2 0x11110100
Group3 0x00005000
Group4 0x0000a080
Group5 0x88880800
Group6 0x22220200

Figure 5 – Bitmap

ha_mc5x20_e.gif

The next sample configuration is for 4+1 high availability for five MC5x20 cards with one uBR-RFSW in the 4+1 Protect mode. The Protection mode affects the bitmaps of the Switch and the cable modem termination system (CMTS) configuration. If you add one more 5x20, the whole thing must be changed.

Refer to the cabling in Cabling Cisco uBR 3x10 RF Switches to Cisco uBR10-MC5X20S/U Cable Interface Line Cards in a Cisco uBR10012 CMTS.

  1. Take the header that says RF Switch 2 (top Switch) and leave in slots 1, 2, 3, and 4.

  2. Take the header that says RF Switch 1 and place in slots 5, 6, 7, and 8 of RF Switch 2.

  3. Take the Protect from RF Switch 2 and put it in Protect 2.

  4. Take the Protect from RF Switch 1 and put it in Protect 1 of RF Switch 2.

  5. Once you get to five working 5x20 cards, the bitmap configuration must be changed and the headers must be moved around, from one RF Switch to the other.

    For example, the slot 5 header of RF Switch 2 will move to the slot 1 header of RF Switch 1.

The configuration is labeled rfswa, as it pertains to slots 1 through 4 and their respective Protect slot, which is Protect 2. Protect 1 covers slots 5 through 8 on the RF Switch, and it is labeled rfswb. In the 4+1 mode, the RF Switch slots 5 through 8 are considered to be slots 1 through 4 for configuration purposes.

Substitute your RF Switch IP address for the one that is shown in the next example (10.10.10.10).

4+1 Working Configuration
interface c7/1/0
hccp 1 working 1
hccp 1 channel-switch 1 rfswa rfswitch-group 10.10.10.10 44440400 1
interface c7/1/1
hccp 2 working 1
hccp 2 channel-switch 1 rfswa rfswitch-group 10.10.10.10 11110100 1
interface c7/1/2
hccp 3 working 1
hccp 3 channel-switch 1 rfswa rfswitch-group 10.10.10.10 00005000 1
hccp 3 channel-switch 1 rfswb rfswitch-group 10.10.10.10 0000a080 1

!--- Prepended 0s will not show up when you execute a show run
!--- command. Do not blindly copy and paste an interface
!--- configuration.

interface c7/1/3
hccp 4 working 1
hccp 4 channel-switch 1 rfswb rfswitch-group 10.10.10.10 88880800 1
interface c7/1/4
hccp 5 working 1
hccp 5 channel-switch 1 rfswb rfswitch-group 10.10.10.10 22220200 1
-------------------------------------------------------------------
interface c6/0/0
hccp 1 working 2
hccp 1 channel-switch 2 rfswa rfswitch-group 10.10.10.10 44440400 2
interface c6/0/1
hccp 2 working 2
hccp 2 channel-switch 2 rfswa rfswitch-group 10.10.10.10 11110100 2
interface c6/0/2
hccp 3 working 2
hccp 3 channel-switch 2 rfswa rfswitch-group 10.10.10.10 00005000 2
hccp 3 channel-switch 2 rfswb rfswitch-group 10.10.10.10 0000a080 2
interface c6/0/3
hccp 4 working 2
hccp 4 channel-switch 2 rfswb rfswitch-group 10.10.10.10 88880800 2
interface c6/0/4
hccp 5 working 2
hccp 5 channel-switch 2 rfswb rfswitch-group 10.10.10.10 22220200 2
-------------------------------------------------------------------
interface c6/1/0
hccp 1 working 3
hccp 1 channel-switch 3 rfswa rfswitch-group 10.10.10.10 44440400 3
interface c6/1/1
hccp 2 working 3
hccp 2 channel-switch 3 rfswa rfswitch-group 10.10.10.10 11110100 3
interface c6/1/2
hccp 3 working 3
hccp 3 channel-switch 3 rfswa rfswitch-group 10.10.10.10 00005000 3
hccp 3 channel-switch 3 rfswb rfswitch-group 10.10.10.10 0000a080 3
interface c6/1/3
hccp 4 working 3
hccp 4 channel-switch 3 rfswb rfswitch-group 10.10.10.10 88880800 3
interface c6/1/4
hccp 5 working 3
hccp 5 channel-switch 3 rfswb rfswitch-group 10.10.10.10 22220200 3
-------------------------------------------------------------------
interface c5/0/0
hccp 1 working 4
hccp 1 channel-switch 4 rfswa rfswitch-group 10.10.10.10 44440400 4
interface c5/0/1
hccp 2 working 4
hccp 2 channel-switch 4 rfswa rfswitch-group 10.10.10.10 11110100 4
interface c5/0/2
hccp 3 working 4
hccp 3 channel-switch 4 rfswa rfswitch-group 10.10.10.10 00005000 4
hccp 3 channel-switch 4 rfswb rfswitch-group 10.10.10.10 0000a080 4
interface c5/0/3
hccp 4 working 4
hccp 4 channel-switch 4 rfswb rfswitch-group 10.10.10.10 88880800 4
interface c5/0/4
hccp 5 working 4
hccp 5 channel-switch 4 rfswb rfswitch-group 10.10.10.10 22220200 4

Protect Interface Configurations
interface c5/1/0
hccp 1 protect 1 10.10.10.1
hccp 1 channel-switch 1 rfswa rfswitch-group 10.10.10.10 44440400 1
hccp 1 protect 2 10.10.10.1
hccp 1 channel-switch 2 rfswa rfswitch-group 10.10.10.10 44440400 2
hccp 1 protect 3 10.10.10.1
hccp 1 channel-switch 3 rfswa rfswitch-group 10.10.10.10 44440400 3
hccp 1 protect 4 10.10.10.1
hccp 1 channel-switch 4 rfswa rfswitch-group 10.10.10.10 44440400 4
-------------------------------------------------------------------
interface c5/1/1
hccp 2 protect 1 10.10.10.1
hccp 2 channel-switch 1 rfswa rfswitch-group 10.10.10.10 11110100 1
hccp 2 protect 2 10.10.10.1
hccp 2 channel-switch 2 rfswa rfswitch-group 10.10.10.10 11110100 2
hccp 2 protect 3 10.10.10.1
hccp 2 channel-switch 3 rfswa rfswitch-group 10.10.10.10 11110100 3
hccp 2 protect 4 10.10.10.1
hccp 2 channel-switch 4 rfswa rfswitch-group 10.10.10.10 11110100 4
-------------------------------------------------------------------
interface c5/1/2
hccp 3 protect 1 10.10.10.1
hccp 3 channel-switch 1 rfswa rfswitch-group 10.10.10.10 00005000 1
hccp 3 channel-switch 1 rfswb rfswitch-group 10.10.10.10 0000a080 1
hccp 3 protect 2 10.10.10.1
hccp 3 channel-switch 2 rfswa rfswitch-group 10.10.10.10 00005000 2
hccp 3 channel-switch 2 rfswb rfswitch-group 10.10.10.10 0000a080 2
hccp 3 protect 3 10.10.10.1
hccp 3 channel-switch 3 rfswa rfswitch-group 10.10.10.10 00005000 3
hccp 3 channel-switch 3 rfswb rfswitch-group 10.10.10.10 0000a080 3
hccp 3 protect 4 10.10.10.1
hccp 3 channel-switch 4 rfswa rfswitch-group 10.10.10.10 00005000 4
hccp 3 channel-switch 4 rfswb rfswitch-group 10.10.10.10 0000a080 4
-------------------------------------------------------------------
interface c5/1/3
hccp 4 protect 1 10.10.10.1
hccp 4 channel-switch 1 rfswb rfswitch-group 10.10.10.10 88880800 1
hccp 4 protect 2 10.10.10.1
hccp 4 channel-switch 2 rfswb rfswitch-group 10.10.10.10 88880800 2
hccp 4 protect 3 10.10.10.1
hccp 4 channel-switch 3 rfswb rfswitch-group 10.10.10.10 88880800 3
hccp 4 protect 4 10.10.10.1
hccp 4 channel-switch 4 rfswb rfswitch-group 10.10.10.10 88880800 4
-------------------------------------------------------------------
interface c5/1/4
hccp 5 protect 1 10.10.10.1
hccp 5 channel-switch 1 rfswb rfswitch-group 10.10.10.10 22220200 1
hccp 5 protect 2 10.10.10.1
hccp 5 channel-switch 2 rfswb rfswitch-group 10.10.10.10 22220200 2
hccp 5 protect 3 10.10.10.1
hccp 5 channel-switch 3 rfswb rfswitch-group 10.10.10.10 22220200 3
hccp 5 protect 4 10.10.10.1
hccp 5 channel-switch 4 rfswb rfswitch-group 10.10.10.10 22220200 4

These configurations are for MAC interface failovers, but keep in mind that a whole JIB (application-specific integrated circuit [ASIC]) will fail together. DSs 0 and 1 share the same ASIC, DSs 2 and 3 share the same ASIC, and DS 4 is on its own ASIC. If an interface does not have HCCP configured, then it will not failover, even if it shares the same ASIC.

If you configure cab upstream max hosts x and or cab u4 connector y , then you have configured a VI (virtual interface), also known as configurable MAC domains. Now, the entire linecard will failover as a bundle when you have any interface failure. If connector commands are deleted, the only way to undo the virtual interface affect on failovers is to reload the router.

8+1 Sample Configuration
uBR10012-1# show run

Current configuration : 8567 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname uBR10k
!
boot system flash slot0: ubr10k-k8p6-mz.122-15.BC1
logging rate-limit console all 10 except critical
enable secret 5 $1$.Dvy$fcPOhshUNjyfePH73FHRG
cable modulation-profile 21 request 0 16 0 22 qpsk scrambler 152 no-diff 32 fixed
cable modulation-profile 21 initial 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 21 station 5 34 0 48 qpsk scrambler 152 no-diff 64 fixed
cable modulation-profile 21 short 3 76 12 22 qpsk scrambler 152 no-diff 64 shortened
cable modulation-profile 21 long 9 232 0 22 qpsk scrambler 152 no-diff 64 shortened
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file docsis.cm
 frequency 453000000
 service-class 1 max-upstream 10000
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1522
!
redundancy
  main-cpu
    auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1gigethernet-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 2/1 2cable-tccplus
card 5/0 5cable-mc520s-d
card 5/1 5cable-mc520s-d
card 6/0 5cable-mc520s-d
card 6/1 5cable-mc520s-d
card 7/0 5cable-mc520s-d
card 7/1 5cable-mc520s-d
card 8/0 5cable-mc520s-d
card 8/1 5cable-mc520s-d
ip subnet-zero
ip host rfswitch 2001 10.10.10.1

!--- This is set for console access from the 10K to the Switch.
!--- The IP address is for Loopback0.

ip dhcp pool MODEMS1
   network 172.25.1.0 255.255.255.0
   bootfile docsis.cm
   next-server 172.25.1.1
   default-router 172.25.1.1
   option 7 ip 172.25.1.1
   option 4 ip 172.25.1.1
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp pool MODEMS2
   network 172.25.2.0 255.255.255.0
   bootfile docsis.cm
   next-server 172.25.2.1
   default-router 172.25.2.1
   option 7 ip 172.25.2.1
   option 4 ip 172.25.2.1
   option 2 hex 0000.0000
   lease 2 3 4
!
ip dhcp-client network-discovery informs 2 discovers 2 period 15

!--- An internal DHCP server was used for testing instead of external servers
!--- (cable helper, TOD, TFTP, and so forth). External servers are recommended
!--- in a “real” production network.

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.252
!
interface FastEthernet0/0/0
 ip address 10.97.1.8 255.255.255.0
 ip rip receive version 2
 no ip split-horizon
 no keepalive
!
interface GigabitEthernet1/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto
!

N+1 Sample Interface Configuration

!--- This assumes rfsw2 is on the top, as shown in the cable reference guide.
!--- Other interfaces will be the same, except a different member number for each
!--- HCCP group.

interface Cable5/1/0

!--- This is the Protect for the first group. It may be best to configure the Protect
!--- interface(s) last, after the Working interfaces are configured, or keep the
!--- interface “shut” until finished with all configurations.

 no ip address

!-- No need to set the IP address because it will come from the Working card via SNMP.

 no keepalive

!--- This defaults to 10 seconds with the N+1 Cisco IOS code, but it should be disabled
!--- on the Protect interface or set relatively high.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32

!--- The DS modulation and Interleave must be the same on Protect and Working
!--- of the same group. The Protect interface itself must be “no shut” for HCCP
!--- to activate.

 cable downstream rf-shutdown
 cable upstream 0 shutdown

!--- These will automatically become “no shut” when a failover occurs.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 hccp 1 protect 1 10.10.10.1

!--- This is the HCCP first group and it is protecting member 1 with member one’s
!--- FE IP address. If it is intra-chassis, you can use the Loopback0 IP address.

 hccp 1 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 AA200000 1

!--- This is the IP address of the Switch and it is protecting member 1,
!--- which has a bitmap of AA200000 in Switch slot 1.

 hccp 1 protect 2 10.10.10.1

!--- This is the HCCP first group and it is protecting member 2 with the loopback
!--- IP address.

 hccp 1 channel-switch 2 rfsw2 rfswitch-group 10.97.1.20 AA200000 2

!--- This is the IP address of the Switch and it is protecting member 2,
!--- with a bitmap of AA200000 in Switch slot 2.

 hccp 1 protect 3 10.10.10.1
 hccp 1 channel-switch 3 rfsw2 rfswitch-group 10.97.1.20 AA200000 3
 hccp 1 protect 4 10.10.10.1
 hccp 1 channel-switch 4 rfsw2 rfswitch-group 10.97.1.20 AA200000 4
 hccp 1 protect 5 10.10.10.1
 hccp 1 channel-switch 5 rfsw2 rfswitch-group 10.97.1.20 AA200000 5
 hccp 1 protect 6 10.10.10.1
 hccp 1 channel-switch 6 rfsw2 rfswitch-group 10.97.1.20 AA200000 6
 hccp 1 protect 7 10.10.10.1
 hccp 1 channel-switch 7 rfsw2 rfswitch-group 10.97.1.20 AA200000 7

!--- These channel-switch configurations can be copied and pasted into their
!--- respective Working interfaces.

 hccp 1 timers 5000 15000

!--- hccp 1 timers <hellotime> <holdtime>
!--- This is mostly for inter chassis communication, so set it high for the 10K
!--- as this can create extra CPU load.

 no hccp 1 revertive
!
interface Cable5/1/1

!--- This is the Protect for the second group.

 no ip address
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream rf-shutdown
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 !
 hccp 2 protect 1 10.10.10.1
 hccp 2 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 55100000 1

!--- Because this MAC domain is on right side of header, the bitmap in hexadecimal
!--- code is 55100000.

 hccp 2 protect 2 10.10.10.1
 hccp 2 channel-switch 2 rfsw2 rfswitch-group 10.97.1.20 55100000 2
 hccp 2 protect 3 10.10.10.1
 hccp 2 channel-switch 3 rfsw2 rfswitch-group 10.97.1.20 55100000 3
 hccp 2 protect 4 10.10.10.1
 hccp 2 channel-switch 4 rfsw2 rfswitch-group 10.97.1.20 55100000 4
 hccp 2 protect 5 10.10.10.1
 hccp 2 channel-switch 5 rfsw2 rfswitch-group 10.97.1.20 55100000 5
 hccp 2 protect 6 10.10.10.1
 hccp 2 channel-switch 6 rfsw2 rfswitch-group 10.97.1.20 55100000 6
 hccp 2 protect 7 10.10.10.1
 hccp 2 channel-switch 7 rfsw2 rfswitch-group 10.97.1.20 55100000 7
 hccp 2 timers 5000 15000
 no hccp 2 revertive

interface Cable5/1/2

!--- This is the Protect for the third group.

 no ip address
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream rf-shutdown
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 hccp 3 protect 1 10.10.10.1
 hccp 3 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 00C80000 1
 hccp 3 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 00C00000 1

!--- Because the third MAC domain will traverse both Switches, two statements are
!--- needed. The “00” in front of the bitmaps will be dropped when viewing the
!--- running configuration.

 no hccp 3 revertive

interface Cable5/1/3

!--- This is the Protect for the fourth group.

 hccp 4 protect 1 10.10.10.1
 hccp 4 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 AA200000 1
 hccp 4 protect 2 10.10.10.1
 hccp 4 channel-switch 2 rfsw1 rfswitch-group 10.97.1. 19 AA200000 2
 hccp 4 protect 3 10.10.10.1
 hccp 4 channel-switch 3 rfsw1 rfswitch-group 10.97.1. 19 AA200000 3
 hccp 4 protect 4 10.10.10.1
 hccp 4 channel-switch 4 rfsw1 rfswitch-group 10.97.1. 19 AA200000 4
 hccp 4 protect 5 10.10.10.1
 hccp 4 channel-switch 5 rfsw1 rfswitch-group 10.97.1. 19 AA200000 5
 hccp 4 protect 6 10.10.10.1
 hccp 4 channel-switch 6 rfsw1 rfswitch-group 10.97.1. 19 AA200000 6
 hccp 4 protect 7 10.10.10.1
 hccp 4 channel-switch 7 rfsw1 rfswitch-group 10.97.1. 19 AA200000 7
 no hccp 4 revertive

interface Cable5/1/4

!--- This is the Protect for the fifth group.

 hccp 5 protect 1 10.10.10.1
 hccp 5 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 55100000 1
 hccp 5 protect 2 10.10.10.1
 hccp 5 channel-switch 2 rfsw1 rfswitch-group 10.97.1. 19 55100000 2
 hccp 5 protect 3 10.10.10.1
 hccp 5 channel-switch 3 rfsw1 rfswitch-group 10.97.1. 19 55100000 3
 hccp 5 protect 4 10.10.10.1
 hccp 5 channel-switch 4 rfsw1 rfswitch-group 10.97.1. 19 55100000 4
 hccp 5 protect 5 10.10.10.1
 hccp 5 channel-switch 5 rfsw1 rfswitch-group 10.97.1. 19 55100000 5
 hccp 5 protect 6 10.10.10.1
 hccp 5 channel-switch 6 rfsw1 rfswitch-group 10.97.1. 19 55100000 6
 hccp 5 protect 7 10.10.10.1
 hccp 5 channel-switch 7 rfsw1 rfswitch-group 10.97.1. 19 55100000 7

!--- Output suppressed.

!
interface Cable8/1/0

!--- This is the Working for the first group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.1.1 255.255.255.0

!--- Interface bundling is supported as well as subinterfaces.

 ip rip send version 2
 ip rip receive version 2
 keepalive 1

!--- The keepalive time is in seconds and the default is 10 seconds for HCCP code.
!--- Only set this when modems have stabilized.

 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000

!--- This is DS frequency, which must be set for the internal upconverter to operate.

 cable downstream channel-id 0
 no cable downstream rf-shutdown

!--- This is needed to turn on the DS RF output.

 cable upstream 0 frequency 24000000

!--- If you are doing dense mode combining, the upstream frequencies must be different.
!--- If no two US ports are shared, then the same frequency can be used.

 cable upstream 0 power-level 0
 cable upstream 0 connector 0

!--- This is a new command for virtual interfaces, where USs can be used for different
!--- DS MAC domains.

 cable upstream 0 channel-width 3200000
 cable upstream 0 minislot-size 2
 cable upstream 0 modulation-profile 21
 no cable upstream 0 shutdown

!--- Output suppressed.

 cable dhcp-giaddr policy

!--- This tells CMs to get an IP address from the primary scope and
!--- tells CPEs to use the secondary scope.

 hccp 1 working 1

!--- This is Working member 1 of HCCP Group 1.

hccp 1 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 AA200000 1

!--- This is the IP address of Switch and member 1, which has a bitmap of
!--- AA200000 in Switch slot 1.

 hccp 1 reverttime 120

!--- This is the time in minutes (plus 2 minute suspend) for the card to switch back
!--- to normal mode, if the fault has cleared. If a fault was initiated by a keepalive
!--- and you had a fault on the Protect card, it would revert back after the suspend
!--- time and not wait the full revert time.

!
interface Cable8/1/1

!--- This is the Working interface for the second HCCP group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.2.1 255.255.255.0
 ip rip send version 2
 ip rip receive version 2
 keepalive 1
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000
 cable downstream channel-id 1
 no cable downstream rf-shutdown
 cable upstream 0 frequency 24000000
 cable upstream 0 power-level 0
 cable upstream 0 connector 4
 cable upstream 0 channel-width 3200000
 cable upstream 0 minislot-size 22
 cable upstream 0 modulation-profile 21
 no cable upstream 0 shutdown

!--- Output suppressed.

 cable dhcp-giaddr policy
 hccp 2 working 1

!--- This is Working member 1 of HCCP Group 2.

 hccp 2 channel-switch 1 rfsw2 rfswitch-group 10.97.1.20 55100000 1

!--- This is the IP address of the Switch and Member 1 of Group 2, which has a bitmap
!--- of 55100000 in Switch slot 1.

 hccp 2 reverttime 120
!
interface Cable8/1/2

!--- This is the Working interface for the third HCCP group.

 ip address 10.192.5.1 255.255.255.0 secondary
 ip address 172.25.3.1 255.255.255.0
 ip rip send version 2
 ip rip receive version 2
 keepalive 1
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 453000000
 cable downstream channel-id 2
 no cable downstream rf-shutdown
 cable upstream 0 frequency 24000000
 cable upstream 0 power-level 0
 cable upstream 0 connector 8
 cable upstream 0 channel-width 3200000
 cable upstream 0 minislot-size 2
 cable upstream 0 modulation-profile 21
 no cable upstream 0 shutdown
 cable dhcp-giaddr policy

!--- Output suppressed.

 hccp 3 working 1

!--- This is Working member 1 of HCCP Group 3.

 hccp 3 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 00c80000 1
 hccp 3 channel-switch 1 rfsw2 rfswitch-group 10. 97.1.20 00c00000 1
 hccp 3 reverttime 120

interface Cable8/1/3

!---This is the Working interface for the fourth HCCP group.

 hccp 4 working 1
 hccp 4 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 AA200000 1
 hccp 4 reverttime 120

interface Cable8/1/4

!--- This is the Working interface for the fifth HCCP group.

 hccp 5 working 1
 hccp 5 channel-switch 1 rfsw1 rfswitch-group 10.97.1.19 55100000 1
 hccp 5 reverttime 120

!
ip classless
no ip http server
!
no cdp run
snmp-server community private RW

!--- This does not affect the HCCP communications between the Switch and 10K,
!--- unless it is changed.

snmp-server enable traps cable
no cdp run
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
alias exec t configure terminal
alias exec scm show cable modem
alias exec scr sh cab mode remote
alias exec shb sh hccp br
alias exec shd sh hccp detail
alias exec shc sh hccp chan
!
line con 0
 logging synchronous
line aux 0
 no exec
 transport input all

!--- The three lines above were used to console from the Auxiliary port of the 10K
!--- to the Switch.

line vty 0 4
 session-timeout 400
 password xx
 login
endBuilding configuration...

Related Information

Updated: Oct 04, 2005
Document ID: 49776