Guest

Cable Modem Termination Systems (CMTS)

Configuring cable modem remote-query Command

Cisco - Configuring Cable Modem Remote-query Command

Document ID: 12209

Updated: May 23, 2006

   Print

Introduction

The cable modem remote-query command was introduced in Cisco IOS® Software Release 12.0(7)XR and 12.1(2)T. This command allows you to query the cable modem (CM) performance statistics directly from the uBR Cable Modem Termination System (CMTS).

The idea is to poll the CMs periodically using Simple Network Management Protocol (SNMP), and to cache information, such as IP address, MAC address, S/N ratio, and Upstream Transmit Power on the CMTS (see output). This helps you know the state of a single modem, and have an overall status of the plant.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on this software version:

  • IOS Software Release 12.0(7)XR and 12.1(2)T

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

On the cable modem, an SNMP community string must be configured. This is performed using one of these methods:

  • Manual configuration: add the snmp-server community<string> global configuration command

  • Force the CM to download an IOS config file via Data-over-Cable Service Interface Specifications (DOCSIS) configuration file

  • Configure the CM community via SNMP Object IDentifiers (OIDs) defined in the DOCSIS config file

On the CMTS, configure these global configuration commands:

  1. snmp-server community<community string>

  2. snmp-server manager

Note: In 12.2(33)SC, you cannot configure snmp-server community <community string> RO after configuring cable modem remote-query <community string> . It is redundant because IOS automatically adds the community noted in cable modem remote <community string> as an SNMP RO <community string> community. When you try to configure, you will get the error message which says %Error: Community <Name> already exists and is used for cable modem remote-query, configure new community string for SNMP management.

The cable modem remote-query [polling interval] [Community string] is where [polling interval] defines the time interval at which the query is performed. For example, 30 means that the query is performed every 30 seconds. [Community string] defines the community string.

When configuring cable remote-query, all the community strings have to match:

  • the snmp-server community string configured on the CM

  • the snmp-server community string configured on the CMTS

  • the snmp community string configured in the cable modem remote-query [polling interval] [Community string] command


Current configuration : 3473 bytes 

! 

version 12.1 

service timestamps debug uptime 

service timestamps log uptime 

no service password-encryption 

! 

hostname big-cmts 

! 

! 

cable modem remote-query 30 test 



!--- This configures the CMTS to perform the remote 
!--- query every 30 seconds with a community string of test.
 

no cable qos permission create 

no cable qos permission update 

cable qos permission modems 

cable time-server 

ip subnet-zero 

no ip finger 

no ip domain-lookup 

ip dhcp relay information option 

no ip dhcp relay information check 

! 

interface Ethernet2/0 

ip address 10.200.68.3 255.255.255.0 

! 

interface Cable3/0 

ip address 10.200.71.17 255.255.255.240 secondary 

    

ip address 10.200.71.1 255.255.255.240 

no keepalive 

cable downstream annex B 

cable downstream modulation 64qam 

cable downstream interleave-depth 32 

cable upstream 0 frequency 20000000 

cable upstream 0 power-level 0 

no cable upstream 0 shutdown 

cable dhcp-giaddr policy 

cable helper-address 10.200.68.200 

! 

ip classless 

ip route 0.0.0.0 0.0.0.0 10.200.68.1 

no ip http server 

! 

snmp-server community test RO 



!--- The community string has to match the one 
!--- set on the CM and the one configured above in the cable modem remote-query 
!--- command.


snmp-server manager
 


!--- Needed to configure the CMTS as SNMP manager 
!--- so that is is able to generate requests to the SNMP agents on the CM.
 
    

line con 0 

transport input none 

line aux 0 

line vty 0 4 

login 

! 

end 

For the CMs, configure the factory defaults with the addition of the global command snmp-server community test RO.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Verify

This is the output of the information collected:

big-cmts#show cable modem remote-query 

IP address      MAC address     S/N    US     DS    Tx Time Micro (dB) Modem 
                               Ratio  Power  Power Offset  Reflection State 

10.200.71.8     0001.9659.47af  36.6   31.0    0.0  12352   17        online 
10.200.71.4     0001.9659.47c7  36.6   37.0    0.0  12352   17        online 
10.200.71.6     0001.9611.b9a3  36.6   37.0    0.0  12353   15        online 
10.200.71.3     0001.9659.47a9  36.6   37.0    0.0  12351   16        online 
10.200.71.2     0001.9659.47c1   0.0    0.0    0.0  0       0         online 


!--- This modem does not answer to the SNMP query.


If the modem does not answer to SNMP query, you need some debugs to verify:

big-cmts#debug cable remote-query 

CMTS remote-query debugging is on 

*Sep 26 01:30:41.677: 

For IP address 10.200.71.2 



!--- The IP address of the modem showing all 0s in the show cable modem remote-query
!--- command output.
 

*Sep 26 01:30:41.677: 


!--- SNMP proxy exec got event, but the queue is empty. 


The preceding message indicates the modem has been queried, but no answer has been received. To receive further detail, view the SNMP level:

big-cmts#show snmp sessions 

Destination: 10.200.71.2.161, V1 community: test 


!--- "V1": SNMP version - "test": community string used to query the modem.


  Round-trip-times: 0/0/0 (min/max/last) 

  packets output 

    2147 Gets, 0 GetNexts, 0 GetBulks, 0 Sets, 0 Informs 


!--- Number of SNMP GETS issued to the modem.
 

    2146 Timeouts, 0 Drops 


!--- All the SNMP GETS timed out.
 

  packets input 

    0 Traps, 0 Informs, 0 Responses (0 errors)

This is the debug cable remote-query command output for a modem answering to remote-query:

*Sep 26 01:30:49.709: 

For IP address 10.200.71.8 

*Sep 26 01:30:49.713:  docsIfSignalQualityEntry.5.3 = 366 

*Sep 26 01:30:49.713:  docsIfMibObjects.2.2.1.3.2 = 310 

*Sep 26 01:30:49.717:  docsIfDownstreamChannelEntry. 6.3 = 0 

*Sep 26 01:30:49.717:  docsIfUpstreamChannelEntry.6. 4 = 12352 

*Sep 26 01:30:49.721:  docsIfSignalQualityEntry.6.3 = 17

This is the SNMP session detail for the same modem. Notice that the number of Gets equals the number of responses with no Timeouts or Drops:

Destination: 10.200.71.8.161, V1 community: test, Expires in 581 secs 

  Round-trip-times: 1/1/1 (min/max/last) 

  packets output 

    5421 Gets, 0 GetNexts, 0 GetBulks, 0 Sets, 0 Informs 

    0 Timeouts, 0 Drops 

  packets input 

    0 Traps, 0 Informs, 5421 Responses (0 errors)

This output shows a mismatch in the community strings defined for the remote-query, and in the CMTS snmp-server community line:

big-cmts#sh snmp 

Chassis: 6888364 

0 SNMP packets input 

    0 Bad SNMP version errors 

    30 Unknown community name 


!--- Community string mismatch.


    0 Illegal operation for community name supplied 

    0 Encoding errors 

    0 Number of requested variables 

    0 Number of altered variables 

    0 Get-request PDUs 

    0 Get-next PDUs 

    0 Set-request PDUs 

3944 SNMP packets output 

    0 Too big errors (Maximum packet size 1500) 

    0 No such name errors 

    0 Bad values errors 

    0 General errors 

    0 Response PDUs 

    0 Trap PDUs 


Troubleshoot

The most common problem is that changing the cable modem remote-query [polling interval] [Community string] command parameters causes it to fail. It is recommended to perform these steps:

  1. Remove the command with no cable modem remote-query.

  2. Reinstate the command.

Another problem is when changing the community string defined with the command snmp-server community <string>. It is recommended to perform these steps:

  1. Remove the cable modem remote-query [polling interval] [Community string] command.

  2. Change the community string.

  3. Reinstate the cable modem remote-query [polling interval] [Community string] command.

Related Information

Updated: May 23, 2006
Document ID: 12209