Guest

Cable Modem Termination Systems (CMTS)

CMTS Configuration FAQ

Document ID: 12180

Updated: Oct 04, 2005

   Print

Introduction

This document answers some frequently asked questions on Cable Modem Termination Systems (CMTS).

Q. What is a basic sample configuration for a cable interface on a Cisco uBR7200 Series?

A. Here is a sample configuration:

interface Cable4/0 
 ip address 10.1.1.1 255.255.0.0
 
!--- For the cm to talk to the CMTS. Usually this address is private.

 ! 
 ip address 200.1.1.1 255.255.0.0 secondary
 
!--- For the PCs to talk to the CMTS. Usually this address is public so 
 !--- that the PCs can go to the Internet.

 ! 
 load-interval 30 
 no ip directed-broadcast 
 cable helper-address 200.1.162.170 
 
!--- Specify the IP address of the DHCP server.

 no keepalive 
 cable downstream annex B

 !--- Default.

 cable downstream modulation 64qam

 !--- Default.
 
 cable downstream interleave-depth 32
 
 !--- Default.

 cable downstream frequency 525000000

 !--- This is cosmetic on uBR7200 but must match the upconverter for the 
 !--- uBR7200 platforms so that you know the exact value on the upconverter.

 Cable upstream 0 power-level 0 
 
 !--- Default.

 no cable upstream 0 shutdown  

 !--- Enables port Upstream 0. Enter this command to turn the port on.
 
 Cable upstream 0 frequency 37008000

 !--- Upstream frequency. Make sure that this frequency is set to a clean
 !--- part of the spectrum and is set after careful analysis of your cable 
 !--- plant.

 cable upstream 1 shutdown 
 cable upstream 2 shutdown 
 cable upstream 3 shutdown 
 cable upstream 4 shutdown 
 cable upstream 5 shutdown
 cable dhcp-giaddr policy

 !--- Enable cable DHCP giaddr functionality so that primary addresses 
 !--- are assigned to cable modems and secondary addresses are assigned
 !--- to remote hosts.

Q. What is a basic sample configuration for a cable interface on a Cisco uBR7100 Series?

A. Here is a sample configuration:

interface Cable1/0
 ip address 111.111.111.111 255.255.255.0 secondary

 !--- For the PCs to communicate with the CMTS. Usually this address  
 !--- is public so that the PCs can go to the Internet.

 ip address 10.4.1.1 255.255.255.0

 !--- For the cm to talk to the CMTS. Usually this address is private.

 cable downstream annex B

 !--- Default.
 
 cable downstream modulation 64qam

 !--- Default.

 cable downstream interleave-depth 32

 !--- Default.

 cable downstream frequency 525000000

 !--- Needs to be set to the center frequency of the downstream channel.
 
 no cable downstream rf-shutdown

 !--- Enables the integrated upconverter.

 cable downstream rf-power 51

 !--- Sets the RF power output level on the integrated upconverter 
 !--- (default=50dBmV).

 cable upstream 0 frequency 32000000

 !--- Upstream frequency, you need to make sure that this frequency is set 
 !--- to a clean part of the spectrum and is set after careful analysis
 !--- of your cable plant.

 cable upstream 0 power-level 0

 !--- Default.

 cable upstream 0 timing-adjust threshold 0

 !--- Default.

 cable upstream 0 timing-adjust continue 0

 !--- Default.

 no cable upstream 0 shutdown

 !--- Enables port upstream 0. Must enter this command to turn the port on.
 
 Cable upstream 1 timing-adjust threshold 0
 cable upstream 1 timing-adjust continue 0
 cable upstream 1 shutdown
 cable upstream 2 timing-adjust threshold 0
 cable upstream 2 timing-adjust continue 0
 cable upstream 2 shutdown
 cable upstream 3 timing-adjust threshold 0
 cable upstream 3 timing-adjust continue 0
 cable upstream 3 shutdown
 cable dhcp-giaddr policy

!--- Enable cable DHCP giaddr functionality so that primary addresses  
!--- are assigned to cable modems and secondary addresses are assigned
!--- to remote hosts.

!

Q. How do I configure the CMTS to run Time of Day (ToD), Trivial File Transfer Protocol (TFTP), and Dynamic Host Configuration Protocol (DHCP) all in one?

A. First, make sure that you have the latest 12.x EC version when you use the configuration in this section.

You do not need the cable helper address statement in your configuration because the DISCOVER packet does not need to be "helped" to another machine. The DISCOVER packet resides on the CMTS.

Here are two configuration files that were created inside the configuration of the uBR7200. One configuration file is called platinum.cm and the other file is called disable.cm. If you create the DOCSIS Configuration files in the CMTS, you do not need to copy the file to flash or use TFTP. With this configuration you do not need to have an external docsis configuration file.

   cable config-file disable.cm    
    access-denied 
    service-class 1 max-upstream 1 
    service-class 1 max-downstream 1600 
    cpe max 1 
    timestamp 
   ! 
   cable config-file platinum.cm 
    service-class 1 max-upstream 128 
    service-class 1 guaranteed-upstream 10 
    service-class 1 max-downstream 10000 
    service-class 1 max-burst 1600 
    cpe max 10 
    timestamp

Note: If the IP helper address command underneath the interface points to an external DHCP server that you have configured, the cable modems take the configurations from the external DHCP server.

Here is the policy for cable modems that dynamically pulls the platinum.cm configuration file:

ip dhcp pool cm-platinum 
  network 10.1.4.0 255.255.255.0 
  bootfile platinum.cm 
  next-server 10.1.4.1 
  default-router 10.1.4.1 
  option 7 ip 10.1.4.1 
  option 4 ip 10.1.4.1 
  option 2 hex ffff.8f80 
  lease 7 0 10

Here is the policy for the PCs to get addresses:

ip dhcp pool pcs-c4 
      network 172.16.29.0 255.255.255.224 
      next-server 172.16.29.1 
      default-router 172.16.29.1 
      dns-server 172.16.30.2 
      domain-name cisco.com 
      lease 7 0 10

Here is a static binding for the MAC address of a specific cable modem mapped to disable.cm:

ip dhcp pool cm-0010.7bed.9b45 
      host 10.1.4.65 255.255.255.0 
      client-identifier 0100.107b.ed9b.45 
      bootfile disable.cm  

Here is a static binding for the MAC address of a specific cable modem mapped to the silver.cm configuration file that resides in flash:

ip dhcp pool cm-0010.7bed.9b23 
      host 10.1.4.66 255.255.255.0 
      client-identifier 0100.107b.ed9b.23 
      bootfile silver.cm  

Use the tftp server slot0:silver.cm alias silver.cm statement when the .cm file resides in flash and not on the TFTP server.

Complete these steps in order to put the DOCSIS configuration file in the flash of your uBR72xx:

  1. On your uBR7200, type the copy tftp slot:0: command and press ENTER. The parser prompts you for the name of the remote host.
  2. Specify the address of the TFTP server where your .cm file resides. The parser prompts you for the Source Filename.
  3. Type the .cm filename and press ENTER.
  4. Type the show slot0: command to verify whether the DOCSIS configuration file is present, and check whether the size matches the size in your TFTP server.

Q. Can I configure Cisco CMTS as a bridge?

A. You cannot configure the uBR72xx series as a bridge. However, the uBR7100 series designed for the Hospitality industry supports bridging, so if you want to use static IP addresses on your laptop, you can connect to the Internet when you travel on business. Refer to Configuring the UBR 7100 in Bridge Mode for more information.

Q. Does the Cisco CMTS support PPPoE?

A. The Cisco uBR7200 series routers support Point-to-Point Protocol over Ethernet (PPPoE) Termination but not PPPoE forwarding. PPPoE Termination currently is available in Cisco IOS® Software Release 12.1(5)T.

PPPoE allows direct connection to cable interfaces. PPPoE provides service-provider digital-subscriber line (DSL) support. The support of PPPoE on cable interfaces of the Cisco uBR7200 series routers allows customer premises equipment (CPE) behind the cable modem to use PPP as a mechanism to get the IP addresses and use them for all subsequent data traffic, just like a dial-up PPP client. In a PPP dial-up session, the PPPoE session is authenticated and the IP address is negotiated between the PPPoE client and the server. The server can be either a Cisco uBR7200 series router or a Home Gateway. Refer to Configuring PPPoE Termination on a uBR7100 CMTS with L2TP Tunneling for more information.

Q. How do I configure Baseline Privacy in DOCSIS 1.0?

A. Here are the prerequisites for such configuration:

  • You must have K1 images on the CMs and CMTSs.

  • You must have a configuration file editor.

Complete these steps to enable baseline privacy on the configuration file editor:

  1. Open the CPE DOCSIS Configurator.
  2. If you use version V2.0.4 or version 3.0.a, edit the DOCSIS configuration file to change the value to 1 from 0 in the Baseline Privacy Enable field. 0 is the default value, which indicates that Baseline Privacy is not enabled.

    cable_faq_DOCSIS-configurator-bpi-enable.gif

    Remember these points:
    • The DOCSIS configuration file must reside in the tftpboot directory.

    • The tftpboot directory resides on the TFTP server.

    • The TFTP server is connected to the FE port of the CMTS or in the LAN of the CMTS.

    After the CM reboots, the CM loads your newly created DOCSIS configuration file parameters. The CM negotiates baseline privacy interface (BPI) with the CMTS. If you issue the show cable modem command, the CM appears registered as: online(PT) instead of just as online. If you do not see (PT), you need to double check to see if you indeed have K1 images on CM and the CMTS and enabled Class-of-Service Privacy to = 1. Refer to Building DOCSIS 1.0 Configuration Files Using Cisco DOCSIS Configurator ( registered customers only) for more information on how to use the CPE configurator V3.2 tool.

Q. How can I configure bundling on a Cisco CMTS?

A. Here is the basic bundling configuration:

hostname 7246VXR
 !
 interface Ethernet2/0
  ip address 172.16.135.11 255.255.255.128
  no ip mroute-cache
  half-duplex
 !

 interface Cable4/0
  ip address 172.16.30.1 255.255.255.0   

 !--- IP address configured.

  ip helper-address 172.16.135.20        

 !--- IP address of DHCP server.

  no ip route-cache cef
  no keepalive
  cable bundle 1 master                  

 !--- Master interface in bundle 1.

  cable downstream rate-limit token-bucket shaping
  cable downstream annex B
  cable downstream modulation 64qam
  cable downstream interleave-depth 32
  cable downstream frequency 555000000
  cable upstream 0 frequency 40000000
  cable upstream 0 power-level 0
  no cable upstream 0 shutdown
  cable upstream 1 shutdown
  cable upstream 2 shutdown
  cable upstream 3 shutdown
  cable upstream 4 shutdown
  cable upstream 5 shutdown
  cable dhcp-giaddr policy
 !
 interface Cable5/0
  no ip address
  load-interval 30
  no keepalive
  cable bundle 1                      

 !--- Slave interface in bundle 1.

  cable downstream rate-limit token-bucket shaping
  cable downstream annex B
  cable downstream modulation 64qam
  cable downstream interleave-depth 32
  cable downstream frequency 620000000
  cable upstream 0 frequency 25008000
  cable upstream 0 power-level 0
  cable upstream 0 channel-width 1600000 3200000
  no cable upstream 0 shutdown
  no cable upstream 1 shutdown
  no cable upstream 2 shutdown
  cable upstream 3 shutdown
  cable upstream 4 shutdown
  cable upstream 5 shutdown
  cable dhcp-giaddr policy

Refer to Bundling Cable Interfaces Sample Configuration and Verification for more information on how to verify and troubleshoot this configuration.

Related Information

Updated: Oct 04, 2005
Document ID: 12180