Guest

IP over ATM

Frequently Asked Questions About Bridging on ATM Interfaces

Document ID: 10405

Updated: Nov 15, 2007

   Print

Introduction

This document answers frequently asked questions about bridging over ATM router interfaces.

Q. Does the Gigabit Switch Router (GSR) support bridging?

A. No. The GSR runs Cisco IOS® Software Releases 12.0S and 11.2GS, which are designed to provide robust IP routing and enhanced IP services for the Internet Service Provider (ISP) community. They do not provide support for full bridging protocols such as transparent bridging or source route bridging, nor do they support integrated routing and bridging (IRB). However, you can use bridged-style permanent virtual circuits (BPVCs) to allow ATM line cards to connect to a Catalyst switch or to another remote device that supports bridged-format request for comments RFC 1483 leavingcisco.com PDUs only.

Q. Does the Catalyst 6000 FlexWAN support bridged-format RFC 1483 protocol data units (PDUs)?

A. Yes. The performance of this feature varies with your Cisco IOS Software Release, which determines whether such PVCs are supported in the software or hardware forwarding path.

Cisco IOS 12.1(13)E introduces hardware support RFC 1483 Bridged PDUs on the Cisco 7600 Series with a PA-A3 ATM port adapter and FlexWAN. Cisco recommends upgrading to this release to ensure maximum forwarding performance. In previous releases, RFC 1483 Bridged PDUs significantly reduces the forwarding performance of the Catalyst 6000 when using "IRB" and is not recommended.

If you cannot upgrade to Cisco IOS 12.1(13)E, an alternate solution is to use the OC-12 ATM module (WS-X6101) for the Catalyst 6000 Series to support strictly layer-2 applications such as bridged-format PDUs or LAN emulation (LANE). If you cannot use an OC-12 interface and your application is digital subscriber line (DSL) aggregation, use a Cisco 7200 or 7400 Series router running routed bridge encapsulation (RBE).

Cisco IOS 12.1(5a)E1 introduced support for RFC 1483 Bridged PDUs on the FlexWAN with the PA-A3. In this release, the cwan atm bridge hidden command is required. We recommend running Cisco IOS 12.1(11a)E1 or higher to avoid CSCdw22284 and CSCdw44684. The cwan atm bridge command is not needed when using Cisco IOS 12.1(13)E or newer.

RFC 1483 Bridged PDUs are supported in both Cisco IOS (Native IOS) and Hybrid Mode (MSFC) starting with Cisco IOS 12.1(13)E or newer software. The following table illustrates a sample configuration for RFC 1483 Bridged PDUs on the FlexWAN and PA-A3. Ensure that you map the correct VLAN to the correct PVC. This configuration is done in the distributed path of the FlexWAN.

Sample Configuration for RFC 1483 Bridged PDUs 12.1(13)E1 or Later
vlan 30 
! 
interface FastEthernet7/1 
 no ip address 
 duplex full 
 speed 100 
 switchport 
 switchport access vlan 30 
! 
interface ATM9/1/0 
 no ip address  
 mtu 4096
 atm bridge-enable 
  bandwidth 2000 
  pvc 0/39  
  bridge-vlan 30 
 encapsulation aal5snap 
! 
router rip 
 network 10.0.0.0 
 network 30.0.0.0 
! 

The ATM OC-12 Optical Services Module (OSM) for the Cisco 7600 Series also supports RFC 1483 bridging. For more information and a sample configuration, see Configuring the OC-12 ATM Optical Services Modules.

Q. Why don't the Catalyst 5000/6000 ATM modules bridge between two subinterfaces in the same virtual LAN (VLAN)?

A. The configuration guides for the ATM modules note the following restriction: If two PVCs are configured on the same VLAN and ATM module, packets received from one PVC are not forwarded to the other PVC. The reason has to do with the architecture of the modules. The WS-X515x series and the WS-X5166 use a unidirectional backplane interface chip that prevents the module from sending packets that it receives. The WS-X516x series uses two unidirectional backplane interface chips. However, it cannot send packets that it receives because of automatic echo suppression, which is enabled by default to avoid loops since the Spanning Tree logic in the Catalyst 5000 works per-port, per-VLAN and not on individual PVCs.

The workarounds are:

  • Use a full-mesh rather than a hub-and-spoke ATM PVC design.

  • Use a router configured with the standard Cisco IOS bridging. You must configure two different subinterfaces in the same bridge group to allow broadcasts and other traffic to pass between two remote hosts.

  • Use a route switch module (RSM), route switch feature card (RSFC), or multilayer switch feature card (MSFC). Terminate the PVCs on the router and then route or bridge between them.

Q. Do Cisco routers support RFC 1483 aal5mux bridged encapsulation format?

A. No. Virtual Circuit (VC)-based multiplexing requires that the encapsulated or carried protocol be manually configured on the ATM interface. Cisco supports the following protocols with aal5mux encapsulation:

7500-1(config-subif)#atm pvc 1 0 200 aal5mux ? 
     apollo     Apollo Domain 
     appletalk  AppleTalk 
     decnet     DECnet 
     ip         IP 
     ipx        Novell IPX 
     vines      Banyan VINES 
     xns        Xerox Network Services

With VC-based multiplexing, the network protocol carried across the ATM network is identified implicitly by the VC connecting the two ATM stations. That is, each protocol must be carried over a separate VC. This is not available on the Cisco 7600 with the ATM OSM.

Q. Will a router pass an 802.1Q header through an ATM interface?

A. No. In the following topology, the router will not preserve the 802.1Q label when bridging over the ATM link. The 802.1Q label is removed at the Ethernet interface.

atm_bridging_faq.gif

However, there is an alternate way to build end-to-end VLANs. Configure both routers with the same set of bridge groups and 802.1Q subinterfaces. In other words, the two router ends have a one-to-one mapping between a bridge-group and an 802.1Q subinterface. This is not applicable to the Cisco 7600.

Router Configuration for end-to-end VLANs
interface FastEthernet4/0 
no ip address 
! 
interface FastEthernet4/0.100 
 encapsulation dot1Q 100 
 bridge-group 1 
! 
interface atm 5/0.100 
 bridge-group 1

In addition, Cisco IOS now supports layer-2 virtual private networks (VPNs) to transparently carry a Layer 2 architecture across an ATM cloud. Any Transport over Multiprotocol Label Switching (AToM) is the Cisco solution for transporting Layer 2 packets over an Internet Protocol/Multiprotocol Label Switching (IP/MPLS) backbone. Atom extends the usability of IP networks by enabling the transport of Layer 2 frames over an MPLS backbone. AToM is required for supporting legacy services over MPLS infrastructures and for supporting several new connectivity options, including Layer 2 VPNs and Layer 2 virtual leased lines. For more information on AToM, see Overview - Cisco Any Transport over MPLS.

Cisco IOS Software Releases 12.0(10)ST/12.0(21)ST and 12.0(22)S introduce support for ATM Atom (AAL5 over MPLS) on Cisco 12000 Series ATM line cards. See MPLS AToM-ATM AAL5 over MPLS for more information. Cisco IOS Software Release 12.0(22)SY introduces ATM cell relay over MPLS on the 7200 Series and 7500 Series.

Related Information

Updated: Nov 15, 2007
Document ID: 10405