Guest

Cisco LocalDirector 400 Series

Configuring Standard and Statefull Failover in LocalDirector

Cisco - Configuring Standard and Statefull Failover in LocalDirector

Document ID: 15060

Updated: Jan 31, 2006

   Print

Introduction

The information in this Tech Note applies to all hardware and software versions of the Cisco LocalDirector in a failover configuration.

Two types of failover can be implemented in LocalDirector: standard failover and statefull failover. In standard (non-statefull) failover, all existing connection information is lost upon failover; however, statefull failover maintains session information, as well as sticky session information.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document applies to all hardware and software versions of the Cisco LocalDirector in a failover configuration.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Failover Commands

  • failover ip address ip_address —Sets the failover IP address. The ip_address argument indicates the IP address used by the standby unit to communicate with the active unit. Use this IP address with the ping command to check the status of the standby unit. This address must be on the same network as the system IP address. For example, if the system IP address is 192.168.1.1, set the failover IP address to 192.168.1.2.

  • failover [active]—Enables access to the optional failover feature. The optional active argument makes a LocalDirector the active unit.

  • replicate interface interface_number —Enables statefull failover, and specifies an interface for sending replication data. The interface_number argument indicates the number through which the active LocalDirector unit sends connection replication data to the standby unit. The default is interface 0.

  • failover alias ip address ip_address —Assigns a failover alias IP address. The IP address is used by the standby unit to communicate with the active unit.

  • failover reset—Takes a unit out of the failed state.

  • show failover—Shows LocalDirector failover status, cable status, primary and secondary host status, and interface descriptions.

  • shutdown ethernet | fddi interface_number —Disables an interface.

For more information, refer to The LocalDirector Command Reference.

Configurations

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

LocalDirector in Standard Failover

This is a basic configuration of LocalDirector in standard failover:

LocalDirector in Standard Failover
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 auto 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp 
: end 
[OK] 
localdirector(config)#

LocalDirector in Statefull Failover

Below is a sample configuration of LocalDirector in statefull failover. Statefull failover units share connection information for active connections and are configurable on a per-virtual basis. Each time the state of the Transmission Control Protocol (TCP) connection changes, the data is sent to the standby LocalDirector via LocalDirector-statefull protocol. This allows the current state of all the TCP sessions to be mirrored to the standby LocalDirector.

LocalDirector-statefull protocol uses User Datagram Protocol (UDP) packets to send the state changes to the Standby LocalDirector over the Ethernet interface. Use a separate Ethernet interface to send statefull failover messages. With statefull failover, there is no interruption of service to client. It is ideal for mission-critical applications and allows for high availability.

Note: This example uses interface Ethernet 2, which has a crossover between the two LocalDirectors to transfer state information. This example also uses these replicate commands:

replicate interface 2 
replicate 10.1.1.5:0:0:tcp

These commands tell LocalDirector to replicate the connection state from active to standby units across Ethernet 2 and also to replicate all state information from the virtual 10.1.1.5 to the standby unit.

LocalDirector in Statefull Failover
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
no shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 100full 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
replicate interface 2 
replicate 10.1.1.5:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp

Note: All interfaces initially are in waiting mode, meaning that network monitoring has not started. After network interfaces go into normal mode, network monitoring begins. This happens when LocalDirector-HELLO messages begin sending every five seconds.

If a 30-second interval passes with no LocalDirector-HELLO messages being received, units go into testing mode to determine which unit failed. If the serial cable is pulled, units will maintain their current role. If the unit does not pass a test, it will become failed and the other unit will become active. Every time the ?state? of the TCP connection changes, data is sent to the standby LocalDirector via LocalDirector-statefull protocol. The state of all the TCP sessions is mirrored to the Standby LocalDirector. If a virtual is changed to support statefull failover then state information for only the new connections is sent to the standby LocalDirector. LocalDirector statefull protocol does not copy the state of existing TCP sessions.

Verifying Failover Status

The show failover command can be used to display the current failover status of the units and their interfaces, as shown in this example:

Failover Off 
Cable status: My side not connected 
        This host: Secondary - Active 
                Active time: 1 weeks, 3 days, 1 hours, 2 minutes, 5 seconds 
                Interface 5 (10.86.16.225): Normal (Waiting) 
                Interface 4 (10.86.16.225): Normal (Waiting) 
                Interface 3 (10.86.16.225): Normal (Administratively down) 
                Interface 2 (10.86.16.225): Normal (Administratively down) 
                Interface 1 (10.86.16.225): Normal (Waiting) 
                Interface 0 (10.86.16.225): Normal (Waiting) 
        Other host: Secondary - Standby 
                Interface 5 (0.0.0.0): Normal (Waiting) 
                Interface 4 (0.0.0.0): Normal (Waiting) 
                Interface 3 (0.0.0.0): Normal (Administratively down) 
                Interface 2 (0.0.0.0): Normal (Administratively down) 
                Interface 1 (0.0.0.0): Normal (Waiting) 
                Interface 0 (0.0.0.0): Normal (Waiting)

This shows that hello packets are being passed back and forth between the two units and that two of the interafaces on the LDs have been shut down.

Related Information

Updated: Jan 31, 2006
Document ID: 15060