Guest

Cisco DistributedDirector

How to Configure HTTP-Redirect in DistributedDirector

Cisco - How to Configure HTTP-Redirect in DistributedDirector

Document ID: 15052

Updated: Jan 31, 2006

   Print

Introduction

This document provides a sample configuration for HTTP-redirect. The key command that identifies this is ip director ip-address. Although each DistributedDirector (DD) can support several Web sites, this document only covers a single Web site with one server each on the East and West Coast.

There are two modes of operation for Cisco DD:

  • behaving as a Domain Name Service (DNS) server and returning an IP address

  • behaving as a Web server and providing a HTTP-redirect

The concept behind both modes is to give the client the address of one of several widely separated servers.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

DD only works on Cisco Series 2500 and 4700 Routers. DD functions are available for other platforms starting with Cisco IOS Software Release 12.2.

The information in this document is based on these software images:

  • Cisco IOS Software Release 11.1(25)IA or newer 11.1(xx)IA image or Cisco IOS Software Release 12.0(3)T and newer (including 12.1)

Note: These images can found in the Cisco IOS software planner. The platform type can be any DD hardware version

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Configurations

This document uses these configurations:

  • Cisco 2501 Router (Cisco IOS Software Release 11.1(27)IA)

  • Cisco 2621 Router (Cisco IOS Software Release 12.0(3)T3 )

Cisco 2501 Router (Cisco IOS Software Release 11.1(27)IA)
DistributedDirector#show ver
Cisco DistributedDirector System Software 
IOS (tm) 3000 Software (IGS-W3-L), Version 11.1(27)IA
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Wed 27-Oct-99 14:14 by cynthia
Image text-base: 0x03021328, data-base: 0x00001000
ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
ROM: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)
DistributedDirector uptime is 2 days, 15 hours, 17 minutes
System restarted by power-on
System image file is "flash:igs-w3-l.111-27.IA.bin", booted via flash
cisco 2500 (68030) processor (revision N) with 6144K/2048K bytes of memory.
Processor board ID 16311988, with hardware revision 00000000
Bridging software.
X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
1 Ethernet/IEEE 802.3 interface.
2 Serial network interfaces.
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)
Configuration register is 0x2102

Cisco 2621 Router (Cisco IOS Software Release 12.0(3)T3 )
drp_router#show ver

Cisco Internetwork Operating System Software 
IOS (tm) C2600 Software (C2600-I-M), Version 12.0(3)T3,  RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Thu 15-Apr-99 15:41 by kpma
Image text-base: 0x80008088, data-base: 0x80693A88
ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
drp_router uptime is 2 days, 15 hours, 53 minutes
System restarted by power-on
System image file is "flash:c2600-i-mz.120-3.T3"
cisco 2621 (MPC860) processor (revision 0x101) with 18432K/6144K bytes of memory.
Processor board ID JAB032200NB (3274443039)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
2 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
Configuration register is 0x2102

Note: Director Response Protocol (DRP) servers run a variety of Cisco IOS software. Verify that the Cisco IOS software supports DRP. Cisco IOS Software Release 11.x and newer is preferred.

Refer to this diagram for the DistributedDirector v.11.1, DRPWest, and DRPEast configurations:

http_redirect.jpg

DistributedDirector v.11.1
DistributedDirector#
DistributedDirector#show run
Building configuration...
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname DistributedDirector
!
enable password letmein
!
!
key chain KEY-CHAIN-NAME
 key 1
  key-string my_keychain_password
!
interface Ethernet0
 ip address 192.168.134.234 255.255.255.248
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
ip host ddwest-servers.mycompany.com 172.18.73.51 192.168.14.83
ip host ddwest.mycompany.com 192.168.134.236
ip name-server 192.168.187.10
ip drp authentication key-chain KEY-CHAIN-NAME
no ip classless
ip route 0.0.0.0 0.0.0.0 192.168.134.233
ip dns primary ddwest-servers.mycompany.com soa ns.mycompany.comyourname.mycompany.com 
   21600 900 7776000 86400
ip dns primary ddwest.mycompany.com soans.mycompany.com yourname.mycompany.com
   21600 900 7776000 86400
ip director ip-address 192.168.134.236
ip director server 172.18.73.51 drp-association 172.18.73.31
ip director server 192.168.14.83 drp-association 192.168.134.235
ip director hosts ddwest-servers.mycompany.com priority ran 10 drp-r 5
ip director hosts ddwest-servers.mycompany.com connect 80 interval 60
logging buffered
access-list 99 deny   171.70.24.166
access-list 99 permit any
tftp-server flash igs-w3-l.111-27.IA.bin
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password letmein
 login
!
end
DistributedDirector#

DRPWest
DRPWest#show run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DRPWest
!
enable password letmein
!
ip subnet-zero
!
!
key chain KEY-CHAIN-NAME
 key 1
  key-string my_keychain_password
!
!
!
interface FastEthernet0/0
 ip address 192.168.134.235 255.255.255.248
 no ip directed-broadcast
 no ip mroute-cache
 full-duplex
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 full-duplex
!
ip drp authentication key-chain KEY-CHAIN-NAME
ip drp server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.134.233
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password letmein
 login
!
end
DRPWest#exit

DRPEast
DRPEast#show run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DRPEast
!
enable password letmein
!
ip subnet-zero
!
!
key chain KEY-CHAIN-NAME
 key 1
  key-string my_keychain_password
!
!
!
interface FastEthernet0/0
 ip address 172.18.73.31 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 full-duplex
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 full-duplex
!
ip drp authentication key-chain KEY-CHAIN-NAME
ip drp server
ip classless
ip route 0.0.0.0 0.0.0.0 172.18.73.233
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password letmein
 login
!
end
DRPEast#exit

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show ip director—Use this command to get DD status and information about the settings of DD parameters.

  • show ip director hosts—Use this command to display DD host information. The command can help troubleshoot problems related to the correct operation of the DD, including the correct sorting of addresses.

  • show ip director servers—Use this command to display DD server-preference information. The command can help troubleshoot problems related to the correct operation of DD, including the correct sorting of addresses.

  • debug ip director—Use this command to show debugging information for the DD.

  • debug ip drp—Use this command to display DRP information.

Note: Before attempting debug commands, please see .

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jan 31, 2006
Document ID: 15052