Guest

Cisco DistributedDirector

How to Configure the DistributedDirector to Serve DNS MX Records

Document ID: 12601

Updated: Jan 31, 2006

   Print

Introduction

This document describes how to configure Domain Name System (DNS) Mail Exchange (MX) records on a Cisco DistributedDirector (DD).

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • DistributedDirector

  • Cisco IOS® Software Releases 11.1(25)IA, 12.0(7)T, and later

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure the DistributedDirector to Serve DNS MX Records

Task

In this section, you are presented with the information to configure the features described in this document.

Step-by-Step Instructions

Complete these steps to configure your DD to serve DNS MX records. Before you begin, make sure that the DD is in global configuration mode for the commands.

  1. Make an Address record (A record), which maps the DNS name to an IP address for the e-mail server.

    Issue the ip host host-name [additional] [tcp-port-number] address1 [address2...addressN] command.

    The host-name is the name of the Simple Mail Transfer Protocol (SMTP) server. The address1 is the IP address of the SMTP server. Here is an example:

    ip host smtp.testdomain.com 172.18.124.101
    
  2. Make an MX record, which maps the domain to an e-mail (SMTP) server name.

    Issue the ip host host-name mx preference target-host-name command.

    The host-name is the DNS name of the domain for which you want to accept e-mail. The preference sets the target-host-name preference, and the target-host-name is the DNS name of the SMTP server. Here is an example:

    ip host testdomain.com mx 10 smtp.testdomain.com
    

    Note: You can repeat Step 1 and Step 2 for each SMTP server that you wish to configure. If you set equal preference numbers, the e-mail server load balances.

  3. Create a Start of Authority (SOA) record for the domain for which you intend to take e-mail.

    Issue the ip dns primary domain soa primary contact [refresh [retry [expire [minimum]]]] command to create the SOA record.

    The domain is the DNS name of the domain for which you want to accept e-mail. The primary is the DNS name of the DD. The contact is the e-mail of the administrator domain. The refresh, retry, expire, and minimum values are 10800, 3600, 604800, and 86400 in this example:

    ip dns primary testdomain.com soa dd.testdomain.com admin.testdomain.com 
     10800 3600 604800 86400
    

    Note: This command should be on one line.

  4. Set a maximum Time to Live (TTL) value for the MX record for the domain in other DNS caches.

    Issue the ip director host [a | mx] host-name ttl seconds command.

    The host-name is the DNS name of the domain for which you want to accept e-mail. Here is an example:

    ip director hosts testdomain.com mx ttl 43200
    
  5. Set a maximum TTL value for the MX record for the SMTP server in other DNS caches.

    Issue the ip director host [a | mx] host-name ttl seconds command.

    The host-name is the DNS name of the SMTP server. Here is an example:

    ip director hosts smtp.testdomain.com ttl 43200
    

Configuration

DistributedDirector
43-dd2500#show running-config 
Building configuration...
Current configuration : 1344 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 43-dd2500
!
enable password XX
!
!
!
!
!
ip subnet-zero
ip host smtp.testdomain.com 172.18.124.101
ip host testdomain.com mx 10 smtp.testdomain.com
ip domain-name cisco.com
ip name-server 161.44.21.250
!
!
!
!
interface Ethernet0
ip address 10.27.2.7 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.27.2.1
no ip http server
ip dns primary testdomain.com soa dd.testdomain.com admin.testdomain.com
10800 3600 604800 86400
!
no ip director cache
ip director hosts testdomain.com MX ttl 43200
ip director hosts smtp.testdomain.com ttl 43200
!
line con 0
transport input pad v120 telnet rlogin udptn
line aux 0
line vty 0 4
password XX
login
!
end

Test the MX Record

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Here is an example of how to test the MX record with the use of the nslookup set type=[any | mx] host-name command:

D:\> nslookup
Default Server:  [10.27.2.7]

!--- This is the IP address of the DD.

Address:  10.27.2.7
> set type=any  

!--- This part of the command checks the data return for the domain.
!--- The data are any record type.

> testdomain.com
Server:  [10.27.2.7]
Address:  10.27.2.7
testdomain.com  MX preference = 10, mail exchanger = smtp.testdomain.com
testdomain.com
primary name server = dd.testdomain.com
responsible mail addr = admin.testdomain.com
serial  = 2939936458
refresh = 10800 (3 hours)
retry   = 3600 (1 hour)
expire  = 604800 (7 days)
default TTL = 86400 (1 day)
>
> smtp.testdomain.com 

!--- This part of the command checks the A record for the SMTP server.

Server:  [10.27.2.7]
Address:  10.27.2.7
smtp.testdomain.com     internet address = 172.18.124.101

> set type=mx 

!--- This part of the command checks the MX record for only the domain 
!--- in question.

> testdomain.com
Server:  [10.27.2.7]
Address:  10.27.2.7
testdomain.com  MX preference = 10, mail exchanger = smtp.testdomain.com
smtp.testdomain.com     internet address = 172.18.124.101
>

show Command

Here is a sample output from the issue of the show ip director hosts command on the DD:

43-dd2500#show ip director hosts
Host testdomain.com (MX queries):
TTL for DNS replies is 43200
Servers:
Server 172.18.124.101:
Advertised 0 times, last at 00:00:00
Default preference: 10
Default portionhits: 0
Host smtp.testdomain.com (A queries):
TTL for DNS replies is 43200
Servers:
Server 172.18.124.101:
Advertised 0 times, last at 00:00:00
Default preference: 10
Default portionhits: 0

For more information about the commands, refer to the Command Reference section in DistributedDirector Enhancements for Cisco IOS Release 11.1(25)IA.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jan 31, 2006
Document ID: 12601