Guest

Cisco CSS 11500 Series Content Services Switches

Box-to-Box Redundancy on the CSS 11xxx Configuration Example

Cisco - Box-to-Box Redundancy on the CSS 11xxx Configuration Example

Document ID: 50405

Updated: Jun 09, 2004

   Print

Introduction

This document provides a sample configuration for Content Services Switch (CSS) 11xxx box-to-box redundancy. Box-to-box redundancy provides chassis-level redundancy between two identically configured CSSs.

Prerequisites

Requirements

Before attempting this configuration, ensure that you meet these requirements:

  • Both of the CSSs you are using for this redundant configuration must be running the same version of code. Running different versions of code is not supported for redundancy.

  • Expect the behavior of the CSSs to be active (master)/standby (backup); only the master CSS processes flows.

  • You must configure a dedicated Fast Ethernet (FE) link between the CSSs for the Virtual Router Redundancy Protocol (VRRP) heartbeat.

  • Do not use box-to-box if you require the connection of a Layer 2 device between the redundant CSS peers. Use VIP redundancy instead. Refer to Configuring VIP and Virtual Interface Redundancy for more information.

Components Used

The information in this document is based on the CSS 11150 SW Version: 6.10 Build 107.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Related Products

This configuration can also be used with these hardware and software versions:

  • all Cisco CSS 11000 - 11500 series CSS products

  • Cisco WebNS Software Release 5.0 and later

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Background Information

CSSs participate in a redundant configuration when a redundancy link has been defined between two CSSs. The protocol used for this redundancy link is VRRP, using multicast address 224.0.0.18. The CSSs use this link to maintain contact and activity status with one another. Only one crossover link between the CSSs is supported. You must use a crossover cable to connect directly to the FE ports on the redundant CSSs. Do not use Layer 2 devices between the two CSSs on the redundant link. Do not install the crossover cable on Gigabit Ethernet (GE) ports; this configuration is not supported.

Note: The CSS box-to-box redundancy protocol is now supported on the CSS 11501, CSS 11503, and CSS 11506 GE ports in software version 7.10.1.02 and 7.20.0.01 and later.

There are two main conditions detected on this redundancy link that drive master and backup states on the two CSSs:

  • The first condition is maintaining the heartbeat, which is an advertisement every second. The master CSS provides this heartbeat on the redundancy link, and the backup CSS keeps track of the heartbeat every three seconds (default). If the heartbeat times out (for example, heartbeats are not detected in this period), then the backup takes over as master.

    The new master CSS begins sending out redundancy protocol messages as well as gratuitous Address Resolution Protocol (ARP) messages to update the ARP tables on neighboring nodes and the forwarding tables of attached bridging devices (for example, Layer 2 switches) with the new master CSS MAC address. The CSS transmits one ARP request packet and one ARP reply packet for every gratuitous ARP invocation.

  • The second condition is that of a VRRP switch priority change. The CSS advertising the highest priority is negotiated to become master. This is the mechanism used by the uplink services, and some of the special commands (described below) for initiating a failover event.

Note that in the event that the CSSs are misconfigured (for example, two or more CSSs are set up as the IP redundancy master), the CSS with the highest VRRP IP address takes over as the master.

The Cisco WebNS software allows you to:

Configure

In this section, you are presented with the information to configure the features described in this document.

Issue the ip redundancy command to enable CSS-to-CSS redundancy on two CSSs interfaced with a crossover cable. By default, redundancy is disabled on the CSSs until you issue this command on both CSSs.

When you include the master option with this command, you can designate which CSS is the master CSS. Initially, booting two CSSs interfaced with a crossover cable determines which is the master and which is the backup. The CSS that boots first is the master CSS. If the CSSs boot at the same time, the CSS with the numerically higher IP address becomes the master.

When you issue the ip redundancy master command on the CSS, the CSS becomes the master CSS. You can issue this command on either the current master or backup. If you issue the master option on the backup CSS, the CSS becomes the master and the other CSS automatically becomes the backup.

If you designate a master CSS, the CSS regains master status after going down and then comes up again. For example, when the master CSS goes down, the backup CSS becomes master. When the former designated master CSS comes up again, however, the CSS becomes the master again.

If you have no requirement to designate a CSS as the master when both CSSs are up, do not include the master option when enabling redundancy on the master CSS.

Network Diagram

This document uses this network setup:

box_to_box_config.jpg

Configurations

This document uses these configurations:

  • CSS 11150 FL

  • nws-4-5

CSS 11150 FL
CSS-11150-FL# sh running-config
!Generated on 03/22/2004 18:32:17
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 		


!--- Redundancy is enabled.


  app     			


!--- This is optional if you want to synchronize the configurations.

  app session 172.17.6.2   

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.1 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.2 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

CSS-11150-FL# 

nws-4-5
nws-4-5# sh running-config 
!Generated on 03/22/2004 18:53:37
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 	


!--- Redundancy is enabled.



  app 


!--- This is optional if you want to syncronize the configurations.

  app session 172.17.6.1 

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.2 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.1 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

nws-4-5# 


Support for Multiple Uplink Services

You can create a service that is associated with a router’s IP address. This service enables the master CSS to monitor the router with a keepalive (ICMP). If the keepalive fails, the master relinquishes control and the backup CSS takes control. You can configure more than one service by issuing the type redundancy-up command; the CSSs use all redundancy uplinks when making the failover decision.

If a CSS is active, and loses all uplinks designated as redundancy-up, the CSS relinquishes the active state and becomes the backup. The CSS uses the redundancy protocol to inform the other CSS to become active. If both CSSs have lost their uplinks, a CSS stays in the active state for 45 seconds, waiting for the uplink to come alive. After 45 seconds, if there is still no viable uplink, the CSS goes into backup mode, giving the other switch a try. This allows both CSSs to get a chance to test their uplinks without thrashing back and forth many times each minute.

Note: A CSS goes into failover when there are no longer live uplink services.

Considerations

This feature is disabled when the ip redundancy master command is issued. When the ip redundancy master command is issued, the type redundancy-up command cannot be configured. When a service is configured by issuing the type redundancy-up command, the ip redundancy master command cannot be issued.

Configuration

CSS11150# configure terminal
CSS11150(config)# service uplink1
CSS11150(config-service[uplink1])# type redundancy-up           

!--- If this upstream router goes down, then fail the switch over.

CSS11150(config-service[uplink1])# ip address 10.66.86.33
CSS11150(config-service[uplink1])# active

Support for Physical Interface Failure Failover

If any one of the physical interfaces configured for redundancy goes down, the CSS relinquishes control, and the backup CSS immediately takes over as master. This feature is based on link state as opposed to the redundancy-up service, which is based on IP connectivity. The CSS can determine link state when in backup mode. You must make sure that the upstream or downstream path of the backup CSS does not also run through this same interface; this will cause the CSS boxes to flap the ownership of the master status.

Considerations

This feature is disabled by issuing the ip redundancy master command. When the ip redundancy master command is issued, the redundancy-phy interface command fails. When the redundancy-phy interface command is issued, the ip redundancy master command fails.

Configuration

CSS-11150-FL# configure terminal
CSS-11150-FL(config)# interface e1
CSS-11150-FL(config-if[e1])# redundancy-phy

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • sh redundancy— This command verifies that the CSSs are running in a redundant configuration; this command also displays which CSS is master and which is backup, as well as the reason for the last failover.

    nws-4-5# sh redundancy
    Redundancy:               Enabled    Redundancy Protocol:      Running   
    Redundancy State:         Master     MasterMode:               No        
    Number of times redundancy state changed to Master:            2         
                                             to Backup:            2         
    Redundancy interface:     172.17.6.2
    Current State Duration:   1 day 02:54:04
    Last Fail Reason:         No Fail    
    VRID:                     128        Priority:                 100 
  • show log sys.log— This command displays messages with information for mastership between the CSS devices.

    CSS-11150-FL# sh log sys.log
    
    APR 15 18:05:49 5/1 85 REDUNDANCY-4: Redundancy force master temporarily
    APR 15 18:05:52 5/1 86 REDUNDANCY-4: Transition to redundancy master
    APR 15 18:05:52 5/1 87 VRRP-4: Virtual router 128: master on interface 172.17.6.1
  • show app and show app session — This command displays the state of the app session.

    nws-4-5# sh app
    APP CONFIGURATION:
    Enabled PortNumber: 5001 MaxFrameSize: 10240
    
    nws-4-5# sh app session
    App Session Information 'no hostname':
    Session ID: 87df3710 IP Address: 172.17.6.1 State: APP_SESSION_UP

You can force the backup to master for maintenance purposes. Issue the redundancy force-master command to configure a backup CSS as a temporary master. This is a temporary setting because the command is not copied to the running-configuration. This command is useful in a redundant configuration when you need to take the master CSS offline for maintenance or an upgrade.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jun 09, 2004
Document ID: 50405