Guest

Cisco Application and Content Networking System (ACNS) Software

How to Configure a Cache Engine for Reverse-Proxy Caching Using WCCP

Cisco - How to Configure a Cache Engine for Reverse-Proxy Caching Using WCCP

Document ID: 28832

Updated: Jan 31, 2006

   Print



Contents


Introduction

This document describes how to configure the Cisco Cache Engine for reverse-proxy caching by using the Web Cache Coordination Protocol (WCCP).

Hardware and Software Version

This configuration was developed and tested using the software and hardware versions below.

  • Cisco Cache Engine 560 running Cisco Cache Software Release 2.3 and ACNS version 4.0 and ACNS 5.0 in a lab environment with cleared configurations.

  • Cisco 2600 Router running Cisco IOS® Software Release 12.1(2).
The information presented in this document was created using equipment in a lab environment. The devices started with a cleared (default) configuration. If you are working in a live network, make sure that you understand the potential impact of a command before using it.

Network Diagram


Configurations

Cache Engine 560 (Cache Software Release 2.3 or ACNS Software Release 4.0 or 5.0)
Current configuration:
!
!
user add admin uid 0 
password 1 "eeSdy9dcy" 
capability admin-access
!
!
!
hostname ce
!
interface ethernet 0
 ip address 10.0.0.2 255.255.255.0
!--- Important: If you configure the Cache Engine
!--- with a private address, it must get translated
!--- to a public address.
 ip broadcast-address 10.0.0.255 exit ! interface ethernet 1 exit ! ip default-gateway 10.0.0.1 ip name-server 171.70.168.183 ip domain-name cisco.com ip route 0.0.0.0 0.0.0.0 10.0.0.1 cron file /local/etc/crontab ! wccp router-list 1 10.0.0.1 wccp reverse-proxy router-list-num 1 wccp version 2 ! authentication login local enable authentication configuration local enable rule no-cache url-regex .*cgi-bin.* rule no-cache url-regex .*aw-cgi.* ! !

Cisco 2600 Router (Cisco IOS Software Release 12.1[2])
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2611-5
!
enable secret 5 $1$9VQ.$BTPbq8xlE2dsKwKPDDmpL/
!
!
ip subnet-zero
ip wccp 99
!
!
interface Ethernet0/0
 description Interface to the Internet 
 ip address 172.17.63.194 255.255.255.192
 no ip redirects
!
interface Serial0/0
 no ip address
 no ip mroute-cache
 shutdown
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp 99 redirect out
!
interface Ethernet1/1
 no ip address
 shutdown
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

debug and show Commands

Before issuing debug commands, please see Important Information on Debug Commands.

Cache Engine debug and show commands:

  • show wccp cache - Show WCCP CE information
  • show wccp flows - Show WCCP packet flows
  • show wccp routers - Show WCCP router list
  • show wccp services - Show WCCP services configured
  • show wccp slowstart - Show WCCP Slow Start
  • show wccp status - Show WCCP running status
  • show statistics http savings - Displays HTTP savings statistics
  • debug wccp all - WCCP Turn on all debugging
  • debug wccp events - WCCP events
  • debug wccp packets - WCCP packet-related information
Router debug and show commands:
  • show ip wccp 99 detail - This command displays Cache Engine and WCCP router statistics for a service group.
  • show ip wccp 99 view - Service group view information
  • debug ip wccp events - WCCP events
  • debug ip wccp packets - WCCP packet-related information

Verification

Verify that reverse proxy caching is working with these commands.

Issue this command to check WCCP Cache/Content Engine status:

router#sh ip wccp 99 detail 
WCCP Cache-Engine information: 
       IP Address:            10.0.0.2 
       Protocol Version:      2.0 
       State:                 Usable                              
	   !--- This cache is active.
       Initial Hash Info:     00000000000000000000000000000000 
                              00000000000000000000000000000000 
       Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                              FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
       Hash Allotment:        256 (100.00%) 
       Packets Redirected:    93 
       Connect Time:          00:15:27

Issue this command to check WCCP transparent reverse redirection on the router:

router#sh ip wccp 99 
Global WCCP information: 
    Router information: 
        Router Identifier:                   172.17.63.194 
        Protocol Version:                    2.0 
    Service Identifier: 99 
        Number of Cache Engines:             1 
        Number of routers:                   1 
        Total Packets Redirected:            93                   
		!--- The router is redirecting.
        Redirect access-list:                -none- 
        Total Packets Denied Redirect:       0 
        Total Packets Unassigned:            0 
        Group access-list:                   -none- 
        Total Messages Denied to Group:      0 
        Total Authentication failures:       0


Issue this command to check HTTP statistics on the Cache/Content Engine:

cache#sh statistic http request 
                              Statistics - Requests 
                                                Total             % of Requests 
                            --------------------------------------------------- 
     Total Received Requests:                      23                         - 
              Forced Reloads:                       2                       8.7 
               Client Errors:                       0                       0.0 
               Server Errors:                       0                       0.0 
         URL Blocked (Reset):                       0                       0.0 
                 URL Blocked:                       0                       0.0 
      Sent to Outgoing Proxy:                       0                       0.0 
Failures from Outgoing Proxy:                       0                       0.0 
Excluded from Outgoing Proxy:                       0                       0.0 
             ICP Client Hits:                       0                       0.0 
             ICP Server Hits:                       0                       0.0 
               If-Range Hits:                       0                       0.0 
           HTTP 0.9 Requests:                       0                       0.0 
           HTTP 1.0 Requests:                       0                       0.0 
           HTTP 1.1 Requests:                      23                     100.0 
       HTTP Unknown Requests:                       0                       0.0 
           Non HTTP Requests:                       0                       0.0 
          Non HTTP Responses:                       0                       0.0 
      Chunked HTTP Responses:                       0                       0.0 
        Http Miss Due To DNS:                       0                       0.0 
     Http Deletes Due To DNS:                       0                       0.0 
  Objects cached for min ttl:                       4                      17.4

Issue this command to verify the caching of requests:

cache#sh stat http sav 
                         Statistics - Savings 
                        Requests                          Bytes 
         ----------------------------------------------------------- 
  Total:                      23                          16481 
   Hits:                       6                           2205 
   Miss:                      17                          14276 
Savings:                    25.0 %                         13.4 %

Command Summary

These Cache Engine commands were used in this configuration.
  • wccp version {1 | 2}
  • wccp router-list number ip-address
  • wccp router-list-num number
These router commands were used in this configuration.
  • ip wccp {web-cache | service-number}
  • ip wccp {web-cache | service-number} redirect out
  • ip wccp version 2


Related Information


Updated: Jan 31, 2006
Document ID: 28832