Guest

Cisco 500 Series Cache Engines

How to Configure a Cache Engine for Transparent Caching Using WCCP

Document ID: 15043

Updated: Jul 26, 2006

   Print

Introduction

This document describes how to configure the Cisco Cache Engine for transparent caching using the Web Cache Coordination Protocol (WCCP).

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco Cache Engine 560

  • Cisco Application and Content Networking System software (ACNS) release 5.1

  • Cisco 3600 Router running Cisco IOS® Software Release 12.2(17)

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

transparentconfig.jpg

Configurations

This document uses these configurations:

Cache / Content Engine
ce-560#write terminal
! ACNS version 5.1.9
!
hostname ce560
!
ip domain-name cisco.com
!
interface FastEthernet 0/0
 ip address 10.0.0.2 255.255.255.0
 exit
interface FastEthernet 0/1
 shutdown
 exit
!
ip default-gateway 10.0.0.1
!
primary-interface FastEthernet 0/0
!
ip name-server 10.66.86.18
!
wccp router-list 1 10.0.0.1
wccp web-cache router-list-num 1
wccp version 2
!
transaction-logs enable
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

Router
c3640#write terminal
Building configuration...
Current configuration : 1905 bytes
!
! NVRAM config last updated at 11:30:04 AEST Wed Aug 4 2004
!
version 12.2
no service password-encryption
!
hostname c3640
!
enable password cisco
!
clock timezone AEST 10
ip subnet-zero
ip wccp web-cache
ip cef
!
interface Ethernet0/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp web-cache redirect in
 full-duplex
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
full-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.254
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Note: Refer to Important Information on Debug Commands before you use debug commands.

Cache Engine debug and show Commands

  • show wccp cache—Displays WCCP cache engine information.

  • show wccp flows—Displays WCCP packet flows.

  • show wccp routers—Displays the WCCP router list.

  • show wccp services—Displays the WCCP services that are configured.

  • show wccp slowstart—Displays the WCCP slow start.

  • show wccp status—Displays the WCCP running status.

  • show statistics http savings—Displays HTTP savings statistics.

  • debug wccp all—Turns on all debugging for WCCP.

  • debug wccp events—Debugs WCCP events.

  • debug wccp packets—Debugs WCCP packet-related information.

Router debug and show Commands

  • show ip wccp web-cache detail—Displays cache engine and WCCP router statistics for a particular service group.

  • show ip wccp web-cache view—Displays service group view information.

  • debug ip wccp events—Debugs WCCP events.

  • debug ip wccp packets—Debugs WCCP packet-related information.

Command Summary

These are the cache engine commands that were used in this configuration:

  • wccp version {1 | 2}

  • wccp router-list number ip-address

  • wccp web-cache router-list-num number

These are the router commands that were used in this configuration:

  • ip wccp {web-cache | service-number}

  • ip wccp {web-cache | service-number} redirect out

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jul 26, 2006
Document ID: 15043