Guest

Cisco MWR 1900 Mobile Wireless Routers

Cisco MWR 1941 Router Redundancy

  • Viewing Options

  • PDF (202.0 KB)
  • Feedback

Overview

The Cisco ® MWR 1941-DC-A Mobile Wireless Edge Router can be used either in a redundant configuration or as a standalone device. For redundancy, the Cisco MWR 1941 uses the existing Hot Standby Router Protocol (HSRP) feature and provides 1:1 redundancy for the cell site router. The 1:1 redundancy solution requires an active Cisco MWR 1941 to be deployed with a second Cisco MWR 1941 that is connected to the same network but in standby mode. (See Figure 1, and refer to the "HSRP Operation" section for more information.) Custom Y-cable is used for connecting T1/E1 ports on two separate routers to a single T1/E1 line. Protection switching relays on the T1/E1 ports enable the routers to be deployed 1:1 with Y-cables. LEDs differentiate the active and standby routers. Custom health check software interfacing with HSRP is also used to monitor the redundancy status of the router pair.
Redundancy is one of the important functions that mobile operators require for deploying Cisco Radio Access Network Optimization in their Radio Access Network (RAN). Redundancy can help mobile operators increase system reliability and minimize service interruption in the event of a fatal error caused by hardware components or embedded software in the active Cisco MWR 1941.

Figure 1. Logical Connections in a Redundant Cisco MWR 1941 Deployment

• Global System for Mobile Communications (GSM) base transceiver station (BTS)

• Universal Mobile Telecommunications Service (UMTS)

• Fast Ethernet (FE)

• Multilink Point-to-Point Protocol (MLPPP)

• Base station controller (BSC)

• Radio network controller (RNC)

HSRP Operation

HSRP is a network protocol designed specifically for providing network redundancy for IP networks. It helps ensure that user traffic immediately and transparently recovers from failures in network devices.
HSRP makes a set of routers work as a single virtual router to the hosts in the network. This set is known as an HSRP group or a standby group. A single router elected from the group is responsible for forwarding the packets that other hosts send to the virtual router. This router is known as the active router. Another router is elected as the standby router. In the event that the active router fails, the standby assumes the packet-forwarding duties of the active router.
HSRP consists of a virtual MAC address and a virtual IP address that are shared between two routers and a process that monitors both LAN and serial interfaces using a multicast protocol. The protocol works by the exchange of multicast messages that advertise priority among HSRP-configured routers. When the active router fails to send a hello message within a configurable period of time, the standby router with the highest priority becomes the active router and also assumes control of the virtual MAC and IP addresses. The transition of packet-forwarding functions between routers is completely transparent to all hosts on the network.
HSRP-configured routers exchange three types of multicast messages:

Hello: The hello message conveys to other HSRP routers the router's HSRP priority and state information. By default, an HSRP router sends hello messages every three seconds.

Coup: When a standby router assumes the function of the active router, it sends a coup message.

Resign: An active router sends this message when it is about to shut down or when a router that has a higher priority sends a hello message.

At any time, HSRP-configured routers are in one of the following states:

Active: The router is performing packet-transfer functions.

Standby: The router is prepared to assume packet-transfer functions if the active router fails.

Speaking and listening: The router is sending and receiving hello messages.

Listening: The router is receiving hello messages.

HSRP uses a priority scheme to determine which HSRP-configured router is to be the default active router. In initial router configuration, you assign a priority to each HSRP-configured router. The default priority is 100. The router with the highest final priority in the HSRP group will become the default active router. To understand how to calculate the final priority for the MWR, see the following section.

Failover Scenarios

Router redundancy relies on three configured virtual interfaces to track the health status of the active Cisco MWR 1941.

• The first virtual loopback interface, typically loopback 101 and referred to as the health interface, is a proxy for router health. The interface is brought up or down by the health-monitoring function.

• The second virtual loopback interface, typically loopback 102, is the revertive interface and is maintained in the opposite state as the backhaul interface. This ensures that a healthy standby router has a higher score than a non-healthy active router, compensating for the absence of the MLPPP bundle on the standby.

• The third virtual loopback interface, typically loopback 103 and referred to as the short-haul interface, is a proxy for the Abis/Iub interfaces. Loopback 103 is brought up or down by tracking the short-haul interfaces as a whole.

Each virtual interface is assigned with a priority score in the Cisco MWR 1941 configuration. The default score is 10. The score of each virtual interface is used as a priority offset that indicates the amount to decrement the router's baseline priority in the event that the interface being tracked is down. The baseline priority is the value configured in an HSRP group with "standby <group> priority" command. Therefore,
Cisco MWR 1941 final priority = Baseline priority - Priority scores of the virtual interfaces that are down
Cisco MWR 1941 failover happens mostly in following scenarios:

• The whole router is down because of a power supply failure or software errors. This would either cause loopback 101 to change its state, or have HSRP detect the failure of the active Cisco MWR 1941. Failover will then take place.

• All backhaul interfaces are down. This would cause loopback 102 to change its state. Failover will then take place.

• All short-haul interfaces are down. This would cause loopback 103 to change its state. Failover will then take place.

Failover Time

When an active Cisco MWR 1941 failure is detected by HSRP, router failover will take place. Because current Cisco MWR 1941 redundancy implementation is stateless, after failover, the new active router would need to activate itself. The whole process includes bringing up all interfaces and controllers (for the short haul and the back haul), establishing MLPPP, negotiating IMA, establishing RAN Optimization peering, etc. Actual failover time would vary depending on how fast the Cisco MWR 1941 can finish negotiations with its peer and establish all the T1/E1 connections with the RAN equipment.

The Y-Cable

Figure 2. Cisco MWR 1941 Redundancy with a Y-Cable

A custom T1/E1 Y-cable is required for Cisco MWR 1941 redundancy (Figure 2). Y-cables connect the two interfaces on the Cisco 2-Port RJ-48 T1/E1 RAN WAN Interface Card to a single T1/E1 backhaul in the BTS or Node B. The Y-cable that is connected to a pair of redundant Cisco MWR 1941 routers can differentiate the active router from the standby router through the LEDs. The active router carrier detect is green, the standby alarm is amber with no carrier detect.
The Y-cable is available from Anixter, a third-party vendor. (Part number Q#00066036.) Please see http://www.anixter.com for local sales offices worldwide.

Redundancy Configuration

To configure Cisco MWR 1941 redundancy, three major tasks need to be performed in addition to regular RAN optimization configurations on the router:

• Enable gsm-redundancy, and indicate the three virtual loopback interfaces used for redundancy under mode y-cable.

• Configure three loopback interfaces for tracking the router health status.

• Configure HSRP group 1 and parameters under a Fast Ethernet interface. There can be multiple HSRP groups configured on a Cisco MWR 1941 at a time, and the voice/WAN interface card (VWIC) relays are only controlled by the HSRP group 1 when gsm-redundancy is configured.

For detailed configuration procedures, please refer to the Cisco MWR 1941 configuration guide:
http://www.cisco.com/en/US/products/hw/routers/ps4062/products_configuration_guide_chapter09186a00804d45e3.html#wp1061241.
Figure 3 shows a configuration example for Cisco MWR 1941 redundancy.

Figure 3. Sample Cisco MWR 1941 Redundancy Configuration

Current configuration : 4489 bytes
!
version 12.4
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
service password-encryption
!
hostname MWR-BTS
!
boot-start-marker
boot system slot0:mwr1941-ipran-mz.124-4.MR1.bin
boot-end-marker
!
card type e1 0 0
card type e1 0 1
card type e1 0 2
logging buffered 4096 debugging
enable password 7 <removed>
!
no aaa new-model
!
resource policy
!
redundancy
mode y-cable
standby gsm-redundancy
standby use-interface Loopback101 health
standby use-interface Loopback102
revertive
standby use-interface Multilink1 backhaul
standby use-interface Loopback103
shorthaul
!
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-participate aim 1
network-clock-select 1 E1 0/2
network-clock-select 2 E1 0/3
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
ipran-mib snmp-access inBand
ipran-mib location cellSite
ipran-mib threshold-acceptable 65
!
!
controller E1 0/0
framing NO-CRC4
clock source internal
channel-group 0 timeslots 1-31
!
controller E1 0/1
shutdown
framing NO-CRC4
clock source internal
channel-group 0 timeslots 1-31
!
controller E1 0/2
channel-group 0 timeslots 1-31
!
controller E1 0/3
channel-group 0 timeslots 1-31
!
controller E1 0/4
mode atm aim 1
clock source internal
!
controller E1 0/5
mode atm aim 1
clock source internal
!
!
!
!
!
class-map match-any abis
match ip dscp ef
!
!
policy-map llq-policy
class abis
priority percent 99
class class-default
bandwidth remaining percent 1
queue-limit 45
!
!
!
!
interface Loopback100
ip address 20.20.2.1 255.255.255.255
!
interface Loopback101
no ip address
!
interface Loopback102
no ip address
shutdown
!
interface Loopback103
no ip address
!
interface Multilink1
ip address 10.10.1.2 255.255.255.0
ip tcp header-compression ietf-format
load-interval 30
no keepalive
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
max-reserved-bandwidth 100
service-policy output llq-policy
hold-queue 50 out
ip rtp header-compression ietf-format
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
shutdown
duplex auto
speed auto
!
interface Serial0/0:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.1.2 3334
gsm-abis remote 10.10.1.1 3334
gsm-abis set dscp ef
!
interface FastEthernet0/1
ip address 50.50.1.1 255.255.255.0
duplex auto
speed auto
no keepalive
standby 1 ip 50.50.1.3
standby 1 timers 1 3
standby 1 preempt
standby 1 name one
standby 1 track Loopback101
standby 1 track Loopback102 15
standby 1 track Loopback103
standby 1 track Multilink1
!
interface Serial0/1:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.1.2 3336
gsm-abis remote 10.10.1.1 3336
gsm-abis set dscp ef
!
interface Serial0/2:0
no ip address
encapsulation ppp
ppp multilink group 1
max-reserved-bandwidth 100
!
interface Serial0/3:0
no ip address
encapsulation ppp
ppp multilink group 1
max-reserved-bandwidth 100
!
interface ATM0/4
no ip address
scrambling-payload
ima-group 0
no atm ilmi-keepalive
!
interface ATM0/5
no ip address
scrambling-payload
ima-group 0
no atm ilmi-keepalive
!
interface ATM0/IMA0
no ip address
no atm ilmi-keepalive
atm umts-iub
umts-iub set dscp ef
umts-iub set peering dscp ef
umts-iub local 10.10.1.2 6000
umts-iub remote 10.10.1.1 6000
pvc 1/42
encapsulation aal0
umts-iub set dscp cs1
!
pvc 1/43
encapsulation aal0
!
pvc 1/44 qsaal
!
pvc 1/45 qsaal
!
pvc 1/46
encapsulation aal0
!
pvc 1/54 qsaal
!
pvc 1/55 qsaal
!
pvc 1/56
encapsulation aal0
!
!
ip classless
ip route 192.168.1.0 255.255.255.0 Multilink1
ip route 192.168.1.0 255.255.255.0 50.50.1.2 10
!
ip http server
!
snmp-server community <removed> RO
snmp-server ifindex persist
snmp-server trap-source Loopback100
snmp-server source-interface informs Loopback100
snmp-server queue-length 100
snmp-server location Base Station
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server host 192.168.1.10 version 2c <removed>
!
disable-eadi
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password 7 <removed>
login
!
end