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Introduction

Cisco Supervisor Desktop for Cisco Unified Contact Center Express (Unified CCX) is a 
robust computer telephony integration solution for IP-based contact centers that is 
easy to deploy, configure, and manage. It provides supervisors with powerful tools to 
increase productivity and improve customer satisfaction. 

Supervisor Desktop’s features allow you to view real time statistics, monitor and 
coach agents,  and record active agent calls when necessary, enabling effective 
management of agent resources.

What’s New in This Version

Cisco Supervisor Desktop 6.6(1) includes these new features:

■ Integration of Agent E-Mail

■ Browser improvements: tabs moved to the top of the browser pane, number of 
tabs increased to 10, page history increased to 25

■ Workgroup-specific reason codes

■ Global and workflow group-specific wrap-up data

■ Addition of Cisco Agent Desktop—Browser Edition (CAD-BE) agents

■ Accessibility improvements
April 2009 5



Cisco Supervisor Desktop User Guide
Supervisor Desktop Feature Levels

There are three feature levels of Cisco Supervisor Desktop: Standard, Enhanced, and 
Premium. 

The following table outlines the features that are available at each feature level. All 
features not listed here are present in all three feature levels.

Feature Standard Enhanced Premium

Silent monitoring × ×

Recording × ×

Team messages (TMs) × ×

E-mail contact service queues ×

Supervisor work flows—threshold alerts for tree 
control actions × ×

Supervisor work flows—all actions except 
threshold alerts for tree control actions ×

Skill statistics × × ×

Real time displays (text) × × ×

Real time displays (charts) ×

Web page push to agents ×

Integrated browser × × ×
6 April 2009



Starting Supervisor Desktop
Starting Supervisor Desktop

If you want to use all of the functionality of Supervisor Desktop, you must first log into 
Agent Desktop. For more information, see the Cisco Agent Desktop User Guide.

To start Supervisor Desktop:

1. Choose Start > Programs > Cisco > Desktop > Supervisor. The login dialog box 
appears (Figure 1).  

2. Enter your Supervisor Desktop login ID and password in the appropriate fields, 
and then click OK or press Enter. Supervisor Desktop starts, but does not 
show any data and the status bar displays “No Service”. 

3. From the Team drop-down list, select a team. 

The first time you log into Supervisor Desktop:

■ Your user ID and password are the same as your Cisco Agent Desktop user ID 
and password.

■ The User ID field is empty. The next time you log in, the User ID field is 
automatically filled with the information you entered before. If you share a 
computer with another supervisor, verify that this field has your information 
and not the other supervisor’s information.

■ It may take some time for Supervisor Desktop to start because default report 
data must be generated.

Figure 1. Supervisor Login dialog box
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Access Through a VPN From Behind a NAT Firewall or 
Router

When a desktop is using network address translation (NAT) due to a firewall or router, 
then virtual private network (VPN) software must be used on the desktop to ensure 
full bi-directional network connectivity between the contact center servers and the 
desktop. Failure to use VPN software will result in connectivity issues and a loss in 
functionality, such as silent monitoring failures and missing information in the agent 
tree.

NOTE:  Using a VPN is recommended in order to provide a more 
secure connection when using Supervisor Desktop outside the 
contact center.

The VPN connection must be established before starting Supervisor Desktop. If the 
VPN connection is lost during a session, you must restart Supervisor Desktop after the 
connection is reestablished.

If Supervisor Desktop can log into all services except the Chat service, you must 
restart Supervisor Desktop after the Chat service comes back online. 

It has been verified that Cisco VPN 3000 Concentrator and Cisco VPN Client work 
properly with Supervisor Desktop, and are supported for access. VPN solutions from 
other vendors may work correctly, but since they have not been formally verified, they 
are not supported. If you want an alternative solution to be verified, please contact 
your Cisco distributor.
8 April 2009
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Automated Updates

CAD enables your administrator to update all instances of the CAD desktop 
applications automatically to a newer version. It also ensures that the correct version 
of Java Runtime Environment (JRE) is installed on your computer.

CAD Desktop Applications

Every time you launch Supervisor Desktop, the software checks to see if there is an 
updated version available, or if there was a system configuration change that requires 
a Windows registry change. If either of these conditions exists, the software 
automatically runs the update process.

When an update is available, you will see a dialog box notifying you that your copy of 
Supervisor Desktop will be updated. Click OK to proceed with the update.

A progress bar is displayed to show you the status of the update process.

When the update is finished, you will see a final dialog box that tells you the update is 
complete, and which applications were updated. If you have other CAD applications 
(Cisco Agent Desktop and Cisco Desktop Administrator) on your PC, they will all have 
been updated. 

NOTE:  Enhanced and Premium packages only: Because Agent 
Desktop is automatically installed when Supervisor Desktop is 
installed, only Supervisor Desktop will be listed as having been 
updated in the final dialog box. Agent Desktop will be listed only if 
Supervisor Desktop is not present on your PC.

When you click OK to close the dialog box, any CAD application that had been running 
on your desktop restarts automatically.

NOTE:  To ensure that automated updates function correctly, you 
must configure Internet Explorer so that it checks for newer versions 
of stored pages. To configure this setting, launch Internet Explorer 
and choose Tools > Internet Options. In the Browsing history section 
on the General tab, click Settings. Select the option labeled Every 
time I visit the web page.

NOTE:  If your system is configured with two Unified CCX servers, and 
one server is upgraded while your instance of Supervisor Desktop is 
connected to the older Unified CCX server, and your administrator 
performs a failover to switch all agents to the upgraded server, your 
instance of Supervisor Desktop will not automatically upgrade when 
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you log into the new server. You must shut down Supervisor Desktop 
and start it again for the automatic upgrade to take place.

Java Runtime Environment

Every time Supervisor Desktop is launched, it checks to see if the correct version of 
JRE is installed. If the correct version is not detected, you will be notified, and 
Supervisor Desktop will download and install the correct JRE.
10 April 2009
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The Supervisor Desktop Window

The Supervisor Desktop window is divided into 5 areas:

■ The skill group tree, which lists all of the contact service queues associated 
with the team you choose from the team selection list

■ The agent tree, which lists all of the agents and supervisors on the team

■ Tabular/graphical real time displays of contact service queue information

■ Tabular/graphical real time displays of agent and team information

■ Integrated browser (if enabled)

The Supervisor Desktop interface is highly configurable. By default, the browser is not 
enabled and the panes are not dockable. However, you can configure real time 
displays, enable the integrated browser, and enable all panes to act as dockable 
windows (so you can move them and resize them independently). You can also change 
the size of the toolbar icons from the default 16 × 16 pixels to 32 × 32 pixels.

The specific panes that are displayed depends on the nodes that you select in the skill 
group and agent trees. If you choose to enable the integrated browser, the real time 
displays and the browser appear on tabs in the right pane. Figure 2 shows the 
Supervisor Desktop window in its default configuration.

Figure 2. Supervisor Desktop interface
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Real time display panes are identified as containing information related to voice CSQ, 
e-mail CSQs, or agents by the text in their title bars (Figure 3).

When Supervisor Desktop is in default layout (movable windows are disabled), 
Contact Service Queue real time displays occupy approximately the top half of the 
right pane, and the Agents real time displays occupy approximately the lower half of 
the right pane. The tree panes and real time display panes can all be resized by 
dragging the horizontal splitters up and down and the vertical splitters left and right. 

If you choose to enable movable windows (see Setting Preferences on page 14), all of 
the real time display panes can be resized and moved anywhere on your desktop. 
However, each type of display can only dock to another display of its own type. In other 
words, Contact Service Queue displays dock to other Contact Service Queue displays 
and Agent displays dock to other Agent displays. For example, you cannot separate 

Figure 3. Identifying real time displays
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CSQ information and

Agents information

These displays are in 
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anywhere on the desktop
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one Agent display from another Agent display, although they can be resized in 
relationship to each other (Figure 4).

You can also drag the vertical splitter between the trees panes and the display panes 
left or right, and the horizontal splitter between the two trees panes up and down. 

If you choose to enable movable windows (see "Setting Preferences"), Skill Groups 
displays dock to Skill Groups displays and Agents displays dock to Agents displays, 
but they are all free to be resized and moved anywhere on your desktop. 

If you choose to enable the integrated browser, the real time displays and the browser 
appear on tabs in the area to the right of the skill group and agent navigation trees. 

Figure 4. Example of rearranged and resized displays
April 2009 13



Cisco Supervisor Desktop User Guide
Setting Preferences

The Preferences dialog box controls what information is displayed in the display panes 
and how those panes behave. Table 1 summarizes what you can configure using 
Preferences. 

Table 1. Configurable Elements of the Supervisor Desktop Interface 

Tree Control 
Node Available Displays

Configure 
Columns?

Configure 
Graphs?

Configure 
Refresh? 

Contact Service 
Queues Team Summary Yes Yes Yes

Voice > CSQ
Summary Yes No Yes

Detail Yes Yes No

E-Mail > CSQ*

* Premium bundle only.

Summary Yes No Yes

Detail Yes No Yes

Team
Team Summary Yes Yes Yes

Team State Yes Yes No

Agent Agent vs. Team 
Summary

Yes Yes Yes

Logs
State Yes No No

Call Yes No No

Calls

Active Call Yes No No

Enterprise Data Yes No No

Enterprise Call History Yes No No

E-Mail Active E-Mail Yes No Yes

Browser Supervisor browser 
tabs

— — —
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To set your interface preferences:

1. Choose View > Preferences.The Preferences dialog box appears (Figure 5).  

2. In the left pane, select a node. The right pane displays that node’s settings.

NOTE: If a display element is disabled, it cannot be configured.

3. If you want to configure the columns that are displayed, complete the 
following steps:

a. Select Columns and click the ellipsis (…). The Configure Columns dialog 
box appears.

b. Select the columns you want to appear in the display. Use the up and 
down arrows to set the order in which you want them to appear.

c. Click OK when done.

4. If you want to configure the chart that is displayed, complete the following 
steps.

a. Select Graphical displays and click the ellipsis (…). The Select charts 
dialog box appears.

b. Select the chart you want to appear in the display, then click OK. You can 
select only one chart for each real time display.

Figure 5. Preferences window
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5. If you want to configure the refresh rate, select Refresh rate in seconds and 
adjust the rate.

6. If you want to be able to rearrange the real time display panes, select the 
Enable movable windows check box.

7. If you want the toolbar icons to be 32 × 32 pixels instead of the default 
16 × 16 pixels, select the Enable Large Toolbar Icons check box.

8. If you want to have access to the integrated browser in Supervisor Desktop, 
select the Enable Integrated Browser check box.

■ To configure a home page that is different from the default of 
www.cisco.com, select the Browser node in the left pane. Enter a URL in 
the Browser Home Page field in the right pane, and then click OK.

■ If you want to have access to more than one browser tab, complete the 
following steps.

a. Select the Browser node in the left pane.

a. Select a number from 1 to 10 in the Number of Browser Tabs field in 
the right pane.

a. For each additional browser tab, select the tab from the Browser Tab 
field, then enter a URL in the Browser Home Page field. If you do not 
enter a home page or you delete an existing URL, the tab will use the 
Cisco home page (www.cisco.com).

Agent Tree

The Agent tree displays all agents and supervisors on the selected team who are 
currently logged in. The icon next to the agent’s name indicates which agent state the 
agent is in (see "Toolbar" on page 19 to see examples of the agent state icons). 

In addition to the agent state icons, this icon  indicates that an agent is in the 
Not Ready state and is on a call.

NOTE:  If you have the Standard bundle, only IP Phone agents appear 
in the agent tree.

Formatting Agent Names in the Agent Tree

The Preferences dialog box enables you to control how agent names are displayed in 
the agent tree. 

An agent can be identified by any or all of the following:

■ Name

■ Extension
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■ Application used by the agent (CAD, CAD-BE, or IPPA)

At least one of these must be selected to identify an agent in the agent tree. If all 
options are selected, the information in the agent tree appears as follows:

Jane Smith x1500 CAD

In this example, Jane Smith is a CAD agent. Her extension is 1500.

To format agent names in the agent tree:

1. Choose View > Preferences, and then select the Agents node.

2. In the Format node text grid, check the elements you want to use to identify 
an agent. You must select at least one element. A sample of what the name 
will look like appears on the Sample line.

3. Click OK.

Restoring the Interface Default Layout

To restore Supervisor Desktop to its default layout, open the Preferences window 
(choose View > Preferences) and click Restore Default Layout. 

Clicking this button makes the following changes:

■ In the Real Time Displays pane, moves displays to their default positions

■ Disables the integrated browser

■ Disables movable windows

■ Disables any graphical real time displays you selected previously

■ Resets the toolbar buttons to the default size

■ Resets the report font to the default size

■ Disables Cisco Unified Presence
April 2009 17
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Clicking this button does not make any of the following changes. You must manually 
resize the columns yourself and reset the other two elements to their default settings 
in the Preferences window (see "Setting Preferences" on page 14).

■ Resize columns to their default widths

■ Restore columns to real time displays that you removed previously

■ Reset the report font size to the default (15)

Accessibility

Supervisor Desktop has a number of features that aid accessibility by vision-impaired 
users. They are:

■ Follows Windows settings for screen resolution and color/contrast settings

■ Choice of small (16 × 16 pixels) or large (32 × 32 pixels) toolbar icons (see 
"Setting Preferences" on page 14)

■ Screen reader-compatible tool tips for all controls

■ Screen reader-compatible shortcut keys for navigating the application and 
toolbar (see "Interface Shortcut Keys" on page 18 and "Toolbar" on page 19)

Interface Shortcut Keys

Shortcut keys are available to navigate the Supervisor Desktop interface. The shortcut 
keys are:

Once you have set focus to the skill group tree, the agent tree, or the team node in the 
agent tree, you can use the tab key to navigate to the real time display panes. Once 
your focus is in a real time display pane, you can use the arrow keys to navigate 
around the display grid.

NOTE:  The tab key will move you among the real time display panes, 
but the order in which you access them will not necessarily be in sync 
with the physical arrangement of the display panes on your desktop.

Table 2. Accessibility shortcut keys

Shortcut Keys Description

Ctrl+Shift+S Selects the Skill Groups node in the Skill Groups tree.

Ctrl+Shift+A Selects the Agents node in the Agents tree.

Ctrl+Shift+T Selects the Team node in the Agents tree.

Ctrl+H Selects and drops down the Team Selection List.
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Toolbar

The Supervisor Desktop toolbar consists of the following buttons. To view a tooltip 
explaining a button’s function, move your mouse pointer over the button.

Integrated Browser Pane

The integrated browser pane allows you to view internet and intranet web pages to 
help you assist agents and customers. The integrated browser has from 1 to 10 tabs, 
each of which can display a different web page. You configure each tab to display a 
specific web site.

Table 3.  Supervisor Desktop toolbar buttons 

Button Name Shortcut Key Description

Refresh Ctrl+F Refreshes the information in the active 
data view pane.

Logout Ctrl+L Logs the selected agent out of the ACD.

Ready Crtl+E Puts the selected agent in the Ready 
agent state.

Not Ready Ctrl+N Puts the selected agent in the Not 
Ready agent state.

Work Ctrl+D Puts the selected agent in the Work 
agent state.

Chat Ctrl+J Opens the Chat window.

Team 
Message

Ctrl+X Opens the Team Message dialog box.

Start Record Ctrl+R Starts recording the selected phone 
call.

Stop Record Ctrl+S Stops recording the selected phone 
call.

Start Voice 
Monitor

Ctrl+A Starts monitoring the selected agent.

Stop Voice 
Monitor

Ctrl+P Stops monitoring the selected agent.

Voice Monitor 
Volume

Ctrl+V Pops up a slider that enables you to 
control or mute the volume when 
monitoring a call.
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For more information about this pane, see "Using the Integrated Browser" on page 50.

Status Bar

The status bar (Figure 6) displays current information about Supervisor Desktop.

In the event of a service failure, the Current Status section changes from “In Service” 
to “Partial Service” or “No Service.” To learn what features are affected by the service 
outage, double-click the Current Status section of the status bar to view a popup 
window that displays which features are active or inactive.

Figure 6. Status bar.
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Real Time Displays

The real time displays contain the information you need to manage your teams and 
agents. Real time displays include the following:

■ Agent – Agent vs. Team Summary (page 21)

■ Agent Contact – Active Call (page 25)

■ Agent Contact – Active E-Mail (page 25)

■ Agent Contact – Enterprise Call History (page 26)

■ Agent Contact – Enterprise Data (page 26)

■ Agent Logs – Call (page 27)

■ Agent Logs – State (page 27)

■ Agents – Team State (page 28)

■ Agents – Team Summary (page 28)

■ E-Mail CSQ – Detail (page 30)

■ E-Mail CSQ – Summary (page 31)

■ E-Mail CSQs – Team Summary (page 32)

■ Voice CSQ – Detail (page 33)

■ Voice CSQ – Summary (page 34)

■ Voice CSQs – Team Summary (page 36)

There are two types of displays: tabular and graphical.

■ Tabular displays present skill group, team, and agent information in a grid. 
Tabular information can be sorted in ascending/descending order by clicking 
any column header in the grid. You can sort by one column only. 

■ Graphical displays present that same information as bar charts, except for the 
Agent vs. Team Statistics, which is presented as two pie charts.

NOTE:  Graphical displays are available at the Premium level only.

Agent – Agent vs. Team Summary

The Agent vs. Team Summary display is available when you select a specific agent in 
the Agents tree. This display presents the performance details for the agent and 
compares them to the performance details of the team. 

The data is obtained from the CAD Recording & Statistics service, and is for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
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every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 30 
seconds.

The graphical display (Figure 7) is presented as two pie charts. These pie charts show 
the percentage of time a specific agent spends in various ACD states in comparison to 
the percentages spent by the team as a whole. 

NOTE:  Percentages in the pie chart are rounded to 2 decimal places. 
As a result, the total of all percentages might not equal 100%. 

NOTE:  If Other Time is a small value, it might not show up as a slice in 
the graphical display pie chart. 

Figure 7. Agent vs. Team Percent Time in State graphical display

Table 4. Agent vs. Team Summary display data 

Column Name Description

ID Identifies the statistics as for the selected agent or the 
team.

Logon Time The amount of time (in seconds) since midnight the 
agent and team have been logged into Agent Desktop.

Calls Presented The number of inbound calls (ACD and non-ACD) 
presented to the agent since midnight.
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Calls Handled The number of inbound calls (ACD and non-ACD) 
presented to and answered by the agent since midnight.

Max Talking The longest talk time (in seconds) of all calls handled 
since midnight.

Avg Talking The average talk time and hold time (in seconds) of all 
calls handled since midnight.

Total Talking The total Reserved time, talk time, and hold time (in 
seconds) of all calls handled today.

Max Ready The longest time (in seconds) spent in the Ready state 
since midnight.

Avg Ready The average time (in seconds) spent in the Ready state 
since midnight.

Total Ready The total time (in seconds) spent in the Ready state 
since midnight.

Max Not Ready The longest time (in seconds) spent in the Not Ready 
state since midnight.

Avg Not Ready The average time (in seconds) spent in the Not Ready 
state since midnight.

Total Not Ready The total time (in seconds) spent in the Not Ready state 
since midnight.

Max After Call Work The longest time (in seconds) spent in the Work state 
since midnight.

Avg After Call Work The average time (in seconds) spent in the Work state 
since midnight.

Total After Call Work The total time (in seconds) spent in the Work state since 
midnight.

Other Time The total time (in seconds) spent in states other than 
Talking, Ready, Not Ready, Reserved, and Work since 
midnight.

E-Mails Retrieved The number of e-mails received since midnight.

E-Mails Sent The number of e-mails sent since midnight.

Table 4. Agent vs. Team Summary display data (cont’d)

Column Name Description
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Max Processing For all sent e-mail, the longest time (in seconds) spent in 
the E-Mail Processing state with the e-mail in focus since 
midnight. All processing time is included, whether it 
occurred before or after midnight.

Avg Processing For all sent e-mail, the average time (in seconds) spent 
in the E-Mail processing state with the e-mail in focus 
since midnight. All processing time is included, 

Total Processing For all sent e-mail, the total time (in seconds) spent in 
the E-Mail Processing state with the e-mail in focus since 
midnight. All processing time is included, whether it 
occurred before or after midnight.

Max On Desk For all sent e-mail, the maximum time (in seconds) an 
e-mail spent on desk since midnight. On-desk time 
begins when an agent receives an e-mail and ends when 
the agent sends a reply to that e-mail. All on-desk time is 
included, whether it occurred before or after midnight.

Avg On Desk For all sent e-mail, the average time (in seconds) an 
e-mail spent on desk since midnight. On-desk time 
begins when an agent receives an e-mail and ends when 
the agent sends a reply to that e-mail. All on-desk time is 
included, whether it occurred before or after midnight.

Max E-Mail Ready The longest time (in seconds) spent in the E-Mail Ready 
state since midnight.

Avg E-Mail Ready The average time (in seconds) spent in the E-Mail Ready 
state since midnight.

Total E-Mail Ready The total time (in seconds) spent in the E-Mail Ready 
state since midnight.

Max E-Mail Not Ready The longest time (in seconds) spent in the E-Mail Not 
Ready state since midnight.

Avg E-Mail Not Ready The average time (in seconds) spent in the E-Mail Not 
Ready state since midnight.

Total E-Mail Not Ready THe total time (in seconds) spent in the E-Mail Not 
Ready state since midnight.

Table 4. Agent vs. Team Summary display data (cont’d)

Column Name Description
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Agent Contact – Active Call

The Active Call display is available when you select an active call under a specific 
agent’s name in the Agents tree. This display presents information about each party in 
the current active call. The data refresh rate is 1 second, and is not configurable.

Agent Contact – Active E-Mail

The Active E-Mail display is available when you select the E-Mail node underneath a 
specific agent’s name in the Agents tree. 

This display presents a summary of the e-mails the agent is working on. The data is for 
the current day starting at midnight. The data refresh rate is 1 second, and is not 
configurable.

Table 5. Agent Active Call display data 

Column Name Description

Name Name of the parties in the call, if known. If this data is 
not known, <unavailable> is displayed.

Number The party’s phone number.

Call Status Hook state of the party (Active or Held).

Duration The length of time the party has been in the call.

Contact Service Queue The ID of the contact service queue that the call was 
queued to, if applicable.

Table 6. Active E-Mail display data 

Field Description

From The sender of the e-mail.

To The recipient of the e-mail.

Subject The subject of the e-mail.

Date Received The date the e-mail was received.

Date Retrieved The date the e-mail was retrieved from the queue by the 
agent.

In Process Duration The length of time the agent spent processing the 
e-mail. Processing time includes all time that the agent 
was in E-Mail Processing state with the e-mail in focus.
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Agent Contact – Enterprise Call History

The Enterprise Call History display is available when you select an active call under a 
specific agent’s name in the Agents tree. This display presents a history of the call’s 
presence in the contact center. The data refresh rate is 1 second, and is not 
configurable.

Agent Contact – Enterprise Data

The Enterprise Data display is available when you select an active call under a specific 
agent’s name in the Agents tree. The data displayed is configured by your 
administrator. The data in the report can be refreshed manually by clicking the 
Refresh button on the toolbar.

On Desk Duration The length of time the e-mail was on the agent’s desk. 
On-desk time begins when an agent receives an e-mail 
and ends when the agent sends a reply to that e-mail. 

Contact Service Queues The name of the contact service queue to which the 
e-mail was routed.

Table 6. Active E-Mail display data (cont’d)

Field Description

Table 7. Enterprise Call History display data 

Column Name Description

Threshold The acceptable amount of time a call can remain at a 
particular device or contact center. The administrator 
may assign caution and warning threshold values to 
each device type, as well as a total threshold value for a 
call. 

If a call remains at a device longer than the defined 
caution and warning thresholds, a caution or warning 
icon is displayed in this field.

Device A device that the call has passed through.

Type The type of device the call has passed through.

Description Description of the device.

Duration The amount of time the call spends at a device.
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Agent Logs – Call

The Call display is available when you select the Logs node underneath a specific 
agent’s name in the Agents tree. 

This display presents a history of the calls made and received by the agent during the 
current session. By default, the data displayed is sorted in ascending order by time of 
day. The data in the report can be refreshed manually by clicking the Refresh button 
on the toolbar.

Agent Logs – State

The State display is available when you select the Logs node underneath a specific 
agent’s name in the Agents tree. 

This display presents a history of the ACD states the agent transitioned through during 
the current session. By default, the data displayed is sorted in ascending order by time 
of day. The data in the report can be refreshed manually by clicking the Refresh button 
on the toolbar.

Table 8. Call display data 

Column Name Description

Start Time The time the call was answered.

Direction Inbound or outbound call.

Answered (Yes/No) Answered or unanswered call.

Calling Party The originating phone number.

Called Party The recipient phone number.

Call Duration The length of the call.

Table 9.  State display data 

Column Name Description

Start Time The time the agent state was initiated.

Agent State The ACD agent state.

Wrap-up Data Any wrap-up data the agent entered, if the agent state 
transitioned to after ending a call or sending an e-mail is 
After Call Work (Work).

Reason Code Any reason code the agent entered, if the agent state 
transitioned to is Not Ready or Logout (if required).

State Duration The length of time the agent was in the agent state.
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Agents – Team State

The Team State display is available when you select the Team node or Agents node in 
the Agents tree. This display presents the performance details for each agent on the 
team. By default, the data displayed is sorted in ascending order by agent name.

The data is obtained from the CAD Chat service, and is for the current day starting at 
midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of the information consists of a bar chart with ACD states on the 
Y axis and the number of agents currently in each ACD state. 

Agents – Team Summary

The Team Summary display is available when you select the Team node or Agents 
node in the Agents tree.

This display presents the real time state of the agents on the selected team who are 
currently logged into the ACD. By default, the data displayed is sorted in ascending 
order by agent name.

The data is obtained from the CAD Recording & Statistics service, and is for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 30 
seconds.

Table 10. Team State display data 

Column Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID. 

Current State The agent’s current ACD state.

Skill Group The skill group ID of the call the agent is currently 
servicing (in Talking state). If there is no call, or if the call 
is a non-ACD call, this field is blank.

Contact Service Queue Name of the contact service queue.

State Duration The amount of time, in seconds, that the agent has been 
in the current ACD state.

Reason Code The reason why the agent is in the current ACD state. 
Reason codes are available for the Not Ready and 
Logout states only. 
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Real Time Displays
Graphical displays of the information consist of bar charts with agent names on the Y 
axis and the average amount of time (hh:mm:ss) the agent spent in a selected ACD 
state.

Table 11. Team Summary display data 

Column Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID. 

Logon Time The total amount of time the agent has been logged into 
the ACD today.

Calls Presented The number of inbound calls (ACD and non-ACD) 
presented to the agent today.

Calls Handled The number of inbound calls (ACD and non-ACD) 
presented to and answered by the agent today.

Max Talking The longest talk time of all calls handled today.

Avg Talking The average talk time and hold time of all calls handled 
today.

Total Talking The total Reserved time, talk time, and hold time of all 
calls handled today.

Max Ready The longest time the agent spent in the Ready state 
today.

Avg Ready The average time the agent spent in the Ready state 
today.

Total Ready The total time the agent spent in the Ready state today.

Max Not Ready The longest time the agent spent in the Not Ready state 
today.

Avg Not Ready The average time the agent spent in the Not Ready state 
today.

Total Not Ready The total time the agent spent in the Not Ready state 
today.

Max After Call Work Longest time spent in the Work state.

Avg After Call Work The total time spent in the Work state divided by the 
number of times spent in the Work state.

Total After Call Work The total time spent in the Work state.
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E-Mail CSQ – Detail

The Detail display is available when you select a specific contact service queue from 
the Contact Service Queues > E-Mail tree. 

The data is for the current day starting at midnight. The data refresh rate is 
configurable. By default it is every 15 seconds. The minimum rate is 5 seconds, and 
the maximum rate is 60 seconds.

There is no graphical display available for these statistics.

Other Time The total time (in seconds) the agent spent in states 
other than Talking, Ready, Not Ready, Reserved, and 
Work since midnight.

Table 11. Team Summary display data (cont’d)

Column Name Description

Table 12. Detail display data

Column Name Description

Agent Name The agent’s name.

Current Voice State The agent’s current voice agent state.

Voice State Duration The length of time the agent has been in the current 
voice agent state.

Voice Reason Code The reason code the agent selected when transitioning 
to the current voice agent state.

Current E-Mail State The agent’s current e-mail state.

E-Mail State Duration The length of time the agent has been in the current 
e-mail state.

E-Mail Reason Code The reason code the agent selected when transitioning 
to the current e-mail state.

Contact Service Queue The name of the contact service queue for which the 
agent is currently handling a contact, if any.

Contact Service Queue 
ID

The ID of the contact service queue for which the agent 
is handling a contact, if any.

Media The media type of the contact service queue, Voice or 
E-Mail.
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E-Mail CSQ – Summary

The Summary display is available when you select a specific contact service queue 
from the Contact Service Queues > E-Mail tree. 

The data is for the current day starting at midnight. The data refresh rate is 
configurable. By default it is every 15 seconds. The minimum rate is 5 seconds, and 
the maximum rate is 60 seconds.

There is no graphical display available for these statistics.

Table 13. Summary display data

Column Name Description

Contact Service Queue Name of the contact service queue.

Agents Logged In The number of agents in this contact service queue who 
are currently logged in

Agents Processing The number of agents in this contact service queue who 
are currently in the Processing E-Mail state.

Agents Ready The number of agents in this contact service queue who 
are currently in the Ready state.

Agents Not Ready The number of agents in this contact service queue who 
are currently in the Not Ready state.

Oldest in Queue Of the e-mails currently in queue for this contact service 
queue, the length of time in queue (in seconds) of the 
e-mail that has been in the queue the longest.

Total E-Mail in Queue The current number of e-mails in queue that have not 
been routed to an agent.

Total E-Mails Received The number of e-mails routed to this contact service 
queue since the Start Time.

Handled Today The number of e-mails routed through this contact 
service queue that agent have sent since midnight. The 
time of the sent event determines whether the e-mail is 
included in the count.

Average Handle The average processing time for e-mails sent since 
midnight. All the processing time is included for the 
e-mail, including any time before or after midnight.
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E-Mail CSQs – Team Summary

The Team Summary display is available when you select the Contact Service Queues > 
E-Mail node. 

The data is for the current day starting at midnight. The data refresh rate is 
configurable. By default it is every 15 seconds. The minimum rate is 5 seconds, and 
the maximum rate is 60 seconds.

There is no graphical display available for these statistics.

Average Response The average response time for e-mails sent since 
midnight. Response time is the difference between the 
times the e-mail was received and sent. All the response 
times is included for the e-mail, including any time 
before or after midnight.

Longest Handle Of the e-mails routed through the contact service queue 
and sent since midnight, the handle time is seconds for 
the e-mail with the longest handle time. All the 
processing time is included for the e-mail, including any 
time before or after midnight.

Longest Response Of the e-mails routed through the contact service queue 
and sent since midnight, the response time for the 
e-mail with the longest response time (in seconds). All 
the response time is included for the e-mail, including 
any time before or after midnight.

Table 13. Summary display data

Column Name Description

Table 14. Team Summary display data

Column Name Description

Contact Service Queue The name of the contact service queue.

Agents Logged In The number of agents currently logged in who support 
the contact service queue.

Agents Processing The number of agents currently in the Processing E-Mail 
state who support the contact service queue.

Agents Ready The number of agents currently in the E-Mail Ready state 
who support the contact service queue.

Agents Not Ready The number of agents currently in the E-Mail Not Ready 
state who support the contact service queue.
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Voice CSQ – Detail

The Voice CSQ—Detail display is available when you select a specific contact service 
queue from the Skill Groups tree. 

This display presents information about each agent logged into the ACD and assigned 
to the selected contact service queue. By default, the data displayed is sorted in 
ascending order by agent name.

Oldest in Queue Of the e-mails currently in queue for this contact service 
queue, the length of time in queue (in seconds) of the 
e-mail that has been in the queue the longest.

Total E-Mail in Queue The current number of e-mails in queue that have not 
been routed to an agent.

Total E-Mails Received The number of e-mails routed to the contact service 
queue since midnight.

Handled Today The number of e-mails routed through the contact 
service queue that agents sent since midnight. The time 
the e-mail was sent determines whether the e-mail is 
included in this count.

Average Handle The average e-mail processing time for e-mails sent 
since midnight. All the processing time is included for 
the e-mail, including any time before or after midnight

Average Response The average response time for e-mails sent since 
midnight. Response time is the difference between the 
times the e-mail was received and sent. All the response 
times is included for the e-mail, including any time 
before or after midnight.

Longest Handle Of the e-mails routed through the contact service queue 
and sent since midnight, the handle time is seconds for 
the e-mail with the longest handle time. All the 
processing time is included for the e-mail, including any 
time before or after midnight.

Longest Response Of the e-mails routed through the contact service queue 
and sent since midnight, the response time for the 
e-mail with the longest response time (in seconds). All 
the response time is included for the e-mail, including 
any time before or after midnight.

Table 14. Team Summary display data

Column Name Description
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The data is obtained from the CAD Chat service, and are for the current day starting at 
midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of this information consists of a bar chart with the ACD states on 
the Y axis and the number of agents on the X axis. 

Voice CSQ – Summary

The CSQ — Summary display is available when you select a specific contact service 
queue from the Skill Groups tree. 

This display presents a summary of a specific contact service queue’s statistics. 
These statistics are from the entire contact center, not just from members of the 
selected team.

The data is obtained from the CTI service unless otherwise noted, and are for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 60 
seconds.

NOTE:  Even though you can configure the refresh rate, it is still 
dependent on how often the Enterprise service queries the CTI 
service (every 10 seconds). If the refresh rate is changed to a shorter 
time interval, the display will be refreshed at that interval, but the 
statistics might not change until the Enterprise service receives the 
updated information from the CTI service.

Table 15. CSQ Detail real time display data 

Column Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Current State The agent’s current ACD state.

Skill Group The skill group ID of the ACD call the agent is currently 
servicing (in Talking state). If there is no call, or if the call 
is a non-ACD call, this field is blank.

Contact Service Queue Name of the contact service queue.

State Duration The amount of time, in seconds, that the agent has been 
in the current ACD state.

Reason Code The reason why the agent is in the current ACD state. 
Reason codes are available for the Not Ready and 
Logout states only. 
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Real Time Displays
There is no graphical display available for these statistics.

Table 16. CSQ–Summary display data 

Field Description

Contact Service Queue Name of the contact service queue.

Agents Logged In Number of agents currently logged into the system.

Agents in Talking Number of agents currently in the Talking state.

Agents Ready Number of agents currently in the Ready state.

Agents Not Ready Number of agents currently in the Not Ready state.

Agents in Work Number of agents currently in the Work state.

Agents Reserved Number of agents currently in the Reserved state.

Current Oldest The number of calls in queue and the elapsed wait time 
of the oldest call in the queue, displayed in the format 
“x [hh:mm:ss]”, where X is hte number of calls and 
hh:mm:ss is the elapsed wait time.

Total Calls Total number of calls that have arrived, including calls 
waiting, calls connected to agents, and calls that have 
disconnected.

Handled Calls Today Number of calls handled by the contact service queue 
for the current reporting period. A call is considered to 
be handled when an agent picks up the call.

Calls Abandoned Number of calls that were routed to the contact service 
queue but were not answered by an agent because the 
caller hung up or was disconnected.

Calls De-queued Number of calls that were dequeued. A call is 
considered to be dequeued from a particular contact 
service queue if the call is handled by an agent in 
another contact service queue. This situation can occur 
when a call is queued for more than one contact service 
queue.

Start Time Starting date and time of the current reporting period.

End Time Ending date and time of the current reporting period.

Talk Average Average talk time for all calls handled by agents. Talk 
time is the elapsed time between the time that an agent 
connects to a call and when the call is disconnected or 
transferred, not including hold time.
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Voice CSQs – Team Summary

The Team Skill Statistics display is available when you select the Skill Groups node in 
the Skill Groups tree. 

This display presents the details of each individual skill group, regardless of whether 
or not an agent with that skill is logged in. By default, the data displayed is sorted in 
ascending order by skill name. 

The data is obtained from the CTI service unless otherwise noted, and are for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 60 
seconds.

NOTE:  Even though you can configure the refresh rate,.it is still 
dependent on how often the Enterprise service queries the CTI 
service (every 10 seconds). If the refresh rate is changed to a shorter 
time interval, the display will be refreshed at that interval, but the 
statistics might not change until the Enterprise service receives the 
updated information from the CTI service.

Average Waiting 
Duration

Average wait time for calls routed to the contact service 
queue. Wait time is the elapsed time between the time a 
call entered the queue and the time the call was 
answered by an agent or was disconnected.

Longest Talking Longest talk time of any one call that agents have 
handled. Talk time is the elapsed time between the time 
that an agent connects to a call and when the call is 
disconnected or transferred, not including hold time.

Longest Waiting Longest wait time for any one call routed to the contact 
service queue. Wait time is the time that elapsed 
between the time a call entered the queue and the time 
the call was answered by an agent or was disconnected.

Calls Priority 1… 
Calls Priority 10

Total number of Priority N calls that were routed to each 
contact service queue.

Table 16. CSQ–Summary display data (cont’d)

Field Description
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Real Time Displays
Graphical displays of this information consist of bar charts with the skill name on the Y 
axis and any of the available statistics listed in the table below on the X axis, 
expressed in either an integer (0, 1, 2…) or time duration (hh:mm:ss).

Table 17. Team Skill Statistics display data 

Field Description

Contact Service Queue Name of the contact service queue.

Agents Logged In Number of agents currently logged into the system.

Agents in Talking Number of agents currently in the Talking state.

Agents Ready Number of agents currently in the Ready state.

Agents Not Ready Number of agents currently in the Not Ready state.

Agents in Work Number of agents currently in the Work state.

Agents Reserved Number of agents currently in the Reserved state.

Current Oldest The number of calls in queue and the elapsed wait time 
of the oldest call in the queue, displayed in the format 
“x [hh:mm:ss]”, where X is hte number of calls and 
hh:mm:ss is the elapsed wait time.

Total Calls Total number of calls that have arrived, including calls 
waiting, calls connected to agents, and calls that have 
disconnected.

Handled Calls Today Number of calls handled by the contact service queue 
for the current reporting period. A call is considered to 
be handled when an agent picks up the call.

Calls Abandoned Number of calls that were routed to the contact service 
queue but were not answered by an agent because the 
caller hung up or was disconnected.

Calls De-queued Number of calls that were dequeued. A call is 
considered to be dequeued from a particular contact 
service queue if the call is handled by an agent in 
another contact service queue. This situation can occur 
when a call is queued for more than one contact service 
queue.

Start Time Starting date and time of the current reporting period. 
Note: If there is a failover, the start time reflects the time 
when the failover occurred.

End Time Ending date and time of the current reporting period.
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Talk Average Average talk time for all calls handled by agents. Talk 
time is the elapsed time between the time that an agent 
connects to a call and when the call is disconnected or 
transferred, not including hold time.

Average Wait Duration Average wait time for calls routed to the contact service 
queue. Wait time is the elapsed time between the time a 
call entered the queue and the time the call was 
answered by an agent or was disconnected.

Longest Talking Longest talk time of any one call that agents have 
handled. Talk time is the elapsed time between the time 
that an agent connects to a call and when the call is 
disconnected or transferred, not including hold time.

Longest Waiting Longest wait time for any one call routed to the contact 
service queue. Wait time is the time that elapsed 
between the time a call entered the queue and the time 
the call was answered by an agent or was disconnected.

Calls Priority 1… 
Calls Priority 10

Total number of Priority N calls that were routed to each 
contact service queue.

Table 17. Team Skill Statistics display data (cont’d)

Field Description
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Monitoring Agents

The voice monitor button enables you to silently listen in on an agent’s phone 
conversations.

Voice monitoring is available whenever an agent is logged in, whether or not the agent 
is on the phone. It is not available when:

■ You are a participant in a phone call (you cannot monitor yourself).

■ You use the Barge-In or Intercept function.

The Voice Monitor Volume button allows you to control the volume when monitoring an 
agent’s phone conversation. The system remembers your last volume setting and 
uses it the next time you log in.

To start monitoring an agent:

1. Choose an agent in the Agents tree.

2. Click the Start Voice Monitor button, or choose Intervention > Start Voice 
Monitor.

To stop monitoring an agent:

■ Click the Stop Voice Monitor button, or choose Intervention > Stop Voice 
Monitor.
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Pushing a Web Page to an Agent

You can coach an agent by pushing a web page to that agent’s Agent Desktop 
integrated browser.

To push a web page to an agent:

1. From the Agent tree, select an agent. 

2. Choose Intervention > Coach by Pushing a Page. The Push URL to Agents 
dialog box appears (Figure 8).

3. Enter the URL of the web page you want the agent to see, and then click Push 
to send the web page to the agent. The web page you pushed to the agent is 
displayed in the first tab of the agent’s integrated browser. This tab is 
reserved for pushed web pages.

NOTE:  There are no restrictions on what you can enter as a URL (for 
example, you are not required to prefix the URL with “http://”) as long 
as the URL can be resolved by a browser. Some sites require that 
“http” or “https” be part of the URL.

NOTE:  If the integrated browser is not enabled for the selected agent 
(by default, it is not enabled in CAD-BE), this operation will fail, but no 
error message will appear. 

Figure 8. Push URL to Agents dialog box.
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Recording Calls

You can use Supervisor Desktop to record, save, and play back calls handled by 
agents on your team. Multiple recordings can be in progress at the same time, 
although only one recording can be made per agent at any one time. You use the 
Supervisor Record Viewer to review recorded calls.

You can use the Voice Monitor feature while recording.

When recording a call, keep in mind the following considerations:

■ The recording feature is not intended to record every call. It is an on-demand 
solution only.

■ When you select a specific call from the Team View pane to record, all voice 
activity to and from that particular agent is recorded. The recording is not 
limited to the call you selected. For instance, if the agent puts the selected 
call on hold and switches to another call, both calls will be recorded.

■ The recording will end when the selected call terminates, or when you 
manually stop recording, whichever comes first.

■ Agents can be configured so that they can start and stop recording calls. 
However, an agent cannot stop a recording started by a supervisor. If an agent 
attempts to do so, their Agent Desktop or IP Phone Agent interface indicates 
the recording is stopped. However, the recording is not stopped, and 
Supervisor Desktop displays an icon indicating that recording is proceeding.

■ You can stop a recording initiated by an agent.

■ If notification is off, agents have no way of knowing if you are recording their 
calls. If an agent attempts to start recording a call that you are already 
recording, the agent will see a recording icon on the call, although the agent is 
not in control of the recording. 

■ When you or an agent record a call, a recording license is used. The license is 
released when the recording stops. If all recording licenses are in use when 
you attempt to start a recording, the recording will not start.

To record a call:

1. Choose the call you want to record from the Agents tree.

2. Click the Start Record button, or choose Intervention > Call/Agent Start 
Recording.

3. When you are finished, click the Stop Record button, or choose 
Intervention > Call/Agent Stop Recording. The call is archived to the 
Recording service database, where it is automatically saved for seven days. 

NOTE:  If you want to save the recording for a longer period, you can 
do so for up to 30 days, after which it is deleted. For more information 
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on playing and saving recordings, see "Using Supervisor Record 
Viewer" on page 64. 
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Changing Agents’ ACD States

You can use Supervisor Desktop to change the ACD state of an agent on your team, 
including logging an agent out. 

NOTE:  If you log a CAD agent out, that agent will continue to appear in 
the agent tree and will be able to chat and receive team messages. If 
you log out an IP Phone agent or CAD-BE agent, that agent disappears 
from the agent tree.

To change an agent’s agent state:

1. From the Agents tree, select the agent whose state you want to change.

2. On the toolbar, click the appropriate agent state button.

NOTE:  There is a delay of about 2 to 3 seconds before the command 
to change agent state takes effect. To ensure you set the desired 
agent state, allow enough time between clicking Agent State buttons 
for the command to take effect.

NOTE:  If an agent state change fails, you will not see any failure 
message. You will know that an agent state change succeeds if the 
icon next to the agent’s name in the team view pane changes to the 
current agent state icon.
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Using Chat

Chat enables you to send instant messages to agents and supervisors on your teams.

Figure 9 displays a supervisor’s Contact Selection window.  

Your contacts are organized in groupings called drawers.

■ The Agents drawer lists all the agents on the team selected in Supervisor 
Desktop. The agents’ agent state is indicated both by an icon to the left of the 
agent name and by text to the right of the agent name. The agent state is 
updated whenever an agent state changes. Agents do not have to be currently 
logged into Cisco Agent Desktop to be listed here, but they must have Cisco 
Agent Desktop open and they must have logged in at least once. 

■ The Supervisors drawer lists all supervisors on your team. Their status is 
always listed as Available. Supervisors must be logged in to be listed here.

■ The Conference drawer appears when you are on a conference call with other 
agents.

NOTE:  You cannot chat with Cisco Agent Desktop—Browser Edition 
(CAD-BE) agents or IP Phone agents.

Some Chat features include:

■ You can send the same chat message to multiple recipients (their replies, if 
any, appear in separate chat windows, one for each person).

Figure 9. Contact Selection window

This Contact Selection window 
displays two contact lists, or 
drawers: Agents and Supervisors.
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■ You can participate in multiple concurrent chat sessions.

■ The title bar of the Chat window displays the name of the person with whom 
you are chatting.

■ If you flag a chat message as high priority, the Chat window will pop on the 
other person’s screen so the message will be noticed immediately.

■ If the priority of a chat message is normal (the default), the Chat window will 
remain in its current state (open or minimized) and the corresponding icon 
will flash on your Windows task bar.

■ A log of the chat messages sent between you and your chat partner (chat 
history) is available as long as the Chat window is open. After you close the 
Chat window, the log is lost.

■ Chat history is in chronological order, with the oldest messages at the top of 
the log pane.

■ You can chat with agents who are logged out of the ACD as long as they still 
have Agent Desktop open.

Sending a Chat Message

To initiate a chat session:

1. On the toolbar, click Chat. The Contact Selection window appears (see 
Figure 9 on page 45). This window lists the names and status of people with 
whom you can chat.
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2. To chat with one person, double-click that person’s name. To chat with several 
people, select their names and press Enter or choose Actions > Chat. A Chat 
window opens and a session begins with the people you selected (Figure 10).

3. Type your message in the text entry field. 

4. If you want your message to be noticed immediately by popping on the 
recipient’s screen, select the High priority check box.

5. Click Send or press Enter. Your message is sent to your chat partner and 
logged in the chat log pane.

Replies from recipients of a group message appear in individual chat session 
windows. They cannot reply to the group, they can reply only to you.

To terminate a chat session:

■ Choose File > Close or click Close in the upper right-hand corner of the Chat 
window.

Figure 10. Chat session window.

Chat history pane

Text entry pane
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Predefined High-Priority Chat Messages

Agents might have a task button in Agent Desktop and CAD-BE configured to send a 
predefined high-priority chat message to their supervisor(s). This predefined message 
(for example, “Please barge in on my call”) is set up by the administrator. It behaves 
just like a regular chat message that is flagged as high priority—it pops up on your 
screen on top of all other windows for your immediate attention.

You can reply to a predefined high-priority chat message from a CAD agent. You 
cannot reply to one sent by a CAD-BE agent, since CAD-BE does not include two-way 
Chat functionality.
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Monitoring Agent-Deleted E-Mail

Agents are able to delete e-mail that is delivered to their in box. Some reasons for 
deleting an e-mail are:

■ the e-mail is spam

■ the e-mail is abusive

The deleted e-mail is not actually deleted, it is transferred to an e-mail address set up 
by the administrator in Cisco Desktop Administrator. Supervisors can access that 
e-mail account using any e-mail client (for example, Microsoft Outlook) and determine 
if the e-mails should be deleted or sent back to the e-mail queue and handled by an 
agent.

Consult with your system administrator for the procedure for accessing agent-deleted 
e-mails.
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Using the Integrated Browser

The integrated browser enables you to view intranet and internet web pages from 
within Supervisor Desktop. When enabled, the browser appears as a tab in the real 
time display pane, with up to 20 characters of the name of the current web page 
displayed on the tab. The real time displays appear on another tab in that pane.

NOTE:  You must have Internet Explorer 6 or 7 installed on your PC for 
the integrated browser to function.

By default, the browser is not enabled. See "Setting Preferences" on page 14 for 
instructions on enabling the browser and configuring a home page.

The Address field’s drop-down list contains the URLs of the last 25 websites visited for 
quick access to frequently-visited websites.

Browser Toolbar

The browser toolbar is the basic Internet Explorer toolbar. It allows you to navigate 
among web pages you view, refresh a current page, and return to your home page.

Table 18. Browser toolbar buttons 

Button Name
Shortcut 
Key Description

Back Alt–left 
arrow

Returns you to the last page you viewed.

Forward Alt–right 
arrow

Takes you to the page you viewed before you 
clicked the Back button.

Stop Esc Stops the browser from displaying a web page 
(for example, if the download is taking too 
long).

Refresh F5 Refreshes the web page displayed to ensure 
you see the latest content.

Home Alt–Home Returns you to your predefined home page.
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Sending Team Messages

You can send a team message to all CAD agents on a team, whether or not the agent 
is logged into the ACD. As long as Agent Desktop is open, an agent can view a team 
message.

NOTE:  You cannot send team messages to CAD-BE or IP Phone 
agents. 

The Team Messages dialog box (Figure 11) stores the last 10 team messages you 
broadcast. You can select any one of these messages to broadcast again. If you send 
more than 10 team messages, the oldest one drops off the stored list. You cannot 
designate any particular team message for permanent storage.

NOTE:  By default, the team message scrolls across Agent Desktop’s 
team message pane. Individual agents can set their preference in 
Agent Desktop to view team messages as stationary. A stationary 
team message is more compatible with screen readers, which are 
often used by vision-impaired agents. 

The Current Message pane displays the message that is currently being sent to your 
team.

To send a team message to all agents on a team:

1. From the team selection list, choose the team to which you want to send the 
message, and then click View > Team Messages or click the Team Messages 
button.

2. Type your message in the text box. The TM can be up to 255 characters long.

Figure 11. Team Message dialog box.
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3. In the Expires at field, choose a specific time for the message to expire. 

By default, the message runs for 30 minutes.

4. Click Start or press Enter.

The team message is sent to the team for the length of time you chose. The 
text of the message you sent is logged in the current team performance 
message field. 

To cancel a team message:

■ In the Team Message dialog box, click Stop.
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Creating Supervisor Work Flows

Using the Supervisor Work Flow Administrator feature, you can configure your desktop 
to perform certain actions based on queue statistics for calls waiting and calls in 
queue for specified skill groups. 

These work flows apply only to you, not to any other supervisors, and are available to 
you no matter where you log into Supervisor Desktop. They are tied to your login 
information.

NOTE:  Supervisor work flow actions are available at the Premium 
feature level, except for the Tree Control action, which is also 
available at the Enhanced feature level. 

In general, work flows consist of events, rules, and actions. 

■ The event that triggers an action is a skill groups queue statistics update. 
Queue statistics are updated once every 5 seconds.

■ The rule the event must meet is one or both of the following:

— The number of calls waiting is below, within, or above specified limits

— The oldest call in queue is below, within, or above specified time 
durations

■ The actions triggered by meeting the rules can be:

— Change the color of the skill group name in the tree control and/or add a 
message next to it

— Highlight data in the tabular real time display

— Display a popup message on your desktop

— Play a *.wav file on your desktop

— Send an email to selected recipients

For example, you can set up a work flow so that when there are more than 10 calls 
waiting in the queue for Skill Group 6500, the skill group name in the Skill Groups tree 
turns red and an audible warning sounds every 15 seconds. 

To set up a supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator.

The Supervisor Work Flow List dialog box appears.

2. Click Add.

The Add New Work Flow dialog box appears.

3. Enter a name for your new work flow, and then click OK.
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The Skill Group Selection dialog box appears.

4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished. 

NOTE:  A skill group may be a part of only one work flow per 
supervisor.

The Supervisor Work Flow Setup dialog box appears (Figure 12).

5. Set up the parameters for the work flow:

a. Specify the upper and lower limits for the Call Waiting and/or Current 
Oldest threshold. 

NOTE:  When you select both Calls Waiting and Current Oldest, 
the highest threshold crossed takes precedence.

Figure 12. Supervisor Work Flow Setup dialog box.
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b. Select Above from the Thresholds pane. 

c. Click Add, and from the resulting Action Type Selection dialog box, select 
the action you want to be triggered when the Calls Waiting and/or Current 
Oldest statistic is above the upper limit you set, and then click OK. See 
"Work Flow Actions" on page 58 for information on the types of actions 
available.

d. Repeat for the Within and Below thresholds.

6. When you have finished, click OK to enable the work flow.

Example: Setting Up a Supervisor Work Flow

The following is a step-by-step illustration of setting up a supervisor work flow. This 
work flow:

■ Changes the skill group name color to green and displays “Below” next to it in 
the Skill Groups tree control when there are fewer than 2 calls waiting, or if 
the current oldest call is less than 1 minute old

■ Changes the skill group name color to blue and displays “Caution” when there 
are 2 to 5 calls waiting, or if the current oldest call is between 1 and 5 
minutes old

■ Changes the skill group name color to red and displays “Warning” when there 
are more than 5 calls waiting, or if the current oldest call is more than 5 
minutes old 

To set up the example supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator.

The Supervisor Work Flow List dialog box appears.

2. Click Add.

The Add New Work Flow dialog box appears.

3. Enter the name Customer Management, and then click OK.

The Skill Group Selection dialog box appears.

4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished.

The Supervisor Work Flow Setup dialog box appears.

5. Select the Calls Waiting check box and set the lower limit to 2 and the upper 
limit to 5. 
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6. Select the Current Oldest check box and set the lower limit to 1 minute and 
the upper limit to 5 minutes.

7. Select Below in the Thresholds pane and then click Add under the Actions 
pane.

The Action Type Selection dialog box appears.

8. Select Tree Control Node Action and then click OK.
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The Tree Control Action dialog box appears.

9. Check Display Text and enter Below in the field. 

10. Check Change Text Color, click Set Color, choose green from the color palette 
displayed, and then click OK.

11. Repeat steps 7 through 10 for the Above and Within thresholds. For Above, 
select “Warning” as the display text and set the color to red. For Within, select 
“Caution” as the display text and set the color to blue.

12. When you are finished, click OK to enable the work flow. The skill group 
names will now be color-coded with text displayed.
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Work Flow Actions

There are 5 possible work flow actions that can be triggered by threshold rules. These 
actions are:

■ Audible Alert Action (page 58)

■ Message Box Action (page 59)

■ Report Action (page 60)

■ Tree Control Action (page 61)

■ Email Alert Action (page 61)

Audible Alert Action

The Audible Alert action plays a *.wav file on your desktop whenever the threshold 
rules are met. By default, the file plays once, but you can also configure it so that it 
plays repeatedly at specified intervals. 

NOTE:  You can turn off audible alerts that are configured to repeat at 
intervals by choosing Actions > Supervisor Work Flow — Audio Off 
from the menu.

Your computer most likely has system *.wav files available that are used to signal 
standard Windows events. These files are a good source of sounds. 

NOTE:  Any *.wav file you select must be 50KB or smaller. 
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To set up an audible alert, in the Audible Alert Action dialog box (Figure 13) click Add 
New and then browse to the location of your selected *.wav file. If desired, set up a 
repeat interval, and then click OK.

Message Box Action

The Message Box action pops a message box containing a customized message on 
your desktop whenever the threshold rules are met. The message box is cleared by 
clicking OK. 

Figure 13. Audible Alert Action dialog box.
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To set up a message box, in the Message Box Action dialog box (Figure 14) type your 
message in the Message Text field, select the appropriate message icon, and then 
click OK.

Report Action

The Report action highlights in color cells in the Contact Service Queue and Oldest in 
Queue columns in the tabular Team Skill Statistics real time display when the data in 
the cell exceeds the threshold rules. 

To set up a Report action, In the Report Action dialog box (Figure 15) click Set Color to 
select the color to use for highlighting the display cells, and then click OK. 

If you select the Show Team Skill Statistics Report check box, then whenever a 
statistic changes that triggers a Report action Supervisor Desktop automatically 
changes its focus to display the Team Skill Statistics report so that you will see the 
current report with the cells highlighted. 

Figure 14. Message Box Action dialog box.

Figure 15. Report Action dialog box.
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Tree Control Action

The Tree Control action enables you to select a color to apply to a skill group name 
and/or a message to display beside the skill group name in the Skill Groups tree 
control whenever the threshold rules are met.

To set up a Tree Control action, in the Tree Control Action dialog box (Figure 16) check 
the effect(s) you want applied to the skill group name. Click Set Color to select a text 
color, enter your own message or select from the drop-down list a predefined message 
(Caution or Warning) to appear next to the skill group name, and then click OK.

Email Alert Action

The Email Alert action enables you to send an email to specified people whenever the 
threshold rules are not met. 

The email messages have predefined subject lines, depending on what threshold rule 
is met. They are:

■ Skill: <skill group name>, Number of Calls Waiting is above upper limit

■ Skill: <skill group name>, Number of Calls Waiting is below lower limit

■ Skill: <skill group name>, Number of Calls Waiting is within upper and lower 
limits

■ Skill: <skill group name>, Oldest Call in Queue is above upper limit

■ Skill: <skill group name>, Oldest Call in Queue is below lower limit

■ Skill: <skill group name>, Oldest Call in Queue is within upper and lower limits

Figure 16. Tree Control Action dialog box.
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The email messages sent can consist only of the Subject line; a message in the body 
of the email is optional. 

To set up an email alert action, complete the Email Alert Action Setup dialog box 
(Figure 17) as follows:

Figure 17. Email Alert Action Setup dialog box.

Table 19. Email Alert Action Setup dialog box fields 

Field Description

From: Required. Enter your email address. The first time this 
dialog box is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.

To: Required. Enter the email addresses of the recipients, 
separated by a semicolon. The first time this dialog is 
displayed the field is blank; thereafter it is automatically 
filled with what you previously entered.

Mail Server: Required. The SMTP IP address or host name of the 
email server used to send the email. The first time this 
dialog is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.
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Use the Send button to check if the email alert action is configured correctly. When 
you click Send, a test email is sent to the email addresses in the To and BCC fields.

If the test email is successful, “Mail Sent Successfully” appears in the field next to the 
test button. If it is unsuccessful, “Mail Send Failed” appears. In that event, check your 
entries in the To, BCC, and Mail Server fields for accuracy and test it again.

BCC: Optional. Enter the email addresses of the recipients you 
want copied in on the email message. The first time this 
dialog is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.

Subject: The subject line is automatically generated by the 
action.

High Priority Select the check box if you want the email to be 
delivered with high priority. Leave it unselected for 
normal email delivery.

Message Pane (not 
labeled)

Optional. Enter a message to appear in the body of the 
email. 

Table 19. Email Alert Action Setup dialog box fields (cont’d)

Field Description
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Using Supervisor Record Viewer

The Supervisor Record Viewer (Figure 18) displays all recordings made by your team 
over the last seven days as well as those you tag for 30-day extended lifetime. 

NOTE:  A license is used whenever you open the Supervisor Record 
Viewer, and is released when you close it. If no licenses are available, 
Supervisor Record Viewer will start but no recordings will be listed 
and the error message, “Licensing error” will be displayed. You must 
wait until a license is released and available for you to use in order to 
review any recordings. For this reason, it is important to close 
Supervisor Record Viewer after you are finished using it.

The recordings are archived as raw voice data packets; they can only be played back 
using the Supervisor Record Viewer. However, if you wish to save selected recordings 
as *.wav files, you can use the “Play and Save” button and save the recording to a 
folder in *.wav format.

Unless recordings are tagged for an extended lifetime, they are automatically deleted 
after seven days. 

If a recording is tagged for the 30-day extended lifetime, they will not be deleted until 
that 30-day period expires. If you delete them manually before the 30-day period 
expires, they are deleted in the next folder cleanup—cleanups run daily at midnight.

Figure 18. Supervisor Record Viewer
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The Supervisor Record Viewer displays the following information:

To start Supervisor Record Viewer:

1. From the Supervisor Desktop menu bar, choose Tools > Recorded Files. 
Supervisor Record Viewer starts with no day selected.

2. From the Day Select section, click one of the option buttons to view the 
recordings made by your team on that date.

To listen to a recording:

1. From the Day Select section of Supervisor Record Viewer, click the option 
button for the date of the recording you want to review.

You can also click the Extended Lifetime option button to view a list of all 
recordings that have been tagged for extended 30-day archiving. 

2. Select the recording you want to review.

Figure 19. Supervisor Record Viewer toolbar

Table 20. Supervisor Record Viewer fields 

Column Name Description

Agent The agent whose call is recorded.

Team The team to which the agent belongs.

Time The time the recording was made.

Duration The length of the recording in hh:mm:ss format.

Lifetime The length of time the recording is archived: Normal is 7 
days, Extended is 30 days.

Date Recorded (Appears only when “Extended Lifetime” is selected in 
Day Select) The date the recording was made.

Play
Play & Save

Stop
Set Extended Lifetime

Set Normal Lifetime
Delete

Volume Control

Pause
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3. Click the Play button, or choose Recording > Play from the menu bar.

Use the Pause or Stop buttons to control the recording playback, and the 
volume slider to control the playback volume.

There is a progress bar at the bottom of the screen that shows where you are 
within the recording. You can click the progress bar and drag it backwards or 
forwards to rewind or fast forward the recording. You must click Play again 
after you reposition the progress bar to restart the playback.

NOTE:  You cannot play back a recording while you are monitoring a 
call.

To save a recording:

1. Select the recording you want to save.

2. Click the Play and Save button, or choose Recording > Play and Save from the 
menu bar. The Save As dialog box appears.

3. Select the folder where the recording is to be saved, enter a file name for the 
recording, and then click Save. The recording plays and simultaneously is 
saved as a *.wav file to the location you selected.

To tag a recording for extended archiving:

1. Select the recording you want to archive for 30 days.

2. Click the Set Extended Lifetime button, or choose File > Set Extended Lifetime 
from the menu bar. The recording is tagged to be archived for 30 days from 
the date of recording.
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Service Autorecovery

The service autorecovery feature allows Supervisor Desktop to automatically recover 
its connection to the Cisco services in the event of a service restart or a network 
outage.

When Supervisor Desktop detects that it is unable to communicate with a service 
(generally within three minutes of the service failure), the status bar displays “Partial 
Service” or “No Service” to indicate some or all of the services have failed.

When Supervisor Desktop detects that the service is again available (usually within 
one minute of service recovery), the status bar displays “In Service” to indicate that 
the services have recovered.

To learn more about what is affected by the service failure, double-click the status 
message on the status bar. Supervisor Desktop displays a popup box (Figure 20) that 
lists features and indicates if that feature is available or not due to the service outage. 

The agent must drop any call he or she is on in order for the phone to reconnect to the 
network. If the agent continues on a call, CAD will not be able to show the call’s actual 
length because it shows as “terminated” in the system.

When the phone comes back into service, the agent will see the popup window display 
a message that the phone is in service. The agent can then change the agent state 
back to Ready and resume taking calls. 

Figure 20. Service Status popup window.
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Phone Network Failure

In the event that an agent’s phone loses its connection to the network, the agent is 
automatically moved to the Not Ready agent state, and will see a popup window 
displaying a message that the phone is out of service.

The supervisor will see the change of agent state in the Agent ACD State Log report, 
along with the “Device out of service” reason code (code 32759).

The agent must drop any call he or she is on in order for the phone to reconnect to the 
network. If the agent continues on a call, CAD will not be able to show the call’s actual 
length because it shows as “terminated” in the system.

When the phone comes back into service, the agent will see the popup window display 
a message that the phone is in service. The agent can then change the agent state 
back to Ready and resume taking calls. 
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