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Introduction

Cisco Supervisor Desktop for Cisco Unified Contact Center Express (Unified CCX) 
is a robust computer telephony integration solution for IP-based contact centers 
that is easy to deploy, configure, and manage. It provides supervisors with 
powerful tools to increase productivity and improve customer satisfaction. 

Supervisor Desktop’s features allow you to view real-time statistics, monitor and 
coach agents, barge-in, intercept, and record active agent calls when necessary, 
enabling effective management of agent resources.

What’s New In This Version

Cisco Supervisor Desktop 6.5 includes these new features:

■ Support for Microsoft Windows Vista, Business and Ultimate Editions
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About This Document

Intended Audience

This document is written for contact center supervisors who use Cisco Supervisor 
Desktop on their computers.

Conventions Used

This document uses the following conventions:

Convention Use

Bold Highlights keys, buttons, and menu items you can 
select in the interface.

Code Highlights file paths and code.

Italic Highlights book titles, variables, and terms that are 
defined.

> The angle bracket indicates a menu choice. For 
example, “choose File > Open” means “click the File 
menu, and then click Open.”
6 September 2007
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Supervisor Desktop Feature Levels

There are three feature levels of Cisco Supervisor Desktop: Standard, Enhanced, and 
Premium. The following chart outlines the features available at each feature level. All 
features not listed here are present in all three versions.

Feature Standard Enhanced Premium

Silent monitoring × ×

Barge-in × ×

Intercept × ×

Recording (up to 32 simultaneous 
recordings/playbacks)

× ×

Team messages (TMs) × × ×

Supervisor work flows—tree control action × ×

Supervisor work flows—all actions ×

Skill statistics × × ×

Real-time displays (text) × × ×

Real-time displays (charts) ×

Web page push to agents ×

Integrated browser × × ×
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Starting Supervisor Desktop

NOTE:  In order to be able to use all of Supervisor Desktop’s 
functionality, you must first start and log into Cisco Agent Desktop.

To start Supervisor Desktop:

1. Choose Start > Programs > Cisco > Desktop > Supervisor.

The login dialog box appears (see Figure 1).

Figure 1. Supervisor Login dialog box.

2. Enter your Supervisor Desktop login ID (maximum 31 characters) and 
password in the appropriate fields, and then click OK or press Enter.

Supervisor Desktop starts. The application will show no data and the status 
bar will display “No Service” until you select a team from the Team drop-down 
list.

NOTE:  The first time you log into Supervisor Desktop, the password is 
the same as your login ID by default. Create your own password by 
using the Change Password function. 

NOTE:  It may take some time for Supervisor Desktop to start because 
default report data must be generated.

Changing Your Password

Your password should remain confidential. If it becomes known, follow these steps to 
change it. 
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Starting Supervisor Desktop
To change your password:

1. From the menu bar, choose Tools > Change Password.

The Change Password dialog box appears (see Figure 2).

Figure 2. Change Supervisor Password dialog box.

2. Type your old password, a new password, and then the new password again. 

Your password can have a maximum of 32 alphanumeric characters.

3. Click OK.

Your password is changed.

Access Through a Virtual Private Network

Supervisor Desktop is able to connect to the Cisco servers through a virtual private 
network (VPN). This enables you to work remotely and still have the benefit of 
Supervisor Desktop’s full functionality. 

NOTE:  It is recommended that you use a VPN in order to provide a 
more secure connection when using Supervisor Desktop outside the 
contact center.

NOTE:  It is intended that you use IP Communicator when running 
Agent Desktop behind a VPN, not a hard IP phone.

The VPN connection must be established before starting Supervisor Desktop. If the 
VPN connection is lost during a session, you must restart Supervisor Desktop after the 
connection is reestablished.

If Supervisor Desktop can log into all services except the Chat service, it must be 
restarted after the Chat service comes back online.

It has been verified that Cisco VPN 3000 Concentrator and Cisco VPN Client work 
properly with Supervisor Desktop and are supported for access. VPN solutions from 
other vendors might work correctly, but since they have not been formally verified, they 
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are not supported. If you want an alternative solution to be verified, please contact 
your Cisco distributor.
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Automated Updates
Automated Updates

Every time you start Supervisor Desktop, it checks to see if there is an updated 
version available, or if there was a system configuration change that requires a 
Windows registry change. If there is, it automatically runs the update process. 

NOTE:  For automated updates to function correctly, Internet Explorer 
must be configured so that it checks for newer versions of stored 
pages. In Internet Explorer, choose Tools > Internet Options and 
select the General tab. In the Temporary Internet Files section, click 
Settings and ensure that any option other than Never is selected.

NOTE:  If your system is configured with two CRS servers, and one 
server is upgraded while your instance of Supervisor Desktop is 
connected to the older CRS, and your system administrator performs 
a failover to switch all agents to the upgraded server, your instance of 
Supervisor Desktop will not automatically upgrade when you log into 
the new server. You must shut down Supervisor Desktop and start it 
again for the automatic upgrade to take place.

When an updated version of Supervisor Desktop is detected, you will see a dialog box 
notifying you that your copy of Supervisor Desktop will be updated (see Figure 3, left).

Click OK and then follow the instructions in the series of dialog boxes that follows. 
When the update is finished, you will see a final dialog box telling you that your update 
is complete (see Figure 3, right). When you click OK, restart Supervisor Desktop and 
log in as usual.

Figure 3. Update notification dialog box.
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The Supervisor Desktop Window

The Supervisor Desktop window is divided into 5 areas:

■ The skill group tree, showing all skill groups associated with the team you 
choose from the team selection list

■ The agent tree, showing all the agents and supervisors on the team

■ Tabular/graphical real-time displays of skill group information

■ Tabular/graphical real-time displays of agent and team information

■ Integrated browser, if enabled

The Supervisor Desktop interface can be extremely flexible in its configuration. Using 
the Preferences dialog box, you can add or remove real-time displays in the right-hand 
portion of the window, enable all panes in the interface to act as dockable windows 
(that is, they can be resized and moved anywhere on your desktop) and enable the 
integrated browser. By default, the panes are not dockable and the browser is not 
enabled. You can also change the size of the toolbar icons from the default 16 × 16 
pixels to 32 × 32 pixels.

Which panes are displayed depends on which nodes are selected in the skill group 
and agent trees. Figure 4 shows the Supervisor Desktop window in its default 
configuration.

Figure 4. Supervisor Desktop interface, with a skill group and the Agents nodes selected

Skill group 
tree

Agent tree

Tabular and 
graphical 
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Status bar

Integrated browser
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The Supervisor Desktop Window
Real-time display panes are identified as containing information related to skill groups 
or agents by the text in their title bars (see Figure 5).

Figure 5. Identifying Real-time Displays 

When Supervisor Desktop is in default layout (movable windows are disabled), Skill 
Groups real-time displays occupy approximately the top half of the right pane, and the 
Agents real-time displays occupy approximately the lower half of the right pane. These 
displays can be resized by dragging the horizontal splitters up and down. 

Each type of display will dock to another display of its own type. For example, you 
cannot separate one Agents display from another, although they can be resized in 
relationship to each another (see Figure 6). In contrast, a Skill Groups display will not 
dock to an Agents display.

Figure 6. Examples of docked and resized displays
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Groups and Agents displays 
have been resized by dragging 
the horizontal splitters up and 
down. Note the blank space 
between the types of displays 
because Agents displays will 
not dock to Skill Groups 
displays. 
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You can also drag the vertical splitter between the trees panes and the display panes 
left or right, and the horizontal splitter between the two trees panes up and down. 

If you choose to enable movable windows (see "Setting Preferences"), Skill Groups 
displays dock to Skill Groups displays and Agents displays dock to Agents displays, but 
they are all free to be resized and moved anywhere on your desktop. 

If you choose to enable the integrated browser, the real-time displays and the browser 
appear on tabs in the area to the right of the skill group and agent navigation trees. 

Setting Preferences

The Preferences dialog box controls what information is displayed in the display panes 
and how those panes behave. Table 1 summarizes what you can configure using 
Preferences. 

To set your interface preferences:

1. Choose View > Preferences.

The Preferences dialog box is displayed.

2. From the left pane, select the node whose displays you want to configure.

Table 1. Configurable Elements of the Supervisor Desktop Interface

Tree Control 
Node Available Displays

Configure 
Columns?

Configure 
Graphs?

Configure 
Refresh? 

Configure 
URL?

Skill Groups Team Skill Statistics Yes Yes Yes No

Skill Skill Summary Statistics Yes No Yes No

Skill Agent Statistics Yes Yes No No

Team Team Agent Statistics Yes Yes Yes No

Team Agent State Yes Yes No No

Agent Agent vs. Team Statistics Yes Yes Yes No

Logs Agent Call Log Yes No No No

Agent ACD State Log Yes No No No

Calls Agent Active Call Yes No No No

Enterprise Data Yes No No No

Call History Yes No No No

Browser Integrated Browser N/A N/A N/A Yes
14 September 2007



The Supervisor Desktop Window
The displays for that node are listed in the right pane. 

3. Configure the display as follows. If the element of the display is disabled, it 
cannot be configured.

a. Columns—select Columns, and then click the ellipsis (…) to display the 
Configure Columns dialog box. Select the columns you wish to appear in 
the display, and use the up and down arrows to set the order in which they 
appear. If a column name is disabled (appears grayed out), you cannot 
move it. Click OK when you are done.

b. Graphical Displays—select Graphical displays, and then click the ellipsis 
(…) to display the Select Charts dialog box. Select the chart you wish to 
appear, and then click OK. You can select one chart only for each 
real-time display. 

c. Refresh rate—select Refresh rate in seconds and adjust the rate.

4. If you want to be able to move and rearrange the panes that make up the 
Supervisor Desktop window, select the Enable movable windows check box.

5. If you want the toolbar icons to be 32 × 32 pixels instead of the default 
16 × 16 pixels, select the Enable large toolbar icons check box.

6. If you want to enable the integrated browser, select the Enable Integrated 
Browser check box. 

If you want to configure a browser home page, select the Browser node in the 
left pane and enter the URL of the web page you want to appear by default in 
the browser in the URL field in the right pane.

7. Click Apply to save your configuration. 

Agent Tree

The Agent tree displays all agents and supervisors on the selected team who are 
currently logged in. The icon next to the agent’s name indicates which agent state the 
agent is in. 

Formatting Agent Names in the Agent Tree

The Preferences dialog box enables you to control how agent names are displayed in 
the Agent tree. 

An agent can be identified by any or all of the following:

■ Name

■ Extension

■ Application used by the agent (CAD or IPPA)

At least one of these must be selected to identify an agent in the Agent tree. If all 
options are selected, the information in the Agent tree appears as follows:
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Jane Smith x1500 CAD

To format agent names in the Agent tree:

1. Choose View > Preferences, and then select the Agents node.

2. In the Format node text grid, check the elements you want to use to identify 
an agent. You must select at least one element. A sample of what the name 
will look like appears on the Sample line.

3. Click OK.

Restoring the Interface Default Layout

You can restore your Supervisor Desktop layout to its default configuration by 
accessing the Preferences dialog box (View > Preferences) and clicking the Restore 
default layout button. 

This button does the following:

■ Resets the arrangement of real-time display panes to the default 
arrangement

■ Disables the integrated browser

■ Deselects any graphical real-time displays you had selected

■ Resets the toolbar icon setting to the default setting.

It does not reset the columns displayed in each pane to the original selection. You 
must use the Preferences dialog box (see "Setting Preferences" on page 14) to 
manually reset these elements to their original configuration.

Accessibility

Supervisor Desktop has a number of features which aid accessibility by 
vision-impaired users. They are:

■ Follows Windows settings for screen resolution and color/contrast settings

■ Choice of small (16 × 16 pixels) or large (32 × 32 pixels) toolbar icons (see 
"Setting Preferences" on page 14)

■ Screen reader-compatible tool tips for all controls

■ Screen reader-compatible shortcut keys for navigating the application and 
toolbar (see "Interface Shortcut Keys" on page 17 and "Toolbar" on page 17)
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Interface Shortcut Keys

Shortcut keys are available to navigate the Supervisor Desktop interface.

Once you have set focus to the skill group tree, the agent tree, or the team node in the 
agent tree, you can use the tab key to navigate to the real-time display panes. Once 
your focus is in a real-time display pane, you can use the arrow keys to navigate 
around the display grid.

NOTE:  The tab key will move you among the real-time display panes, 
but the order in which you access them will not necessarily be in sync 
with the physical arrangement of the display panes on your desktop.

Toolbar

The Supervisor Desktop toolbar consists of the following buttons. To view a tooltip 
explaining a button’s function, move your mouse pointer over the button.

Table 2. Accessibility shortcut keys

Shortcut Keys Description

Ctrl-Shift-S Selects the Skill Groups node in the Skill Groups tree.

Ctrl-Shift-A Selects the Agents node in the Agents tree.

Ctrl-Shift-T Selects the Team node in the Agents tree.

Ctrl-H Selects and drops down the Team Selection List.

Table 3.  Supervisor Desktop toolbar buttons 

Button Name Shortcut Key Description

Refresh Ctrl-F Refreshes the information in the active 
data view pane.

Logout Ctrl-L Logs the selected agent out of the ACD.

Ready Crtl-E Puts the selected agent in the Ready 
agent state.

Not Ready Ctrl-N Puts the selected agent in the Not 
Ready agent state.

Work Ctrl-D Puts the selected agent in the Work 
agent state.

Barge-In Ctrl-B Enables you to join the selected 
agent’s phone conversation.
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Status Bar

The status bar displays current information about Supervisor Desktop.

Figure 7. Status Bar

In the event of a service failure, the Current Status section changes from “In Service” 
to “Partial Service” or “No Service.” To learn what features are affected by the service 
outage, double-click the Current Status section of the status bar to view a popup 
window that displays which features are active or inactive.

Intercept Ctrl-I Enables you to intercept the selected 
agent’s phone call while disconnecting 
the agent from the phone call.

Chat Ctrl-J Opens the Chat window.

Team 
Message

Ctrl-X Opens the Team Message dialog box.

Start Record Ctrl-R Starts recording the selected phone 
call.

Stop Record Ctrl-S Stops recording the selected phone 
call.

Start Voice 
Monitor

Ctrl-A Starts monitoring the selected agent.

Stop Voice 
Monitor

Ctrl-P Stops monitoring the selected agent.

Voice Monitor 
Volume

Ctrl-V Pops up a slider that enables you to 
control or mute the volume when 
monitoring a call.

Table 3.  Supervisor Desktop toolbar buttons — Continued

Button Name Shortcut Key Description

Current system time in 24-hour format
Current status of Supervisor Desktop features

User ID or name, as entered in the Login dialog box

User name
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For more information on the Current Status popup window and service autorecovery, 
see "Service Autorecovery" on page 59.
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Real-Time Displays

The real-time displays contain the information you need to manage your teams and 
agents. 

There are two types of displays: tabular and graphical.

■ Tabular displays present skill group, team, and agent information in a grid. 

■ Graphical displays present that same information as bar charts, except for the 
Agent vs. Team Statistics, which is presented as two pie charts.

NOTE:  Graphical displays are available at the Premium feature level 
only.

Tabular information can be sorted in ascending/descending order by clicking any 
column header in the grid. You can sort by one column only.

Team Skill Statistics

The Team Skill Statistics real-time display is available when you select the Skill Groups 
node in the Skill Groups tree. 

This display presents the details of each individual skill group, regardless of whether 
or not an agent with that skill is logged in. By default, the data displayed is sorted in 
ascending order by skill name. 

The data is obtained from the CTI server unless otherwise noted, and are for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 60 
seconds.

Graphical displays of this information consist of bar charts with the skill name on the Y 
axis and any of the available statistics listed in the table below on the X axis, 
expressed in either an integer (0, 1, 2…) or time duration (hh:mm:ss).

Table 4. Team Skill Statistics real-time display data 

Field Description

Contact Service Queue Name of the contact service queue.

Agents Logged In Number of agents currently logged into the system.

Agents in Talking Number of agents currently in the Talking state.

Agents Ready Number of agents currently in the Ready state.

Agents Not Ready Number of agents currently in the Not Ready state.
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Real-Time Displays
Agents in Work Number of agents currently in the Work state.

Agents Reserved Number of agents currently in the Reserved state.

Oldest in Queue Elapsed wait time of the oldest call in the queue.

Total Calls Total number of calls that have arrived, including calls 
waiting, calls connected to agents, and calls that have 
disconnected.

Handled Today Number of calls handled by the contact service queue 
for the current reporting period. A call is considered to 
be handled when an agent picks up the call.

Calls Abandoned Number of calls that were routed to the contact service 
queue but were not answered by an agent because the 
caller hung up or was disconnected.

Calls Dequeued Number of calls that were dequeued. A call is 
considered to be dequeued from a particular contact 
service queue if the call is handled by an agent in 
another contact service queue. This situation can occur 
when a call is queued for more than one contact service 
queue.

Start Time Starting date and time of the current reporting period.

End Time Ending date and time of the current reporting period.

Average Talking Average talk time for all calls handled by agents. Talk 
time is the elapsed time between the time that an agent 
connects to a call and when the call is disconnected or 
transferred, not including hold time.

Average Waiting Average wait time for calls routed to the contact service 
queue. Wait time is the elapsed time between the time a 
call entered the queue and the time the call was 
answered by an agent or was disconnected.

Longest Talking Longest talk time of any one call that agents have 
handled. Talk time is the elapsed time between the time 
that an agent connects to a call and when the call is 
disconnected or transferred, not including hold time.

Longest Waiting Longest wait time for any one call routed to the contact 
service queue. Wait time is the time that elapsed 
between the time a call entered the queue and the time 
the call was answered by an agent or was disconnected.

Table 4. Team Skill Statistics real-time display data — Continued

Field Description
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Skill Summary Statistics

The Skill Summary Statistics real-time display is available when you select a specific 
skill from the Skill Groups tree. 

This display presents a summary of a specific skill group’s statistics. These statistics 
are from the entire contact center, not just from members of the selected team.

The data is obtained from the CTI server unless otherwise noted, and are for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 60 
seconds.

There is no graphical display available for these statistics.

Calls Priority 1… 
Calls Priority 10

Total number of Priority N calls that were routed to each 
contact service queue.

Table 4. Team Skill Statistics real-time display data — Continued

Field Description

Table 5. Skill Summary Statistics real-time display data 

Field Description

Contact Service Queue Name of the contact service queue.

Agents Logged In Number of agents currently logged into the system.

Agents in Talking Number of agents currently in the Talking state.

Agents Ready Number of agents currently in the Ready state.

Agents Not Ready Number of agents currently in the Not Ready state.

Agents in Work Number of agents currently in the Work state.

Agents Reserved Number of agents currently in the Reserved state.

Oldest in Queue Elapsed wait time of the oldest call in the queue.

Total Calls Total number of calls that have arrived, including calls 
waiting, calls connected to agents, and calls that have 
disconnected.

Handled Today Number of calls handled by the contact service queue 
for the current reporting period. A call is considered to 
be handled when an agent picks up the call.
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Skill Agent Statistics

The Skill Agent Statistics real-time display is available when you select a specific skill 
from the Skill Groups tree. 

This display presents information about each agent logged into the ACD and assigned 
to the selected skill group. By default, the data displayed is sorted in ascending order 
by agent name.

Calls Abandoned Number of calls that were routed to the contact service 
queue but were not answered by an agent because the 
caller hung up or was disconnected.

Calls Dequeued Number of calls that were dequeued. A call is 
considered to be dequeued from a particular contact 
service queue if the call is handled by an agent in 
another contact service queue. This situation can occur 
when a call is queued for more than one contact service 
queue.

Start Time Starting date and time of the current reporting period.

End Time Ending date and time of the current reporting period.

Average Talking Average talk time for all calls handled by agents. Talk 
time is the elapsed time between the time that an agent 
connects to a call and when the call is disconnected or 
transferred, not including hold time.

Average Waiting Average wait time for calls routed to the contact service 
queue. Wait time is the elapsed time between the time a 
call entered the queue and the time the call was 
answered by an agent or was disconnected.

Longest Talking Longest talk time of any one call that agents have 
handled. Talk time is the elapsed time between the time 
that an agent connects to a call and when the call is 
disconnected or transferred, not including hold time.

Longest Waiting Longest wait time for any one call routed to the contact 
service queue. Wait time is the time that elapsed 
between the time a call entered the queue and the time 
the call was answered by an agent or was disconnected.

Calls Priority 1… 
Calls Priority 10

Total number of Priority N calls that were routed to each 
contact service queue.

Table 5. Skill Summary Statistics real-time display data — Continued

Field Description
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The data is obtained from the CAD Chat service, and are for the current day starting at 
midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of this information consists of a bar chart with the ACD states on 
the Y axis and the number of agents on the X axis. 

Team Agent Statistics

The Team Agent Statistics real-time display is available when you select the Team 
node or Agents node in the Agents tree.

This display presents the real-time state of the agents on the selected team who are 
currently logged into the ACD. By default, the data displayed is sorted in ascending 
order by agent name.

The data is obtained from the CAD Recording & Statistics service, and is for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 30 
seconds.

Graphical displays of the information consist of bar charts with agent names on the Y 
axis and the average amount of time (hh:mm:ss) the agent spent in a selected ACD 
state.

Table 6. Skill Agent Statistics real-time display data 

Column Name Description

Agent Name The agent’s name.

Current State The agent’s current ACD state.

Skill Group The skill group ID of the ACD call the agent is currently 
servicing (in Talking state). If there is no call, or if the call 
is a non-ACD call, this field is blank.

Contact Service Queue Name of the contact service queue.

State Duration The amount of time, in seconds, that the agent has been 
in the current ACD state.

Reason Code The reason why the agent is in the current ACD state. 
Reason codes are available for the Not Ready and 
Logout states only. 

Table 7. Team Agent Statistics real-time display data 

Column Name Description

Agent Name The agent’s name.
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Team Agent State

The Team Agent State real-time display is available when you select the Team node or 
Agents node in the Agents tree. 

Logon Time The total amount of time the agent has been logged into 
the ACD today.

Calls Presented The number of inbound calls (ACD and non-ACD) 
presented to the agent today.

Calls Handled The number of inbound calls (ACD and non-ACD) 
presented to and answered by the agent today.

Maximum Talking The longest talk time of all calls handled today.

Average Talking The average talk time and hold time of all calls handled 
today.

Total Talking The total talk time and hold time of all calls handled 
today.

Maximum Ready The longest time the agent spent in the Ready state 
today.

Average Ready The average time the agent spent in the Ready state 
today.

Total Ready The total time the agent spent in the Ready state today.

Maximum Not Ready The longest time the agent spent in the Not Ready state 
today.

Average Not Ready The average time the agent spent in the Not Ready state 
today.

Total Not Ready The total time the agent spent in the Not Ready state 
today.

Maximum Work Longest time spent in the Work state.

Average Work The total time spent in the Work state divided by the 
number of times spent in the Work state.

Agents in Talking Number of agents currently in the Talking state.

Other Time The total time the agent spent in states other than 
Talking, Ready, Not Ready, or Work today.

Table 7. Team Agent Statistics real-time display data — Continued

Column Name Description
September 2007 25



Cisco Supervisor Desktop User Guide
This display presents the performance details for each agent on the team. By default, 
the data displayed is sorted in ascending order by agent name.

The data is obtained from the CAD Chat service, and is for the current day starting at 
midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of the information consists of a bar chart with ACD states on the 
Y axis and the number of agents currently in each ACD state. 

Agent vs. Team Statistics

The Agent vs. Team Statistics real-time display is available when you select a specific 
agent in the Agents tree. 

This display presents the performance details for the agent and compares them to the 
performance details of the team. 

The data is obtained from the CAD Recording & Statistics service, and is for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 
30 seconds.

The graphical display (entitled the “Agent vs. Team Percent Time in State display”) is 
presented as two pie charts. These pie charts show the percentage of time a specific 
agent spends in various ACD states in comparison to the percentages spent by the 
team as a whole. The ACD states compared are:

■ Ready

■ Not Ready

■ Talking

Table 8. Team Agent State real-time display data 

Column Name Description

Agent Name The agent’s name.

Current State The agent’s current ACD state.

Skill Group The skill group ID of the call the agent is currently 
servicing (in Talking state). If there is no call, or if the call 
is a non-ACD call, this field is blank.

State Duration The amount of time, in seconds, that the agent has been 
in the current ACD state.

Reason Code The reason why the agent is in the current ACD state. 
Reason codes are available for the Not Ready and 
Logout states only. 
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■ After Call Work (Work)

■ Other Time (all other ACD states not listed here)

Table 9. Agent vs. Team Statistics real-time display data 

Column Name Description

ID Identifies the statistics as for the selected agent or the 
team.

Logon Time The amount of time the agent and team have been 
logged into Agent Desktop.

Calls Presented Agent: The number of inbound calls (ACD and non-ACD) 
presented to the agent today.

Team: The total number of inbound calls (ACD and 
non-ACD) presented to all members of the team today.

Calls Handled Agent: The number of inbound calls (ACD and non-ACD) 
presented to and answered by the agent today.

Team: The number of inbound calls (ACD and non-ACD) 
presented to and answered by all members of the team 
today.

Maximum Talking Agent: The longest talk time of all calls handled today.

Team: The longest talk time of all calls handled by any 
member of the team today.

Average Talking Agent: The average talk time and hold time of all calls 
handled today.

Team: The average talk time and hold time of all calls 
handled by all members of the team today.

Total Talking Agent: The total talk time and hold time of all calls 
handled today.

Team: The total talk time and hold time of all calls 
handled by all members of the team today.

Maximum Ready Agent: The longest time the agent spent in the Ready 
state today.

Team: The longest time any member of the team spent 
in the Ready state today.
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Average Ready Agent: The average time the agent spent in the Ready 
state today.

Team: The average time all members of the team spent 
in the Ready state today.

Total Ready Agent: The total time the agent spent in the Ready state 
today.

Team: The total time all members of the team spent in 
the Ready state today.

Maximum Not Ready Agent: The longest time the agent spent in the Not 
Ready state today.

Team: The longest time any member of the team spent 
in the Not Ready state today

Average Not Ready Agent: The average time the agent spent in the Not 
Ready state today.

Team: The average time all members of the team spent 
in the Not Ready state today.

Total Not Ready Agent: The total time the agent spent in the Not Ready 
state today.

Team: The total time all members of the team spent in 
the Not Ready state today.

Maximum Work Agent: The longest time the agent spent in the Work 
state today.

Team: The longest time any member of the team spent 
in the Work state today.

Average Work Agent: The average time the agent spent in the Work 
state today.

Team: The average time all members of the team spent 
in the Work state today.

Total Work Agent: The total time the agent spent in the Work state 
today.

Team: The total time all members of the team spent in 
the Work state today.

Table 9. Agent vs. Team Statistics real-time display data — Continued

Column Name Description
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Agent Call Log

The Agent Call Log real-time display is available when you select the Logs node 
underneath a specific agent’s name in the Agents tree. 

This display presents a history of the calls made and received by the agent during the 
current session. By default, the data displayed is sorted in ascending order by time of 
day. The data in the report must be refreshed manually by clicking the Refresh button 
on the toolbar.

Agent ACD State Log

The Agent ACD State Log real-time display is available when you select the Logs node 
underneath a specific agent’s name in the Agents tree. 

This display presents a history of the ACD states the agent transitioned through during 
the current session. By default, the data displayed is sorted in ascending order by time 

Other Time Agent: The total time the agent spent in states other 
than Talking, Ready, Not Ready, and Work today.

Team: The total time all members of the team spent in 
states other than Talking, Ready, Not Ready, and Work 
today.

Table 9. Agent vs. Team Statistics real-time display data — Continued

Column Name Description

Table 10. Agent Call Log real-time display data 

Column Name Description

Call Start Time The time the call was answered.

Call Direction Inbound or outbound call.

Call Answered (Yes/No) Answered or unanswered call.

Calling Party The originating phone number.

Called Party The recipient phone number.

Call Duration The length of the call.
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of day. The data in the report must be refreshed manually by clicking the Refresh 
button on the toolbar.

Agent Active Call

The Agent Active Call real-time display is available when you select an active call under 
a specific agent’s name in the Agents tree. 

This display presents information about each party in the current active call. 

Enterprise Data

The Enterprise Data real-time display is available when you select an active call under 
a specific agent’s name in the Agents tree. The data displayed is configured by your 
administrator.

Call History

The Call History real-time display is available when you select an active call under a 
specific agent’s name in the Agent’s tree. 

Table 11. Agent ACD State Log real-time display data 

Column Name Description

Start Time The time the agent state was initiated.

Agent State The ACD agent state.

Reason Code Any reason code the agent entered, if the agent state 
transitioned to is Not Ready or Logout (if required).

State Duration The length of time the agent was in the agent state.

Table 12. Agent Active Call real-time display data 

Column Name Description

Name Name of the parties in the call, if known. If this data is 
not known, <unavailable> is displayed.

Number The party’s phone number.

Call Status Hook state of the party (Active or Held).

Duration The length of time the party has been in the call.

Skill Group The skill group ID the called was queued to, if applicable.
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This display presents a history of the call’s presence in the contact center. 

Table 13. Call History real-time display data

Column Name Description

Threshold The acceptable amount of time a call can remain at a 
particular device or contact center. The administrator 
may assign caution and warning threshold values to 
each device type, as well as a total threshold value for a 
call. 

If a call remains at a device longer than the defined 
caution and warning thresholds, a caution or warning 
icon is displayed in this field.

Device A device that the call has passed through.

Type The type of device the call has passed through.

Description Description of the device.

Duration The amount of time the call spends at a device.
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Monitoring Agents

The voice monitor button enables you to silently listen in on an agent’s phone 
conversations.

Voice monitoring is available whenever an agent is logged in, whether or not the agent 
is on the phone. It is not available when:

■ You are a participant in a phone call (you cannot monitor yourself).

■ You use the Barge-In or Intercept function.

The volume slide allows you to control the volume when monitoring an agent’s phone 
conversation. The system remembers your last volume setting and uses it the next 
time you log in.

To start monitoring an agent:

1. Choose an agent in the Agents tree.

2. Click the Start Voice Monitor button, or choose Intervention > Start Voice 
Monitor.

To stop monitoring an agent:

1. Click the Stop Voice Monitor button, or choose Intervention > Stop Voice 
Monitor.
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Pushing a Web Page to an Agent

You can coach an agent while monitoring the agent’s phone call by pushing a web 
page to that agent’s Agent Desktop integrated browser. 

To push a web page to an agent:

1. While monitoring an agent, choose Intervention > Coach by pushing a page.

The Push URL to Agents dialog box appears (see Figure 8).

Figure 8. Push URL to Agents dialog box.

2. Enter the URL of the web page you want the agent to see, and then click Push 
to send the web page to the agent.

The web page you pushed to the agent is displayed in the agent’s integrated 
browser.
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Barging In on Calls

The Barge-In feature enables you to join an agent’s phone conversation. When you 
click the Barge-In button, you are automatically added to the phone call. It is a forced 
conference.

NOTE:  You can barge in only once on a call per supervisor.

The agent sees a message that you are attempting to join the call, then sees a 
message that you have successfully joined it.

When you use the Barge-In feature, voice monitoring is disabled.

You can’t barge in:

■ If the agent is on hold

■ If the agent is on two calls

■ If the agent is in a conference call

■ If you are already on another call

To barge in:

1. Select an agent call in the team view pane.

2. Click the Barge-In button or choose Intervention > Barge-In.

You are added to the call.

At any time during the conference call, you may click Intercept to disconnect 
the agent whose call is selected from the conference call and continue talking 
with the remaining parties yourself.

To drop the barged-in call:

■ In Cisco Agent Desktop, select the conference call from the dashboard and 
then click Drop.
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Intercepting Calls

The Intercept feature enables you to intercept a phone call while disconnecting the 
agent from that phone call. It is a forced transfer.

NOTE:  You can intercept a call only once per supervisor. For example, 
if you intercept a call, drop out of the conversation, and then attempt 
to intercept the same call again, you will not be able to do so.

The agent sees a message that you are attempting to intercept the phone call, then 
sees a further message when the interception is successful.

When you use the Intercept feature, voice monitoring is disabled.

You can’t intercept: 

■ If the agent is on hold

■ If the agent is on two calls

■ If you are already on another call

To intercept a phone call:

1. Select an agent call in the team view pane.

2. Click the Intercept button or choose Intervention > Intercept.

The call is transferred to you.

If you are intercepting a conference call you are on, the agent call you 
selected in the team view pane is dropped from the conference call, and all 
other participants in the conference call remain connected.

To drop the intercepted call:

■ In Cisco Agent Desktop, select the intercepted call from the dashboard and 
then click Drop.
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Recording Calls

You can use Supervisor Desktop to record, save, and play back calls handled by 
agents on your team. Multiple recordings can be in progress at the same time, 
although only one recording may be made per agent at any one time. You use the 
Supervisor Record Viewer to review recorded calls.

You can use the Barge-In, Intercept, and Voice Monitor features while recording. 

When recording a call, keep in mind the following:

■ The recording feature is not intended to record every call. It is an on-demand 
solution only.

■ Although you select a specific call from the Team View pane when recording, 
you are actually recording all voice activity to and from that particular agent. It 
is not limited to the call you selected. For instance, if the agent puts the 
selected call on hold and switches to another call, the recording will record 
both calls.

■ The recording will end when the selected call terminates, or when you 
manually stop recording, whichever comes first.

■ Agents may be configured so that they are allowed to start and stop recording 
calls. However, an agent cannot stop a recording that you, as a supervisor, 
started. If an agent attempts to do so, their Agent Desktop or IP Phone Agent 
interface indicates the recording is stopped. However, the recording is not 
stopped, and Supervisor Desktop displays an icon indicating that recording is 
proceeding.

■ You can stop a recording initiated by an agent.

■ If notification is off, agents have no way of knowing if you are recording their 
calls. If an agent attempts to start recording a call that you are already 
recording, the agent will see a recording icon on the call, although the agent is 
not in control of the recording. 

■ When you or an agent record a call, a recording license is used. The license is 
released when the recording stops. If all recording licenses are in use when 
you attempt to start a recording, the recording will not start.

To record a call:

1. Choose the call you wish to record from the Agents tree.

2. Click the Start Record button, or choose Intervention > Call/Agent Start 
Recording.

3. When you are finished, click the Stop Record button, or choose Intervention > 
Call/Agent Stop Recording.
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The call is archived to the Recording service database, where it is 
automatically saved for seven days. If you want to save it for a longer period, 
you may do so for up to 30 days, after which it is deleted (see "Using 
Supervisor Record Viewer" on page 55 for more information on playing and 
saving recordings). 
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Changing Agents’ ACD States

You can use Supervisor Desktop to change the ACD state of an agent on your team, 
including logging an agent out. 

NOTE:  If you log a CAD agent out, that agent will continue to appear in 
the agent tree and will be able to chat and receive team messages. If 
you log out a IP Phone agent, that agent disappears from the agent 
tree.

To change an agent’s agent state:

1. From the Agents tree, select the agent whose state you want to change.

2. On the toolbar, click the appropriate agent state button.

NOTE:  If an agent state change fails, you will not see any failure 
message. You will know that an agent state change succeeds if the 
icon next to the agent’s name in the team view pane changes to the 
current agent state icon.
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Using Chat

Chat allows you to send instant messages to agents on your team and to other 
supervisors. You initiate a chat session by clicking the Chat button on the toolbar.

NOTE:  You cannot chat with IP Phone agents.

Chat Features

■ You can participate in multiple concurrent chat sessions.

■ You can send the same chat message to multiple recipients (their replies, if 
any, appear in separate chat windows, one for each person).

■ The Chat Session window’s title bar displays the name of the person with 
whom you are chatting.

■ High priority chat messages pop on your screen so they are immediately 
noticed, while normal priority chat messages are minimized and flash on your 
Windows task bar.

■ Chat logs are available as long as the Chat Session window is open. Once you 
close the window, the log is lost.

■ Chat logs are in chronological order, with the oldest messages at the top of 
the log pane.

To initiate a chat session:

1. On the toolbar, click the Chat button.

The Chat Selection window is displayed (see Figure 9).

Figure 9. Chat Selection window
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The window lists the people with whom you can chat (logged-in members of 
your team and other supervisors).

2. Select the check box next to the name of the person(s) with whom you wish to 
chat. 

If you select the check box next to Desktop Agents or Supervisors, the check 
boxes next to all agents or supervisors listed underneath are automatically 
selected. You can then send a message to multiple recipients.

A Chat Session window is displayed and a chat session is initiated with the 
selected people (see Figure 10).

Figure 10. Chat Session window

3. Type your message in the text entry field. 

4. If you want your message to be noticed immediately by popping on the 
recipient’s screen, select the High priority check box.

5. Click Send or press Enter.

Your message is sent to your chat partner and logged in the chat log pane.

Replies from recipients of a group message appear in individual chat session 
windows. They cannot reply to the group, they can reply only to you.

To terminate a chat session:

■ Click Close in the upper right-hand corner of the Chat Session window.

Chat log pane

Text entry field
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Predefined High-Priority Chat Messages

Agents may have a task button in Agent Desktop configured to send a predefined 
high-priority chat message to their supervisor(s). This predefined message (for 
example, “Please barge in on my call”) is set up by the administrator. It behaves just 
like a regular chat message that is tagged as high priority—it pops up on your screen 
on top of all other windows for your immediate attention.
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Using the Integrated Browser

The integrated browser enables you to view intranet and internet web pages from 
within Supervisor Desktop. When enabled, the browser appears as a tab in the 
real-time display pane, with up to 20 characters of the name of the current webpage 
displayed on the tab. The real-time displays appear on another tab in that pane.

NOTE:  You must have Internet Explorer 6 or 7 installed on your PC for 
the integrated browser to function.

By default, the browser is not enabled. See "Setting Preferences" on page 14 for 
instructions on enabling the browser and configuring a home page.

The Address field’s drop-down list contains the URLs of the last 10 websites visited for 
quick access to frequently-visited websites.

Browser Toolbar

The browser toolbar is the basic Internet Explorer toolbar. It allows you to navigate 
among web pages you view, refresh a current page, and return to your home page.

Table 14. Browser toolbar buttons 

Button Name Shortcut Key Description

Back Alt–left arrow Returns you to the last page you viewed.

Forward Alt–right 
arrow

Takes you to the page you viewed before you 
clicked the Back button.

Stop Esc Stops the browser from displaying a web page 
(for example, if the download is taking too long).

Refresh F5 Refreshes the web page displayed to ensure 
you see the latest content.

Home Alt–Home Returns you to your predefined home page.
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Sending Team Messages

You can send a team message (TM) to all agents on a team, whether or not the agent 
is logged into the ACD. As long as Agent Desktop is open, an agent can view a TM.

NOTE:  You cannot send TMs to IP Phone agents.

The Team Messages dialog box (see Figure 11) stores the last 10 TMs you broadcast. 
You can select any one of these messages to broadcast again. If you send more than 
10 TMs, the oldest one drops off the stored list. You cannot designate any particular 
TM for permanent storage.

Figure 11. Team Message dialog box.

NOTE:  By default, the TM scrolls across Agent Desktop’s TM pane. 
Individual agents can set their preference in Agent Desktop to view 
TMs as stationary. A stationary TM is more compatible with screen 
readers, which are often used by vision-impaired agents. 

The Current Message pane displays the message that is currently being sent to your 
team.

To send a TM to all agents on a team:

1. From the team selection list, choose the team to which you want to send the 
message, and then click View > Team Messages or click the Team Messages 
button.

2. Type your message in the text box. The TM can be up to 255 characters long.
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3. In the Expires at field, choose a specific time for the message to expire. 

By default, the message runs for 30 minutes.

4. Click Start or press Enter.

The TM is sent to the team for the length of time you chose. The text of the 
message you sent is logged in the current team performance message field. 

To cancel a TM:

■ In the Team Message dialog box, click Stop.
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Creating Supervisor Work Flows

Using the Supervisor Work Flow Administrator feature, you can configure your desktop 
to perform certain actions based on queue statistics for calls waiting and calls in 
queue for specified skill groups. 

These work flows apply only to you, not to any other supervisors, and are available to 
you no matter where you log into Supervisor Desktop. They are tied to your login 
information.

NOTE:  Supervisor work flow actions are available at the Premium 
feature level, except for the Tree Control action, which is also 
available at the Enhanced feature level. 

In general, work flows consist of events, rules, and actions. 

■ The event that triggers an action is a skill groups queue statistics update. 
Queue statistics are updated once every 5 seconds.

■ The rule the event must meet is one or both of the following:

— The number of calls waiting is below, within, or above specified limits

— The oldest call in queue is below, within, or above specified time 
durations

■ The actions triggered by meeting the rules can be:

— Change the color of the skill group name in the tree control and/or add a 
message next to it

— Highlight data in the tabular real-time display

— Display a popup message on your desktop

— Play a *.wav file on your desktop

— Send an email to selected recipients

For example, you can set up a work flow so that when there are more than 10 calls 
waiting in the queue for Skill Group 6500, the skill group name in the Skill Groups tree 
turns red and an audible warning sounds every 15 seconds. 

To set up a supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator.

The Supervisor Work Flow List dialog box appears.

2. Click Add.

The Add New Work Flow dialog box appears.

3. Enter a name for your new work flow, and then click OK.
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The Skill Group Selection dialog box appears.

4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished. 

NOTE:  A skill group may be a part of only one work flow per 
supervisor.

The Supervisor Work Flow Setup dialog box appears (see Figure 12).

Figure 12. Supervisor Work Flow Setup dialog box.

5. Set up the parameters for the work flow:

a. Specify the upper and lower limits for the Call Waiting and/or Current 
Oldest threshold. 

NOTE:  When you select both Calls Waiting and Current Oldest, 
the highest threshold crossed takes precedence.

b. Select Above from the Thresholds pane. 
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c. Click Add, and from the resulting Action Type Selection dialog box, select 
the action you want to be triggered when the Calls Waiting and/or Current 
Oldest statistic is above the upper limit you set, and then click OK. See 
"Work Flow Actions" on page 49 for information on the types of actions 
available.

d. Repeat for the Within and Below thresholds.

6. When you have finished, click OK to enable the work flow.

Example: Setting Up a Supervisor Work Flow

The following is a step-by-step illustration of setting up a supervisor work flow. This 
work flow:

■ Changes the skill group name color to green and displays “Below” next to it in 
the Skill Groups tree control when there are fewer than 2 calls waiting, or if 
the current oldest call is less than 1 minute old

■ Changes the skill group name color to blue and displays “Caution” when there 
are 2 to 5 calls waiting, or if the current oldest call is between 1 and 5 
minutes old

■ Changes the skill group name color to red and displays “Warning” when there 
are more than 5 calls waiting, or if the current oldest call is more than 5 
minutes old 

To set up the example supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator.

The Supervisor Work Flow List dialog box appears.

2. Click Add.

The Add New Work Flow dialog box appears.

3. Enter the name Customer Management, and then click OK.

The Skill Group Selection dialog box appears.

4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished.

The Supervisor Work Flow Setup dialog box appears.

5. Select the Calls Waiting check box and set the lower limit to 2 and the upper 
limit to 5. 

6. Select the Current Oldest check box and set the lower limit to 1 minute and 
the upper limit to 5 minutes.
September 2007 47



Cisco Supervisor Desktop User Guide
7. Select Below in the Thresholds pane and then click Add under the Actions 
pane.

The Action Type Selection dialog box appears.

8. Select Tree Control Node Action and then click OK.

The Tree Control Action dialog box appears.

9. Check Display Text and enter Below in the field. 

10. Check Change Text Color, click Set Color, choose green from the color palette 
displayed, and then click OK.
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11. Repeat steps 7 through 10 for the Above and Within thresholds. For Above, 
select “Warning” as the display text and set the color to red. For Within, select 
“Caution” as the display text and set the color to blue.

12. When you are finished, click OK to enable the work flow. The skill group 
names will now be color-coded with text displayed.

Work Flow Actions

There are 5 possible work flow actions that can be triggered by threshold rules. These 
actions are:

■ Audible Alert Action (page 50)

■ Message Box Action (page 50)

■ Report Action (page 51)

■ Tree Control Action (page 51)

■ Email Alert Action (page 52)
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Audible Alert Action

The Audible Alert action plays a *.wav file on your desktop whenever the threshold 
rules are met. By default, the file plays once, but you can also configure it so that it 
plays repeatedly at specified intervals. 

NOTE:  You can turn off audible alerts that are configured to repeat at 
intervals by choosing Actions > Supervisor Work Flow — Audio Off 
from the menu.

Your computer most likely has system *.wav files available that are used to signal 
standard Windows events. These files are a good source of sounds. 

NOTE:  Any *.wav file you select must be 300K or smaller. 

To set up an audible alert, in the Audible Alert Action dialog box (see Figure 13) click 
Add New and then browse to the location of your selected *.wav file. If desired, set up 
a repeat interval, and then click OK.

Figure 13. Audible Alert Action dialog box.

Message Box Action

The Message Box action pops a message box containing a customized message on 
your desktop whenever the threshold rules are met. The message box is cleared by 
clicking OK. 
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To set up a message box, in the Message Box Action dialog box (see Figure 14) type 
your message in the Message Text field, select the appropriate message icon, and 
then click OK.

Figure 14. Message Box Action dialog box

Report Action

The Report action highlights in color the Calls Waiting and Current Oldest cells in the 
tabular Team Skill Statistics real-time display when the data in the cell exceeds the 
threshold rules. 

To set up a Report action, In the Report Action dialog box (see Figure 15) click Set 
Color to select the color to use for highlighting the display cells, and then click OK. 

If you select the Show Team Skill Statistics Report check box, then whenever a 
statistic changes that triggers a Report action Supervisor Desktop automatically 
changes its focus to display the Team Skill Statistics report so that you will see the 
current report with the cells highlighted. 

Figure 15. Report Action dialog box

Tree Control Action

The Tree Control action enables you to select a color to apply to a skill group name 
and/or a message to display beside the skill group name in the Skill Groups tree 
control whenever the threshold rules are met.

To set up a Tree Control action, in the Tree Control Action dialog box (see Figure 16) 
check the effect(s) you want applied to the skill group name. Click Set Color to select a 
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text color, enter your own message or select from the drop-down list a predefined 
message (Caution or Warning) to appear next to the skill group name, and then click 
OK.

Figure 16. Tree Control Action dialog box

Email Alert Action

The Email Alert action enables you to send an email to specified people whenever the 
threshold rules are not met. 

The email messages have predefined subject lines, depending on what threshold rule 
is met. They are:

■ Skill: <skill group name>, Number of Calls Waiting is above upper limit

■ Skill: <skill group name>, Number of Calls Waiting is below lower limit

■ Skill: <skill group name>, Number of Calls Waiting is within upper and lower 
limits

■ Skill: <skill group name>, Oldest Call in Queue is above upper limit

■ Skill: <skill group name>, Oldest Call in Queue is below lower limit

■ Skill: <skill group name>, Oldest Call in Queue is within upper and lower limits
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The email messages sent can consist only of the Subject line; a message in the body 
of the email is optional. 

Figure 17. Email Alert Action Setup dialog box

To set up an email alert action, complete the Email Alert Action Setup dialog box (see 
Figure 17) as described in the following table.

Table 15. Email Alert Action Setup dialog box fields 

Field Description

From: Required. Enter your email address. The first time this 
dialog box is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.

To: Required. Enter the email addresses of the recipients, 
separated by a semicolon. The first time this dialog is 
displayed the field is blank; thereafter it is automatically 
filled with what you previously entered.

Mail Server: Required. The SMTP IP address or host name of the 
email server used to send the email. The first time this 
dialog is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.

BCC: Optional. Enter the email addresses of the recipients you 
want copied in on the email message. The first time this 
dialog is displayed the field is blank; thereafter it is 
automatically filled with what you previously entered.
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Use the Send button to check if the email alert action is configured correctly. When 
you click Send, a test email is sent to the email addresses in the To and BCC fields.

If the test email is successful, “Mail Sent Successfully” appears in the field next to the 
test button. If it is unsuccessful, “Mail Send Failed” appears. In that event, check your 
entries in the To, BCC, and Mail Server fields for accuracy and test it again.

Subject: The subject line is automatically generated by the 
action.

High Priority Select the check box if you want the email to be 
delivered with high priority. Leave it unselected for 
normal email delivery.

Message Pane (not 
labeled)

Optional. Enter a message to appear in the body of the 
email. 

Table 15. Email Alert Action Setup dialog box fields — Continued

Field Description
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Using Supervisor Record Viewer

The Supervisor Record Viewer (see Figure 18) displays all recordings made by your 
team over the last seven days as well as those you tag for 30-day extended lifetime. 

NOTE:  A license is used whenever you open the Supervisor Record 
Viewer, and is released when you close it. If no licenses are available, 
Supervisor Record Viewer will start but no recordings will be listed 
and the error message, “Licensing error” will be displayed. You must 
wait until a license is released and available for you to use in order to 
review any recordings. For this reason, it is important to close 
Supervisor Record Viewer after you are finished using it.

The recordings are archived as raw voice data packets; they can only be played back 
using the Supervisor Record Viewer. However, if you wish to save selected recordings 
as *.wav files, you can use the “Play and Save” button and save the recording to a 
folder in *.wav format.

Unless recordings are tagged for an extended lifetime, they are automatically deleted 
after seven days. 
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If a recording is tagged for the 30-day extended lifetime, they will not be deleted until 
that 30-day period expires. If you delete them manually before the 30-day period 
expires, they are deleted in the next folder cleanup—cleanups run daily at midnight.

Figure 18. Supervisor Record Viewer

Figure 19. Supervisor Record Viewer toolbar.

Table 16. Supervisor Record Viewer fields 

Column Name Description

Agent The agent whose call is recorded.

Team The team to which the agent belongs.

Play
Play & Save

Stop
Set Extended Lifetime

Set Normal Lifetime
Delete

Volume Control

Pause
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To start Supervisor Record Viewer:

1. From the Supervisor Desktop menu bar, choose Tools > Recorded Files.

Supervisor Record Viewer starts with no day selected.

2. From the Day Select section, click one of the radio buttons to view the 
recordings made by your team on that date.

To listen to a recording:

1. From the Day Select section of Supervisor Record Viewer, click the radio 
button for the date of the recording you want to review.

You can also click the Extended Lifetime radio button to view a list of all 
recordings that have been tagged for extended 30-day archiving. 

2. Select the recording you want to review.

3. Click the Play button, or choose Recording > Play from the menu bar.

Use the Pause or Stop buttons to control the recording playback, and the 
volume slider to control the playback volume.

There is a progress bar at the bottom of the screen that shows where you are 
within the recording. You can click the progress bar and drag it backwards or 
forwards to rewind or fast forward the recording. You must click Play again 
after you reposition the progress bar to restart the playback.

NOTE:  Playing back a recording while you are monitoring a call is not 
supported.

To save a recording:

1. Select the recording you want to save.

2. Click the Play and Save button, or choose Recording > Play and Save from the 
menu bar.

The Save As dialog box appears.

Time The time the recording was made.

Duration The length of the recording in hh:mm:ss format.

Lifetime The length of time the recording is archived: Normal is 7 
days, Extended is 30 days.

Date Recorded (Appears only when “Extended Lifetime” is selected in 
Day Select) The date the recording was made.

Table 16. Supervisor Record Viewer fields — Continued

Column Name Description
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3. Select a folder to save the recording to, enter a file name for the recording, 
and then click Save.

The recording plays and simultaneously is saved as a wav file to the location 
you selected.

To tag a recording for extended archiving:

1. Select the recording you want to archive for 30 days.

2. Click the Set Extended Lifetime button, or choose File > Set Extended Lifetime 
from the menu bar.

The recording is tagged to be archived for 30 days from the date of recording.
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Service Autorecovery

The service autorecovery feature allows Supervisor Desktop to automatically recover 
its connection to the Cisco services in the event of a service restart or a network 
outage.

When Supervisor Desktop detects that it is unable to communicate with a service 
(generally within three minutes of the service failure), the status bar displays “Partial 
Service” or “No Service” to indicate some or all of the services have failed.

When Supervisor Desktop detects that the service is again available (usually within 
one minute of service recovery), the status bar displays “In Service” to indicate that 
the services have recovered.

To learn more about what is affected by the service failure, double-click the status 
message on the status bar. Supervisor Desktop displays a popup box (see Figure 20) 
that lists features and indicates if that feature is available or not due to the service 
outage. 

Figure 20. Service Status popup window

The agent must drop any call he or she is on in order for the phone to reconnect to the 
network. If the agent continues on a call, CAD will not be able to show the call’s actual 
length because it shows as “terminated” in the system.

When the phone comes back into service, the agent will see the popup window display 
a message that the phone is in service. The agent can then change the agent state 
back to Ready and resume taking calls. 
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Phone Network Failure

In the event that an agent’s phone loses its connection to the network, the agent is 
automatically moved to the Not Ready agent state, and will see a popup window 
displaying a message that the phone is out of service.

The supervisor will see the change of agent state in the Agent ACD State Log report, 
along with the “Device out of service” reason code (code 32759).

The agent must drop any call he or she is on in order for the phone to reconnect to the 
network. If the agent continues on a call, CAD will not be able to show the call’s actual 
length because it shows as “terminated” in the system.

When the phone comes back into service, the agent will see the popup window display 
a message that the phone is in service. The agent can then change the agent state 
back to Ready and resume taking calls. 
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